Willkommen beim EMS SQL Studio!

SQL Management Studio for InterBase/Firebird ist die vollständige Lösung für die Datenbankverwaltung und -entwicklung. Ob Sie ein Datenbank - oder Anwendungsentwickler, DBA- oder Businessanalyst sind, finden Sie in SQL Studio alle notwendigen Werkzeuge, um Ihre Arbeit viel produktiver zu machen. SQL Studio bündelt diese Werkzeuge in einer leistungsstarken und einfachen Arbeitsumgebung.

SQL Studio stellt Werkzeuge für Datenbankverwaltung und Objektmanagement sowie für Datenbankmigration, Vergleichen, Datenextrakt, Export und Import, zur Verfügung.

Eigenschaften:

  • Manueller Start von Werkzeugen und Diensten.
  • Abspeichern aller Vorlagen in einem einzigen Repository.
  • Gesamte Liste der Datenquellen für alle Dienste und Werkzeuge.
  • Erzeugung von komplexen, verzweigten Skripts.
  • Möglichkeit, externe Anwendungen aus Skripten zu starten.
  • Abspeichern aller Logs der Skript-Ausführung in einer Datenbank.
  • Zeitgesteuerte Skript-Ausführung.
  • Erzeugung von benutzerdefinierten Benachrichtigungen und deren Versand.
  • Schneller Zugang zum technischen Supportzentrum.
  • Möglichkeit, die Ansicht für alle Anwendungen anzupassen.

Vorteile:

  • Wenig Zeitbedarf für den Sart der Datenbankaufgaben, daher mehr Konzentration auf die Ergebnisse.
  • Das gemeinsame Vorlagenrepository macht Ihre Arbeit mit den Werkzeugen sehr einfach.
  • Flexible Skripts sparen Zeit und erledigen für Sie alle regelmäßigen Arbeiten.
  • Die Zeitsteuerung der Skripts automatisiert die regelmäßigen Tasks.
  • E-Mail Benachrichtung erlaubt Ihnen "up-to-date" zu bleiben und schnell zu reagieren.
  • Alle Logs sind an einem Ort gespeichert. Das erlaubt Ihnen, alle Operationen nachzuvollziehen.
  • Der Stil der Benutzeroberflächen ist für alle Produkte gleich.


Neuigkeiten

Version |
SQL Management Studio for InterBase/Firebird 1.2.0.1 | Dezember 4, 2008

Was ist neu im SQL Management Studio for InterBase/Firebird?

  • Der Task planer kann jetzt als Windows-Dienst oder als separater Prozess gestartet werden.
  • Wenn ein benutzerdefinierter Task manuell gestartet wird, kann sein Ausführungsprozess in einem speziellen Fenster verfolgt werden.
  • Der SSH- bzw. HTTP-Verbindungstyp kann jetzt im Feld des Hostnamen angezeigt werden.
  • Die Einstellungen der Symbolleiste wurden gelegentlich nach dem Herunterfahren des Programms zurückgesetzt. Dies wurde behoben.
  • Implementierung der Möglichkeit für das Öffnen des PDF-Dokumentes aus dem Hauptmenü heraus.
  • Weitere kleine Verbesserungen und Bugfixes.

Siehe auch:

Vorherige Versionen


System Anforderungen

  • Pentium ® 166 MHz oder höher empfohlen
  • Microsoft® Windows® 95/98/Me/NT4/2000/XP/2003/Vista/7
  • 32 MB RAM (64 MB oder mehr wird empfohlen)
  • 130 MB des verfügbaren Festplattenplatz für die Programminstallation
  • Windows® kompatible Grafikkarte mit mindestens 800x600 Auflösung (1024x768 wird empfohlen)
  • Windows® kompatible Maus
  • Möglichkeit, zu einem lokalen oder remote InterBase/Firebird zu verbinden


Installation

Wenn Sie SQL Management Studio for InterBase/Firebird zum ersten Mal auf Ihrem PC installieren:

  • Laden Sie das Installationspaket des SQL Management Studio for InterBase/Firebird von unserer Download Seite;
  • Entpacken Sie die ZIP-Datei in einem lokalen Verzeichnis, z.B. c:\unzipped;
  • Starten Sie Setup.exe. und folgen Sie den Anweisungen des Installationsassistenten;
  • Nach Beendigung der Installation, finden Sie die Verknüpfung des SQL Management Studio for InterBase/Firebird in der entsprechenden Gruppe des Windows Startmenü.

Wenn Sie die installierte Kopie des SQL Management Studio for InterBase/Firebird auf die letzten Version aktualisieren möchten:

  • Laden Sie die ausführbare Datei des SQL Management Studio for InterBase/Firebird von unserer Download Seite;
  • Entpacken Sie die heruntergeladene Datei in ein lokales Verzeichnis, z.B. c:\unzipped;
  • Beenden Sie SQL Management Studio for InterBase/Firebird, wenn das Programm noch läuft;
  • Ersetzen Sie die vorherige Version des SQL Management Studio for InterBase/Firebird mit der neuen Version durch Kopieren der entpackten Dateien ins SQL Management Studio for InterBase/Firebird Verzeichnis;
  • Starten SQL Management Studio for InterBase/Firebird über die Verknüpfung im Windows Startmenü.

Sie können auch das ganze Installationspacket benutzen, um Ihre derzeitige Version des SQL Management Studio for InterBase/Firebird zu aktualisieren. In diesem Fall müssen Sie alle Schritte wiederholen, die Sie bei der ersten Installation gemacht haben. Bitte beachten Sie, dass das ganze Installationspacket viel größer ist als eine ausführbare Datei.


Kauf

Um es leichter für Sie zu machen, unsere Produkte zu kaufen, haben wir uns mit share-it! Registrierungsdienst verbündet. Share-it! Bestellprozess wird über eine sichere Verbindung geschützt und macht die Online-Bestellung mit der Kredit-/Debitkarte schnell und sicher.

Share-it! ist ein globaler e-Commerce-Anbieter für den Vertrieb von Software und Shareware im Internet. Share-it akzeptiert US Dollars, Euros, Pfund Sterling, Japanische Yens, Australische Dollars, Kanadische Dollars und Schweizer Franken. Man kann mit Kreditkarte (Visa, MasterCard / EuroCard, American Express, Diners Club), Banküberweisung, Scheck oder Bar zahlen.

Wenn Sie unsere Produkte Online erworben haben und Informationen über Ihren Einkauf durchsehen wollen, oder andere Fragen über Bestellprozess, Bezahlung oder Lieferung haben, dann melden Sie sich bei unserem Customer Care Center.

Beachten Sie bitte, dass alle unseren Produkte nur über den ESD (elektronische Software-Auslieferung) geliefert werden. Nach dem Erwerb sind Sie sofort in der Lage, die Lizenzschlüssel oder Passwörter herunterzuladen. Sie erhalten auch die entsprechende Kopie Ihrer Lizenzschlüssel oder Passwörter an Ihre E-Mail-Adresse. Überzeugen Sie sich davon, dass Sie die gültige E-Mail-Adresse in Ihrer Bestellung angegeben haben. Wenn Sie die Lizenzschlüssel innerhalb von zwei Stunden nicht bekommen, dann schreiben Sie bitte an sales@sqlmanager.net.

Produktbeschreibung | Share It!
EMS SQL Management Studio for InterBase/Firebird (Business) + 3 Year Maintenance | Jetzt kaufen!
EMS SQL Management Studio for InterBase/Firebird (Business) + 2 Year Maintenance | Jetzt kaufen!
EMS SQL Management Studio for InterBase/Firebird (Business) + 1 Year Maintenance | Jetzt kaufen!
EMS SQL Management Studio for InterBase/Firebird (Non-commercial) + 3 Year Maintenance | Jetzt beantragen!
EMS SQL Management Studio for InterBase/Firebird (Non-commercial) + 2 Year Maintenance | Jetzt beantragen!
EMS SQL Management Studio for InterBase/Firebird (Non-commercial) + 1 Year Maintenance | Jetzt beantragen!


Registrierung

Nach der Installation SQL Management Studio for InterBase/Firebird wird Ihnen eine 30-tägige Evaluierungsversion angeboten. Die Testversion der Software ist eine vollfunktionsfähige Version mit einigen kleinen Funktionsbeschränkungen. Während der ganzen Testzeit wird das unten angezeigte Dialogfenster erscheinen.

Welcome to SQL Studio - Unregistered copy

Nach Ablauf der Testzeit ist es nicht möglich, die Software zu evaluieren. Die weitere Anwendung SQL Management Studio for InterBase/Firebird Ihrer Kopie ist nach dem Einkauf und der Registration des Produktes möglich.

Welcome to SQL Studio - About

Um Ihre eingekaufte Kopie von EMS zu registrieren, SQL Management Studio for InterBase/Firebird führen Sie bitte die folgenden Schritte aus:

  • Erhalten Sie die Benachrichtigunsmail mit Registrierungsinformationen von Share-it!
  • Geben Sie den Registrierungsnamen und den Registrierungsschlüssel von diesem Schreiben ein.
  • Vergewissern Sie sich, dass der Registrierungsprozess erfolgreich abgeschlossen war - öffnen Sie das Fenster Info mittels Hauptmenüpunktes Hilfe | Info

Welcome to SQL Studio - Register product

Der Registrierungsschlüssel, den Sie bekommen haben, enthält eine Wartungslizenz, die während des bestimmten Zeitraums gültig ist. Nachdem Ihre Wartung abgelaufen ist, ist es nicht möglich, Ihre Software zu erneuern oder eine technische Unterstützung zu bekommen. Um Ihre Investitionen abzusichern und Ihre Software auf dem neuesten Stand zu halten, brauchen Sie Ihre Wartung zu erneuern. Wenn Ihr Wartungszeitraum verfällt, wird das unten angezeigte Dialogfenster erscheinen.

Sie können Ihre Wartung einfach durch unser Onlineinterface für schnelle Wiedereinsetzung/Erneuerung der Wartung neustarten/erneuern. Nach der Wiedereinsetzung/Erneuerung erhalten Sie eine Bestätigungsmail mit allen notwendigen Informationen.

Siehe auch:

Kauf


Vorherige Versionen

Version | Release date
Version 1.1 | December 12, 2007
Version 1.0 | October 18, 2006

Vorherige Versionen sind auch auf unserer Website unter http://www.sqlmanager.net/de/products/studio/ibfb/news zu finden.

Version 1.1

Was ist neu im SQL Management Studio 1.1?

  1. Aufgabenplaner: Hinzufügen der Funktionalität zum mehrfachen Planen der Aufgaben pro Tag.
  2. Starten des SQL-Studio-Tools über das Kontextmenü des Agenten, der sich auf der Systemleiste befindet.
  3. Beim Aufruf eines Utilites mit einer nicht zutreffenden Vorlage wird eine Meldung angezeigt bzw. eine jeweilige Protokollmeldung erstellt.
  4. Die SQL Query kann nun eine gemeinsame Datenbank-Repository mit dem SQL Studio verwenden.
  5. Verbesserung der Softwareaktualisierung über die Option SQL Studio Direct:
  • beim Downloaden des Updates wird der Download-Status angezeigt;
  • beim Installieren des Updates, das wegen des Ablaufs der Wartungsperiode nicht verfügbar ist, wird eine Warnung angezeigt..
  6. Fehlerbehebung beim Löschen eines einzigen Schrittes in einer Aufgabe.
  7. Die Konfiguration des visuellen Schemas wird jetzt auf alle Komponenten des SQL Studios angewandt.
  8. Das im SQL Manager ausgeführte Hinzufügen und Löschen von Datenbanken wurden im DB-Explorer des gestarteten SQL Studios nicht angezeigt. Dies wurde behoben.
  9. Fehlerbehebung einer Anzahl der Artefakten, die beim Arbeiten mit 2 Bildschirmen entstanden.
  10. Wenn ein Nutzer mit begrenzten Berechtigungen das SQL-Studio zum Starten brachte, ohne vorher den SQL Studio Agent zu starten, trat ein Fehler auf. Dies wurde behoben.
  11. Erhebliche Verbesserung der Geschwindigkeit beim Öffnen des Abschnittes für die Verwaltung der Vorlagen mit einer großen Liste von Vorlagen.
  12. Speichern der Position des SQL-Studio-Fensters für die nächste Sitzung.
  13. Beim Arbeiten mit dem Windows 2003 Server trat ein Fehler "Tool path is not correct" beim Starten einer Aufgabe auf. Dies wurde behoben.
  14. Hinzufügen einer Bestätigungsabfrage beim Löschen eines SchrNew Linkittes der Aufgabe.
  15. Weitere kleine Verbesserungen und Bugfixes.

Version 1.0

SQL Studio Vorteile:

  1. Wenig Zeiteinsatz beim Start der Datenbank Tasks, daher mehr Zeit für die Konzentration auf das Ergebnis
  2. Mit dem einzigen Template Repository ist das Arbeiten mit den Utilities sehr einfach
  3. Flexible Skripts erledigen Routinejobs und führen zu großen Zeiteinsparungen
  4. Das Script-Scheduling automatisiert Ihre Routinearbeiten
  5. Benachrichtigungen und Email-Warnungen gewähren Kontrolle und helfen schnell zu reagieren
  6. Alle Logs werden an einem Ort gespeichert und erlauben damit die volle Kontrolle aller Operationen
  7. Das visuelle Interface Style wird einheitlich nach Ihrem Wunsch für alle Applikationen gesetzt

Vorteile für den Kauf:

  1. Erwerb einer ganzen Sammlung von “must-have”-Tools für nur 50% ihres regulären Preises!
  2. Ein Jahr Softwarewartung kostenlos inbegriffen!
  3. Kostenlose Software-Updates und -Upgrades während der Wartungsperiode!
  4. Kostenloser und uneingeschränkter technischer Support während der Wartungsperiode!
  5. Angemessener Preis für Erneuerung der Softwarewartung – ab 20% pro Jahr!

Siehe auch:

What's new


EMS SQL Studio FAQ

Lesen Sie bitte diese Seite aufmerksam, wenn Sie Fragen über SQL Management Studio for InterBase/Firebird haben.

Inhaltstabelle

Über Studio

  • Was ist das EMS SQL Management STUDIO for InterBase/Firebird (STUDIO)?
  • Das STUDIO bietet reichhaltige Möglichkeiten. Werde ich diese alle benötigen? Gibt es auch ein einfacheres Produkt?
  • Was benötige ich um mit STUDIO anzufangen?
  • Viele Werkzeuge, die im STUDIO enthalten sind werden auch als Einzelprodukte verkauft. Welche Vorteile gibt es, alle im STUDIO enthaltenen Tools zu kaufen?

DB Registrierung und Verbindung

  • Kann ich simultan mit mehreren Datenbanken arbeiten?
  • Ich setze das Windows Betriebssystem ein, aber mein InterBase/Firebird Server läuft auf einem Linux Rechner. Werde ich das STUDIO einsetzen können um auf diesem Server zu arbeiten?
  • Warum verwendet das STUDIO eine Repository mit registrierten Datenbanken?
  • Welchen Datenbanken unterstützt STUDIO?
  • Was bedeutet SSH Tunneling?
  • Ich arbeit hinter einer Firewall (Router). Kann ich STUDIO einsetzen, um einen Remote InterBase/Firebird Server zu verwalten?
  • Warum kann ich mich nicht zum lokalen InterBase/Firebird Server verbinden?
  • Warum kann ich mich nicht zu einem entfernten InterBase/Firebird Server verbinden?
  • Ich kann die Verbindung zum InterBase/Firebird Server über SSH nicht herstellen. Was für Werte muss ich in die Felder des SSH-Reiters im Datenbank Registrierungs-Dialog eintragen?
  • Wenn ich versuche eine Datenbank zu registrieren, erhalte ich folgende Meldung: "Ihr Benutzername und Passwort ist nicht definiert". Warum?
  • I erhalte folgende Fehlermeldung: "Database ... shutdown". Was mache ich falsch?
  • Ich habe eine Datenbank registriert, aber wenn ich versuche sie zu öffnen erhalte ich folgende Meldung: "Die gewählte Client-Bibliothek wurde auf Ihrem System nicht gefunden".

Objektmanipulation

  • Auf welche Datenbank Objekte kann über STUDIO zugegriffen werden?
  • Ich habe über eine Million Einträge in der Tabelle, aber das Data-Grid zeigt nur 1.000 Einträge. Was ist das Problem?
  • Wie kann ich meine Arbeit im Falle von großen Tabellen beschleunigen?
  • Was kann ich mit Datenbank-Objekten machen?
  • Wenn ich eine Tabelle "TestTable" erzeuge, wird diese als "testtable" angelegt. Das ist falsch!
  • Wie kann ich Datenformate in einem Grid anpassen?
  • Meine Datenbank arbeitet mit einer "Greek" Codierung. Im Daten-Grid-View werden alle Infos als "??????" angezeigt. Was ist falsch?
  • Ich habe eine Tabelle mit nur ~ 1000 Einträgen und einer Vielzahl von Feldern. Das Öffnen dieser Tabelle über den Daten Reiter dauert zu lange.

Query

  • Ich kenne InterBase/Firebird noch nicht und habe Schwierigkeiten beim manuellen Erstellen der SQL-Statements. Hat das STUDIO einen visuellen Query Builder wie MS ACCESS?
  • Kann ich den Visual Query Builder in STUDIO verwenden um komplexe Abfragen mit Unions und Subqueries zu erstellen?
  • Kann ich eine erzeugte Abfrage für den späteren Gebrauch abspeichern?
  • Kann ich die Abfrage über die Kommandozeile ausführen?
  • Kann ich ein Abfrageergebnis in ein CVS- oder XLS-Datei speichern?

Bericht Designer

  • Wie kann ich einen Bericht erzeugen?
  • Wie kann ich einen Bericht basierend auf der Abfrage erzeugen?
  • Kann ich meinen Bericht in HTML, EXCEL oder Word speichern?
  • Ich versuche einen Bericht mit dem Report Designer zu erzeugen und habe ein Master Datenband hinzugefügt, aber ich bekomme keinen Zugriff auf die Tabellendaten: "Quell-Liste der Band Daten ist leer".

Datenmanipulation

  • Was ist er Unterscheid zwischen den Export/Import Funktionen in STUDIO und SQL Manager for InterBase/Firebird?
  • Ich muss die Daten aus einer CSV-Datei importieren. Wie kann ich das mit Hilfe von STUDIO tun?
  • Wie kann ich das Standardverzeichnis ändern, wohin die exportierten Daten gespeichert werden sollen?
  • Welchem Zweck dienen die Konsole-Versionen der Werkzeuge zur Datenmanipulation die im STUDIO enthalten sind?
  • Ich habe eine Datenbank in MS Access. Ich möchte zu einem InterBase/Firebird Remote-Server migrieren. Wie kann ich dies mit Hilfe von STUDIO tun?
  • Ich habe eine ODBC Datenquelle. Kann ich davon auf InterBase/Firebird migrieren?
  • Von welchen Datenbanken kann ich mit Hilfe von STUDIO nach InterBase/Firebird migrieren?
  • Ich arbeite an der Anwendung. Die DB-Struktur wurde bereits erzeugt. Wie kann mir STUDIO dabei helfen, die Datenbank mit Testdaten zu füllen?
  • Meine Datenbank enthält viele Beziehungen zwischen Tabellen und andere Einschränkungen. Wird STUDIO dies bei der Erzeugung der Testdaten berücksichtigen?

Daten Analyse

  • Ich muss den Unterschied in den Metadaten zweier Datenbanken finden um sie danach zu synchronisieren. Wie unterstützt mich STUDIO bei dieser Aufgabe?
  • Ich muss die Unterschiede der Daten zwischen der bestehenden DB und der gestern gesicherten DB finden. Was muss ich tun?
  • Kann ich Metadaten und Daten verschiedener InterBase/Firebird Versionen synchronisieren?
  • Kann ich die Synchronisation von Metadaten oder Daten von der Kommandozeile aus starten?
  • Kann STUDIO InterBase/Firebird DBs mit MySQL DBs synchronisieren?

Backup/Restore

  • Welche Backup Möglichkeiten bietet das STUDIO?
  • Welche Datenbank-Objekte werden in der Sicherungsdatei gespeichert?
  • Ist es möglich, die Sicherung von einem Server auf einem anderen Server wiederherzustellen?
  • Wo kann die Sicherungsdatei abgelegt werden?
  • Was sind die Unterschiede zwischen Extract und BackUp Funktionen im STUDIO?

Vorlagen Management

  • Für was werden die Vorlagen der Export/Import Funktionen verwendet? Für was sind diese gedacht?
  • Wo sind die STUDIO Vorlagen abgelegt?
  • Wenn ich eine Vorlage aus der Liste in STUDIO lösche, wird diese auch von der Platte gelöscht?
  • Wie kann ich eine neue Vorlage für den Import erstellen?

Planer

  • Ich muss einige DB-Management Funktionen außerhalb der Geschäftszeit (nachts) ausführen (Export von einer DB, Import dieser Daten in eine andere DB, Backup beider DBs). Hat STUDIO hierfür eine Lösung?
  • Wie kann ich eine Aufgabe konfigurieren, damit ich im Falle eines Fehlers, eine Email an die angegebene Adresse erhalte?
  • Kann der Aufgabenprozess in Abhängigkeit der Ergebnisse von einzelnen Arbeitsschritten verändert werden?
  • Wie kann ich die Info über die abgelaufenen Tasks sehen?
  • Was geschieht, wenn während der Durchführung der Aufgabe die Ausführung der Anwendung nicht beendet werden kann (kritischer Fehler, antwortet nicht)? Wird die Ausführung der Aufgabe gestoppt?
  • Was muss ich tun um mit dem Task Planer zu arbeiten?
  • Was geschieht, wenn auf dem gerade gestarteten Computer, unausgeführte Tasks vorgefunden werden?

Log Management

  • Es ist mir wichtig, die Infos aus den Log-Dateien der Anwendungen zu bekommen, die vom Task Planer durchgeführt wurden. Speichert STUDIO diese Log-Dateien ab?
  • Die externe Anwendung, die über eine der Tasks durchgeführt wurde hat keine Log-Datei, nur ein Bildschirm-Log. Wie kann ich die Daten vom Bildschirm sichern?
  • Wie lange werden die Log-Dateien im STUDIO beibehalten?

Lokalisierung

  • Was für Interface Lokalisierungen sind im STUDIO verfügbar?

Fragenliste

Über Studio

F: Was ist das EMS SQL Management STUDIO for InterBase/Firebird (STUDIO)?

A: Das EMS SQL Management Studio ist eine komplette Lösung für Datenbankadministration und Entwicklung. Das STUDIO ist eine integrierte Suite von leistungsstarken Datenbankwerkzeugen, die in einer einfach handhabbaren Arbeitsumgebung integriert sind. Die Entwickler werden die Möglichkeiten, Erzeugen/Editieren/Löschen von Datenbank Objekten schätzen und werden den DB-Vergleich, Datenexport/Import und das Generierungswerkzeuge für Testdaten sehr hilfreich finden. Datenbankmigration, Backup und Restore Werkzeuge werden sehr nützlich für DBAs sein. So auch den Planer, über den ein Großteil der Administrationsaufgaben automatisiert werden kann.

F: Das STUDIO bietet reichhaltige Möglichkeiten. Werde ich diese alle benötigen? Gibt es auch ein einfacheres Produkt?

A: Diese Frage stellt sich häufig, wenn Sie Neueinsteiger im Bereich der Datenbankverwaltung und Entwicklung sind. Es wird nicht gleich offensichtlich sein, warum Sie gleich so viele unterschiedliche Werkzeuge benötigen. Wir möchten darauf hinweisen, dass Ihre Erfahrung tagein, tagaus wächst, dass neue, komplizierte Aufgaben auf Sie zukommen und Sie mehrere Werkzeuge benötigen, um diese zu lösen. Das STUDIO enthält ALLE unbedingt nötigen Werkzeuge für DBAs und Entwickler. Und es wird mit Ihren zunehmenden Fachkenntnissen Schritt halten. Sobald Sie die Werkzeuge vom STUDIO verinnerlicht haben, werden Sie die einfachsten, passendsten und zuverlässigsten Lösungen für Ihre Aufgaben haben! Wir haben festgestellt, dass unsere Produkte nicht nur von Experten eingesetzt werden, deshalb haben wir viele Assistenten eingebunden, die das Arbeiten erleichtern und auch Neueinsteigern die Arbeit erleichtern. Das STUDIO Interface ist so entworfen, dass die Komponenten nur dann aufgerufen werden, wenn diese benötigt werden, so dass Sie sonst an Ihrer Arbeit nicht gehindert werden. Unsere Erfahrungen zeigen, dass die meisten Kunden sehr schell mit unseren Produkten zurecht kommen.

F: Was benötige ich um mit STUDIO anzufangen?

A: Um mit dem STUDIO zu arbeiten müssen Sie das Installationspaket herunterladen. Danach starten Sie die Installationsdatei auf einem MS Windows PC. Wenn die Installation erfolgt ist, kann das Programm in einem Testmodus benutzt werden. Sie können die Testversion 30 Tage lang testen. Während dieser Zeit können Sie Ihre Kaufentscheidung treffen. Sie können das STUDIO hier kaufen. Nach dem Zahlungseingang erhalten Sie per Email Ihre Registrierungsinfos. Nach Eingabe dieser Information (Hauptmenü/Hilfe/Registrieren) wird Ihre STUDIO eine Registrierte Version.

F: Viele Werkzeuge, die im STUDIO enthalten sind werden auch als Einzelprodukte verkauft. Welche Vorteile gibt es, alle im STUDIO enthaltenen Tools zu kaufen?

A: Um einige einfache Aufgaben zu erledigen, können Sie auch einzelne oder mehrere EMS Werkzeuge kaufe. Wenn Sie jedoch diese Werkzeuge mit dem STUDIO kaufen, erhalten Sie Zusatzfunktionalität. Erstens können Sie STUDIO Anwendungen über den Task Planer starten. Daher können Sie die Reihenfolge festlegen, in denen die Werkzeuge ausgeführt werden, setzen die benötigten Parameter, die Zeit oder Zeitintervalle für die Arbeiten die getan werden sollen und gehen zu einem schönen Bowling-Spiel ;-). Der Planer erledigt alle Ihre Aufgaben, speichert die Logs für die durchgeführten Operationen und wird Sie per Email über die erfolgreichen/erfolglosen Fertigstellung informieren. Der Planer hilft Ihnen, die meisten Ihrer DB Wartungsarbeiten zu automatisieren. Zweitens sind Sie in der Lage, alle registrierten Datenbanken in einem Repository zu speichern. Daher werden Sie Ihre Datenquelle nur einmal registrieren und diese aber mit allen STUDIO Werkzeugen verwenden können. Das spart Ihnen Zeit und reduziert die Fehlerwahrscheinlichkeit auf ein Minimum. Der Dritte, gleich bedeutende Vorteil ist der Preis. Beim Kauf der Tools im STUDIO, zahlen Sie weitaus weniger, als wenn Sie die einzelnen Produkte kaufen. Das sind bis zu 40% weniger als der Gesamtpreis.

Nach oben scrollen

DB Registrierung und Verbindung

F: Kann ich simultan mit mehreren Datenbanken arbeiten?

A: Ja, STUDIO erlaubt es, gleichzeitig mit mehreren Datenbanken zu arbeiten. Sie können ebenso mit einer Vielzahl von Datenbanken über SSH Tunneling arbeiten. Sobald die Datenbank in der DB Quellenrepository richtig registriert ist, können Sie damit arbeiten.

F: Ich setze das Windows Betriebssystem ein, aber mein InterBase/Firebird Server läuft auf einem Linux Rechner. Werde ich das STUDIO einsetzen können um auf diesem Server zu arbeiten?

A: Ja, das ist möglich. Es spielt keine Rolle auf welchem Betriebssystem der InterBase/Firebird Server läuft, das STUDIO läuft nur unter der Windows.

F: Warum verwendet das STUDIO eine Repository mit registrierten Datenbanken?

A: Das zentrale Repository mit registrierten Datenbanken erlaubt es, dass auf eine Datenbank von unterschiedlichen STUDIO Tools zugegriffen wird. Bei früher erworbenen Produkt-Suiten (Bündle) mussten Sie die Datenbank Informationen in jedem Tool separat eingeben. Das führte zu unnötiger Zeitverschwendung und Tippfehlern. In STUDIO wurde jetzt das Problem mit DB-Repository gelöst.

F: Welchen Datenbanken unterstützt STUDIO?

A: Unsere Produkte unterstützen alle Versionen von InterBase Server bis zum 7.5 und Firebird Server bis zum 2. Die Server können auf dem lokalen Netzwerk oder Remote auf jeder Plattform (Linux, Unix, Windows, etc) erreichbar sein. Sie können auch Remote auf InterBase/Firebird Server über SSH Tunneling zugreifen.

F: Was bedeutet SSH Tunneling?

A: Das SSH (Secure Shell Host) Protokoll wird verwendet um die Computer-Sicherheit unter einem Unix System im Internet zu erhöhen. SSH benutzt verschiedene Verschlüsselungsalgorythmen mit unterschiedlichen Sicherheitsstufen. Die Spannweite des SSH steht auch in Verbindung mit der Tatsache, dass einige Linux-like BS's (z.B. FreeBSD) den SSH Server in ihr Standard-Angebot integrieren. Um zu diesem Thema mehr zu erfahren, sehen Sie bitte unter http://openssh.org nach. Das SSH Tunneling des SQL Manager bedeutet eine sichere Verbindung zum InterBase/Firebird Server wenn über unsichere Verbindungskanäle gearbeitet wird. Sie können den SSH Tunnel auch so benutzen, eine Verbindung zum InterBase/Firebird Remote Host zu bekommen, auch wenn der Port 3306 aus irgendwelchen Gründen für externe Verbindungen geschlossen ist. Die Verbindung über den SSH Tunnel arbeitet folgendermassen: Als erstes wird eine Verbindung zwischen dem SSH Client des SQL Manager und dem Remote InterBase/Firebird Server hergestellt und es erfolgt eine Authentifizierung. Danach werden alle ein-/und ausgehenden Informationen zwischen den Programmen und dem InterBase/Firebird Server durch den SSH Server mit Hilfe des Kommunikationsport (gewöhnlich ist es 22) versendet und der SSH Server leitet die Information direkt an den InterBase/Firebird Server weiter. Um eine Datenbank zu registrieren, die über den SSH Tunnel verbunden ist, müssen Sie die folgenden Parameter im Datenbank Registrations-Wizard des SQL Manager for InterBase/Firebird einstellen:

Beim ersten Schritt:

Host ist der Host bei dem der InterBase/Firebird Server als SSH Server fungiert. Wenn SSH und der InterBase/Firebird Server sich auf der gleichen Maschine befinden, ist es der SSH Host, oder kann auch der 'localhost' sein.

Port ist ein Port des InterBase/Firebird Servers auf dem Remote Host, normalerweise ist es 3050.

Benutzername ist ein Name der InterBase/Firebird Benutzer.

Passwort ist das Passwort des InterBase/Firebird Benutzers.

Bitte beachten, dass der InterBase/Firebird Hostname in diesem Falle relativ zum SSH Server gesetzt werden muss. Zum Beispiel, wenn beide, also InterBase/Firebird Server und SSH Server sich auf dem gleichen Computer befinden, müssen Sie localhost als Hostname anstatt des Server's externe Hostname oder IP Adresse spezifizieren.

Bitte nicht vergessen, Tunneling Nutzen und SSH Tunneling zu wählen.

Beim zweiten Schritt:

SSH Hostname ist ein Host bei dem der SSH Server aktiviert ist.

SSH Port ist ein Port bei dem der SSH Server aktiviert ist.

SSH Benutzername ist ein Benutzer auf der Linux Maschine. (Es ist ein Linux User. Es ist kein User vom InterBase/Firebird Server.)

SSH Passwort ist ein Linux User Passwort.

F: Ich arbeit hinter einer Firewall (Router). Kann ich STUDIO einsetzen, um einen Remote InterBase/Firebird Server zu verwalten?

A: Wenn Sie wegen der Sicherheitsrichtlinien in Ihrem Firmennetzwerk oder Ihres Hostproviders keine Verbindung zu einem InterBase/Firebird Server direkt über TCP/IP (Beispiel: Ihr Firewall verhindert dies), herstellen möchten, können Sie die SSH Tunneling Funktionalität des SQL Manager nutzen um Ihre Aufgabe dennoch zu erledigen.

F: Warum kann ich mich nicht zum lokalen InterBase/Firebird Server verbinden?

A: Es gibt mehrere Gründe warum Sie sich nicht zur lokalen Datenbank verbinden können. Falls Sie während der Verbindung die Fehlermeldung erhalten: "Verbindung gescheitert. Der Server wurde beendet oder eine falsche Client Bibliothek wurde für die Verbindung zum Datenbankserver verwendet. SQLCode: -904 IB Error Nummer: 335544375" sollten Sie prüfen, ob der Port oder der Dienst, der für die Verbindung zum Server verwendet wird, richtig gesetzt ist und ob der lokale Server läuft. Um zu prüfen ob der Dienst gestartet wurde, öffnen Sie Systemsteuerung->Verwaltung->Dienste und suchen Sie den Dienst "InterBase Guardian" (falls Sie InterBase verwenden) oder "Firebird Guardian" (falls Sie Firebrid verwenden). Wenn Sie den Dienst gefunden haben, starten Sie ihn mit dem Start Button oder verwenden Sie den Eintrag 'Start' im Kontextmenü. Sollten Sie den Dienst nicht starten können, ist der Server vermutlich nicht korrekt installiert und Sie müssen ihn erneut installieren. Ein weiterer möglicher Grund ist, dass die Version der Client Bibliothek nicht mit der Version des Servers übereinstimmt. Wenn Sie folgende Fehlermeldung erhalten: "Ihr Benutzername und Passwort sind unbekannt. Fragen Sie Ihren Datenbank Administrator nach Ihren Benutzerdaten. SQL Code: -902 IB Error Number: 335544472", besteht der Grund darin, dass Ihre eingegebenen Benutzerdaten nicht in der Berechtigungsdatenbank enthalten sind. Sie müssen sich mit dem richtigen Benutzernamen und Passwort auf dem Server registrieren.

F: Warum kann ich mich nicht zu einem entfernten InterBase/Firebird Server verbinden?

A: Es gibt mehrere Gründe warum eine Verbindung zu einer entfernten Datenbank scheitern kann. Falls Sie die Fehlermeldung erhalten: "Verbindung gescheitert. Der Server wurde beendet oder eine falsche Client Bibliothek wurde für die Verbindung zum Datenbankserver verwendet. SQLCode: -904 IB Error Nummer: 335544375" sollten Sie prüfen, ob der Port oder der Rechnername, der für die Verbindung zum Server verwendet wird, richtig gesetzt ist und ob der entfernte Server läuft. Es kommt häufig vor, dass der Port, über den die Verbindung mit dem InterBase/Firebird Server (normal 3050) aufgebaut wird, aus Sicherheitsgründen von einer lokalen, netzweiten oder entfernten Firewall gesperrt wird. Bitte prüfen Sie dies mit Ihrem Systemadministrator oder ISP. Um diese Einschränkungen zu umgehen, können Sie einen SSH Tunnel verwenden (50, 55). Im Falle von folgender Fehlermeldung: "Ihre Benutzername und Passwort sind unbekannt. Fragen Sie Ihren Datenbankadministrator nach Ihren Zugangsdaten. SQL Code: -902 IB Error Number: 335544472", hat der Benutzer keine Berechtigung auf die Datenbank zuzugreifen. Sie müssen den Benutzer mit den richtigen Zugangsdaten auf dem Server registrieren.

Im Falle von folgender Fehlermeldung: "Ihre Benutzername und Passwort sind unbekannt. Fragen Sie Ihren Datenbankadministrator nach Ihren Zugangsdaten. SQL Code: -902 IB Error Number: 335544472", hat der Benutzer keine Berechtigung auf die Datenbank zuzugreifen. Sie müssen den Benutzer mit den richtigen Zugangsdaten auf dem Server registrieren.

F: Ich kann die Verbindung zum InterBase/Firebird Server über SSH nicht herstellen. Was für Werte muss ich in die Felder des SSH-Reiters im Datenbank Registrierungs-Dialog eintragen?

A: Um eine richtige SSH Verbindung zu erstellen, geben Sie die folgenden Werte in die entsprechenden Felder ein:

Bei SSH Page/Tabulator:

SSH Hostname ist ein Host bei dem der SSH Server aktiviert ist.

SSH Port ist der Port bei dem der SSH Server aktiviert ist.

SSH Benutzername ist ein Benutzer auf der Linux Maschine. (Es ist ein Linux User. Es ist kein InterBase/Firebird Server User.)

SSH Passwort ist ein Linux User Passwort.

Bei Eigenschaften Verbindungen/Allgemein Seite/Reiter:

Host ist der Host bei dem der InterBase/Firebird Server als SSH Server fungiert. Wenn SSH und InterBase/Firebird Server sich auf der gleichen Maschine befinden, ist es gleich dem SSH Host, oder kann auch 'localhost' sein.

Port ist ein Port des InterBase/Firebird Servers auf dem Remote Host, Standardmäßig ist es 3050.

User Name ist ein InterBase/Firebird User Name.

Passwort ist ein Passwort des InterBase/Firebird Users.

Bitte beachten, dass der InterBase/Firebird Hostname in diesem Falle relativ zum SSH Server gesetzt werden muss. Zum Beispiel, wenn beide, also InterBase/Firebird Server und SSH Server sich auf dem gleichen Computer befinden, müssen Sie localhost als Host Name anstatt des Server's externe Hostname oder IP Adresse spezifizieren.

F: Wenn ich versuche eine Datenbank zu registrieren, erhalte ich folgende Meldung: "Ihr Benutzername und Passwort ist nicht definiert". Warum?

A: Dies wird durch die Tatsache verursacht, dass Ihre Daten in der Berechtigungsdatenbank Ihres Servers fehlen. Sie müssen den Benutzer mit dem richtigen Benutzernamen und Passwort auf Ihrem Server registrieren.

F: I erhalte folgende Fehlermeldung: "Database ... shutdown". Was mache ich falsch?

A: Diese Meldung bedeutet, dass Ihre Datenbank im Single-user Modus betrieben wird und nur vom Ersteller und SYSDBA darauf zugegriffen werden kann. Um in den Multi-User Modus zu wechseln müssen Sie die Ihre Datenbank publizieren.

F: Ich habe eine Datenbank registriert, aber wenn ich versuche sie zu öffnen erhalte ich folgende Meldung: "Die gewählte Client-Bibliothek wurde auf Ihrem System nicht gefunden".

A: Sie erhalten diese Fehlermeldung, weil das Programm die Client Bibliothek nicht finden kann, die wesentlich für die Erstellung einer Verbindung mit dem Server ist. Sie müssen prüfen ob die angegebenen Pfade in den Registrierungsinformationen des Servers korrekt sind und ob die Client Bibliothek vorhanden ist. Falls die Datei fehlt, müssen Sie die Client Software aus dem Installationspaket des Servers installieren.

Nach oben scrollen

Objektmanipulation

F: Auf welche Datenbank Objekte kann über STUDIO zugegriffen werden?

A: Sie können mit allen Objekten der InterBase/Firebird Datenbank arbeiten wie Tabellen, Felder, Indizes, Views, Stored Procedures und Funktionen, Triggers, UDF's und Events.

F: Ich habe über eine Million Einträge in der Tabelle, aber das Data-Grid zeigt nur 1.000 Einträge. Was ist das Problem?

A: Bitte wählen Sie die Option 'Alle Datensätze einer Tabelle auswählen' aus im Abschnitt "Grid" des Dialogs Optionen/Umgebungsoptionen. Bitte sind Sie sich bewusst, dass das Auswählen aller Datensätze einer Tabelle erhebliche Zeit in Anspruch nehmen kann.

F: Wie kann ich meine Arbeit im Falle von großen Tabellen beschleunigen?

A: Zu Ihrem Nutzen und zu Beschleunigung der Arbeit, bietet die Rasteransicht mehrere Möglichkeiten der Anpassung. Hier die wichtigsten Parameter (erreichbar über Optionen/Umgebungsoptionen): Im Abschnitt Raster:

  • Begrenzende Optionen in Tabellen und View Editoren. Die Option "Alle Datensätze einer Tabelle auswählen" ermöglicht es Ihnen, ohne erneute Verbindung zum Server alle Datensätze einer Tabelle zu sehen, jedoch im Falle von großen Tabellen oder einer nicht sehr schnellen Verbindung werden die Daten mit großen Zeitverzögerungen empfangen und der eingehende Datenverkehr kann erheblich ansteigen. Dieser Modus wird in privaten Netzen oder mit lokalen Datenbanken empfohlen. Die Option "Nur auswählen" begrenzt die maximale Anzahl der Datensätze, die nach dem Absetzen der Suche zurückgegeben werden. Der Mensch ist nicht in der Lage eine große Menge an Informationen auf einmal zu verarbeiten, deswegen bieten wir diesen Modus an. Um den nächsten Teil der Daten anzufordern und darzustellen, klicken Sie auf den Button Nächste Seite (>>) in der Toolbar der Rasteransicht. Diese Arbeitsweise beschleunigt die Ansicht der Datentabellen erheblich und vermeidet das Hängen sowie den Timeout der Verbindung. Sie wird empfohlen für die Arbeit mit großen Tabellen, bei Verbindungen mit geringer Übertragungsrate und wenn das Übertragungsvolumen eine Rolle spielt. Dies ist der Default Modus. In diesem Modus können die Optionen " SQL-Sortierung verwenden" und "SQL-Filter verwenden" sehr hilfreich sein.
  • Im Abschnitt Grid->Datenoptionen:
  • Standard-Rastermodus: Diese Option definiert ob die angeforderten Zeilen komplett in das Raster geladen werden, oder in Teilen (sichtbare Zeilen) wenn der Benutzer durch die Tabellendaten nach unten scrollt. Der erste Modus erhöht die Öffnungszeit der Suche, beschleunigt aber das Scrollen. Im zweiten Modus wird die Suche sehr schnell ausgeführt, aber es können Verzögerungen bei der Navigation durch das Raster auftreten.
  • In der Datenansicht SQL-Sortierung verwenden: Ist die Option eingeschaltet, wird eine neue Anfrage an den Server gesendet, wenn der Benutzer die Datensortierung verwendet. Die Ergebnisse werden erneut im Raster dargestellt. Diese Option ins im Modus "Nur auswählen" sehr hilfreich, erhöht jedoch den Datenverkehr. Ist diese Option ausgeschaltet, wird die Sortierung nur auf dem Client durchgeführt jedoch werden nur die geladenen Daten sortiert. D.h. wenn sie "Nur auswählen" auf 1000 Einträge gesetzt haben, werden nur diese 1000 Datensätze sortiert.
  • In der Datenansicht SQL Filter verwenden: Ist diese Option eingeschaltet, werden die Daten auf dem Server sortiert, an den die Anfrage geschickt wird und die Ergebnisse werden erneut im Raster dargestellt. Diese Option ist ebenfalls im "Nur auswählen" Modus sehr hilfreich, erhöht aber auch den Datenverkehr. Ist diese Option ausgeschaltet, wird die Sortierung nur auf dem Client durchgeführt jedoch werden nur die geladenen Daten sortiert. D.h. wenn sie "Nur auswählen" auf 1000 Einträge gesetzt haben, werden nur diese 1000 Datensätze sortiert.

Wir empfehlen folgende Einstellungen der Optionen um die maximale Effizienz bei der Arbeit mit großen Tabellen zu erreichen:

  • Nur auswählen
  • Sichtbare Zeilen laden
  • SQL-Sortierung verwenden
  • SQL-Filter verwenden

F: Was kann ich mit Datenbank-Objekten machen?

A: Sie können neue Objekte erstellen, bestehende Objekte löschen oder editieren. Außerdem können Sie existierende Objekte von/nach Datenbanken kopieren, die sich auf dem gleichen oder unterschiedlichen Hosts befinden.

F: Wenn ich eine Tabelle "TestTable" erzeuge, wird diese als "testtable" angelegt. Das ist falsch!

A: Finden Sie bitte die Option "Erzeugte Objektnamen in Kleinschreibung konvertieren" in Optionen/Umgebungsoptionen/Objekt Editor Menü und schalten Sie sie aus, wenn nötig.

F: Wie kann ich Datenformate in einem Grid anpassen?

A: Sie können alle Anzeigeformate ändern: Integer, Float, Datum, Zeit, und Datum/Zeit in dem Dialog Umgebungsoptionen um Menü Optionen.

F: Meine Datenbank arbeitet mit einer "Greek" Codierung. Im Daten-Grid-View werden alle Infos als "??????" angezeigt. Was ist falsch?

A: Sie müssen den richtigen Client-Zeichensatz einstellen um zu gewährleisten, dass die Daten mit der benötigten Codierung vom Server geliefert werden. Bitte öffnen Sie das Dialogfenster "Datenbank Registrierungsinfo" und stellen Sie die Client-Zeichensatz Option auf 'greek (ISO 8859-7 Greek)'.

F: Ich habe eine Tabelle mit nur ~ 1000 Einträgen und einer Vielzahl von Feldern. Das Öffnen dieser Tabelle über den Daten Reiter dauert zu lange.

A: Sie haben vermutlich die Option 'Spaltenbreite automatisch anpassen' in den Optionen/Umgebungsoptionen Abschnitt Grid gewählt. Versuchen sie diese zu deaktivieren.

Nach oben scrollen

Query

F: Ich kenne InterBase/Firebird noch nicht und habe Schwierigkeiten beim manuellen Erstellen der SQL-Statements. Hat das STUDIO einen visuellen Query Builder wie MS ACCESS?

A: Ja, das STUDIO hat einen leistungsstarken visuellen Query Builder der es einem Neuling erlaubt komplexe Suchbefehle zu erstellen und auch einem fortgeschrittenen Anwender hilft extrem viel Zeit zu sparen. Sie müssen nur die Tabellen spezifizieren, die in der Suche verwendet werden sollen, deren Beziehungen und die Daten, die Sie sehen möchten. Der Visual Query Builder erstellt den Suchstring für Sie. Sie können das Ergebnis der Suche begutachten und Korrekturen vornehmen, falls notwendig. Die Änderungen können im Visual Builder oder im Texteditor vorgenommen werden. Werden Änderungen im Visual Builder vorgenommen, so werden diese auch im Texteditor angezeigt und umgekehrt.

F: Kann ich den Visual Query Builder in STUDIO verwenden um komplexe Abfragen mit Unions und Subqueries zu erstellen?

A: Ja, der Visual Builder kann komplexe Abfragen mit Unterabfragen und Unions erstellen.

F: Kann ich eine erzeugte Abfrage für den späteren Gebrauch abspeichern?

A: Natürlich. Zum Abspeichern der Abfragen bietet das STUDIO mehrere Möglichkeiten:

  1. Sämtliche ausgeführten Abfragen werden in der Historie abgespeichert. Sie können die Historie anschauen und jede Abfrage ausführen und ändern, die sie benötigen.
  2. Sie können häufig verwendete Abfragen zu der Liste von favorisierten Abfragen hinzufügen.
  3. Sie können jede Abfrage als ein SQL-Skript in einer Datei auf Ihrer Festplatte speichern und wieder öffnen, wenn Sie es benötigen oder in einem SQL Skript Werkzeug ausführen.
  4. Sie können die Abfrage als Diagramm abspeichern. Wird diese Abfrage erneut mit dem STUDIO geöffnet, wird das Diagramm wie erstellt dargestellt.
  5. Das STUDIO bietet auch die Möglichkeit, Abfragen als Bitmap Bild abzuspeichern.

F: Kann ich die Abfrage über die Kommandozeile ausführen?

A: Ja, das STUDIO bietet hierfür ein SQL Skript Werkzeug. Es kann auch gespeicherte Skript-Dateien ausführen. Diese Funktionalität ermöglicht es Ihnen, Abfragen zu erstellen und deren Ausführung mit dem Task Planer zu planen. Mit dem Planer ist es möglich, Abfragen dann auszuführen wenn sie benötigt werden. Der Planer meldet wenn die Abfrage abgeschlossen wurde.

F: Kann ich ein Abfrageergebnis in ein CVS- oder XLS-Datei speichern?

A: Ja, natürlich. Das STUDIO hat ein leistungsstarkes Werkzeug für den Export Ihrer Daten, einschließlich der Abfrage Ergebnisse. Das STUDIO kann nach MS Access, MS Word, CVS, XLS, HTML, RTF, DBF, XML und andere Formate exportiert werden. Um die Export Prozedur zu erleichtern, besitzt das Studio einen Export Data Wizard.

Nach oben scrollen

Bericht Designer

F: Wie kann ich einen Bericht erzeugen?

A: Um einen Bericht zu erzeugen können Sie den Assistenten zum Erstellen von Berichten (Erstellen->Bericht) oder den Berichts-Designer (Werkzeuge-> Berichts-Designer) verwenden. Um einen einfachen Bericht auf Basis einer Abfrage zu erstellen, müssen Sie das Master Data Band im zweiten Schritt des Assistenten wählen, doppelklicken oder Edit Button klicken und die Abfrage für Ihren Report auswählen. Danach müssen Sie die weiteren Optionen in den anderen Schritten des Assistenten anpassen und auf Fertig klicken.

F: Wie kann ich einen Bericht basierend auf der Abfrage erzeugen?

A: Um einen Bericht auf Basis einer Abfrage zu erzeugen können Sie den Assistenten zum Erstellen von Berichten verwenden. Wählen Sie Erstellen-> Bericht, wählen Sie dann das Master Data Band im zweiten Schritt des Assistenten, doppelklicken oder Edit Button klicken und die Abfrage für Ihren Report auswählen. Danach müssen Sie die weiteren Optionen in den anderen Schritten des Assistenten anpassen und auf Fertig klicken.

F: Kann ich meinen Bericht in HTML, EXCEL oder Word speichern?

A: Ja, öffnen Sie den Bericht durch doppelklicken im DB Explorer und wählen Sie "Bericht Speichern unter" in der Navigations- oder Werkzeugleiste und geben Sie im Feld "Speichern als Typ" das gewünschte Format an.

F: Ich versuche einen Bericht mit dem Report Designer zu erzeugen und habe ein Master Datenband hinzugefügt, aber ich bekomme keinen Zugriff auf die Tabellendaten: "Quell-Liste der Band Daten ist leer".

A: Um eine Datenquelle für einen Bericht auszuwählen müssen Sie ein Dialog-Formular zum Bericht hinzufügen (im Berichtsdesigner Menü "Edit/Add dialog form" wählen). Danach müssen Sie Datenbanken und Komponenten für die Abfrage aus der Symbolleiste auf der linken Seite hinzufügen und die Eigenschaften der Verbindung und der Abfrage setzen. Danach erscheint die Abfrage in der Liste der Datenquellen.

Nach oben scrollen

Datenmanipulation

F: Was ist er Unterscheid zwischen den Export/Import Funktionen in STUDIO und SQL Manager for InterBase/Firebird?

A: Die Export/Import Werkzeuge im STUDIO enthalten zusätzliche Funktionen, die im SQL Manager für InterBase/Firebird nicht vorhanden sind.

  1. Export/Import von Daten aus/in mehrere Tabellen gleichzeitig.
  2. Export/Import von Daten aus gewählten Tabellen von mehreren Datenbanken auf dem selben Host.
  3. Kommandozeile um Daten automatisch mit Hilfe des STUDIO Task Planers zum exportieren/importieren.
  4. Ein einziges registriertes Datenbank Repository.

F: Ich muss die Daten aus einer CSV-Datei importieren. Wie kann ich das mit Hilfe von STUDIO tun?

A: Für diesen Zweck können Sie den Daten Import Assistenten verwenden. Er hilft Ihnen als benötigten Parameter einzustellen. Zudem können Sie diese Einstellungen als Vorlage abspeichern und in der Zukunft verwenden. Außer CVS Dateien, können Sie noch Daten aus MS Excel, MS Access, DBF, XML und TXT Dateien importieren.

F: Wie kann ich das Standardverzeichnis ändern, wohin die exportierten Daten gespeichert werden sollen?

A: Folgen Sie den unten beschriebenen Schritten um das Verzeichnis zu ändern:

Klicken Sie im DB Explorer mit der rechten Maustaste auf die gewünschte Datenbank und wählen Sie "Datenbank Registrierungsinfos" im Kontextmenü (Sie finde diesen Eintrag auch im Hauptmenü "Datenbank"). Es öffnen sich die Datenbank Eigenschaften.

Klicken Sie auf den Reiter "Verzeichnisse".

Im Abschnitt "Standardverzeichnis für Datenexport" können Sie das Verzeichnis wählen, in welches die Daten exportiert werden.

F: Welchem Zweck dienen die Konsole-Versionen der Werkzeuge zur Datenmanipulation die im STUDIO enthalten sind?

A: Die Hauptfunktionen der Konsole-Versionen der STUDIO Werkzeuge dienen der Ausführung von Datenbankoperationen ohne Benutzereingriff. Sämtliche Konsolen-Werkzeuge unterstützen Konfigurationsdateien (Templates), die mit der entsprechenden GUI Version erstellt wurden. Die Templates enthalten alle Informationen, die für das Arbeiten mit der Konsole-Version notwendig sind. Mit Hilfe Konsole und eine Templates können Sie eine Task im Planer erstellen und die gewünschte Zeit und/oder Zeitraum für die Ausführung planen. Natürlich können sie die Konsole in Ihren eigenen Anwendungen verwenden.

F: Ich habe eine Datenbank in MS Access. Ich möchte zu einem InterBase/Firebird Remote-Server migrieren. Wie kann ich dies mit Hilfe von STUDIO tun?

A: Dafür können Sie das Werkzeug Data Pump for InterBase/Firebird verwenden. Um das Data Pump Programm aus STUDIO zu starten wählen Sie bitte den Reiter "Datenmanipulation" und klicken auf Data Pump for InterBase/Firebird oder wählen Start-> Programme-> EMS-> SQL Studio for InterBase/Firebird-> Data Pump for InterBase/Firebird->Data Pump for InterBase/Firebird.

F: Ich habe eine ODBC Datenquelle. Kann ich davon auf InterBase/Firebird migrieren?

A: ODBC (Open DataBase Connectivity) ist eine offene Standard-Schnittstelle um auf Microsoft Datenbanken zuzugreifen. Die meisten Datenbank Systeme haben ihre eigenen ODBC Treiber oder welche die von anderen Herstellern entwickelt wurden.

Um von einer ODBC Datenquelle zu migrieren müssen sie das Programm Data Pump for InterBase/Firebird verwenden. Um das Data Pump Programm aus STUDIO zu starten wählen Sie bitte den Reiter "Datenmanipulation" und klicken auf Data Pump for InterBase/Firebird oder wählen Start-> Programme-> EMS-> SQL Studio for InterBase/Firebird-> Data Pump for InterBase/Firebird->Data Pump for InterBase/Firebird. Wenn Sie mit diesem Programm arbeiten, sollten Sie den OLE DB Provider für ODBC Treiber verwenden um sich mit der ODBC Datenquelle zu verbinden.

F: Von welchen Datenbanken kann ich mit Hilfe von STUDIO nach InterBase/Firebird migrieren?

A: Mit der Hilfe der Data Pump for InterBase/Firebird können Sie von jeder Datenbank migrieren, zu der Sie sich per OLE DB Provider (z.B. SQL Server, Oracle, MS Access, DB2, etc.) und ODBC Driver (MySQL, dbase Dateien, etc.) verbinden können.

F: Ich arbeite an der Anwendung. Die DB-Struktur wurde bereits erzeugt. Wie kann mir STUDIO dabei helfen, die Datenbank mit Testdaten zu füllen?

A: STUDIO hat ein leistungsstarkes Instrument um Testdaten zu generieren - den Data Generator. Der Assistent hilft Ihnen die richtigen Parameter zu setzen, wie z.B. die Anzahl der zu generierenden Zeilen, Wertebereiche für jedes Feld, die Anzahl der Felder mit dem Wert NULL und viele andere. Der Data Generator führt verschieden Algorithmen aus, einschließlich zufällige oder inkrementelle Datengenerierung sowie Generierung entsprechend der vorgegebenen Werteliste und viele anderen. Und natürlich ist es möglich, die Einstellungen für die spätere Verwendung abzuspeichern.

F: Meine Datenbank enthält viele Beziehungen zwischen Tabellen und andere Einschränkungen. Wird STUDIO dies bei der Erzeugung der Testdaten berücksichtigen?

A: Ja, natürlich. Bei der Generierung der Testdaten berücksichtig das STUDIO sämtliche Beziehungen und Einschränkungen die bereits in der Datenbank existieren.

Nach oben scrollen

Daten Analyse

F: Ich muss den Unterschied in den Metadaten zweier Datenbanken finden um sie danach zu synchronisieren. Wie unterstützt mich STUDIO bei dieser Aufgabe?

A: Zu diesem Zweck kann das Programm Database Comparer (DB Comparer) verwendet werden. Seine Oberfläche ist einfach und benutzerfreundlich, die Ergebnisse sind jedoch beeindruckend. Sie müssen nur zwei Datenbanken auswählen, deren Metadaten Sie vergleichen möchten und ein paar zusätzliche Parameter einstellen, wie zum Beispiel die Datenbankobjekte, die Sie vergleichen möchten, die Richtung der Synchronisierung und andere. Das Ergebnis, welches der DB Comparer liefert, ist eine Liste von Unterschieden in den Metadaten der verglichenen Datenbanken und ein Skript mit dessen Hilfe Sie die Datenbanken synchronisieren können. Abgesehen davon, können Sie jeden Unterschied separat synchronisieren, damit Sie jede benötigte Änderung in der richtigen Reihenfolge erhalten. Erinnern Sie sich, wie lange Sie nach einem Feld suchen, welches Sie vor zwei Monaten in eine Tabelle eingefügt haben?

F: Ich muss die Unterschiede der Daten zwischen der bestehenden DB und der gestern gesicherten DB finden. Was muss ich tun?

A: Starten Sie den Data Comparer Assistenten und wählen Sie die Arbeitsdatenbank als Ihre Quelldatenbank aus. Dann wählen Sie die gesicherte Datenbank als Zieldatenbank aus (Sie müssen erst die Datenbank auf einem InterBase/Firebird Server wiederherstellen). Wählen Sie jetzt die Daten in den Tabellen, die Sie vergleichen möchten und folgen dann den weiteren Schritten des Assistenten. Beachten Sie, dass der Data Comparer es erlaubt, Tabellen mit unterschiedlichen Metadaten zu vergleichen. Nach dem Vergleich sehen Sie eine Liste mit den Unterschieden zwischen den Datenbanken und Sie werden gefragt, ob Sie Daten zwischen den beiden Datenbanken synchronisieren möchten. Sie können ein SQL Skript, welches die Synchronisierung durchführt, abspeichern und es später, mit Hilfe eines SQL Skript Werkzeugs ausführen (vielleicht mit dem STUDIO Task Planer).

F: Kann ich Metadaten und Daten verschiedener InterBase/Firebird Versionen synchronisieren?

A: Sie können den DB Comparer for InterBase/Firebird verwenden um die Strukturen der Datenbanken zu synchronisieren.

Um den DB Comparer aus dem STUDIO zu starten, wählen Sie den Reiter Datenanalyse und klicken auf DB Comparer for InterBase/Firebird, oder wählen Sie Start->Programme->EMS->SQL Studio for InterBase/Firebird-> DB Comparer for InterBase/Firebird-> DB Comparer for InterBase/Firebird.

Um die Daten zu synchronisieren, können Sie den Data Comparer for InterBase/Firebird verwenden.

Um den Data Comparer aus dem STUDIO zu starten, wählen Sie den Reiter Datenanalyse und klicken auf Data Comparer for InterBase/Firebird, oder wählen Sie Start->Programme->EMS->SQL Studio for InterBase/Firebird-> Data Comparer for InterBase/Firebird-> Data Comparer for InterBase/Firebird.

F: Kann ich die Synchronisation von Metadaten oder Daten von der Kommandozeile aus starten?

A: Ja, für diesen Zweck gibt des die Konsolen-Versionen unserer Werkzeuge - DB Comparer Console for InterBase/Firebird und Data Comparer Console for InterBase/Firebird. Alle Konsolen Werkzeuge unterstützen Konfigurationsdateien (Vorlagen) die in den GUI Versionen der Werkzeuge erstellt werden. Die Vorlagen Dateien enthalten alle notwendigen Informationen für die Arbeit mit der Konsole. Mit Hilfe der Konsole und dem Vorlagendateien können Sie einfach eine Synchronisierung von der Kommandozeile aus durchführen, ohne eine große Anzahl von Parametern manuell einstellen zu müssen.

F: Kann STUDIO InterBase/Firebird DBs mit MySQL DBs synchronisieren?

A: Diese Funktionalität wird von unseren Werkzeugen nicht unterstützt, da sie nur eine Synchronisierung von Daten und Metadaten nur zwischen Servern des selben Typs erlauben, als InterBase/Firebird mit InterBase/Firebird.

Nach oben scrollen

Backup/Restore

F: Welche Backup Möglichkeiten bietet das STUDIO?

A: Für das Erstellen eines Backups bietet das STUDIO verschiedene Möglichkeiten:

  1. Verwenden Sie den Dienst Backup Tables Databases. Diese Methode ist sehr schnell und zuverlässig. Bei ihrer Anwendung brauchen Sie Ihre Datenbank nicht herunter zu fahren, d.h. andere Anwender können damit weiterarbeiten. Außerdem erlaubt diese Methode, Sicherungsdateien in einem portablen Format zu erhalten, das Ihnen ermöglicht, diese Datenbanken auf den Servern mit unterschiedlichen ODS (on-disk-structure) wiederherzustellen. Das ist entscheidend, um die Datenbankmigration zwischen Servern durchzuführen. Bitte auch beachten, dass diese Sicherungsmethode es erlaubt, den Datenbankeigentümer zu wechseln, was bei einer Änderung der Server-Sicherheitsstruktur wichtig ist. Beim Backup Database Service werden die Tabellenindizes umgerechnet und der Datenbankmüll wird gesammelt, was wiederum Einfluß auf die Datenbankgröße hat und ihre gesamte Leistung verbessert. Die Nachteile der Methode sind, dass Sie das zu speichernde Datenbankobjekt nicht auswählen können und Sie die Sicherungsdatei am lokalen Arbeitsplatz nicht speichern können, wenn Sie die Datenbank auf einen entfernten Server kopieren. Zum Starten dieses Dienstes öffnen Sie den Reiter Datenbankverwaltung im STUDIO und wählen Sie Datenbank Sichern. Um den Dienst aus dem SQL Manager for InterBase/Firebird zu starten, benutzen Sie Dienste/Datenbanksicherung. Um die Datenbanken aus der Sicherungsdatei wiederherzustellen, die mit dieser Methode gesichert wurden, verwenden Sie den Dienst Datenbank Wiederherstellen. Dieser Dienst ermöglicht Ihnen, Ihre Datenbank in die Datei der vorhandenen Datenbank wiederherzustellen, oder eine neue Datenbank auf der Grundlage von der vorhandenen Sicherungskopie zu erzeugen. Wenn die Datenbank in die bereits vorhandenen Datenbank wiederhergestellt wird, kann die Struktur der Sicherungskopie partiell wieder hergestellt werden; demzufolge geht die vorhandene Datenbankstruktur verloren, weshalb wir empfehlen, diese Option nicht zu verwenden. Zum Starten dieses Dienstes öffnen Sie den Reiter Datenbankverwaltung im STUDIO und wählen Sie Datenbank Wiederherstellen. Um den Dienst aus dem SQL Manager for InterBase/Firebird zu starten, benutzen Sie Dienste/Datenbank Wiederherstellen.
  2. Verwenden Sie DB Extract for InterBase/Firebird oder Assistenten des SQL Manager for InterBase/Firebird. Beide Werkzeuge erstellen Sicherungskopien der ganzen Datenbank oder benutzerdefinierten Objekten in Form von SQL Skripts. Das erstellte Skript kann SQL Utility Anweisungen, Daten Definitionsanweisungen oder Anweisungen für das Einfügen von Daten enthalten. Die Hauptvorteile dieser Methode sind die komplette oder partielle Sicherung der Datenbank-Struktur und Daten, sowie Flexibilität für Sonderwünsche. Beim Erstellen von großen Datenbanken mit dieser Methode gibt es jedoch die Nachteile, einer langen Zeitdauer und eines erhöhten Datenverkehrs. Um DB Extract aufzurufen, öffnen Sie den Reiter Datenanalyse im STUDIO und wählen Sie DB Extract for InterBase/Firebird. Um den Assistenten Datenbank Extrahieren zu starten, öffnen Sie den SQL Manager for InterBase/Firebird und wählen Werkzeuge/Datenbank Extrahieren. Um eine Datenbank aus einem Skript mit dieser Methode wiederherzustellen, müssen Sie einfach nur das Skript auf einem InterBase/Firebird Server ausführen. Verwenden Sie bitte das SQL Skript for InterBase/Firebird oder SQL Skript Tool des SQL Manager for InterBase/Firebird.
  3. Verwenden Sie Data Export for InterBase/Firebird. Diese Methode kann zu Sicherung von sämtlichen Tabellen verwendet werden. Verwenden Sie diese bitte nur, wenn Sie reine Daten, ohne deren Struktur sichern möchten. Wir empfehlen das CVS Format für die Sicherung von Daten. Um Data Export zu starten, öffnen Sie den Reiter Datenmanipulation im STUDIO und wählen Sie Data Export for InterBase/Firebird. Um den Assistenten Data Export aus dem SQL Manager for InterBase/Firebird zu starten, öffnen Sie Ihre Tabelle des Datenbank Reiters und wählen Sie Datenmanipulation/Daten Exportieren. Um die Daten aus der mit dieser Methode erstellten Datei wiederherzustellen, können Sie Daten Import for InterBase/Firebird oder den Assistenten für Datenimport aus dem SQL Manager for InterBase/Firebird verwenden. Klicken Sie hier ... für nähere Erläuterungen der Unterschiede zwischen Data Import for InterBase/Firebird und dem Assistenten für den Datenimport aus dem SQL Manager for InterBase/Firebird.

F: Welche Datenbank-Objekte werden in der Sicherungsdatei gespeichert?

A: Der Dienst Backup Datenbank kopiert alle Objekte der ausgewählten Datenbank. Es können auch die Tabelleninhalte der ausgewählten Datenbank optional kopiert werden. Dies wird gemäß dem eingestellten Pfad durchgeführt, der ein lokales Verzeichnis auf dem Server sein muss.

F: Ist es möglich, die Sicherung von einem Server auf einem anderen Server wiederherzustellen?

A:

  1. Die Sicherungsdatei, die mit dem Dienst Backup Database erstellt wurde, kann auf einem anderen Server wiederhergestellt werden, wenn er dieselbe oder eine höhere Version im Vergleich zur Serverversion besitzt, von der die Sicherung durchführt wurde. Bei der Wiederherstellung der Sicherungsdatei muss man außerdem den Servertyp beachten. Es wird nicht empfohlen, eine auf dem Firebird-Server erstellte Sicherungsdatei auf dem InterBase Server und umgekehrt wiederherzustellen. Diese Beschränkungen sind mit möglichen Unterschieden in der SQL Syntax, die bei der Erstellung der Datenbank-Objekte (DDL) und bei der Arbeit mit Daten (DML) auf verschiedenen Servern eingesetzt wird und auch mit der Vorhanden/Nicht Vorhandensein von bestimmten Datentypen in verschiedenen Servertypen und verschiedenen Serverversionen verbunden. Diese Beschränkungen sind nicht zwingend, und es ist sogar möglich, dass die Sicherungskopie trotz dem außer Acht Lassen wiederhergestellt wird. Daher kann nicht garantiert werden, dass eine solche Datenbank wieder einsatzbereit ist.
  2. Die Wiederherstellung der Sicherungskopie, die mit DB Extract for InterBase/Firebird oder Extract Database von dem SQL Manager for InterBase/Firebird erstellt wurde, ist denselben im Punkt 1 aufgeführten Beschränkungen unterworfen.
  3. Die mit Daten Export for InterBase/Firebird oder Save Daten Assistenten des SQL Manager for InterBase/Firebird erstellten Daten können in Tabellen jeder Version von InterBase- oder Firebird-Server wiederhergestellt werden.

F: Wo kann die Sicherungsdatei abgelegt werden?

A: Die Sicherungsdatei, die mit dem Dienst Backup Database erstellt wurde, kann sich nur in einem lokalen Verzeichnis auf dem Server befinden.

F: Was sind die Unterschiede zwischen Extract und BackUp Funktionen im STUDIO?

A: Der Dienst Backup Database erstellt die Sicherungsdateien aller Objekte der ausgewählten Datenbank, sowie die Tabellendaten gemäß dem definierten Pfad, der nur ein lokales Verzeichnis auf dem Server sein darf. DB Extract for InterBase/Firebird oder der Assistent zum Extrahieren von Datenbanken aus dem SQL Manager for InterBase/Firebird erstellt Sicherungen von Datenbanken oder benutzerdefinierten Objekten in Form eines SQL Skripts. Das erstellte Skript kann SQL Werkzeug-Anweisungen, Daten Definitionsanweisungen oder Anweisungen für das Einfügen von Daten enthalten. Folglich nutzt der Dienst Backup Database die Möglichkeiten des InterBase/Firebird Servers, um Sicherungsdatenbanken zu erstellen. Dieser Dienst zeichnet sich durch hohe Zuverlässigkeit aus, jedoch können die Dateien nicht in jedem Client-Verzeichnis abgelegt werden. Es wird empfohlen, diese Methode für die Sicherung der ganzen Datenbank zu verwenden. Der Hauptvorteil der Erstellung von Sicherungen mit dem DB Extract for InterBase/Firebird besteht darin, dass Sie die Struktur und die Daten von einigen spezifischen Datenobjekten oder Schemen und die Sicherungsdateien auf der Client-Seite speichern können. Der Nachteil dieser Methode ist die längere Dauer und der erhöhte Datenverkehr bei der Erstellung von Sicherungen großer Datenbanken.

Nach oben scrollen

Vorlagen Management

F: Für was werden die Vorlagen der Export/Import Funktionen verwendet? Für was sind diese gedacht?

A: Die Vorlagen in STUDIO werden für das abspeichern von Parametern für das Ausführen der STUDIO Tools verwendet. Mit den Vorlagen sind Sie in der Lage, die gleiche Operation zu wiederholen, ohne jedes Mal 10-20 Parameter im Assistenten anzugeben. Die in der Vorlage gespeicherten Parameter können einfach verändert werden oder Sie können eine neue Vorlage auf Basis einer bestehenden erstellen.

F: Wo sind die STUDIO Vorlagen abgelegt?

A: Eine Vorlage ist eine Datei, welche die notwendigen Parameter in einem bestimmten Format speichern kann. Vorlagendateien können überall auf Ihrem PC gespeichert werden, sofern Sie sich den Speicherort merken:). Zur Vereinfachung der Aufgabe des Abspeichern und Suchen nach Vorlagen gibt es im Studio eine Vorlagenverwaltung. Die Vorlagenverwaltung erlaubt es Ihnen die nötigen Vorlagen zu registrieren ohne sich weiterhin darum zu kümmern, wo diese gespeichert werden. Wenn Sie eine neue Vorlage im Studio erstellen, merkt sich die Vorlagenverwaltung automatisch den Ort wo diese gespeichert werden. Sämtliche Vorlagen werden bezüglich der Werkzeuge gruppiert, für die sie vorgesehen sind und stehen jederzeit zu Ihrer Verfügung. Um ein Werkzeug mit einer gewählten Vorlage auszuführen müssen Sie nur auf die Vorlage doppelklicken.

F: Wenn ich eine Vorlage aus der Liste in STUDIO lösche, wird diese auch von der Platte gelöscht?

A: Die Vorlagenverwaltung erlaubt Ihnen beide Operationen: eine Vorlage nur aus der Registrierung löschen oder es zusätzlich auch von der Festplatte zu löschen.

F: Wie kann ich eine neue Vorlage für den Import erstellen?

A: Um eine Vorlage für das Import Werkzeug zu erstellen sollten Sie das Import Werkzeug starten (Hauptmenü/Start/Data Import). Anschließend müssen Sie alle notwendigen Importparameter ausfüllen und jeweils den "Weiter" Button klicken. Im letzten Schritt des Assistenten müssen Sie mit Hilfe des Buttons "Tools/Vorlage Speichern" angeben, wo und unter welchem Namen Sie die neu erstellte Vorlage abspeichern möchten.

Nach oben scrollen

Planer

F: Ich muss einige DB-Management Funktionen außerhalb der Geschäftszeit (nachts) ausführen (Export von einer DB, Import dieser Daten in eine andere DB, Backup beider DBs). Hat STUDIO hierfür eine Lösung?

A: Ja, gewiss. Der STUDIO Planer wurde genau für diesen Zweck gedacht. Der Planer kann die die von Ihnen erstellten Aufgaben ausführen. Sie können den Zeitpunkt und die Periodizität der Ausführung der Task setzen. Jede Task kann eine unbegrenzte Anzahl von Schritten (elementare Operationen) enthalten. Eine Task muss mindestens einen Schritt enthalten. In Ihrem Fall müssen sie folgendes tun:

  1. Erstellen Sie eine neue Task
  2. Erstellen Sie 4 Schritte in der Task (Export, Import, Backup, Backup). Beim Erstellen dieser Schritte müssen Sie angeben, in welchen Vorlagen die notwendigen Parameter gespeichert sind.
  3. Planen Sie die in Schritt 1 erstellte Task im Task Planer.

F: Wie kann ich eine Aufgabe konfigurieren, damit ich im Falle eines Fehlers, eine Email an die angegebene Adresse erhalte?

A: Im Task Editor gibt es einen Reiter Benachrichtigungen. In diesem Reiter können Sie die geeignete Benachrichtigungsmethode angeben um über die erfolgreiche oder fehlerhafte Ausführung der Task informiert zu werden. Die aktuelle Version des STUDIO unterstützt folgende Benachrichtigungsarten: NetSend, Systemlog der Anwendungen (WIN), E-Mail.

F: Kann der Aufgabenprozess in Abhängigkeit der Ergebnisse von einzelnen Arbeitsschritten verändert werden?

A: Ja. Wenn Sie einen Arbeitsschritt erstellen/ändern können Sie angeben, welches der nächste Schritt sein soll. Außerdem, für jeden der drei Prozessereignisse (erfolgreicher Abschluss des Schrittes, fehlerhafter Abschluss oder Abschluss durch Timeout) können Sie eine separate Variante der nächsten Aufgaben angeben.

F: Wie kann ich die Info über die abgelaufenen Tasks sehen?

A: Sämtliche Informationen über die abgelaufenen Tasks werden in den Logs aufgezeichnet. Sie finden dort nicht nur die Informationen über die Task selbst, sondern auch über alle enthaltenen Schritte. Des Weiteren können Sie die Log-Dateien der Anhänge aus einem bestimmten Schritt sehen. Dies ist für die Analyse für Fehler in den Tasks und/oder den einzelnen Schritten sehr hilfreich. Die leistungsstarken Log-Filter helfen Ihnen nun die ausgewählten Datensätze zu sehen.

F: Was geschieht, wenn während der Durchführung der Aufgabe die Ausführung der Anwendung nicht beendet werden kann (kritischer Fehler, antwortet nicht)? Wird die Ausführung der Aufgabe gestoppt?

A: Um solche Konflikte zu lösen, können Sie in jedem Schritt der Task ein Timeout definieren. Wenn der Schritt länger als der definierte Timeout dauert, wird er mit dem Timeout Ereignis abgeschlossen und die Task wird mit dem nächsten Schritt weiter ausgeführt.

F: Was muss ich tun um mit dem Task Planer zu arbeiten?

A: Starten sie den STUDIO Agent (Icon in der Taskbar) um mit dem Task Planer zu arbeiten. Außerdem muss Ihr Computer währen der Zeit laufen, in dem Tasks gestartet werden sollen.

F: Was geschieht, wenn auf dem gerade gestarteten Computer, unausgeführte Tasks vorgefunden werden?

A: Diese Tasks werden nicht ausgeführt.

Nach oben scrollen

Log Management

F: Es ist mir wichtig, die Infos aus den Log-Dateien der Anwendungen zu bekommen, die vom Task Planer durchgeführt wurden. Speichert STUDIO diese Log-Dateien ab?

A: Ja. STUDIO hat ein geeignetes Werkzeug für die Arbeit mit den Log-Dateien. Während Sie einen Schritt im Task erstellen, können Sie den Pfad der Log-Datei der ausgeführten Anwendung angeben. Wenn Sie die Werkzeuge aus dem STUDIO auswählen, wird der Pfad der Log-Datei automatisch gesetzt. Die Log-Dateien der durchgeführten Schritte werden in der internen STUDIO Datenbank gespeichert und sind im Menü Navigation/Logs verfügbar.

F: Die externe Anwendung, die über eine der Tasks durchgeführt wurde hat keine Log-Datei, nur ein Bildschirm-Log. Wie kann ich die Daten vom Bildschirm sichern?

A: Wenn eine Anwendung keine Log-Datei enthält und nur Ausgaben auf dem Bildschirm erzeugt (im Text Modus), kann STUDIO diese Daten als eine Log-Datei abspeichern. Dafür müssen Sie bei Erstellen einer Task die Checkbox "Bildschirm in Log speichern" anklicken.

F: Wie lange werden die Log-Dateien im STUDIO beibehalten?

A: Log-Dateien werden unbegrenzt im STUDIO aufbewahrt. Sie können alle nicht mehr benötigten Log-Dateien manuell im STUDIO löschen (Reiter Logs).

Nach oben scrollen

Lokalisierung

F: Was für Interface Lokalisierungen sind im STUDIO verfügbar?

A: Die aktuelle Version des STUDIO unterstützt derzeit die Sprachen englisch, deutsch, französisch und russisch.

Nach oben scrollen

Haben Sie noch Fragen, dann kontaktieren Sie bitte unser Supportzentrum.


Verwandte Produkte

MySQL

Microsoft SQL

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL ist eine komplette Lösung für MySQL-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der MySQL-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die MySQL-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie MySQL-Datenbankentwurf, Migrationen, Extrahieren, MySQL-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für MySQL in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank-Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for MySQL alle wichtigen MySQL-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for MySQL EMS SQL Manager for MySQL umfasst leistungsstarke Werkzeuge zur Verwaltung und Entwicklung des MySQL-Servers. Der SQL Manager for MySQL hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle MySQL-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, MySQL-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, MySQL-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for MySQL bietet eine Vielzahl von weiteren Diensten an, die MySQL-Verwaltung erheblich vereinfachen.
dataexport | Data Export for MySQL EMS Data Export for MySQL ist ein leistungsfähiges Programm für den schnellen Export der Daten aus MySQL Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der EMS Data Export for MySQL enthält einen Assistenten zur visuellen Einstellung des Exports aus MySQL-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von MySQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for MySQL EMS Data Import for MySQL ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in MySQL-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere MySQL-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den MySQL-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von MySQL-Daten zu verwenden und vieles mehr.
datapump | Data Pump for MySQL EMS Data Pump for MySQL ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in MySQL Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for MySQL erheblich vereinfacht!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der MySQL-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche MySQL-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von MySQL-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for MySQL EMS DB Comparer for MySQL ist ein hervorragendes Werkzeug zum Vergleichen von MySQL-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der MySQL-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von MySQL-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for MySQL EMS DB Extract for MySQL ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for MySQL können sowohl die Metadaten aller Datenbankobjekte als auch die MySQL-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für MySQL Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for MySQL EMS SQL Query for MySQL ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die MySQL-Datenbanken erstellen können. Die MySQL-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit MySQL-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum MySQL Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for MySQL EMS Data Comparer for MySQL ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der MySQL-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den MySQL-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for MySQL bieten eine große Anzahl von Konfigurierungsparametern an, um die Daten von MySQL-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

Microsoft SQL

 | SQL Management Studio for SQL Server EMS SQL Management Studio for SQL Server ist eine komplette Lösung für SQL Server-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der SQL Server-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die SQL Server-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie SQL Server-Datenbankentwurf, Migrationen, Extrahieren, SQL Server-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für SQL Server in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for SQL Server alle wichtigen SQL Server-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server umfasst leistungsstarke grafische Werkzeuge zur Verwaltung und Entwicklung der Datenbanken des Microsoft SQL Servers. Der EMS SQL Manager for SQL Server erlaubt, Datenbankobjekte des MS SQL Servers einfach und direkt zu erstellen/zu bearbeiten, SQL-Skripts zu starten, Rechte von Benutzern des SQL-Servers und ihre Berechtigungen zu verwalten, SQL-Abfragen grafisch zu erstellen, mit Metadaten zu arbeiten, Datenbankdaten des SQL-Servers zu exportieren und zu importieren und vieles mehr.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server ist ein leistungsfähiges Programm für den schnellen Export der Daten aus SQL-Server-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for SQL Server enthält einen Assistenten zur visuellen Einstellung des Exports aus SQL-Server-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von SQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for SQL Server EMS Data Import for SQL Server ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in SQL Server-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere SQL Server-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den SQL Server-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von SQL Server-Daten zu verwenden und vieles mehr.
datapump | Data Pump for SQL Server EMS Data Pump for SQL Server ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in SQL Server Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for SQL Server erheblich vereinfacht!
datagenerator | Data Generator for SQL Server EMS Data Generator for SQL Server ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der SQL Server-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche SQL Server-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von SQL Server-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer for SQL Server ist ein hervorragendes Werkzeug zum Vergleichen von SQL Server-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der SQL Server-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von SQL Server-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for SQL Server EMS DB Extract for SQL Server ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for SQL Server können sowohl die Metadaten aller Datenbankobjekte als auch die SQL Server Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für SQL Server Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for SQL Server EMS SQL Query for SQL Server ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die SQL Server-Datenbanken erstellen können. Die SQL Server-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit SQL Server-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum SQL Server Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for SQL Server EMS Data Comparer for SQL Server ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der SQL Server-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den SQL Server Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for SQL Server bieten eine große Anzahl von Konfigurierungsparametern an, um die Daten von SQL Server-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL ist eine komplette Lösung für PostgreSQL-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der PostgreSQL-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die PostgreSQL-Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie PostgreSQL-Datenbankentwurf, Migrationen, Extrahieren, PostgreSQL-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für PostgreSQL in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank-Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for PostgreSQL alle wichtigen PostgreSQL-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for PostgreSQL EMS SQL Manager for PostgreSQL umfasst leistungsstarke grafische Werkzeuge zur Verwaltung und Entwicklung von Datenbanken des PostgreSQL-Servers. Der EMS SQL Manager for PostgreSQL erlaubt, Datenbankobjekte des PostgreSQL-Servers einfach und direkt zu erstellen/zu bearbeiten, SQL-Skripts zu starten, grafisch PostgreSQL-Datenbanken zu entwerfen, SQL-Abfragen zu erstellen, Metadaten zu extrahieren, auszudrucken und zu suchen, Datenbankdaten des PostgreSQL-Servers zu exportieren und zu importieren und vieles mehr.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL ist ein leistungsfähiges Programm für den schnellen Export der Daten aus PostgreSQL Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for PostgreSQL enthält einen Assistenten zur visuellen Einstellung des Exports aus PostgreSQL-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von PostgreSQL-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in PostgreSQL-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere PostgreSQL-Tabellen bzw. Sichten zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den PostgreSQL-Import abzuspeichern, einen speziellen Masseneinfügemodus zum schnelleren Importieren von PostgreSQL-Daten zu verwenden und vieles mehr.
datapump | Data Pump for PostgreSQL EMS Data Pump for PostgreSQL ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in PostgreSQL Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for PostgreSQL erheblich vereinfacht!
datagenerator | Data Generator for PostgreSQL EMS Data Generator for PostgreSQL ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der PostgreSQL-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche PostgreSQL-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von PostgreSQL-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer for PostgreSQL Server ist ein hervorragendes Werkzeug zum Vergleichen von PostgreSQL-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der PostgreSQL-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von PostgreSQL-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for PostgreSQL EMS DB Extract for PostgreSQL ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for PostgreSQL können sowohl die Metadaten aller Datenbankobjekte als auch die PostgreSQL-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für PostgreSQL Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for PostgreSQL EMS SQL Query for PostgreSQL ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die PostgreSQL-Datenbanken erstellen können. Die PostgreSQL-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit PostgreSQL-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum PostgreSQL Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer for PostgreSQL ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der PostgreSQL-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den PostgreSQL-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for PostgreSQL bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von PostgreSQL-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

InterBase / Firebird

SQL Management Studio for InterBase/Firebird

EMS SQL Management Studio for InterBase/Firebird ist eine komplette Lösung für InterBase und Firebird Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der InterBase und Firebird -Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die InterBase und Firebird Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie InterBase und Firebird Datenbankentwurf, Migrationen, Extrahieren, InterBase und Firebird -Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für IB und Firebird in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for InterBase und Firebird alle wichtigen InterBase-Tools und Firebird-Tools, um Sie produktiver als je zuvor zu machen!

SQL Manager for InterBase/Firebird

EMS SQL Manager for InterBase/Firebird ist ein leistungsstarkes Werkzeug zur Verwaltung und Entwicklung von Datenbanken des InterBase/Firebird-Servers. Der EMS SQL Manager for InterBase/Firebird eignet sich mit allen neuen Versionen der Datenbanken für IB und Firebird und unterstützt alle relevanten neuen Serverfeatures. Das Tool bietet eine Anzahl von leistungsstarken Werkzeugen an, wie z.B. Visual Database Designer, Visual Query Builder und Stored Procedure Debugger zur Entwicklung der SQL-Skripts für Interbase und Firebird und vieles mehr.

dataexport

Data Export for InterBase/Firebird

EMS Data Export for InterBase/Firebird ist ein leistungsfähiges Programm für den schnellen Export der Daten aus InterBase/Firebird Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for InterBase/Firebird enthält einen Assistenten zur visuellen Einstellung des Exports aus InterBase/Firebird-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von InterBase/Firebird-Exportaufträgen mithilfe einer Konfigurationsdatei.

dataimport

Data Import for InterBase/Firebird

EMS Data Import for InterBase und Firebird ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in InterBase und Firebird-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere InterBase/Firebird-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den InterBase und Firebird-Import abzuspeichern, Import-Parameter für jede Quelldatei anzugeben und vieles mehr.

datapump

Data Pump for InterBase/Firebird

EMS Data Pump for InterBase/Firebird ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in InterBase/Firebird Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for InterBase/Firebird erheblich vereinfacht!

datagenerator

Data Generator for InterBase/Firebird

EMS Data Generator for InterBase/Firebird ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der InterBase/Firebird-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche InterBase/Firebird-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von InterBase/Firebird-Testdaten auf einfache und direkte Weise.

dbcomparer

DB Comparer for InterBase/Firebird

EMS DB Comparer for InterBase/Firebird ist ein hervorragendes Werkzeug zum Vergleichen von InterBase/Firebird-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der InterBase/Firebird-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von InterBase/Firebird-Datenbanken einfach und schnell auszuführen.

extract

DB Extract for InterBase/Firebird

EMS DB Extract for InterBase/Firebird ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for InterBase/Firebird können sowohl die Metadaten aller Datenbankobjekte als auch die InterBase/Firebird-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für InterBase/Firebird Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.

query

SQL Query for InterBase/Firebird

EMS SQL Query for InterBase/Firebird ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die InterBase/Firebird-Datenbanken erstellen können. Die InterBase/Firebird-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit InterBase/Firebird-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum InterBase/Firebird Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.

datacomparer

Data Comparer for InterBase/Firebird

EMS Data Comparer for InterBase/Firebird ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der InterBase/Firebird-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den InterBase/Firebird-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for InterBase/Firebird bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von InterBase/Firebird-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.

Erfahren Sie mehr

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle ist eine komplette Lösung für Oracle-Datenbankverwaltung und Datenbankentwicklung. Mit Komponenten, die auf alle kritischen Bereiche der Oracle-Datenbankverwaltung zielen, ist das SQL Studio eine einzige Workbench, die Sie mit allen “must-have“ Tools versorgt, die für die Oracle- Datenbankverwaltung und das Verwalten von Datenbankschema und Datenbankobjekten nötig ist, sowie Oracle-Datenbankentwurf, Migrationen, Extrahieren, Oracle-Abfrageerstellung, Datenimport, Datenexport und Datenbankvergleich. Das SQL Studio vereinigt diese Datenbanktools für Oracle in einer leistungsstarken und einfach zu benutzenden Umgebung, für den “rund um die Uhr“ Einsatz. Ob Sie ein Datenbank- Administrator oder Anwendungsentwickler, DBA oder Businessanalyst sind, bietet das SQL Studio for Oracle alle wichtigen Oracle-Tools, um Sie produktiver als je zuvor zu machen!
 | SQL Manager for Oracle EMS SQL Manager for Oracle umfasst leistungsstarke Datenbankwerkzeuge zur Verwaltung und Entwicklung von Datenbanken des Oracle-Servers. Der SQL Manager Oracle hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle Oracle-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, Oracle-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, Oracle-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for Oracle bietet eine Vielzahl von weiteren Diensten an, die Oracle-Verwaltung erheblich vereinfachen.
dataexport | Data Export for Oracle EMS Data Export for Oracle ist ein leistungsfähiges Programm für den schnellen Export der Daten aus Oracle-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for Oracle enthält einen Assistenten zur visuellen Einstellung des Exports aus Oracle-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von Oracle-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for Oracle EMS Data Import for Oracle ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in Oracle-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere Oracle-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den Oracle-Import abzuspeichern und vieles mehr.
datapump | Data Pump for Oracle EMS Data Pump for Oracle ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in Oracle-Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for Oracle erheblich vereinfacht!
datagenerator | Data Generator for Oracle EMS Data Generator for Oracle ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der Oracle-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche Oracle-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von Oracle-Testdaten auf einfache und direkte Weise.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle ist ein hervorragendes Werkzeug zum Vergleichen von Oracle-Datenbankschemas und Entdeckung von Unterschieden in deren Strukturen. Alle Unterschiede zwischen den Objekten der Datenbanken werden angezeigt. Die Unterschiede in der Oracle-Datenbanken können insgesamt oder gemäß Ihrer Auswahl mit Hilfe eines automatisch generierten SQL-Skripts synchronisiert und beseitigt werden. Sie können Vergleichsparameter nach Ihren Wünschen einstellen und weitere Features, um Ihre Arbeit mit dem Synchronisierungstool von Oracle-Datenbanken einfach und schnell auszuführen.
extract | DB Extract for Oracle EMS DB Extract for Oracle ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for Oracle können sowohl die Metadaten aller Datenbankobjekte als auch die Oracle-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für Oracle Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for Oracle EMS SQL Query for Oracle ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die Oracle-Datenbanken erstellen können. Die Oracle-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit Oracle-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum Oracle-Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle ist ein leistungsfähiges und bedienungsfreundliches Werkzeug für den Vergleich und die Synchronisation der Oracle-Daten. Mit der Hilfe dieses Utilities können Sie alle Unterschiede in den Oracle-Tabellen vergleichen, anschauen und einen automatischen Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der Data Comparer for Oracle bietet eine große Anzahl von Konfigurierungsparametern an, um die Daten von Oracle-Datenbanken schnell und effizient vergleichen und synchronisieren zu können.
 | Erfahren Sie mehr

DB2

 | SQL Manager for DB2 EMS SQL Manager for DB2 umfasst leistungsstarke Datenbankwerkzeuge zur Verwaltung und Entwicklung von DB2-Datenbanken. Der SQL Manager Oracle hat eine benutzerfreundliche grafische Oberfläche und erlaubt, alle DB2-Datenbankobjekte auf eine einfache und direkte Weise zu erstellen/zu bearbeiten, DB2-Datenbanken grafisch zu entwerfen, SQL-Skripts zu starten, DB2-Datenbankdaten zu importieren und zu exportieren. Der SQL Manager for DB2 bietet eine Vielzahl von weiteren Diensten an, die DB2-Verwaltung erheblich vereinfachen.
dataexport | Data Export for DB2 EMS Data Export for DB2 ist ein leistungsfähiges Programm für den schnellen Export der Daten aus DB2-Datenbanken in 19 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF, ODF und viele andere. Der Data Export for DB2 enthält einen Assistenten zur visuellen Einstellung des Exports aus DB2-Datenbanken und ein Befehlszeilen-Dienstprogramm zur automatischen Erstellung von DB2-Exportaufträgen mithilfe einer Konfigurationsdatei.
dataimport | Data Import for DB2 EMS Data Import for DB2 ist ein leistungsfähiges Tool zum Importieren von Daten aus MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF und HTML-Dateien in DB2-Tabellen. Das Dienstprogramm erlaubt, gleichzeitig die Daten in eine oder mehrere DB2-Tabellen bzw. Sichten schnell zu importieren, alle in der aktuellen Sitzung festgelegten Parameter für den DB2-Import abzuspeichern und vieles mehr.
datapump | Data Pump for DB2 EMS Data Pump for DB2 ist ein hervorragendes Migrationstool zum Konvertieren von Datenbanken und Importieren von Tabellendaten aus einer ADO-kompatibeln Quelle (z.B. MS Access, MS SQL Datenbank oder einer anderen Datenbank mit ADO-Unterstützung) in DB2 Datenbanken. Die Datenbankkonvertierung und -migration wird mithilfe des Data Pump for DB2 erheblich vereinfacht!
datagenerator | Data Generator for DB2 EMS Data Generator for DB2 ist ein hervorragendes Werkzeug für das Erzeugen von Testdaten für Tabellen der DB2-Datenbanken. Mit Hilfe dieser Anwendung kann man die Datenbank-Produktionsumgebung simulieren und unterschiedliche DB2-Datenbanktabellen mit Testdaten gleichzeitig auffüllen, Tabellen und Felder für die Erstellung der Daten definieren, Wertebereiche setzten, Generierungsparameter für jeder Feldtyp einstellen und vieles mehr. Das Programm hat eine große Anzahl von leistungsstarken Funktionalitäten zum Generieren von DB2-Testdaten auf einfache und direkte Weise.
extract | DB Extract for DB2 EMS DB Extract for DB2 ist ein leistungsfähiges und anwenderfreundliches Werkzeug für die Erstellung von Datenbank-Backups in Form von SQL-Skripts. Mit Hilfe des DB Extract for DB2 können sowohl die Metadaten aller Datenbankobjekte als auch die DB2-Tabellendaten als Datenbanksnapshots gesichert werden. Die flexiblen Anpassungsmöglichkeiten des Extrahierungsprozesses ermöglichen es, Objekte und Datentabellen für DB2 Datenbank-Dump auszuwählen und viele anderen Optionen einzustellen.
query | SQL Query for DB2 EMS SQL Query for DB2 ist ein hilfreiches Tool, mit dem Sie schnell und einfach SQL-Abfragen für die DB2-Datenbanken erstellen können. Die DB2-Abfragen können grafisch oder in Textform erstellt werden. Mit Hilfe der benutzerfreundlichen grafischen Oberfläche können Sie sich mit DB2-Datenbanken verbinden, Tabellen und Felder für die Abfrage zum DB2-Server auswählen, Kriterien der Auswahl und vieles mehr einstellen.
 | Erfahren Sie mehr

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL (für Borland Delphi und C++ Builder) erlaubt Ihnen, Daten in allen gängigen Datenformaten zum späteren Anzeigen, Ändern, Drucken oder Webveröffentlichen zu speichern. Es ist nicht mehr nötig, Zeit für eine anstrengende Datenkonvertierung zu verschwenden. Der Advanced Data Export wird schnell und einfach die Aufgabe ausführen und das Ergebnis im gewünschten Format ausgeben.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET ist eine Komponentensuite für Microsoft Visual Studio .NET 2003, 2005, 2008 und 2010 zum Speichern von Daten in die gängigsten Formate, um dann die Daten betrachten, modifizieren, ausdrucken oder im Internet veröffentlichen zu können. Die Daten können in MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV und viele andere Formate exportiert werden. Jetzt ist es nicht mehr nötig, Zeit zu verschwenden, um Daten per Hand zu konvertieren. Der Advanced Data Export erledigt die Aufgabe einfach und schnell und gibt das Resultat in dem gewünschten Format aus.
advancedimport | Advanced Data Import Advanced Data Import VCL ist ein Komponentensuite für Borland Delphi und C++ Builder, das Ihnen erlaubt Daten aus allen populären Dateiformaten in Datenbank zu importieren. Sie können Daten aus MS Excel, MS Access, DBF, XML, TXT und CSV importieren. Jetzt ist es nicht mehr nötig Zeit zu verschwenden, um Daten per Hand zu konvertieren.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator Komponenten Paket bittet die einfachste Möglichkeit PDF Dokumente zu erzeugen, die mit Delphi oder C++ Builder geschrieben wurden. Sie müssen nicht unbedingt die obligatorischen Spezifikationen der PDF wissen, aber Sie können einfach und schnell mit Hilfe von Advanced PDF Generator PDF-Dateien generieren.
querybuilder | Advanced Query Builder Advanced Query Builder ist eine leistungsstarke Komponentensuite für Borland Delphi und C++ Builder, bestimmt für die visuelle Konstruktion der SQL-Abfragen für die SELECT, INSERT, UPDATE und DELETE Klauseln. Er erlaubt Ihnen, neue visuelle Abfragen zu erstellen und/oder grafisch die bestehenden Abfragen in Ihrer Anwendung darzustellen.
excelreport | Advanced Excel Report Advanced Excel Report Komponent für Delphi ist ein mächtiger Bericht Generator in MS Excel, gegründet auf dem Sektionsprinzip der Konstruktion mit der Benutzung der Vorlagen. Der bequeme Redakteur der Komponente Eigenschaften lassen schnell Berichte für MS Excel erschaffen.
advancedlocalizer | Advanced Localizer Advanced Localizer ist ein unersetzliches Komponentenpaket für Borland Delphi zur mehrsprachigen Hilfe in Ihrer Delphi Anwendung. Mit Hilfe dieses Paketes können Sie einfach und schnell die Eigenschaft aller Komponenten auf jeder Form lokalisieren. Erstellen Sie eine Sprachdatei, der die aktuelle Werte von sprachspezifierten Teileigenschaften enthalten, verwalten Sie lokale Dateien und spezifieren welche Komponenten zu lokalisieren sind.
sourcerescuer | Source Rescuer EMS Source Rescuer ist ein leichtes Utility, das Ihnen helfen kann, den verlorenen Quellcode wiederherzustellen. Falls Sie die Ausgangstexte Ihrer Anlage, die auf Delphi oder C++Builder geschrieben wurde, verloren haben, aber besitzen noch die exe. Datei, dann hilft Ihnen das Utility den Teil der Ausgangstexte wiederherzustellen.
 | Erfahren Sie mehr


Start

Der unten gezeigte Screenshot ist ein Standardbildschirm des SQL Management Studio for InterBase/Firebird. Um die Hauptfunktionen des Programms kennen zu lernen, Informationen über die funktionale Möglichkeiten und die Oberfläche zu bekommen oder Benutzereinstellungen zu erfahren, folgen Sie diesen Links:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Hauptmenü

Toolbars

Arbeitsbildschirm

Navigationsleiste

DB Explorer

Haben Sie Spaß an Ihrer Arbeit mit SQL Management Studio for InterBase/Firebird !

Siehe auch:

Datenbank-Management und Manipulation

Task Planer und Ausführung

Online-Ressourcen

Programmoptionen einstellen


Arbeit mit Studio Agent

SQL Management Studio for InterBase/Firebird Agent ist ein Programm, das im Windows System-Tray liegt und Ihnen hilft Hauptoperationen des SQL Management Studio for InterBase/Firebird auszuführen. Starten Sie SQL Management Studio for InterBase/Firebird durch Doppelklick auf das Agent-Icon.

Sie können mit SQL Management Studio for InterBase/Firebird Agent auch Folgendes tun:

Getting Started - Using Studio Agent

  • Benutzertask ausführen
  • Geplanten Task aussetzen

Diese Optionen befinden sich im Kontextmenü des Agents, das durch Klicken der rechten Maustaste auf das Icon im System-Tray geöffnet wird.

Anmerkung: Um den Agent automatisch mit Windows starten, wählen Sie bitte den entsprechenden Menüpunkt.

Siehe auch:

Auswahl der Sprache

Arbeit starten

Hauptmenü

Toolbars

Arbeitsbildschirm

Navigationsleiste

DB Explorer


Auswahl der Sprache

Wenn Sie SQL Management Studio for InterBase/Firebird zum ersten Mal starten, müssen Sie die Programmsprache wählen. Sie können auch diese Einstellungen später ändern: gehen Sie nur zu Optionen | Lokalisation , um die Programmsprache zu wählen.

Getting Started - Select language

Siehe auch:

Arbeit mit Studio Agent

Arbeit starten

Hauptmenü

Toolbars

Arbeitsbildschirm

Navigationsleiste

DB Explorer


Arbeit starten

Der unten angezeigte Screenshot ist ein Standardbildschirm des SQL Management Studio for InterBase/Firebird. Der Arbeitsbildschirm ist der Hauptarbeitsplatz des SQL Management Studio for InterBase/Firebird; abhängig vom ausgewählten Punkt in der Navigationsleiste können Sie EMS Programme und Werkzeuge starten (Start mit einer Vorlage ist auch möglich), Tasks erzeugen und ihre Ausführung planen, online technische Unterstützung erhalten und viele andere Aufgaben ausführen.

Die Navigationsleiste befindet sich im linken Teil des SQL Management Studio for InterBase/Firebird Fensters. Wenn Sie die entsprechenden Werkzeugleisten wählen, schalten Sie zwischen verschiedene Optionen für InterBase/Firebird und Daten-Management um.

Die folgenden Werkzeugleisten zeigen Optionen für InterBase/Firebird und Daten-Management an:

Toolbar

Datenbank-Management

Datenmanipulation

Datenanalyse

Vorlage-Management

Taskbar

Benutzertasks

Task Planer

Logs

Internetbar

Internetressourcen

SQL Direct Studio

Support

Unter der Navigationsleiste finden Sie den DB Explorer, er zeigt alle registrierten Hosts und Datenbaken an. Mit der Hilfe des DB Explorer können Sie Elemente in/aus dem DB Explorer-Baum hinzufügen/entfernen, Datenbank- und Host-Registrierungsinfo sehen sowie InterBase/Firebird Dienste für die ausgewählte Datenbanken starten. Sie können auch Datenbankregistrierungsinfo in den Werkzeugen finden, die zum SQL Management Studio for InterBase/Firebird gehören.

Der Hauptsymbolleiste dupliziert die Funktionen der Navigationsleiste.

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Hauptmenü

Toolbars

Arbeitsbildschirm

Navigationsleiste

DB Explorer


Hauptmenü

Das Hauptmenü des SQL Studio for InterBase/Firebird erlaubt es Ihnen, Hosts und Datenbanken zu registrieren, zwischen InterBase/Firebird- und Daten-Management Optionen umzuschalten, Werkzeuge zu starten, SQL Studio for InterBase/Firebird Funktionen anzupassen, Hilfe zu lesen und vieles mehr.

Getting Started - Main menu

Datenbank

Datenbank registrieren

Startet den Assistenten Datenbank Registrierung, der Sie durch den Registrierungsvorgang führt.

Datenbank entfernen

Entfernt die Registrierung der Datenbank aus dem DB Explorer-Baum.

Datenbankregistrierungsinfo

Zeigt das Datenbankregistrierungsinfo-Fenster an.

Host registrieren

Startet Host Registrierungsassistenten, der Sie durch den Registrierungsvorgang führt.

Host entfernen

Deregistriert den Host (einschließlich aller seinen Datenbanken) und entfernt ihn aus dem DB Explorer-Baum.

Beenden

Schließt das SQL Studio for InterBase/Firebird.

Ansicht

Erlaubt es Ihnen, die Ansicht des SQL Studio for InterBase/Firebird zu ändern. Sie können die Werkzeugleisten der Navigationsleiste umschalten und die Werkzeugbeschreibung ein/ausschalten.

Navigation

Dieser Menüpunkt erlaubt es Ihnen, zwischen verschiedenen Optionen für InterBase/Firebird und Daten-Management umzuschalten. Er dupliziert die Funktionen der Navigationsleiste.

Start

Starten Sie eines der Werkzeuge des SQL Studio for InterBase/Firebird durch diesen Menüpunkt.

Optionen

Erlaubt Ihnen, Oberflächeneinstellungen des SQL Studio for InterBase/Firebird zu ändern und die Programmsprache zu wählen.

Hilfe

Startet die SQL Studio for InterBase/Firebird Hilfe, erlaubt Ihnen die offizielle Webseite des SQL Studio for InterBase/Firebird zu besuchen und Ihr Programm zu registrieren.

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Toolbars

Arbeitsbildschirm

Navigationsleiste

DB Explorer


Toolbars

Die Hauptwerkzeugleiste finden Sie über dem Arbeitsbildschirm. Durch Auswahl der entsprechenden Leisten, schalten Sie zwischen verschiedenen Optionen für InterBase/Firebird- und Daten-Management um.

Die folgende Leisten zeigen die verfügbaren Optionen für InterBase/Firebird- und Daten-Management an:

Datenbank-Management

Datenmanipulation

Datenanalyse

Vorlagen-Management

Benutzertasks

Task Planer

Logs

Internetressourcen

SQL Direct Studio

Support

Beachten Sie, dass Sie den Hauptwerkzeugleiste anpassen können, um Ihre Bedürfnisse zu befriedigen.

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Hauptmenü

Arbeitsbildschirm

Navigationsleiste

DB Explorer


Arbeitsbildschirm

Der Arbeitsbildschirm ist der Hauptarbeitsplatz des SQL Studio for InterBase/Firebird; abhängig vom ausgewählten Punkt in der Navigationsleiste können Sie EMS Programme und Werkzeuge starten (Start mit einer Vorlage ist auch möglich), Tasks erzeugen und ihre Ausführung planen, Online technische Unterstützung anfordern and viele andere Aufgaben ausführen.

Getting Started - Desktop Panel

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Hauptmenü

Toolbars

Navigationsleiste

DB Explorer


Navigationsleiste

Die Navigationsleiste befindet sich im linken Teil des SQL Management Studio for InterBase/Firebird Fensters. Wenn Sie die entsprechende Werkzeugleiste wählen, schalten Sie zwischen verschiedene Optionen für InterBase/Firebird und Daten-Management um.

Die folgenden Leisten zeigen Optionen für InterBase/Firebird und Daten-Management an:

Toolbar

Datenbank-Management

Datenmanipulation

Datenanalyse

Vorlage-Management

Taskbar

Benutzertasks

Task Planer

Logs

Internetbar

Internetressourcen

SQL Studio Direct

Support

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Hauptmenü

Toolbars

Arbeitsbildschirm

DB Explorer


DB Explorer

Unter der Navigationsleiste finden Sie den DB Explorer, er zeigt alle registrierten Hosts und Datenbaken an. Mit der Hilfe vom DB Explorer können Sie Elemente in/aus dem DB Explorer-Baum hinzufügen/entfernen, Datenbank- und Host-Registrierungsinfo ansehen sowie InterBase/Firebird Dienste für die ausgewählte Datenbank starten. Sie können auch Datenbankregistrierungsinfo in den Werkzeugen finden, die zum SQL Studio for InterBase/Firebird gehören.

Getting Started - DB Explorer

Um einen Host oder eine Datenbank im DB Explorer-Baum hinzuzufügen, verwenden Sie den entsprechenden Punkt im Kontextmenü oder wählen Sie im Hauptmenüpunkt Datenbank | Host registrieren (Datenbank | Datenbank registrieren für Datenbank). Sie können auch die DB Explorer Toolbar benutzen.

Um einen Host oder eine Datenbank aus dem DB Explorer-Baum zu entfernen, verwenden Sie den entsprechenden Punkt im Kontextmenü oder wählen Sie im Hauptmenüpunkt | Host unregistrieren (Datenbank | Datenbank unregistrieren für Datenbank). Sie können auch die DB Explorer Toolbar benutzen.

Datenbankregistrierungsinfos können unter Verwendung des DB Explorer-Kontextmenüs oder SQL Studio for InterBase/Firebird Hauptmenü eingesehen werden.

Um einen InterBase/Firebird Dienst für die registrierte Datenbank zu starten, klicken Sie im DB Explorer mit der rechten Maustaste auf die entsprechende Datenbank und wählen Sie den gewünschten Dienst im Abschnitt Datenbank-Management des Kontextmenüs.

Siehe auch:

Arbeit mit Studio Agent

Auswahl der Sprache

Arbeit starten

Hauptmenü

Toolbars

Arbeitsbildschirm

Navigationsleiste


Datenbank-Management und Manipulation

Sämtliche Möglichkeiten für Datenbank-Management und - Manipulation, die SQL Studio for InterBase/Firebird bietet, teilen sich in mehrere Gruppen auf:

Datenbank-Management

Diese Gruppe erlaubt Ihnen, Datenbanken mit der Hilfe des SQL Manager for InterBase/Firebird zu verwalten und zu entwickeln sowie InterBase/Firebird Dienste zu starten.

Datenmanipulation

Diese Gruppe bietet viele Möglichkeiten, um Daten in/aus 15 gängingen Formaten zu importieren und exportieren, zwischen Datenbanken der verschiedenen Server zu migrieren und Testdaten für Datenbanken zu generieren.

Datenanalyse

Die Werkzeuge dieser Gruppe erlauben es Ihnen, den Inhalt und Struktur Ihrer Datenbanken zu vergleichen und zu synchronisieren, eine Sicherung der Datenbank in Form eines SQL-Skripts zu erstellen, sowie Ihre Daten zu analysieren und Abfragen visuell zu erstellen.

Vorlage-Management

Für Ihre effiziente Arbeit gibt es jetzt die Möglichkeit, Vorlagen zu erstellen und sie zu verwalten.

Sie können diesen Abschnitt auch mit dem entsprechenden Symbol in der Navigationsleiste wählen.

Siehe auch:

Start

Task Planer und Ausführung

Online-Ressourcen

Programmoptionen einstellen


Datenbank-Management

Der Abschnitt Datenbank-Management erlaubt es Ihnen, Datenbanken mit der Hilfe des SQL Manager for InterBase/Firebird zu verwalten und zu entwickeln sowie InterBase/Firebird zu starten.

SQL Manager starten

Verwenden der Dienste

Database Management - Desktop Panel

Siehe auch:

Datenmanipulation

Datenanalyse

Vorlage-Management


SQL Manager starten

SQL Manager for InterBase/Firebird ist ein leistungsfähiges graphisches Werkzeug für die Verwaltung und Entwicklung von InterBase/Firebird Datenbanken. Die benutzerfreundliche graphische Oberfläche macht die Arbeit mit Datenbanken und Objekten einfacher, ermöglicht es die Datentabellen zu verwalten und SQL-Skripts auszuführen. SQL Manager for InterBase/Firebird bietet viele leistungsstarke Werkzeuge für erfahrene Benutzer wie Visual Database Designer und Visual Query Builder an. Sie können leicht mit Metadaten arbeiten, Daten in/aus 15 gängingen Formaten importieren und exportieren, BLOB-Felder bearbeiten und anders mehr.

Starten Sie SQL Manager for InterBase/Firebird durch Klicken auf das entsprechende Icon oder den Link im Arbeitsbildschirm.

Database Management - Running SQL Manager

Siehe auch:

Verwenden der Dienste


Verwenden der Dienste

SQL Management Studio for InterBase/Firebird vereinigt Features, die einfache Möglichkeiten für den Start aller nativen Diensten InterBase/Firebird zur Wartung der Datenbank und Tabellen anbieten. Folgende Dienste stehen zur Verfügung:

Database Management - Services

Backup (Datensicherung) der Datenbank

Speichern der Tabellen vom lokalen Host in den Dateien für zukünftige Wiederherstellung.

Wiederherstellung der Datenbank

Wiederherstellung der Tabellen aus den Dateien auf der Platte in die Datenbank.

Validierung der Datenbank

Validierung der Datenbank für die Prüfung der Integrität der Datenbankstruktur.

Datenbankstatistik

Erhalt der Datenbankstatistik

Online Schalten oder Herunterfahren der Datenbank

Diese Option ermöglicht Ihnen eine Datenbank herunterzufahren (ab uns zu braucht man zu einem einzigen DB-Verbindungsmodus umzuschalten) und die Datenbank wieder zurück online zu bringen.

Neuerstellen und Neuberechnen von Datenbank-Indizes

Die Option ermöglicht, die Indizes neu zu erstellen und neu zu berechnen. Hochgradig fragmentierte Indizes können die Abfrageleistungen beeinträchtigen. Die Index-Fragmentierung kann entweder durch Neuorganisieren oder Neuerstellen des Index behoben werden.

Um den Dienst zu starten, klicken Sie bitte auf das Icon oder die Überschrift an der Desktopleiste und verfolgen Sie die Schritte des Assistenten.

Siehe auch:

SQL Manager starten


Datenmanipulation

Der Abschnitt Datenmanipulation bietet viele Möglichkeiten, um Daten in/aus 15 gängingen Formaten zu importieren und zu exportieren, zwischen Datenbanken der verschiedenen Server zu migrieren und Testdaten für Datenbanken zu generieren.

Data Export starten

Data Import starten

Data Pump starten

Data Generator starten

Getting Started - Desktop Panel

Siehe auch:

Datenbank-Management

Datenanalyse

Vorlage-Management


Data Export starten

Data Export for InterBase/Firebird ist ein leistungsstarkes Programm für den schnellen Export der Daten aus den InterBase/Firebird Datenbanken in einer der 20 Formate, einschließlich MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF usw. Data Export for InterBase/Firebird besitzt einen Assistenten, der Ihnen ermöglicht, Exportoptionen für jede Tabelle visuell (exportierte Felder, Datenformate, und viel mehr) zu erstellen. Das Kommandozeilen-Werkzeug erlaubt es Ihnen Daten aus den Tabellen und den Abfragen mit nur einem Klick zu exportieren.

Data Manipulation - Running Data Export

Data Export kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Exportvergangs. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Data Export Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

Data Export documentation.

Siehe auch:

Data Import starten

Data Pump starten

Data Generator starten

SQL Skript starten


Data Import starten

Data Import for InterBase/Firebird ist ein leistungsstarkes Programm, um Ihre Daten schnell aus MS Excel, MS Access, DBF, XML, TXT und CSV Dateien in InterBase/Firebird Tabellen zu importieren. Es bietet justierbare Importparameter, einschließlich der Quelldatenformate für alle Felder und Zielformate für die ausgewählten Felder, Zahl der Aufzeichnungen, usw. Data Import for InterBase/Firebird beinhaltet einen Assistenten, der Ihnen erlaubt, alle Importoptionen für verschiedene Dateien visuell zu setzen, und ein Kommandozeilen-Werkzeug, um Daten mit nur einem Klick zu importieren.

Data Manipulation - Running Data Import

Data Import kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Importvorgangs. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Data Import Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

Data Import documentation.

Siehe auch:

Data Export starten

Data Pump starten

Data Generator starten

SQL Skript starten


Data Pump starten

Data Pump for InterBase/Firebird ist ein leistungsfähiges Werkzeug für die Konvertierung der Datenbanken und Import von Tabellendaten aus einer ADO-Compatible Quelle (Datenbank wie z.B. MS Access oder irgendeine andere Datenbank mit ADO Support) in die InterBase/Firebird Datenbanken. Der benutzerfreundliche Assistent Anwendung erlaubt Ihnen, die ADO-Verbindung zu erstellen, sowie Tabellen, Felder und Indizes umzuwandeln, SQL-Skripts zu bearbeiten und Tabellen für Import vorzuwählen. Datenkonvertierung mit dem Data Pump for InterBase/Firebird wird so einfach, wie noch nie zu vor.

Data Manipulation - Running Data Pump

Data Pump kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Prozesses. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Data Pump Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

Data Pump documentation.

Siehe auch:

Data Export starten

Data Import starten

Data Generator starten

SQL Skript starten


Data Generator starten

Data Generator for InterBase/Firebird ist ein leistungsfähiges Werkzeug, um Testdaten für die eigene InterBase/Firebird Datenbanken erzeugen zu können. Der einfache und benutzerfreundliche Assistent erlaubt Ihnen, Tabellen und Felder für die Erzeugung der Daten zu definieren, Wertstrecken zu setzen, Felder durch Vorlage zu erzeugen, Werte für BLOB-Felder aus den Dateien zu laden, Wertelisten aus den SQL-Abfragen zu bekommen. Dazu gehört auch eine Komandozeilen-Anwendung, die Ihnen erlaubt, Daten mit Hilfe von speziellen Vorlagen mit nur einem Klick zu erzeugen.

Data Manipulation - Running Data Generator

Data Generator kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Generierungsvorgangs. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Data Generator Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

Data Generator documentation.

Siehe auch:

Data Export starten

Data Import starten

Data Pump starten

SQL Skript starten


SQL Skript starten

Die Utility SQL Skript ist ein leicht zu bedienendes Werkzeug zur effizienten Ausführung von SQL Skripts.

Das SQL Skript for InterBase/Firebird stellt ein Editor-Fenster bereit, das leicht die Skripts zu verwalten ermöglicht. Außer der GUI-Version enthält das SQL Skript InterBase/Firebird eine Konsoleversion, die zum Starten aus der Windows-Befehlszeile mit einer Vorlage-Dateiname bestimmt, der als Ausführungsparameter verwendet wird.

Um das SQL Skript for InterBase/Firebird starten zu können, muss man das Icon oder die Beschriftung auf der Desktop-Leiste anklicken und die Schritte des Assistenten befolgen. Bei Bedarf kann die Schaltfläche "Pfeil nach unten" zum Öffnen des Menüs angeklickt werden. Somit kann eine Vorlage angegeben werden und der Assistent/die Konsole mit der Vorlage gestartet werden.

Zur Verwaltung der Konfigurationsdateien (Vorlagen) verwendet man einen entspechenden Link zur Verwaltung von Vorlagen. In diesem Fall wird man zum Vorlagenverwaltung-Abschnitt des SQL Management Studio umgeleitet.

Data Manipulation - Running SQL Script

SQL Skript Dokumentation.

Siehe auch:

Data Export starten

Data Import starten

Data Pump starten

Data Generator starten


Datenanalyse

Der Abschnitt Datenanalyse enthält die Werkzeuge, die Ihnen erlauben, den Inhalt und Struktur Ihrer Datenbanken zu vergleichen und zu synchronisieren, Sicherungskopien der Datenbank in Form eines SQL-Skripts zu erstellen, sowie Ihre Daten zu analysieren und Abfragen grafisch zu erstellen.

Data Comparer starten

Database Comparer starten

DB Extract starten

SQL Query starten

Data Analysis - Desktop Panel

Siehe auch:

Datenbank-Management

Datenmanipulation

Vorlage-Management


Data Comparer starten

Data Comparer for InterBase/Firebird ist ein leistungsfähiges und bedienerfreundliches Werkzeug für den Vergleich und die Synchronisierung der Daten. Sie können alle Unterschiede in den Tabellen anschauen und ein automatisches Skript ausführen, um alle ausgewählten Unterschiede zu beseitigen. Der flexible benutzerfreundliche Prozess hilft Ihnen, Tabellen und Felder zu vergleichen und sie zu synchronisieren und viele andere Optionen einzustellen. Data Comparer for InterBase/Firebird schließt einen graphischen Assistenten mit ein, der Sie Schritt für Schritt durch den Vergleichs- und den Synchronisationsprozess führt und ein Kommandozeilen-Werkzeug für die Datensynchronisation mit nur einem Klick.

Data Analysis - Running Data Comparer

Data Comparer kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Vergleichsvorgangs. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Data Comparer Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

Data Comparer documentation.

Siehe auch:

Database Comparer starten

DB Extract starten

SQL Query starten


Database Comparer starten

DB Comparer for InterBase/Firebird ist ein ausgezeichnetes Werkzeug für die InterBase/Firebird Synchronisation und den Vergleich von Datenbanken. Sie können alle Unterschiede in den Tabellen anschauen und ein automatisches Skripts ausführen, um alle ausgewählten Unterschiede zu beseitigen. Seine einfache und verständliche Benutzeroberfläche erlaubt Ihnen, mit mehreren Projekten gleichzeitig zu arbeiten, Vergleichsparameter nach Ihren Wünschen einzustellen, Reporte und modifizierte Skripts auszudrucken. Viele andere Eigenschaften machen die Arbeit mit dem Werkzeug schnell und einfach.

Data Analysis - Running DB Comparer

Database Comparer kann separat gestartet werden, der Assistent führt Sie durch alle Schritte des Vergleichsvorgangs. Klicken Sie dazu auf das entsprechende Icon oder den Link.

Wenn Sie das Werkzeug mit einer Vorlage benutzen möchten, wählen Sie die entsprechende Option unter dem Database Comparer Link.

Die Option Vorlagenverwaltung führt Sie in den Abschnitt Vorlagen-Management des SQL Studio for InterBase/Firebird.

DB Comparer documentation.

Siehe auch:

Data Comparer starten

DB Extract starten

SQL Query starten


DB Extract starten

DB Extract for InterBase/Firebird ist ein leistungsfähiges und bedienerfreundliches Werkzeug für die Erstellung von Datenbanksicherungen in Form eines SQL-Skripts. Er erlaubt Ihnen, Metadaten aller Datenbankobjekte sowie Tabellendaten zu speichern. Mit flexibler Kundenbezogenheit des Extraktprozesses können Sie Objekte und Datentabellen für Extrakt vorwählen und viele andere Optionen zu setzen. DB Extract for InterBase/Firebird schließt einen graphischen Wizard mit ein, der Sie Schritt für Schritt durch den Extraktprozess führt. Dazu gehört auch ein Command Line Service, um nur mit einem Klick Sicherungskopien zu erstellen.

Data Analysis - Running DB Extract

DB Extract kann alein gestartet werden, der Wizard wird Ihnen durch alle Schritte des Exportvergangs führen. Klicken Sie nur auf sein Icon oder Beschriftung.

Wenn Sie das Utility mit dem Vorlage benutzen möchten, wählen Sie die entsprechende Option unter der DB Extract Beschriftung.

Die Vorlagenverwaltung Option wird Ihnen in der Vorlagen-Management Sektion SQL Studio for InterBase/Firebird führen.

DB Extract documentation.

Siehe auch:

Data Comparer starten

Database Comparer starten

SQL Query starten


SQL Query starten

SQL Query for InterBase/Firebird ist ein Werkzeug, mit dem Sie schnell und einfach SQL-Abfragen für die InterBase/Firebird Datenbanken konstruieren können. Verwenden Sie die grafische Erstellung der Abfragen mit der direkten Bearbeitung des Abfragentextes. Die einfache und bequeme graphische Oberfläche lässt sich mit den Datenbanken verbinden, Tabellen und die Felder für die Abfragen auswählen, Kriterien der Auswahl aufstellen. Sie können mit mehreren Abfragen gleichzeitig arbeiten, die Abfragen bearbeiten, die Ergebnisse der Ausführung in verschiedenen Regimes anschauen, sowie jede Operationen, die in der alltäglichen Arbeit mit den Abfragen für die Datenbanken notwendig sind, erledigen.

Data Analysis - Running SQL Query

SQL Query kann durch Klicken auf sein Icon oder den Link gestartet werden.

For detailed information on SQL Query for InterBase/Firebird refer to SQL Query documentation.

Siehe auch:

Data Comparer starten

Database Comparer starten

DB Extract starten


Vorlage-Management

Für die Steigerung der Effizienz Ihrer Arbeit gibt es die Möglichkeit, Vorlagen zu erzeugen und sie zu verwalten. Diese Operationen können Sie mit Hilfe des Abschnittes Vorlagenverwaltung auszuführen.

Bestehende Vorlagen

Erzeugung der neuen Vorlagen

Template Management - Overview

Siehe auch:

Datenbank-Management

Datenmanipulation

Datenanalyse


Bestehende Vorlagen

Der Toolbar Vorlagen erlaubt Ihnen, Vorlagen zu/aus der Liste zu hinzufügen/entfernen, neue Vorlagen zu erzeugen oder die bestehenden Vorlagen zu löschen. Sie können auch eines der Werkzeuge mit einer Vorlage durch einen einzigen Klick starten. Dieselben Operationen können durch Verwendung der entsprechenden Menüpunkte ausgeführt werden.

Die Auswahliste Tool oder Dienst erlaubt Ihnen, die Vorlagen entsprechend dem ausgewählten Tool/Dienst zu filtern.

Template Management - Managing existing templates

Siehe auch:

Erzeugung der neuen Vorlagen


Erzeugung der neuen Vorlagen

Eine neue Vorlage kann entweder mit dem entsprechenden Kontextmenüpunkt, oder dem Symbol in der Vorlagen Werkzeugleiste erzeugt werden. Abhängig vom Werkzeug oder dem Dienst, für die Sie eine Vorlage erzeugen möchten, wird SQL Studio for InterBase/Firebird das entsprechenden Werkzeug oder den Dienst starten. Bei der Arbeit mit dem Assistenten können Sie alle Einstellungen eingeben und sie als Vorlage im letzten Schritt speichern.

Siehe auch:

Bestehende Vorlagen


Task Planer und Ausführung

Alle Funktionalitäten des Task Planer, die SQL Studio for InterBase/Firebird bietet, können Sie unten finden:

Benutzertasks

In diesem Abschnitt können Sie Tasks erzeugen, bearbeiten, löschen und schnell starten. Sparen Sie Ihre Zeit und Mühe durch Verwendung der Batchtasks. Erzeugen Sie Ihren Task mit Hilfe des eingebauten Task-Editors. Wählen Sie auch eine der angebotenen Benachrichtigungen, um die Taskausführung zu bestätigen.

Task Planer

Brauchen Sie die verzögerte oder regelmäßige Taskausführung? Der Task Planer erlaubt Ihnen, die Startzeit für Ihre Tasks einzustellen.

Logs

Um die Taskausführung zu überwachen oder die Ergebnisse anzusehen, steht der Abschnitt Logs zur Verfügung. Benutzen Sie die Voransicht, leistungsstarke Filter und Sortierungsoptionen des Rasters, um Ihre Zeit zu sparen.

Sie können diesen Abschnitt auch mit dem entsprechenden Symbol in der Navigationsleiste wählen.

Siehe auch:

Start

Datenbank-Management und Manipulation

Online-Ressourcen

Programmoptionen einstellen


Benutzertasks

In diesem Abschnitt können Sie Tasks erzeugen, bearbeiten, löschen und schnell starten. Sparen Sie Ihre Zeit und Mühe durch Verwendung der Batchtasks. Erzeugen Sie Ihren Task mit Hilfe des eingebauten Task-Editors. Wählen Sie auch eine der vielfältigen Benachrichtigungen, um die Ausführung der Tasks zu bestätigen.

Für mehr Information folgen Sie diesen Links:

Taskverwaltung

Task-Editor

Benachrichtigungen

Schritt-Editor

Customizing tasks - Task Output

Siehe auch:

Task Planer

Logs


Taskvewaltung

Im Abschnitt Benutzertask können Sie Ihre Tasks verwalten. Sie können einen neuen Task erzeugen oder die bestehenden Tasks durch Verwendung der entsprechenden Kontextmenüpunkte oder mit dem Symbol in der Werkzeugleiste löschen. Um die bestehenden Tasks mit dem Benutzertask-Editor zu bearbeiten, wählen Sie den entsprechenden Kontextmenüpunkt oder das Symbol in der Benutzertask-Werkzeugleiste.

Der erzeugte Task kann geplant oder sofort ausgeführt werden. Um einen Task sofort auszuführen, wählen Sie ihn aus und klicken Sie auf das entsprechenden Symbol in der Werkzeugleiste (eines der Kontextmenüpunkte enthält die selbe Funktion).

Im Abschnitt Benutzertask finden Sie die gesamten Informationen über den ausgewählten Task. Sie enthalten die Schrittliste des laufenden Taskes, Werkzeuge für die Ausführung, Aktionen beim Abschluss und andere nützliche Informationen.

Anmerkung: Sie können die Taskliste schnell durch das Kontextmenü erweitern oder einklappen. Dieselben Operationen können mit den entsprechenden Symbolen in der Werkzeugleiste Benutzertask ausgeführt werden.

Scheduling and Performing tasks - Managing task steps

Siehe auch:

Task-Editor


Task-Editor

Der Task-Editor wird automatisch geöffnet, wenn Sie einen neuen Task erzeugen oder einen bestehenden Task bearbeiten.

Bei der Erzeugung einer neuen Tasks geben Sie zuerst deren Namen ein. Dann definieren Sie im Abschnitt Schritte, die notwendigen Schritte für den Task (jeder Task besteht aus mehreren Schritten, die nacheinander ausgeführt werden müssen).

Sie können einen neuen Schritt erzeugen oder die bestehenden Schritte mit dem entsprechenden Kontextmenüpunkt oder dem Symbol in der Benutzertask-Werkzeugleiste löschen. Um die bestehenden Schritte mit dem Schritt-Editor zu bearbeiten, wählen Sie den entsprechenden Kontextmenüpunkt oder das Symbol in Werkzeugleiste Task-Editor.

Außerdem können Sie die Reihenfolge der Schrittausführung mit den Tasten Schritt nach unten und Schritt nach oben der Werkzeugleiste ändern. Diese Optionenen können auch im Kontextmenü des Task-Editors gefunden werden.

Für mehr Information siehe Schritt-Editor.

Scheduling and Performing tasks - Task Editor - Steps

Im Abschnitt Schritte finden Sie die gesamten Information über den ausgewählten Schritt. Diese enthalten den Pfad für ausführbare Datei, den Namen der benutzten Vorlage, den Pfad zur Logdatei, Aktionen beim Abschluss und andere Informationen.

Um die Information über die Ergebnisse der Taskausführung zu bekommen, können Sie eine zusätzliche (zusätzlich zu den SQL Studio for InterBase/Firebird Logs) Benachrichtigung setzen. Wählen Sie dazu auf den Abschnitt Benachrichtigungen des Task - Editors.

Ein beliebiger Text kann als eine Beschreibung für Ihren Task hinzugefügt werden. Wählen Sie dazu den Abschnitt Beschreibung des Task - Editors.

Benachrichtigungen

Schritt-Editor

Siehe auch:

Taskvewaltung


Benachrichtigungen

Im Abschnitt Benachrichtigungen des Task-Editors können die notwendige Benachrichtigung für Erfolg oder Misserfolg der Taskausführung gesetzt werden. Diese Option ermöglicht es Ihnen, Information über die Ergebnisse der Taskausführung zu erhalten.

Scheduling and Performing tasks - Task Editor - Notifications

Benachrichtigung per Net Send

Diese Option erlaubt Ihnen, Benachrichtigungen per Net Send zu schicken. Schreiben Sie Ihre Meldung für den gewählten Rechner im entsprechenden Fenster.

Diese Benachrichtigungen funktioniert nur, wenn den Nachrichtendienst gestartet ist. (Windows Systemsteuerung | Verwaltung | Dienste | Nachrichtendienst)

Systemlog der Anwendungen verwenden

Hiermit können Sie Benachrichtigungen direkt ins Systemlog schreiben. Schreiben Sie Ihre Meldung für das Systemlog im entsprechenden Fenster.

Um das Systemlog der Anwendung anzuschauen, öffnen Sie bitte Windows Systemsteuerung | Verwaltung | Ereignisanzeige | Anwendung.

E-Mail

Hier können Sie Benachrichtigungen per E-Mail verschicken. Schreiben Sie Ihre Meldung im entsprechenden Fenster. Sie müssen auch die notwendigen Felder ausfüllen: Host (Adresse des SMTP-Servers), Port (25 ist als Standard voreingestellt) und die Adressezeile.

Bemerkng: Sie können auch die Makronamen (#START, #STOP, #RESULT) in Ihrer E-Mail-Benachrichtigung benutzen. #START ist der Zeit, wenn ein Task startet, #STOP ist der Zeit, wenn ein Task beendet ist, #RESULT ist das Ergebnis eines Taskes.

Es gibt zwei Optionen bei Versendung der Benachrichtigung: Beim Erfolg und Beim Misserfolg. Die Test Taste erlaubt Ihnen, eine Meldung sofort mit einem Klick zu schicken.


Schritt-Editor

Der Schritt-Editor wird automatisch geöffnet, wenn Sie einen neuen Schritt erzeugen oder einen bestehenden Schritt bearbeiten.

Scheduling and Performing tasks - Task Editor - Step Editor

Bei der Erzeugung eines neuen Schritts geben Sie zuerst seinen Namen ein.

Werkzeug-Einstellungen

Wählen Sie ein Werkzeug, geben Sie dessen Pfad ein (wenn notwendig), setzen Sie eine zusätzliche Vorlage und wählen Sie den Ort für die Log-Datei in den entsprechenden Feldern.

Log-Einstellungen

Hier können Sie wählen, wie die SQL Studio for InterBase/Firebird Log-Datei erzeugt werden soll.

Option Bildschirm in Log speichern ermöglicht, alle Daten aus der Ausgabe des Werkzeugs in der SQL Studio for InterBase/Firebird Log-Datei zu speichern.

Option Log aus Datei erhalten ermöglicht, die Log-Datei des Werkzeugs zu nutzen; alle Daten werden in der SQL Studio for InterBase/Firebird Log-Datei gespeichert.

Aktionen beim Abschluss

Setzen Sie Aktionen beim erfolgreichen oder fehlerhaften Abschluss des Schrittes. Diese Optionen ermöglicht es Ihnen, zum nächsten Schritt oder zum ausgewählten Schritt weiterzugehen, damit den Task zu beenden und einen Report über erfolgreiche oder nicht erfolgreiche Taskausführung zu erhalten. Der Schritt-Editor ermöglicht, die Timeout-Dauer zu verwalten. So können Sie die gewünschte Timeout-Zeit und die Aktion nach Timeout-Ablauf setzen.

Um eine dieser Aktionen auszuführen, benutzen Sie die entsprechenden Felder des Schritt-Editors.

Fehlerverwaltung

Die Option Misserfolg nur für schwere Fehler erlaubt es, den Report über einen erfolgreichen Taskabschluss zu erhalten, wenn kleine Fehler (z.B. ein Skript wurde mit einigen Fehlern ausgeführt) während der Arbeit vorkommen.

Mit der Option Log Begrenzung können Sie die maximale Größe der Log-Datei für den laufenden Schritt setzen.


Task Planer

Brauchen Sie eine verzögerte oder regelmäßige Task Ausführung? Der Task Planer erlaubt Ihnen, die Startzeit für Ihre Tasks einzustellen.

Verwendung geplanter Tasks

Geplanten Task bearbeiten

Scheduling and Performing tasks - Managing scheduled tasks

Siehe auch:

Benutzertasks

Logs


Verwendung geplanter Tasks

Der Task Planer ermöglicht es Ihnen Tasks zu planen. Sie können eine neue Task hinzufügen oder die bestehenden Tasks durch Verwendung des entsprechenden Kontextmenüpunkt oder mit dem Symbol in der Werkzeugleiste löschen. Um die bestehenden Tasks mit dem Task Editor zu bearbeiten, wählen Sie den entsprechenden Kontextmenüpunkt oder finden Sie das Symbol in der Werkzeugleiste Task Planer.

Scheduling and Performing tasks - Task Scheduler

Im Abschnitt Task Planer gibt es das speziellen Panel, wo Sie die gesamten Information über die ausgewählte Task finden.

Um einen geplanten Task anzuhalten, wählen Sie ihn aus und klicken Sie auf Geplanten Task anhalten in der Werkzeugleiste (einer der Kontextmenüpunkte enthält die selbe Funktion). Die Task kann mit dem entsprechenden Symbol in der Werkzeugleiste Task Planer fortgesetzt werden, oder durch Verwendung des enstprechenden Kontextmenüs.

Der SQL Studio for InterBase/Firebird Agent erlaubt es auch, Ihre Tasks anzuhalten und fortzusetzen. Finden Sie das entsprechende Symbol im Windows System-Tray und klicken auf die rechte Maustaste. Dann wählen Sie Geplanten Task anhalten im Submenü und haken Sie die notwendigen Tasks ab. Die umgekehrte Aktion startet die Task wieder.

Geplanten Task bearbeiten


Geplanten Task bearbeiten

Der Tasks Editor wird automatisch geöffnet, wenn Sie einen neuen geplanten Task erzeugen oder einen bestehenden Task bearbeiten.

Um eine verzögerte Taskausführung zu setzen, bitte wählen Sie den Task, die Sie planen wollen. Wenn Sie die bestehenden Tasks bearbeiten, können Sie auch die Task im Feld Task Name wählen.

Scheduling and Performing tasks - Schedule Editor - Daily

Jetzt bestimmen Sie das Muster der periodischen Ausführung. Mit dem Geplante Tasks Editor können Sie wählen, ob der Task täglich, wöchentlich, monatlich oder jährlich ausgeführt werden soll.

Täglich

Der Task kann Jeden X Tag oder Jeden Werktag (außer Wochenende) gestartet werden.

Wöchentlich

Der Task kann an einem bestimmten Wochentag (Montag, Dienstag, usw. - haken Sie die notwendige Tage ab) jede X-te Woche gestartet werden.

Scheduling and Performing tasks - Schedule Editor - Weekly

Zum Beispiel, Sie wählten das Muster "Jede 3. Woche am Dienstag". Das bedeutet, dass der Task am Dienstag jeder 3. Woche ausgeführt wird.

Monatlich

Der Task kann an einem bestimmten Tag des X-ten Monats ausgeführt werden. Oder Sie können den Task an einem bestimmten Wochentag einer bestimmten Woche von jedem X-ten Monat starten.

Scheduling and Performing tasks - Schedule Editor - Monthly

Jährlich

Sie können den Task an einem bestimmten Tag eines bestimmten Monats (z.B. am 14. Juni) oder am ersten/zweiten/.../letzten Tag einer Woche in einem bestimmten Monat (z.B. am zweiten Dienstag im April) starten.

Scheduling and Performing tasks - Schedule Editor - Yearly

Periode des Wiederauftretens

Hier müssen Sie das Start- und Endedatum der Ausführungsperiode angeben. Setzen Sie das Startdatum and die Startzeit und dann geben Sie die Grenzen der Ausführungsperiode an.

Ohne Endedatum bedeutet, dass es keine Grenzen für Taskausführung gibt.

Beenden nach bedeutet, dass der Task nur X Male ausgeführt werden wird.

Beenden um... bedeutet das genaue Datum, wenn die regelmäßige Taskausführung beendet wird.

Verwendung geplanter Tasks


Logs

Um die Taskausführung zu überwachen oder die Ergebnisse anzusehen, steht der Abschnitt Logs zur Verfügung. Benutzen Sie die Log Voransicht, leistungsstarke Filter und Sortierungsoptionen des Rasters, für eine effiziente Arbeitsweise.

Scheduling and Performing tasks - Managing logs

Die Werkzeugleiste Logs erlaubt Ihnen, Logs der ausgewählten Tasks in Dateien zu speichern oder ein Tasklog zu löschen. Dieselben Operationen können mit den entsprechenden Kontextmenüpunkten ausgeführt werden.

Anmerkung: Sie können die Liste der Tasklogs schnell durch das Kontextmenü erweitern oder reduzieren. Die entsprechenden Symbole in der Werkzeugleiste Logs enthalten die gleichen Operationen.

Das spezielle Log Panel unter dem Reiter Logs zeigt die Information über die Ergebnisse der Taskausführung an. Abhängig davon, welche Logeinstellungen gewählt werden, zeigt es alle Daten aus dem Bildschirmausgabe, aus der Logdatei oder beiden an. Die Logoptionen werden während der Erstellung des Schrittes eingestellt (siehe Schritt-Editor).

Die Auswahlliste Anzeigen Logs während ermöglicht, Tasklogs entsprechend der ausgewählten Periode zu filtern.

Siehe auch:

Benutzertasks

Task Planer


Online-Ressourcen

Die Abschnitt Internet des SQL Studio for InterBase/Firebird bietet die folgenden Online-Ressourcen:

Internetressourcen

Enthält Links über SQL Studio und seine Werkzeuge, Links zu FAQs und Online-Dokumentation.

SQL Studio Direct

Führt Sie direkt zu dem Abschnitt der letzten EMS Nachrichten, enthält Links zu den Nachrichten auf SQLManager.net, zu Produktbeschreibung und zur Download Seite.

Support

Führt Sie direkt zum EMS Support Center. Nach dem Einloggen können Sie alle Ihre Fragen stellen. Wenn Sie ein registrierter Benutzer sind, werden Ihre Fragen innerhalb von 24 Stunden beantwortet.

Jede dieser Abschnitte kann mit dem entsprechenden Symbol der Navigationsleiste aufgerufen werden.

Siehe auch:

Start

Datenbank-Management und Manipulation

Task Planer und Ausführung

Programmoptionen einstellen


Internetressourcen

Dieser Reiter enthält verschiedene Links über SQL Studio und seine Werkzeuge, Links zu FAQs und die Online-Dokumentation.

Wählen Sie den gewünschten Link aus der Liste.

Online Resources - Browsing Internet Resources

Siehe auch:

SQL Studio Direct

Support


SQL Studio Direct

Führt Sie direkt zu dem Abschnitt der letzten EMS Nachrichten, enthält Links zu den Nachrichten auf SQLManager.net, zu Produktbeschreibungen und zur Download Seite.

Online Resources - SQL Studio Direct

Siehe auch:

Internetressourcen

Support


Support

Dieser Abschnitt öffnet das EMS Support Center im eingebauten Browser. Nach dem Einloggen bekommen Sie die technische Unterstützung im SQL Studio for InterBase/Firebird Fenster.

Anmerkung: wenn Sie ein registrierter Benutzer von EMS Software sind, werden Ihre Fragen innerhalb während 24 Stunden beantwortet.

Online Resources - Support Center

Siehe auch:

Internetressourcen

SQL Studio Direct


Programmoptionen einstellen

Dieser Abschnitt hilft Ihnen, SQL Studio for InterBase/Firebird nach Ihren Wünschen anzupassen. Für mehr Information, folgen Sie diesen Links:

Auswahl der Sprache

Oberflache anpassen

Toolbars anpassen

Studio Agent Optionen

Siehe auch:

Start

Datenbank-Management und Manipulation

Task Planer und Ausführung

Online-Ressourcen


Auswahl der Sprache

Wenn Sie die Programmsprache beim ersten Start des SQL Studio for InterBase/Firebird nicht gewählt haben oder Sie die Spracheneinstellungen ändern möchten, verwenden Sie den Punkt Optionen | Lokalisation im Hauptmenü. Dann erscheint das Dialog-Fenster mit der Liste von unterstützen Sprachen. Wählen Sie die Sprache und klicken auf die OK Taste.

Options - Localization

Siehe auch:

Oberfläche anpassen

Toolbars anpassen

Studio Agent Optionen


Oberfläche anpassen

Um die Benutzung des Programms bequem und einfach zu machen, können Sie das Aussehen und den Oberflächenstil des SQL Studio for InterBase/Firebird ändern. Die Programmoberfläche kann durch den Punkt Optionen | Oberfläche im Hauptmenü angepasst werden.

Options - Interface

Anmerkung: Sie können die visuellen Optionen des SQL Studio for InterBase/Firebird für alle Studio Anwendungen mit Hilfe der entsprechenden Option anpassen.

Siehe auch:

Auswahl der Sprache

Toolbars anpassen

Studio Agent Optionen


Toolbars anpassen

Die Werkzeugleisten des Programms können angepasst werden, um eine hohe Effizienz zu erreichen und das Tempo Ihrer Arbeit mit SQL Studio for InterBase/Firebird zu erhöhen. Klicken Sie auf die Hauptleiste oder die DB Explorer Werkzeugleiste und wählen Sie Anpassen...

Options - Customizing menus and toolbars

Dann erscheint das Dialog-Fenster, das Ihnen erlaubt, eigene Leisten zu erzeugen oder löschen (Reiter Toolbars), die Tasten zum entfernen oder hinzufügen (Reiter Befehle), einige funktionale und visuelle Einstellungen der Toolbars zu ändern (Reiter Optionen).

Um eine Taste zur Toolbar hinzuzufügen, öffnen Sie Customizing toolbars auf dem Reiter Befehle, wählen Sie den notwendigen Befehl und ziehen ihn auf eine Toolbar. Dieser kann die Hauptleiste, DB Explorer Toolbar oder Ihren eigene Toolbar sein. Um den Befehl zu entfernen, ziehen Sie ihn aus der Toolbar.

Eine Toolbar kann an jede Seite des SQL Studio for InterBase/Firebird Fenster gezogen und angedockt werden.

Siehe auch:

Auswahl der Sprache

Oberfläche anpassen

Studio Agent Optionen


Studio Agent Optionen

Um den Agent automatisch mit Windows starten, klicken Sie auf das entsprechende Symbol im Windows System-Tray und wählen Sie den entsprechenden Menüpunkt.

Options - Setting agent options

Siehe auch:

Auswahl der Sprache

Oberfläche anpassen

Toolbars anpassen


Verwendung von Vorlagen

Im SQL Management Studio for InterBase/Firebird ist für einige Operationen die Möglichkeit zum Speichern von Reihenfolgen der Aktionen und Parameter in den speziellen Dateien vorhanden. Diese Dateien werden als Vorlage bezeichnet und in den Assistentenprogrammen verwendet, z.B. im Assistenten zum Import und Export von Daten und in weiteren Assistenten.

Wenn sich im Assistenten in der linken unteren Ecke die Schaltfläche Templates befindet, können alle mithilfe des Assistenten angegebenen Parameter in eine Datei mit dem jeweiligen Format gespeichert werden. Jeder Assistent hat ein spezielles Vorlageformat. Dies vermeidet die Fehler beim Öffnen von Vorlagen in einem anderen Assistenten.

Beim Betätigen der Schaltfläche Templates wird die Aktionsliste geöffnet.

Mithilfe dieser Liste kann man:

  • Vorlage laden - Load Template,
  • Vorlage speichern - Save Template,
  • Aktuelle Einstellungen als Standardeinstellungen speichern - Save Current Settings As Default,
  • Gespeicherte Einstellungen zurücksetzen - Reset Saved settings.

Die Vorlage kann in jedem Schritt des Assistentenprogramms gespeichert und geladen werden.


Unterstützte Datei-Formate

RadioButton MS Excel

Das gängigste Tabellenformat, das von Microsoft® Excel (*.xls) verwendet wird. Die Ergebnisdateien sind völlständig mit Microsoft® Excel Versionen 97-2000, 2003 und XP kompatibel.

RadioButton MS Access

Die Datei des Formates Microsoft® Access (*.mdb) wird mit ADO-Verbindung verwendet.

RadioButton MS Word

Eines der gängigsten Textverarbeitungsformate, das von Microsoft® Word (*.doc) verwendet wird. Die Ergebnisdateien werden vollständig mit Microsoft® Word Versionen 97-2000, 2003 und XP eingesetzt.

RadioButton RTF

Das Rich Text Format (*.rtf) wird von vielen Textverarbeitungsprogrammen unterstützt (z.B. WordPad).

RadioButton HTML

Das Dateiformat Hyper Text Markup Language (*.html, *.htm), vollständig kompatibel mit HTML 4.0 Spezifikationen.

RadioButton PDF

Das Standardformat in einer elektronischen Veröffentlichung (*.pdf).

RadioButton Textdatei

Nur-Text-Format (*.txt).

RadioButton CSV-Datei

Dateiformat durch Kommas getrennte Werte (*.csv).

RadioButton DIF-Datei

Datenaustauschformat (*.dif).

RadioButton SYLK

Dateiformat der symbolischen Verknüpfungen (*.slk)

Hinweis: alle Textformate, einschließlich der Textdatei, CSV, DIF, SYLK werden normalerweise als Arbeits- bzw. Austauschformate verwendet.

RadioButton LaTeX

Das spezifische Dateiformat (*.tex), eine gängige (insbesondere unter Mathematikern und Physikern) Makroerweiterung von TeX Pack, das von D.Knut entwickelt wurde.

RadioButton XML

Die Markupssprache für Dokumente, die strukturierte Informationen enthalten (*.xml).

RadioButton DBF

Das Datenbank-Dateiformat (*.dbf), das in dBASE und einer Anzahl von xBASE Anwendungen verwendet wird.

RadioButton MS Excel 2007

Aktuelles Tabellenformat, das im Microsoft® Excel 2007 (*.xlsx) verwendet wird. Die Ergebnisdateien sind vollständig mit Microsoft® Excel 2007 kompatibel.

RadioButton MS Word 2007

Aktuelles Textverarbeitungsformat, das im Microsoft® Word 2007 (*.docx) verwendet wird. Die Ergebnisdateien sind vollständig mit Microsoft® Word 2007 kompatibel.

RadioButton ODF Spreadsheets

OASIS Open Document Format for Office-Anwendungen - Open Document Dateiformat für Spreadsheets (*.ods), das in vielen Anwendungen, einschließlich OpenOffice.org und KOffice verwendet wird.

RadioButton ODF Text

OASIS Open Document Format for Office-Anwendungen - Open Document Dateiformat für die Textverarbeitung (*.odt), das in vielen Anwendungen, einschließlich OpenOffice.org und KOffice verwendet wird.