Добро пожаловать в EMS Data Import

Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel, MS Access, DBF, XML, TXT, CSV, MS Word, ODF и HTML в таблицы базы данных SQL Server. Программа предусматривает настраиваемые параметры импорта, такие, как исходные форматы для всех полей, конечные форматы для выбранных полей, параметры фиксации данных, количество пропускаемых записей и многие другие. Data Import for SQL Server включает в себя мастер настройки для визуальной установки параметров для различных файлов и консольную утилиту для быстрого импорта данных.

Основные возможности

  • Импорт из 10 наиболее популярных форматов: MS Excel, MS Access, XML, DBF, TXT, CSV, MS Word, OpenDocument Format и HTML
  • Импорт данных в одну или несколько таблиц или представлений из нескольких баз данных
  • Автоматическое создание структуры таблиц
  • Использование специализированных команд пакетной вставки для достижения максимально возможной скорости импорта.
  • Несколько режимов импортирования - Вставить все, Вставить новые, Вставка или Обновление и другие
  • Поддержка UNICODE
  • Настраиваемые параметры импорта для каждого исходного файла
  • Сохранение всех параметров импорта активной сессии в файл конфигурации
  • Консольная утилита для быстрого импорта данных с помощью файла конфигурации
  • Мощный модуль настройки внешнего вида системы
  • Дружественный интерфейс мастера настройки


Новости

Версия | Дата выпуска
Data Import for SQL Server 4.1 | 12.07.2023

Что нового в Data Import?

  • Добавлена поддержка Windows 11 ARM.
  • На последний шаг добавлена опция перезапуска Мастера.
  • Добавлена проверка длины имени колонки при создании новой таблицы.
  • Для формата CSV добавлены опции по умолчанию для разделителя и квотирования.
  • Исправлено сохранение пароля в шаблон.
  • Исправлена работа с файлами XML без заголовка.
  • В консольной версии исправлено отображение локализованных сообщений.
  • Для консольных версий исправлены коды возврата в случае ошибок.
  • Другие исправления и улучшения.

Смотрите также:

Предыдущие версии


Системные требования

  • Microsoft® Windows XP, Microsoft® Windows 2003 Server, Windows® 2008 Server, Microsoft® Windows Vista, Microsoft® Windows 7, Microsoft® Windows 8, Microsoft® Windows 2012 R2 Server, Microsoft® Windows 2012 Server, Microsoft® Windows 8.1, Microsoft® Windows 10, Microsoft® Windows 2016 Server, Microsoft® Windows 2019 Server, Microsoft® Windows 11, Microsoft® Windows 11 ARM
  • 512 MB RAM
  • 50MB свободного пространства на жестком диске для установки программы
  • Microsoft Data Access Components (MDAC) или SQL Server Native Client
  • Возможность соединения с локальным или удаленным сервером SQL Server
  • Поддерживаемые версии сервера MS SQL Server: с 2000 по 2022


Установка

Установка программы Data Import for SQL Server

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • откройте файл MsImportSetup.exe и следуйте инструкциям мастера установки,
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Часто задаваемые вопросы по установке ПО

Обновление программы

  • загрузите установочный файл программы со страницы загрузки,
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped),
  • закройте программу Data Import for SQL Server, если она запущена,
  • запустите файл MsImportSetup.exe и следуйте инструкциям мастера обновления.


Приобретение

Для приобретения наших продуктов на территории Российской Федерации вы можете использовать форму он-лайн оплаты платежной картой либо запросить счёт для безналичной оплаты путем банковского перевода.

Выбор типа лицензии, количества лет Сопровождения и способа оплаты происходит на странице покупки продукта.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery).

После приобретения мы отправим вам регистрационный ключ электронной почтой. Регистрационная информация будет так же доступна зарегистрированным пользователям на нашем сайте.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО.

Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

Подробнее об услуге сопровождения читайте на странице https://www.sqlmanager.ru/support/faq#maintenance.

Если у вас остались вопросы - вы можете найти ответы на них в разделе FAQ или обратиться в службу поддержки по адресу sales@sqlmanager.ru.

Смотрите также:

Регистрация


Регистрация

Чтобы зарегистрировать приобретенную копию Data Import for SQL Server, необходимо выполнить следующие действия:

  • Получите извещение, содержащее регистрационную информацию.
  • Введите Регистрационное имя и Регистрационный ключ в поля Registration Name и Registration Key соответственно.
  • На странице Начало работы проверьте, что регистрационные данные были введены верно.

Сопровождение

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов.
  • Консультации по вопросам работы ПО.
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО.
  • Доступ к персональной учетной записи клиента EMS.
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн.
  • Эксклюзивные заблаговременные уведомления о специальных предложениях.
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

В случае, когда Вы приобрели продукт в комплекте с подпиской на Сопровождение, подписка будет автоматически активирована после ввода регистрационного ключа в регистрационный диалог Вашей программы. Если же Вы приобрели подписку на Сопровождение отдельно, просто откройте регистрационный диалог Вашей программы и введите полученные Вами регистрационное имя и ключ.

После введения правильного регистрационного ключа появляется информационное окно сообщающее о том, что Вы теперь имеете право пользоваться программой.

За пять дней до окончания срока сопровождения, в стартовом окне появляется строка состояния, указывающая, какое количество дней осталось до истечения срока сопровождения.

Подробнее о поддержке читайте на сайте. https://www.sqlmanager.ru/support/faq#maintenance

Смотрите также:

Приобретение


Предыдyщие версии

Полную историю версий можно посмотреть на сайте https://www.sqlmanager.ru/products/mssql/dataimport/news

06.06.2022 Выпущен Data Import версии 4.0.0

  • Добавлена поддержка темной темы.
  • Поддержка юникодных имен объектов.
  • Улучшена поддержка последних версий серверов.
  • Добавлен предпросмотр данных для форматов MS Access, DBF и XML Datapacket.
  • Оптимизирована работа с файлами XML, DOCX, XLSX, XLS, ODS, ODT.
  • В некоторых случаях консольная версия завершала работу с критической ошибкой. Исправлено.
  • Другие исправления и улучшения.

28.11.2018 Выпущен Data Import версии 3.8.3

  • В консольной версии программы добавлена возможность задания списка импортируемых файлов.
  • При загрузке шаблона менялся порядок импорта файлов. Исправлено.
  • Для формата TXT не применялась кодировка при использовании шаблона. Исправлено.
  • В некоторых случаях не завершался процесс после окончания импорта. Исправлено.
  • Исправлена ошибка "Range check error" при импорте большого CSV файла.
  • Другие небольшие исправления и улучшения.

30.08.2017 Выпущен Data Import версии 3.8.2

  • Оптимизирована работа программы с большими файлами данных.
  • Выполнение скрипта после импорта теперь опционально.
  • Исправлена ошибка "Out of Memory" при импорте из файлов XML, XLS и XLSX.
  • В некоторых случаях консольная версия зависала при использовании шаблона. Исправлено.
  • Исправлены ошибки работы с файлами MS Excel 2016.
  • Исправлено сопоставление типов для создания новых таблиц при импорте из файлов DBF.
  • В некоторых случаях при импорте из файлов CSV в поля типа VARCHAR данные вставлялись не полностью. Исправлено.
  • Исправлена замена NULL значений при импорте.
  • Исправлен импорт данных c дополнительных вкладок файлов XLSX.
  • Исправлен импорт значений типа DATE из файлов DBF.
  • В некоторых случаях скрипты, содержащие кавычки, сохранялись в шаблон не полностью. Исправлено.
  • Улучшен поиск MS SQL серверов в локальной сети.
  • Другие небольшие исправления и улучшения.

14.04.2016 Выпущен Data Import версии 3.8.1

  • Поддержка последних версий OpenSSH.
  • Данные в формате Юникод теперь корректно импортируются из XLSX-файлов.
  • Некорректно вставлялись данные в таблицы, содержащие символ $ в имени. Исправлено.
  • Исправлены ошибки подключения через SSH с использованием Private key.
  • Исправлены ошибки импортирования данных их XLSX-файлов.

09.03.2016 Выпущен Data Import версии 3.8

  • Изменен синтаксический анализатор XML. Новый синтаксический анализатор позволяет более эффективно обрабатывать данные произвольных XML-файлов, документов Microsoft Office и Open Office, обеспечивая более оптимальное использование памяти и высокую скорость загрузки документов.
  • Исправлены ошибки обработки XML документов, проводившие к исключению "Out of memory".
  • Исправлены ошибки, связанные с импортом XLSX файлов, содержащих символы в формате UNICODE, для которых заданы различные атрибуты шрифта и цвета.
  • Исправлены ошибки, связанные с использованием полей Varchar в качестве первичного ключа для записи в режиме Native mode.
  • Исправлены различные ошибки, связанные с преобразованием типов импортируемых данных.
  • Множество других исправлений и улучшений.

09.06.2014 Выпущен Data Import версии 3.7

  • Увеличена скорость импорта за счет использования многопоточности.
  • XML. Добавлена возможность ручного и автоматического определения типа импортируемого XML-файла.
  • В лог добавлена информация о номере строки, на которой произошла ошибка.
  • При импорте из нескольких файлов их логи размещаются на отдельных вкладках, а в основной лог добавляется общая информация об этих процессах.
  • DBF. Неверно определялись поля типа Integer. Исправлено.
  • Не работала опция "Keep identity". Исправлено.
  • Некорректно распознавался формат yyyy-mm-ddThh:nn:ss. Исправлено.
  • HTML. При импорте из HTML файла со ссылками программа зависала. Исправлено.
  • Прочие исправления и улучшения.

10.05.2012 Выпущен Data Import версии 3.6

  • Теперь вместо значения импортируемого поля можно подставить следующие значения: текущую дату, текущее время, текущие дату и время, полное имя импортируемого файла, краткое имя импортируемого файла.
  • Каждое значение импортируемого поля можно обработать с помощью выражений на MS JavaScript.
  • Теперь консольные версии Data Import используют локализацию, выбранную в GUI версии.
  • Теперь при импорте в новую таблицу вычисляется длина строковых полей.
  • Добавлена опция "Импортировать пустые строки". Если эта опция не выбрана, пустые строки не импортируются.
  • Добавлена опция автоматического обрезания значений. При выборе данной опции, у импортируемых значений обрезаются начальные и конечные пробельные символы.
  • Прочие исправления и дополнения.

11.11.2011 Выпущен Data Import версии 3.5

  • Добавлена возможность отката транзакции при возникновении ошибок.
  • Интерфейс третьего шага для всех типов импортируемых файлов приведен к единообразному виду.
  • Консольное приложение. Теперь вывод информации о процессе импорта происходит через установленные интервалы времени.
  • Мастер импорта данных. Теперь вывод информации о процессе импорта происходит через установленные интервалы времени.
  • Теперь загрузка языков локализации происходит при смене каталога языков.
  • При открытии редактор нового поля заполняется значениями по умолчанию.
  • Теперь при импорте в новую таблицу возможно задавать длину строкового поля по умолчанию.
  • Excel 2007. Добавлена возможность настройки Ranges при импорте из Excel 2007, аналогично импорту из Excel 2003.
  • Excel 2007. Увеличена скорость импорта.
  • XML Data packet. Добавлена возможность выбора кодировки файла.
  • Access. Добавлено диалоговое окно ввода имени пользователя.
  • XML. При импорте в новую таблицу возникала ошибка AV. Исправлено.
  • Excel. Использование в Map диапазона из строк приводило к порче импортируемых данных. Исправлено.
  • Excel. При разборе файла с полем, содержащим функцию SUM с одним аргументом, возникала ошибка. Исправлено.
  • Excel. При открытии редактора диапазона Map Range данные отображались некорректно. Исправлено.
  • Исправлена ошибка автогенератора значений.
  • Прочие улучшения и дополнения.

20.08.2010 Выпущен Data Import версии 3.4

  • Добавлена поддержка файлов Microsoft Office Access 2007.
  • Работа с датами стала удобней. Добавлены шаблоны основных форматов дат.
  • Теперь при импорте из файла MS Access в новую таблицу автоматически создается структура выбранной таблицы из файла MS Access.
  • Также добавилась поддержка сложных шаблонов дат: mmm dd yyyy hh:nn:ss:zzzAP или yyyy-mm-ddThh:nn:ss.zzz
  • Исправлена ошибка утечки памяти при импорте из больших текстовых файлов в режиме (CSV, TXT) Native mode.
  • Теперь для генератора на шаге 5 можно задавать значения типа BigInteger (64bit, 19 Decimal digits).
  • Другие улучшения и исправления.

30.11.2009 Выпущен Data Import версии 3.3

  • Добавлена возможность автоматически создавать поля таблицы при импорте из TXT, CSV, XML document.
  • Добавлена поддержка выбора различных кодировок при импорте из DBF файлов, включая UTF8.
  • Снято ограничение на импорт не более 256 столбцов при импорте из MS Excel 2007.
  • Консольная утилита теперь формирует более информативный лог файл.
  • Визуальные изменения, сохранения размеров, теперь утилитой импорта стало пользоваться еще удобнее.
  • Теперь сохраняются и восстанавливаются при следующей сессии настройки форматов и режимов импорта.
  • DataImport for SQL Server расширена поддержка различных форматов даты, включая YYYYMMDDHHMMSS.
  • Некоторые другие исправления и улучшения.

03.02.2009 Выпущен Data Import версии 3.2

  • Добавлена возможность создавать новую таблицу для импортируемого файла. Структура таблицы строится на основе анализа исходных данных.
  • При импорте из файлов формата TXT или CSV Вы можете указать набор символов используемый исходным файлом.
  • Добавлена возможность автоматического построения соответствий между исходными данными и полями существующих таблиц. Соответствие строится на совпадении имен столбцов исходных данных и имен полей таблиц.
  • Добавлена возможность выбрать кодировку (None, OEM, ANSI) при импорте из файла формата DBF.
  • Добавлена поддержка SQL Server 2008.
  • Добавлен параметр Connection Timeout, который задается при подключении к серверу.
  • Исправлена ошибка использования параметра "-log" в консольной версии утилиты.
  • Другие улучшения и исправления.

26.09.2007 Выпущен Data Import версии 3.1

  • Добавлена возможность импортировать данные из текста вложенных узлов XML документа.
  • Добавлена возможность явно указывать файл данных для консольной версии с помощью параметра -datafile=<source file name>. Теперь вы можете использовать один файл шаблона для импорта нескольких однотипных файлов данных.
  • Добавлены автораспознавание столбцов и автозаполнение полей таблицы (auto fill) для TXT файлов.
  • Размер окна мастера можно изменять.
  • Теперь отображается тип полей для DBF файлов.
  • Импорт Unicode данных в поля типа NTEXT теперь происходит корректно.
  • Ошибка подключения к SQL Server 2000 под управлением Windows Vista с использованием SQL authentication исправлена.
  • Другие улучшения и исправления.

01.03.2007 Выпущен Data Import версии 3.0

  • Добавлен новый режим импорта – Native, который включает два механизма - Single Commands – импорт данных путем генерации и выполнения на сервере одиночных SQL команд, и Batch Insert, использующий специальные команды пакетной вставки BULK - INSERT. Скорость импорта в режиме Native может быть в десятки раз выше, чем для режима Universal, используемого в старых версиях утилит.
  • Поддержка Unicode. Возможность импортировать данные в кодировке Unicode.
  • Добавлена возможность импорта данных из файлов новых форматов:

MS Excel 2007

MS Word 2007

HTML

Generic XML

Open Document Format (Open Document Text и Open Document Spreadsheet)

  • Имена полей, появляющихся в различных списках, теперь сопровождаются также коротким описанием их типов. Включено по умолчанию. При желании эту опцию можно отключить в окне Настройки (Preferences).
  • Значительно оптимизирован код утилит, что существенно увеличило скорость работы.
  • Поддержка Identity полей для Data Import.
  • Возможность импорта из текстовых файлов, содержащих символы TAB в качестве разделителей.
  • Прочие исправления и доработки.

Смотрите также:

Новости


Часто задаваемые вопросы

Содержание

  1. Что такое Data Import for SQL Server?
  2. Что необходимо для начала работы с Data Import for SQL Server?
  3. Как проще всего сконфигурировать файлы-шаблоны для работы с консольным приложением Data Import for SQL Server?
  4. В чем разница между функцией "Импорт" в инструментарии SQL Manager for SQL Server и утилите Data Import for SQL Server?
  5. Есть ли какие-нибудь ограничения в триал версии?
  6. Как соединиться с именованным экземпляром с помощью SQL Manager for SQL Server?
  7. При соединении с SQL Server я получаю ошибку "SQL Server does not exist or access denied". В чем причина?
  8. Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?
  9. Я загрузил демонстрационную версию Data Import for SQL Server, но получается импортировать только 20 процентов записей из каждой таблицы. В чем причина?
  10. Я нахожусь за файерволом (роутером). Может ли Data Import for SQL Server подключиться к удаленному серверу.

B:

Что такое Data Import for SQL Server?

О:

Data Import for SQL Server - это мощное приложение, предназначенное для быстрого импорта Ваших данных из файлов формата MS Access, MS Excel, DBF, TXT и CSV в таблицы базы данных SQL Server®. Data Import for SQL Server предусматривает полностью настраиваемые параметры импорта, включая формат исходных данных для каждого поля, формат получаемых данных для выбранных полей, параметры фиксации данных, количество пропускаемых строк и так далее. Data Import for SQL Server включает в себя мастер настройки, позволяющий визуально настраивать опции импорта для каждого файла, а также консольное приложение для упрощенного импорта файлов.

Наверх

В:

Что необходимо для начала работы с Data Import for SQL Server?

О:

Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу SQL Server (https://www.microsoft.com/downloads/).

Во-вторых, Вам нужен компьютер, работающий под управлением ОС Microsoft Windows NT4 с SP4 или выше, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista и удовлетворяющий системным требованиям.

Наверх

В:

Как проще всего сконфигурировать файлы-шаблоны для работы с консольным приложением Data Import for SQL Server?

О:

Сконфигурировать файлы-шаблоны для каждой таблицы проще всего визуально, используя Мастер импорта. В "третьем шаге" мастера настройте необходимые параметры и нажмите кнопку "Сохранить параметры импорта/Save Import Options". Все настройки будут сохранены в файле-шаблоне, который может быть использован консольным приложением.

Наверх

В:

В чем разница между функцией "Импорт данных" в инструментарии SQL Manager for SQL Server и утилите Data Import for SQL Server?

О:

Data Import for SQL Server имеет некоторые дополнительные возможности, которые отсутствуют в SQL Manager for SQL Server. Например:

  • Одновременный импорт данных в несколько таблиц одновременно;
  • Импорт данных в выбранных таблиц различных баз данных, расположенных на одном сервере;
  • Консольная утилита для импорта данных с помощью файла конфигурации со всеми параметрами;
  • Автоматическое создание структуры таблиц.

Наверх

В:

Есть ли какие-нибудь ограничения в триал версии?

О:

При работе с триал версией Вы можете импортировать только 20 процентов записей в каждую таблицу.

Важно: Для импорта данных из файлов CSV, TXT и MS Access установлено ограничение в 100 записей.

Наверх

В:

Как соединиться с именованным экземпляром с помощью SQL Manager for SQL Server?

О:

Для соединения с именованным экземпляром на SQL Server 2005 введите имя экземпляра после имени хоста через наклонную черту в поле "Хост" диалога "Регистрационная информация базы данных". (Например, my_server\my_instance.)

Для того, чтобы соединиться с именованным экземпляром на SQL Server 2000, вам необходимо:

- Запустить SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfig.exe) на клиентском компьютере, где установлена STUDIO (в частности EMS SQL Manager for SQL Server).

- Перейти на вторую закладку (Alias).

- Добавить новый псевдоним с именем сервера в виде <server_name>\\<instanse_name> и TCP/IP в качестве сетевой библиотеки.

- Использовать имя псевдонима в качестве имени хоста в STUDIO.

Наверх

В:

При соединении с SQL Server я получаю ошибку "SQL Server does not exist or access denied". В чем причина?

О:

Возможно, ваш SQL Server установлен как именованный экземпляр (См. вопрос "Как соединиться с именованным экземпляром с помощью SQL Manager for SQL Server?").

Кроме этого возможными причинами проблем с соединением могут быть:

- Вы соединяетесь с SQL Server за пределами вашей локальной сети за файервол (См. вопрос "Я нахожусь за файерволом (роутером). Я могу использовать STUDIO для управления удаленным SQL сервером?").

- Введен неверный логин/пароль. Либо вы используете аутентификацию SQL сервера, но этот вид аутентификации запрещен на сервере. Либо вы используете аутентификацию Windows для установления соединения, но на SQL Server отсутствует имя пользователя, соответствующее вашему доменному имени.

- Некорректно работает MDAC (См. вопрос "Как переустановить Microsoft Data Access Components (MDAC)?").

- SQL Server работает на нестандартном (не 1433) порту (См. вопрос "Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?").

- Отключены протоколы клиентских соединений, либо включенные протоколы отключены на стороне сервера. Воспользуйтесь SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfig.exe) для соединения с SQL Server 2000 или ниже, либо используйте SQL Server Configuration Manager, чтобы включить соответствующие протоколы.

Наверх

В:

Я получаю доступ к своему серверу через альтернативный порт. Я пытался найти в SQL Manager for SQL Server опцию, чтобы изменить порт для соединения, но безрезультатно. Как я могу изменить порт?

О:

Для соединения с SQL Server 2005 с помощью альтернативного порта, выполните следующее:

- Запустите SQL Server Configuration Manager на клиентском компьютере, где установлена STUDIO.

- Разверните секцию SQL Native Client Configuration.

- Выберите секцию Aliases.

- Добавьте новый псевдоним и задайте его имя, номер порта и TCP/IP в качестве сетевой библиотеки.

- Используйте имя псевдонима в качестве имени хоста в STUDIO.

Для соединения с SQL Server 2000 с помощью альтернативного порта, выполните следующее:

- Запустите SQL Server Client Network Utility (WINDOWS\\SYSTEM32\\cliconfg.exe) на клиентском компьютере, где установлена STUDIO.

- Выберите вторую закладку (Alias).

- Добавьте новый псевдоним и задайте его имя, номер порта и TCP/IP в качестве сетевой библиотеки.

- Используйте имя псевдонима в качестве имени хоста в STUDIO.

Наверх

В:

Я загрузил демонстрационную версию Data Import for SQL Server, но получается импортировать только 20 процентов записей из каждой таблицы. В чем причина?

О:

Это ограничение демонстрационной версии. После регистрации продукт будет полностью функциональным.

Наверх

В: Я нахожусь за файерволом (роутером). Может ли Data Import for SQL Server подключиться к удаленному серверу?

О:

Да, но для этого Вы должны открыть порт, на котором работает SQL Server, на Вашем файерволе и на файерволе удаленного сервера.

Наверх


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Мастер импорта данных

Data Import for SQL Server - программа для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server. Программа предусматривает настраиваемые параметры импорта, такие, как исходные форматы для всех полей, конечные форматы для выбранных полей, параметры фиксации данных, количество пропускаемых записей и многие другие.

Работа с мастером импорта данных

Использование файлов конфигурации импорта

Настройка программы

Смотрите также:

Консольное приложение


Pабота с мастером импорта данных

Мастер импорта данных состоит из нескольких шагов. На каждом шаге задаются определенные параметры импорта данных.

Начало работы

Шаг 1 - Установка параметров подключения

Шаг 2 - Выбор файла - источника данных

Шаг 3 - Выбор типа XML файла

Шаг 4 - Указание соответствия полей

Шаг 5 - Настройка форматов данных

Шаг 6 - Задание форматов данных для каждого поля

Шаг 7 - Выбор метода импорта

Шаг 8 - Выбор ключевых столбцов

Шаг 9 - Настройка общих опций

Шаг 10 - Задание SQL скрипта

Шаг 11 - Начало процесса импортирования данных


Начало работы

Так выглядит Data Import for SQL Server при первом запуске.

На этой форме Вы можете просмотреть регистрационную информацию, или, нажав кнопку Register, ввести имя и регистрационный ключ в появившемся окне.

Если регистрационный ключ указан правильно, то появится сообщение о дате окончания периода сопровождения.

Если копия программы не зарегистрирована, то в нижней части формы отображается количество дней, оставшихся до окончания действия ознакомительной копии.

Нажмите кнопку Next для перехода к первому шагу мастера импорта данных.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.

Следующий шаг

Смотрите также:

Приобретение и регистрация


Шаг 1 - Установка параметров подключения

На первом шаге необходимо задать параметры подключения к серверу SQL Server.

В разделе Authentication Type задается способ идентификации пользователя на сервере. Будет ли программа распознавать его по доменному имени и паролю - Windows или же по его персональным имени и паролю на сервере - SQL Server.

Если выбираете Windows, то имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows. Если выбираете SQL Server, то следует указать имя и пароль. Имя указывается в поле Login, пароль - в поле Password.

По имени и паролю система определяет ваши права доступа к информации, и, в соответствии с этим, разрешает доступ к объектам.

Из раскрывающегося списка Host выбираете сервер (хост), к которому хотите подключиться. В этот список программа автоматически добавляет серверы, найденные в локальной сети. Если компоненты SQL-DMO components установлены на клиентском компьютере, используется их функция ListAvailableSQLServers. Если SQL-DMO components не установлены, используется функция NetServerEnum из netapi32.dll. Если данная библиотека не установлена, то при первом открытии программы этот список будет пуст, и имя сервера необходимо будет задать вручную. В этом случае в списке Host будут отображаться те серверы, базы данных которых уже зарегистрированы в программе.

Примечание: имя сервера не всегда может отображаться в списке, тогда вводите его вручную.

Интервал подключения в секундах установите в счетчике Connection Timeout. Время ожидания выполнения команды задается счетчиком Command Timeout.

MS SQL Server может быть установлен как именованный экземпляр. То есть, по умолчанию, во время установки ему присваивается имя (например, SQL Server 2005 Express по умолчанию, устанавливается как именованный экземпляр с именем SQLEXPRESS).

В этом случае в Host Вы должны будете указать "имя компьютера (или IP адрес)\ИМЯЭКЗЕМПЛЯРА" (127.0.0.1\SQLEXPRESS).

Если экземпляр сервера не именован, то достаточно указать имя компьютера или его IP адрес.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • открыть файл конфигурации.

Следующий шаг


Выбор зарегистрированной базы данных

В этом диалоге выберите базу данных для импорта данных. Этот диалог доступен только в версии Data Import for SQL Server для EMS SQL Management Studio.

Selecting registered database

В этом списке отображаются все базы данных, зарегистрированные в EMS SQL Management Studio.

Выберите нужную базу и нажмите кнопку OK.

Регистрационная информация базы данных автоматически появится в соответствующих полях на первом шаге.


Шаг 2 - Выбор файла - источника данных

На втором шаге необходимо выбрать формат файла - источника данных и путь к этому файлу.

При нажатии на кнопку iconAddFile Add File открывается стандартное диалоговое окно позволяющее выбрать файл нужного формата. Можно выберать любой тип файла из доступных:

  • MS Excel 97-2003,
  • MS Excel,
  • MS Word,
  • MS Access,
  • DBF,
  • TXT,
  • CSV,
  • HTML,
  • XML Data Pack,
  • XML Doc,
  • ODS - OpenDocument spreadsheet,
  • ODT - OpenDocument text.

При выборе файла неподдерживаемого формата появляется диалог Select Import Type.

В этом диалоге необходимо выбрать тип импорта для поддерживаемых файлов, который будет применен к выбранному файлу.

В нижней части основного окна отображается список, состоящий из двух столбцов.

В столбце File отображаются файлы - источники данных, в столбце Table - таблицы в которые буду импортироваться данные из выбранного файла.

Затем в появившемся окне для него необходимо выбрать базу данных и таблицу, в которую будут импортированы данные. Также возможно создать новую таблицу в существующей базе данных. Для этого выберите опцию Create new table и задайте нужное имя таблицы.

В первой строке указан путь к выбранному файлу.

Нужную базу данных выберите из раскрывающегося списка Database.

После выбора базы данных в списке Tables отображаются все таблицы выбранной базы данных. Чтобы обновить список таблиц используйте кнопку Refresh.

Из этого списка выберите таблицу, в которую хотите импортировать данные из внешнего файла, либо выберите опцию Create new table, если хотите импортировать данные во вновь созданную таблицу.

Чтобы выбрать для импорта файла другую таблицу, нажмите кнопку btnEllipsis.

Schema

Используйте выпадающий список Scheme для выбора схемы, в которой будет создана таблица.

Удалить файл из списка можно, нажав на кнопку iconRemoveFile Remove file.

В списке могут отображаться файлы разных форматов. Если хотите, чтобы отображались файлы только одного формата, то установите флажок Filter by Type. В списке останутся файлы только того формата, который в данный момент установлен в переключателе Import From.

Файлы будут импортироваться в том порядке, в каком они представлены в списке. Изменить порядок файлов в списке можно с помощью кнопок btnMoveUp btnMoveDown .

Следующий шаг


Шаг 3 - Выбор типа XML файла

Этот шаг появляется, если Вы импортируете данные из файлы с расширением *.xml.

Step 3 - Setting XML file type

XML file type

Выберите, какую структуру имеет импортируемый *.xml файл:

RadioButton Auto Detect - тип файла будет определен автоматически;

RadioButton XML MS Access - выберите эту опцию, если файл имеет структуру, аналогичную структуре файлов, экспортируемых из MS Access.

RadioButton XML Data Packet - выберите эту опцию, если файл имеет формат текстового представления данных, используемый Embarcadero.

RadioButton XML Doc File - выберите эту опцию, чтобы установить соответствие между полями таблицы и файла вручную.


Шаг 4 - Указание соответствия полей

При импорте данных в таблицу необходимо установить соответствие полей между таблицей, в которую данные будут импортироваться, и таблицей, из которой они импортируются.

Для каждого формата файлов существуют свои особенности установки соответствия полей:

Excel 97-2003

MS Excel

MS Word

MS Access

DBF

XML

XML Document

TXT

CSV

HTML

ODS - OpenDocument spreadsheet

ODT - OpenDocument text

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Настройки, позволяющее изменять параметры мастера,
  • Сохранить шаблон для сохранения нового или ранее открытого шаблона,
  • Сохранить шаблон как... для задания имени и сохранения в выбранную директорию.

Следующий шаг


MS Excel 97-2003

На этом шаге необходимо установить соответствие между столбцами с данными в книге MS Excel и полями в таблице.

Step 3 - Excel

В левой части, в списке Files отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные. Если в документе содержится несколько листов, то их можно выбирать в списке Table над таблицей.

В списке Fields отображается список полей таблицы, в которую импортируют данные.

В нижней части - фрагмент импортируемого документа MS Excel.

В списке Range показано соответствие, установленное между полями таблицы базы данных и столбцами таблицы Excel.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill Columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by Captions.

Кнопка btnAutoFillRows - автоматически устанавливает соответствие между полем и строкой.

Кнопка btnClearFieldRanges - удаляет одно соответствие.

Кнопка btnClearAllRanges - удаляет все соответствия.

Чтобы добавить соответствие в список Range нажмите на кнопку btnAddRange .

При нажатии на эту кнопку откроется окно для редактирования соответствия.

Можно указать строки и/или столбцы, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В счетчике Skip Col(s) укажите, сколько столбцов, начиная с первого, следует исключить. В счетчике Skip Row(s) - сколько строк.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


MS Excel

На этом шаге необходимо установить соответствие между столбцами с данными документа и полями в таблице базы данных.

Step 3 - Excel 2007

В левой части, в списке Files отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В левой части, в списке Fields, отображается список полей таблицы, в которую следует импортировать данные. В правой части - фрагмент импортируемого документа.

В списке Ranges показано соответствие, установленное между полями таблицы базы данных и столбцами таблицы Excel.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill Columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by Captions.

Кнопка btnClearFieldRanges - удаляет одно соответствие.

Кнопка btnClearAllRanges - удаляет все соответствия.

Чтобы добавить соответствие в список Ranges нажмите на кнопку btnAddRange .

При нажатии на эту кнопку откроется окно для редактирования соответствия.

В поле Col укажите название столбца, который соответствует выбранному полю таблицы базы данных.

С помощью счетчиков Skip Row(s) и Skip col(s) можно указать строки и столбцы, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные. Если в документе содержится несколько листов, то их можно выбирать в списке Table над таблицей.

Важно: Число столбцов, для которых было задано соответствие, отображается в поле Col.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


MS Word

На этом шаге необходимо установить соответствие между столбцами с данными в документе Word и полями в таблице.

В левой части, в списке Files отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке New fields, отображается список полей таблицы, в которую импортируют данные. Grid Column - порядковый номер столбца. В нижней части - фрагмент импортируемого документа.

С помощью кнопок можно автоматически устанавливать соответствие полей и удалять его:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill Columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by Captions.

Кнопка btnClearFieldRanges - удаляет одно соответствие.

Кнопка btnClearAllRanges - удаляет все соответствия.

В счетчике Skip Lines укажите, сколько строк, начиная с первой, следует исключить. Применяется для исключения заголовков из импортируемых данных.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные. Если в файле содержится несколько таблиц, Вы можете выбрать необходимую в выпадающем списке Table.

Step 3 - Word 2007

Следующий шаг


MS Access

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

Step 3 - Access

Установив переключатель в пункт Access table, Вы получаете возможность выбрать для импорта таблицу или запрос из базы данных, которые можно выбрать из раскрывающегося списка.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Если переключатель установлен в пункт Access SQL query, то в редакторе запросов можно создать текст запроса к базе данных.

Загрузить, сохранить и компилировать запрос можно с помощью кнопок.

btnOpen - загрузить текст запроса из файла.

btnSave - сохранить запрос в файл.

btnCompile - компилировать запрос.

В списке Table Fields отображаются поля таблицы, в которую импортируются данные.

В нижней части - фрагмент импортируемого документа MS Access.

С помощью кнопок можно автоматически устанавливать соответствие полей и удалять его:

Кнопка btnAutoFillColumnsXT Auto Fill Columns позволяет автоматически подобрать полям таблицы, в которую импортируются данные соответствующие, поля из таблицы источника данных.

Кнопка btnClearFieldRanges Clear - удаляет одно соответствие.

Кнопка btnClearAllRanges Clear All - удаляет все соответствия.

Следующий шаг


DBF

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке Fields отображаются поля таблицы, в которую импортируются данные.

В нижней части - фрагмент импортируемого документа DBF.

Кнопка btnAutoFillColumnsXT Auto Fill Columns позволяет автоматически подобрать полям таблицы, в которую импортируются данные, соответствующие поля из таблицы источника данных.

Кнопка btnClearFieldRanges Clear - удаляет одно соответствие.

Кнопка btnClearAllRanges Clear All - удаляет все соответствия.

Вы можете задать набор символов исходного файла в поле Charset.

Установка флажка Skip deleted Rows позволяет пропустить при импорте записи, помеченные на удаление.

Step 3 - DBF

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


XML

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке Fields отображаются поля таблицы, в которую импортируются данные.

В нижней части - фрагмент импортируемого файла.

Кнопка btnAutoFillColumnsXT Auto Fill Columns позволяет автоматически подобрать полям таблицы, в которую импортируются данные, соответствующие поля из таблицы источника данных.

Кнопка btnClearFieldRanges Clear - удаляет одно соответствие.

Кнопка btnClearAllRanges Clear All - удаляет все соответствия.

Step 3 - XML

Encoding

Из этого раскрывающегося списка можно выбрать кодировку файла.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


XML Document

На этом шаге необходимо установить соответствие между столбцами в файле источнике данных и полями в таблице.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то на этом шаге Вам необходимо создать нужные для импорта данных поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Step 3 - XML Document

В верхней части, в списке New fields, отображается список полей таблицы, в которую импортируют данные. Grid Column - порядковый номер столбца. После того как выбрали файл источник данных в поле, находящемся рядом со списком полей New fields, отобразится структура документа. Если в документе содержится большое количество данных, то получение структуры документа может занять некоторое время. Структура документа имеет вид дерева. Выберите один из узлов этого дерева, чтобы получить путь к данным, или введите путь вручную в поле (путь должен быть в формате XPath). Чтобы заполнить таблицу данных необходимо нажать кнопку Fill grid. Вы можете выбрать источник данных для импорта открыв раскрывающийся список находящийся слева от кнопки Fill grid. Доступны значения: Sub Nodes Text - текстовые данные дочерних узлов, и Attributes - значения атрибутов.

Кнопка Analyze доступна при импорте в новую таблицу. Используйте ее для автоматического создания полей.

В нижней части формы отображается фрагмент импортируемого документа XML Document.

После того, как таблица заполнена, можно устанавливать соответствия между полями таблицы базы данных и столбцами данных в XML документе.

С помощью кнопок можно автоматически устанавливать это соответствие и удалять его:

Кнопка btnAutoFillColumns - Auto Fill Columns - автоматически устанавливает соответствие между полями и столбцами. Эту функцию можно использовать, если исходный файл и назначенная таблица имеют равное число столбцов.

Кнопка btnClearAllRanges - удаляет все соответствия.

В счетчике Skip Lines укажите, сколько строк, начиная с первой, следует исключить. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Следующий шаг


TXT

На этом шаге необходимо установить соответствие между столбцами с данными в текстовом документе и полями в таблице.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке Fields отображается список полей таблицы, в которую будут импортироваться данные.

В нижней части - фрагмент текстового документа - источника данных.

В текстовом документе не существует такого понятия как поля или столбцы, поэтому в Data Import for SQL Server при экспорте нужно вручную устанавливать разграничители столбцов для текстовых файлов. Разграничители представляют собой вертикальные черные линии, отделяющие один столбец от другого. Изначально в документе разгарничителей нет. Устанавливаются они с помощью двойного щелчка мыши на макете документа. Разграничители должны быть между столбцами, а также перед первым столбцом и после последнего. Размер столбца определяется количеством символов в нем. Для этого сверху и снизу макета документа предусмотрены линейки, на которых каждое деление соответствует символу.

Соответствие между столбцами устанавливается следующим образом:

В списке полей таблицы выбирается поле. В макете документа выбирается столбец. Если соответствие установлено, то рядом с названием поля, в списке Fields появляются две цифры. Первая, в столбце Pos - это номер символа, с которого начинается столбец, вторая, в столбце Length - количество символов в столбце.

Вы можете задать набор символов исходного файла в поле Encoding.

Кнопка Analyze доступна при импорте в новую таблицу. Используйте ее для автоматического создания полей.

Step 3 - TXT

Если хотите удалить все установленные соответствия, то нажмите кнопку Clear - btnClearAllRanges . Кнопка btnAutoFillColumns - Auto Fill Columns - автоматически устанавливает соответствие между полями и столбцами. . Эту функцию можно использовать, если исходный файл и назначенная таблица имеют равное число столбцов.

Если установлен флажок Auto Scroll, то при установке соответствий столбцов, автоматически будет осуществляться прокрутка фрагмента документа к следующему столбцу.

С помощью счетчика Skip Lines можно указать, сколько первых строк не учитывать при импорте. Таким образом, исключаются заголовки столбцов из импортируемых данных.

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то на этом шаге Вам необходимо создать нужные для импорта данных поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


CSV

На этом шаге необходимо установить соответствие между столбцами с данными в файле-источнике данных и полями в таблице.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке New fields отображается список полей таблицы, в которую будут импортироваться данные.Grid Column - порядковый номер столбца.

В нижней части - фрагмент документа - источника данных.

Чтобы при импорте данных из файла формата CSV все столбцы данных корректно отображались необходимо правильно указать разделитель столбцов. Разделители выбираются из раскрывающегося списка Delimiter. В качестве разделителя в этом поле можно задать любой символ. Из раскрывающегося списка Quote Вы можете выбрать вид кавычек.

Вы можете задать набор символов исходного файла в поле Encoding.

Кнопка btnAutoFillColumns - автоматически устанавливает соответствие между полями и столбцами. Эту функцию можно использовать, если исходный файл и назначенная таблица имеют равное число столбцов.

Кнопка btnClearAllRanges - удаляет все соответствия.

В нижней части - фрагмент документа CSV. Все столбцы в нем пронумерованы. Соответствие столбцов устанавливается по номеру столбца документа CSV.

Чтобы установить соответствие поля таблицы, куда импортируют данные, и столбца в документе-источнике данных необходимо выделить поле в списке полей и выделить столбец в макете документа CSV или выбрать нужный номер столбца из списка Col. Если связь установлена, то напротив названия поля появится номер столбца, который поставлен в соответствие с этим полем.

В поле Skip можно указать строки, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

Кнопка Analyze доступна при импорте в новую таблицу. Используйте ее для автоматического создания полей.

Step 3 - CSV

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то на этом шаге Вам необходимо создать нужные для импорта данных поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


HTML

На этом шаге необходимо установить соответствие между столбцами с данными в таблице HTML файла и полями в таблице базы данных.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке New fields, отображается список полей таблицы, в которую импортируют данные. Grid Column - порядковый номер столбца. В правой части - фрагмент импортируемого документа.

С помощью кнопок можно автоматически устанавливать соответствия между столбцами данных в документе HTML документе и полями таблицы и удалять их:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by captions.

Кнопка btnClearAllRanges - удаляет все соответствия.

Из раскрывающегося списка Table Number выберите номер таблицы, из которой хотите импортировать данные. Это сделано на тот случай, если в HTML документе не одна таблица, а несколько.

В разделе Skip lines можно указать строки, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Step 3 - HTML

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (Add field), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


ODS - OpenDocument spreadsheet

Документы формата ODS используются в приложениях Mobile Office, OpenOffice, StarOffice, KOffice и пр.

На этом шаге необходимо установить соответствие между столбцами с данными ODS файла и полями в таблице базы данных.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке New fields, отображается список полей таблицы, в которую импортируют данные. Grid Column - порядковый номер столбца. В правой части - фрагмент импортируемого документа.

С помощью кнопок можно автоматически устанавливать соответствия между столбцами данных в документе HTML документе и полями таблицы и удалять их:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill Columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by Captions.

Кнопка btnClearFieldRanges - удаляет одно соответствие,

Кнопка btnClearAllRanges - удаляет все соответствия.

Из раскрывающегося списка Table выберите лист документа, с которого хотите импортировать данные. Это сделано на тот случай, если в ODS документе не один лист, а несколько.

В счетчике Skip line(s) можно указать количество строк, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные. Если в документе содержится несколько листов, то их можно выбирать, нажимая на вкладки с названиями листов в верхней части таблицы.

Step 3 - ODS

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (New column), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

Следующий шаг


ODT - OpenDocument text

Документы формата ODT используются в приложениях Mobile Office.

На этом шаге необходимо установить соответствие между столбцами с данными ODT файла и полями в таблице базы данных.

В левой части, в списке Files, отображаются файлы-источники. Параметры соответствия указываются для файла, выбранного в этом списке.

В списке New fields, отображается список полей таблицы, в которую импортируют данные. Grid Column - порядковый номер столбца. В правой части - фрагмент импортируемого документа.

С помощью кнопок можно автоматически устанавливать соответствия между столбцами данных в документе HTML документе и полями таблицы и удалять их:

Кнопка btnAutoFillColumnsXT - автоматически устанавливает соответствие между полями и столбцами. Используйте функцию Auto Fill Columns, если порядок столбцов исходной таблицы совпадает с порядком полей в результирующей таблице. В противном случае Вам следует использовать функцию Auto Fill by Captions.

Кнопка btnClearFieldRanges - удаляет одно соответствие,

Кнопка btnClearAllRanges - удаляет все соответствия.

Из раскрывающегося списка Table выберите таблицу, из которой хотите импортировать данные. Это сделано на тот случай, если в ODT документе не одна таблица, а несколько.

В счетчике Skip lines можно указать количество строк, которые не будут импортированы. Применяется для исключения заголовков из импортируемых данных.

В нижней части формы представлена таблица с данными того документа, из которого импортируются данные.

Step 3 - ODT

Если Вы выбрали создавать таблицу для импорта в нее данных на предыдущем шаге, то необходимые для импорта данных поля будут созданы автоматически. Вы можете добавлять, редактировать или удалять поля. Выберите нужный пункт контекстного меню, чтобы добавить поле (Add field), редактировать (Edit) или удалить (Drop).

Нажатие кнопки btnEllipsis рядом с названием поля открывает это поле для редактирования.

Важно: Если таблица уже создана, она будет помечена галочкой Tick. Если при создании таблицы произошла ошибка, то такая таблица будет помечена крестиком Cross.

При нажатии на кнопку Tools открывается список, из которого можно выбрать одно из действий:

  • открыть окно Preferences, позволяющее изменять параметры мастера,
  • создать файл конфигурации,
  • открыть файл конфигурации.

Следующий шаг


Шаг 5 - Настройка форматов данных

На этом шаге необходимо указать вид представления данных для импортируемого файла, выбранного из списка Files. Этот вид должен соответствовать представлению данных в том файле, откуда эти данные импортируются.

Separators

Укажите символы, которые используются в качестве раделителей в исходном файле.

Decimal - Десятки

Thousand - Тысячи

Date - Дата

Time - Время

Constants

Укажите значения в том виде, как они представлены в исходном файле, для корректного распознавания и импорта. В полях можно задать несколько альтернативных значений.

Boolean True

В этом поле вводится текст, который отображается, если значение в ячейке "истина" (значение будет "истина" при совпадении данных в документе и в этом поле).

Boolean False

В этом поле вводится текст, который отображается, если значение в ячейке "ложь".

Null Values

В этом поле вводится текст, который отображается, если значение в ячейке NULL.

Date & Time formats

В этом разделе задаются форматы для отображения даты и времени.

  • Date - дата,
  • Time - время.

ВАЖНО: Обратите внимание, что разделители даты и времени указываются в разделе Separators.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences.

Следующий шаг


Задание форматов данных

Форматы данных определяют вид данных разных типов.

Форматы Float/Integer

0 | Цифра от 0 до 9
# | Символ разряда.
. | символ, отделяющий десятичную часть
, | разделитель групп разрядов
E+ | экспоненциальное представление.

Форматы Date/Time format

С помощью следующих команд укажите какую часть даты и в каком виде нужно отображать.

c | Отображает дату, используя краткий формат даты.
d | День отображается в виде числа от 1 до 31 без нулевого старшего разряда.
dd | День отображается в виде числа от 01 до 31 с нулевым старшим разрядом.
ddd | День отображается в виде аббревиатуры (Sun-Sat).
dddd | Отображается полное название дня недели (Sunday-Saturday).
ddddd | Отображать краткий формат.
dddddd | Использовать полный формат даты.
m | Отображать месяц в виде числа без нулевого старшего разряда (1-12).
mm | Отображать месяц в виде числа с нулевым старшим разрядом (01-12)
mmm | Отображать месяц в виде аббревиатуры (Jan-Dec).
mmmm | Отображать полное название месяца (January-December).
yy | Отображать год в виде последних двух цифр (00-99).
yyyy | Отображать год в четырех цифр (0000-9999).
h | Отображать час в виде числа без нулевого старшего разряда (0-23).
hh | Отображать час в виде числа с нулевым старшим разрядом (00-23).
n | Отображать минуты в виде числа без нулевого старшего разряда (0-59).
nn | Отображать минуты в виде числа с нулевым старшим разрядом (00-59).
s | Отображать секунды в виде числа без нулевого старшего разряда (0-59).
ss | Отображать секунды в виде числа с нулевым старшим разрядом (00-59).
z | Отображать миллисекунды в виде числа без нулевого старшего разряда (0-999).
zzz | Отображать миллисекунды в виде числа с нулевым старшим разрядом (000-999).
t | Отображать время используя Short Time Format.
tt | Отображать время используя Long Time Format.
a/p | Использовать двенадцатичасовой формат даты с префиксом a/p.
am/pm | Использовать двенадцатичасовой формат даты с префиксом am/pm.
/ | Использовать этот разделитель даты (mm/dd/yy).
: | Использовать этот разделитель времени (hh:mm).
'xx'/"xx" | Символы, заключенные в одинарные или двойные кавычки не подлежат форматированию.


Шаг 6 - Задание форматов данных для каждого поля

На этом шаге Вы можете выбрать из списка Field name поле и указать в разделе Field Customization набор свойств, определяющих формат каждого поля для импортируемого файла, выбранного из списка Files.

Generator value - генератор значений. В этом поле задается первоначальное значение для генератора столбца. Если поле, в которое импортируются данные, имеет тип Identity, то генератор не будет работать.

Generator step - в этом поле задайте интервал генератора значений.

Constant value - в это поле вводится значение, которое заменяет все значения в столбце.

Null value - значение, которое устанавливается в ячейке, если значение после импорта в ней остается Null.

В поле Default Value указываете значение, замещающее пустое значение в исходном файле.

Из раскрывающегося списка Function можно выбрать одну из функций, возвращаемое значение которой будет записано в выбранный столбец.

Script - нажмите кнопку btnEllipsis , чтобы открыть редактор скриптов JScript.

Step 5 - Script Editor

В окне Script Editor введите скрипт для обработки выбранного поля таблицы. Данный редактор позволяет использовать все возможности языка Jscript.

На представленном выше скриншоте показан пример использования Jscript для обработки поля Name. Приведенный код преобразует строку формата 'XXXX YYYY' в строку формата 'YYYY, XXXX'. Например, 'Piotr Tchaikovsky' -> 'Tchaikovsky, Piotr'.

Чтобы протестировать код и увидеть результат обработки введите тестовое значение в Field Value For Testing поле и нажмите кнопку Test Run.

Если при выполнении кода произошла ошибка, то на экран выведется сообщение с ее описанием.

При успешном выполнении кода появится окно, содержащее результат выполнения, как показано ниже.

Step 5 - Script Editor - Information

В поле Left quotation задаете левую кавычку, в поле Right quotation - правую.

Quotation action - кавычки.

Из раскрывающегося списка Char case - регистр текстовых данных. В этом случае все символы будут приведены к указанному регистру.

Из раскрывающегося списка Char set - выберите кодировку. Все символы будут представлены в выбранной кодировке.

На этом шаге мастера есть возможность в процессе импорта данных заменить некоторые значения в поле другими значениями. Замен текста для столбца можно создать несколько. С помощью кнопки btnAddRange Add Replacement Вы можете добавить новый параметр замены.

Step 5 - Add Replacement

Все параметры отображаются в списке, где в столбце Text to find находятся те значения текста, которые необходимо заменить, в столбце Replace With - текст, которым надо заменить указанные фрагменты. Если установлен флажок Ignore case, то замена будет произведена без учета регистра. Редактировать условие замены можно, нажав на нем мышью дважды. Кнопка btnDeleteRange Delete Replacement удаляет условие замены.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences.

Следующий шаг


Шаг 7 - Выбор метода импорта

На шестом шаге выберите метод импорта.

Переключатель Import mode позволяет задать те записи, которые будут импортироваться в таблицу.

Insert all - вставить все записи,

Insert new - вставить только новые записи,

Update - обновить записи,

Update or insert - обновить существующие и вставить новые записи,

Delete - удалить те записи, где совпадает первичный ключ таблицы и значение поля, выбранного в качестве ключевого, импортируемого файла,

Delete or insert - удалить совпадающие записи и вставить новые.

Пример:

Таблица в базе данных | Данные из внешнего файла
Step 6 - tab1 | Step 6 - tab2

В качестве ключевого поля выбрано поле ID. (Кроме режима Insert All, который не требует указания ключевого поля)

Insert mode | Insert all | Insert new | Update
Результат | Step 6 - tab3 | Step 6 - tab4 | Step 6 - tab5

Insert mode | Update or insert | Delete | Delete or insert
Результат | Step 6 - tab6 | Step 6 - tab7 | Step 6 - tab8

Native mode Kind - серверозависимый (собственный) режим (режим вставки, реализуемый с помощью специальных возможностей сервера).

В разделе Native Mode Kind выберите вид собственного режима импорта программы:

  • Single Commands - одиночные команды вида "INSERT INTO...".
  • Batch Insert - пакетная вставка.

Keep Nulls - сохранять значения NULL, имеющиеся в исходном документе,

Fire Triggers - разрешить срабатывание триггеров при вставке,

Bulk Insert File Name - Имя файла пакетной вставки,

Bulk Insert Field Terminator - разделитель полей при пакетной вставке.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences

Следующий шаг


Шаг 8 - Выбор ключевых столбцов

На восьмом шаге выберите ключевое поле, по которому сравниваются поля таблицы и файла источника данных.

Этот шаг недоступен, если на предыдущем шаге был выбран режим импорта RadioButton Insert all.

Файл-источник выберите из списка Files. Из списка Available columns выберите доступные поля и с помощью кнопок переместите их в список ключевых полей - Selected columns.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences

Следующий шаг


Шаг 9 - Настройка общих опций

В разделе Commit задайте параметры фиксации транзакции:

  • Commit After Done - фиксировать транзакцию после выполнения импорта,
  • Commit after each n record(s) - фиксировать транзакцию после каждых n записей. Применяется для больших таблиц. Количество записей указывается в счетчике.
  • Rollback on error - откатить транзакцию, если произошла ошибка.

В разделе Records count Вы можете задать количество импортируемых записей. Выберите пункт Import all records, чтобы импортировать сразу все записи, или в счетчике Import only n records задайте их количество.

CheckBox Import empty rows - разрешить импорт пустых полей.

CheckBox Auto trim values - удалять все начальные и конечные знаки пробела из полей.

Если установлен флажок Save Result SQL Script to File, то скрипт, получившийся в результате, будет сохранен в файл, имя и путь которого можно задать в поле.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences.

Следующий шаг


Шаг 10 - Задание SQL скрипта

На десятом шаге Вы можете задать SQL скрипт, который будет выполняться до импорта данных и после импорта данных.

В редакторе Before Import Script задайте SQL скрипт, выполняемый до импорта данных. В редакторе After Import Script - скрипт, выполняемый после импорта данных.

Load - загрузить скрипт из внешнего файла.

Save - сохранить скрипт.

Clear - очистить редактор.

Если установлен флажок Skip this step, то этот шаг будет пропускаться при последующем импортировании файлов. Список пропускаемых шагов можно просмотреть и изменить на вкладке General диалогового окна Preferences.

Следующий шаг


Шаг 11 - Начало процесса импортирования данных

Этот шаг информирует Вас о том, что все параметры импорта заданы, и Вы можете начать импорт данных.

CheckBox Continue if Before Import script is executed with errors

При включенной опции импорт будет выполняться даже при возникновении ошибок в скрипте, указанном пользователем.

CheckBox Execute after import script on import fail

При включенной опции SQL скрипт, заданный для выполнения после импорта, будет выполняться в любом случае.

CheckBox Max mport threads

Благодаря реализации многопоточного импорта данных теперь можно указать Максимальное число потоков.

С помощью кнопки Save Log to File Вы можете сохранить протокол в файл. Нажатие на кнопку Clear log удаляет все записи из протокола выполнения операции.

Если необходимо, Вы можете Сохранить шаблон для использования его в будущем.

Нажатие на кнопку Import запускает процесс импорта данных.

Если хотите изменить параметры импорта, нажмите кнопку Back.


Использование файлов конфигурации импорта

В Data Import for SQL Server предусмотрена возможность сохранения последовательности действий и параметров в специальных файлах, которые называются файлы конфигурации.

В мастере в левом нижнем углу расположена кнопка btnSaveAs. При нажатии на эту кнопку открывается список действий.

Using configuration files - Save Template

С помощью этого списка можно:

  • Restart Wizard - перезапустить мастер,
  • Save Template - сохранить шаблон,
  • Save Template As... - задать имя и сохранить шаблон в выбранную директорию,
  • Load Template - загрузить шаблон,
  • Reopen Template - открыть один из недавно открывавшихся файлов конфигурации импорта.

Все параметры, указанные с помощью мастера, можно сохранить в файл формата *.itm.

Using configuration files - Save Template options

Сохранять шаблон можно на любом шаге мастера, но чтобы сохранились все настройки делать надо это на последнем шаге. Загружать шаблон можно только на вступительном и первом шаге.


Настройка программы

Data Import for SQL Server позволяет полностью настроить интерфейс программы.

Чтобы открыть окно Preferences необходимо на любом шаге мастера нажать кнопку Tools и из появившегося списка выбрать пункт Preferences.

Основные элементы управления располагаются на следующих вкладках:

Задание основных параметров

Выбор шагов

Выбор языка программы

Preferences - General

Нажав на кнопку Reset, Вы можете сбросить принятые настройки и вернуть их к настройкам по умолчанию.


Задание основных параметров

Основные опции программы Data Import for SQL Server задайте на вкладке General.

Preferences - General

CheckBox Confirmation on exit

Установите флажок, если при выходе из программы необходимо запрашивать подтверждение.

CheckBox Key columns reminder

Установите флажок, чтобы включить напоминание о необходимости установки ключевых полей на шаге Выбора метода импорта.

CheckBox Remember password

Если флажок установлен, то пароль будет сохраняться автоматически. Выбор этой опции позволит сохранить только последний использовавшийся пароль.

CheckBox Show number of created tables

Если Вы хотите чтобы программа выводила сообщение о созданных таблицах, включите опцию.

CheckBox Show number of mapped columns

Отображать число столбцов для которых было установлено соответствие.

CheckBox Use first row as caption fields

Чтобы использовать первую строку как заголовки столбцов при установлении соответствий установите флажок.

CheckBox Keep options at steps

Чтобы при следующем запуске программы сохранились текущие настройки импорта установите флажок.

CheckBox Allow JavaScript execution

Включите эту опцию, чтобы скрипт, введенный на Шаге 6 выполнялся всегда.

CheckBox Show databases

На втором шаге мастера импорта данных будут отображаться базы данных, если этот флажок установлен.

CheckBox Exclude autoincrement fields

Если отмечена эта опция, то автоинкрементные поля будут пропускаться при автоматическом задании соответствия полей.

Default min length for new string field

Укажите длину по умолчанию нового поля, если вы импортируете данные в новую таблицу.

Default CSV delimiter

выбираются из раскрывающегося списка разделитель столбцов, чтобы при импорте данных из файла формата CSV все столбцы данных корректно отображались.

Default CSV quote

В этом раскрывающемся списке Вы можете выбрать вид кавычек.


Выбор шагов

Используйте эту группу параметров для определения шагов приложения мастера, которые необходимо пропустить.

Preferences - Skipped steps

CheckBox Skip intermediate steps

Чтобы пропускать промежуточные шаги, установите флажок. Шаги, которые будут пропущены, отметьте флажками:

CheckBox Base Formats

Основные форматы

CheckBox Data Formats

Форматы данных

CheckBox Import Mode

Режим импорта

CheckBox Key Columns

Ключевые столбцы

CheckBox Commit Options

Настройка фиксации

CheckBox Scripts

Скрипты


Выбор языка программы

На вкладке Languages выберите язык интерфейса программы Data Import for SQL Server.

Preferences - Localization

В списке Languages отображаются доступные языки. Из этого списка можно выбрать нужную локализацию.

В столбце Language показан язык локализации, в столбце File Name - название и путь к файлу локализации.

В список локализаций попадают все файлы формата *.lng, содержащиеся в папке, указанной в поле Language Directory. Чтобы сделать указанную в поле папку, директорией в которой содержатся локализации, нужно нажать кнопку Load Languages.


Консольное приложение

Консольное приложение Data Import for SQL Server предназначено для быстрого и удобного импорта данных из внешних файлов в таблицы базы данных SQL Server, а также для использования в любых планировщиках задач.

Работа с консольным приложением

Формат файла конфигурации

Смотрите также:

Мастер импорта данных


Работа с консольным приложением

Все параметры импорта, заданные в Data Import for SQL Server можно сохранить в файл конфигурации импорта (*.itm). Консольное приложение использует имя этого файла как параметр при выполнении импорта.

Чтобы создать шаблон следуйте инструкции:

  • запустите Data Import for SQL Server
  • задайте необходимые параметры на каждом шаге мастера импорта данных
  • проверьте процесс импорта на одиннадцатом шаге
  • сохраните опции в файле конфигурации импорта

Файл конфигурации можно выполнить тремя способами:

  • использовать пункт Load Template из списка, открывающегося при нажатии на кнопку Using Configuratin files - btnTools .
  • дважды щелкнуть на созданном файле конфигурации (*.itm) мышью.
  • задать в консольном приложении команду запуска - <path to Data Import for SQL Server console application>\MsImportC.exe TemplateFile [-datafile=<source file name>] [-B] [-LOG]

datafile=<filename1>;<filename2>;<filename3>

Параметр позволяет заменить имена файлов, сохраненные в шаблоне. При этом количество файлов, указанных в параметре и в шаблоне, должно совпадать.

TemplateFile

Файл шаблона консольного приложения *.itm.

[-B]

Используйте этот параметр в командной строке для запуска консольной версии Data Import for SQL Server в фоновом режиме.

Пример:

Файл конфигурации называется Example.itm.

"C:\Program Files\EMS\Data Import for SQL Server\MsImportC.exe" "C:\EMS\DataImport\Example.itm" -B -datafile=test150283.xls

[-LOG]

Параметр позволяет сгенерировать файл - журнал событий, который имеет расширение *.log и содержит информацию о проведенном импорте данных:

  • дата выполнения импорта,
  • информация о соединении с сервером,
  • путь к файлу источнику данных,
  • время и результат импорта,
  • построчная информация о возникнувших ошибках.

Пример:

"C:\Program Files\EMS\Data Import for SQL Server\MsImportC.exe" "C:\EMS\DataImport\Template1.itm" -LOG="C:\EMS\DataImport\logfile.log"

Важно: Следующие значения кода завершения возвращаются программой Data Import for SQL Server операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка или ошибки;

2 - критическая ошибка. Эта задача не выполнена.


Формат файла конфигурации

Файл конфигурации состоит из нескольких разделов:

В первом разделе - указаны параметры соединения к базе данных.

[CONNECTION]

В этом разделе содержатся параметры подключения к серверу: Host (сервер), Login, Password (encrypted) (Логин, пароль. Пароль закодирован). Эти параметры являются обязательными.

[PREFERENCES]

Основные настройки программы.

ImportToViews

Импорт в представления

1 - доступен, 0 - недоступен

Для каждого файла источника данных указывается уникальные префикс FILE_00, FILE_01, FILE_02 и т.д.

[FILE_00]

В этом разделе используются следующие параметры для каждого внешнего файла:

Database (имя базы данных, в которою импортируются данные), Table (имя таблицы, в которою импортируются данные), FileName (имя файла - источника данных)

ImportType

Тип файла - источника данных. 0 - XLS, 1 - Access, 2 - DBF, 3 - TXT, 4 - CSV, 5 - XML, 6 - MS Excel 2007, 7 - MS Word 2007, 8 - HTML, 9 - XML Document, 10 - ODS, 11 - ODT

В следующем разделе описаны настройки импорта для каждого конкретного источника данных, с указанием номера файла и типа.

[FILE_00_XLS]

SkipRows, SkipCols - количество строк и столбцов, которые надо пропустить при импорте.

[FILE_00_Access]

SourceType - тип источника в базе данных Access. 0 - таблица, 1 - запрос.

TableName and SQL - имя таблицы или запроса.

[FILE_00_TXT]

SkipRows - количество строк, которые надо пропустить при импорте.

[FILE_00_CSV]

SkipRows - количество строк, которые надо пропустить при импорте.

CSVDelimiter, CSVRightQuot, CSVLeftQuot - ограничители и кавычки.

[FILE_XX_MAP].

В этом разделе указано соответствие полей таблицы базы данных и столбцов в источнике данных.

Excel

<DB_FieldName>=CellIndex.

Используйте точку с запятой для разделения ячеек. Вы можете задать строку или столбец, как диапазон ячеек.

Field1=A1;A4;A6-A9;B1-F1.

Access или DBF

<DB_FieldName>=<Source_Field_Name>.

TXT

<DB_FieldName>=<Position>;<Size>.

Вы должны указать позицию начала поля и размер поля.

CSV

Укажите номер столбца исходного файла для каждого поля

Field1=1

Field2=4

Параметры, указываемые в разделах [FILE_XX_BASE_FORMATS] и [FILE_XX_IMPORT_OPTIONS] можно указать на шагах Шаг 4 - Настройка форматов данных и Шаг 8 - Настройка общих опций.

Параметры BOOLEAN TRUE and BOOLEAN FALSE задаются в разделах [FILE_XX_BOOLEAN_TRUE] и [FILE_XX_BOOLEAN_FALSE].

Значения типа NULL указываются в разделе [FILE_XX_NULL_VALUES].

[FILE_XX_DATA_FORMATS_<FIELD_NAME>],

Форматы данных, которые указаны для каждого поля отдельно, хранятся в этой секции.

FILE_00_DATA_FORMATS_FIELD1.

Эти параметры задаются на шаге Шаг 5 - Задание форматов данных для каждого поля.

[FILE_00_IMPORT_OPTIONS]

В этом разделе содержатся параметры импорта, указываемые на шагах 6-9.

CommitAfterDone

Фиксировать транзакцию после выполнения импорта

1 - enabled, 0 - disabled

CommitRecCount

Количество записей после которых будет производиться фиксация транзакции.

В разделе Records counter Вы можете задать количество импортируемых записей. Выберите пункт Import all records, чтобы импортировать сразу все записи, или в счетчике Import only n records задайте их количество.

ImportRecCount

Импортировать определенное количество записей

1 - enabled, 0 - disabled

ImportAllRows

Импортировать сразу все записи

1 - enabled, 0 - disabled

SaveResultSQL

Сохранить скрипт, получившийся в результате, в файл.

1 - enabled, 0 - disabled

Если установлен флажок Save Result SQL Script to File, то скрипт, получившийся в результате, будет сохранен в файл,

ResultSQLFile

The path to the result *.sql file.

Имя и путь к файлу скрипта.

ImportKind

Вид режима импорта программы

0 - Universal Mode, 1 - Native Mode

TruncateLongString

Разрешить обрезать длинные строки

1 - enabled, 0 - disabled

RollbackIfError

Разрешить откат в случае ошибки

1 - enabled, 0 - disabled

ImportMode

Метод импорта

0 - Insert All, 1 - Insert New, 2 - Update, 3 - Update or Insert, 4 - Delete, 5 - Delete or Insert

ImportAddType

Добавление типа импорта

1 - enabled, 0 - disabled

AllowDuplicates

Позволить импорт дублирующихся записей.

1 - enabled, 0 - disabled

NativeModeKind

Вид собственного режима импорта программы

0 - Single Commands, 1 - Batch insert

[#General#]

В этом разделе хранится название и версия продукта.

Смотрите также:

Работа с консольным приложением


Редактирование поля

При импорте во вновь созданную таблицу Вы можете добавлять, редактировать или удалять поля.

В контекстном меню выберите нужный пункт.

При выборе пункта контекстного меню New column или Edit column открывается диалог, в котором Вы можете просмотреть или отредактировать свойства выбранного поля результирующей таблицы.

В строке Column задается имя поля. Помните, что имя каждого поля в таблице должно быть уникальным.

В строке Type необходимо указать тип поля.

Size

Данная строка определяет размер поля.

Scale

Для типов numeric и decimal необходимо определить количество десятичных знаков.

Default value

В этой строке задается значение по умолчанию для добавляемых строк.

CheckBox Not NULL

Включите опцию, чтобы предотвратить добавления нулевых значений в поле.

CheckBox Is Row Guid

Данный флажок указывает, будет ли SQL Server использовать столбец в качестве глобального уникального идентификатора (ROWGUID). Это свойство может быть установлено только для столбцов с типом данных uniqueidentifier.

CheckBox Identity

Эта опция определяет, является ли редактируемое поле идентификатором.

Для идентификатора можно указать:

  • начальное значение - с помощью счетчика Seed,
  • шаг приращения - с помощью Increment.

CheckBox Not for replication

Установив флажок Not for replication, Вы указываете, что редактируемое поле не предназначено для репликации.


Редактирование соответствия

При установке соответствия полей таблиц можно создавать соответствия.

Чтобы добавить соответствие в список Ranges нажмите на кнопку btnAddRange .

При нажатии на эту кнопку откроется окно для редактирования соответствия.

Mapping fields - Excel - Range

В разделе Range Type задайте тип диапазона.

Из раскрывающегося списка выбирается строка или столбец для которого уже задается диапазон. Затем из списка, расположенного рядом, выберите начало диапазона.

Если в качестве типа выбрана ячейка (Cell), то все опции, помимо выбора номера ячейки, недоступны.

В разделах Start и Finish задайте параметры начала и конца редактируемого диапазона.

Это можно сделать автоматически, установив флажок Where data started для начала и Where data Finished для конца диапазона. Или вручную указать номер строки или столбца в счетчиках Start Row и Finish Row.

Также можно указать лист в книге Microsoft Excel, на котором располагаются нужные данные. Если в разделе Sheet выбрать Default Sheet, то будут использованы данные первого листа. Если установить переключатель в положение Custom Sheet, то можно указать нужный лист по номеру (Sheet number) или по имени (Sheet name).

Удалить соответствие из списка можно с помощью кнопки btnDeleteRange.

Чтобы изменить порядок соответствий в списке воспользуйтесь кнопками btnMoveUp и btnMoveDown.


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться Data Import for SQL Server, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

Data Import for SQL Server подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

На первом шаге из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.