Добро пожаловать в EMS SQL Query!

EMS SQL Query for MySQL - это программа для быстрого и простого построения SQL запросов к базам данных MySQL. В программе существует возможность как визуального создания запросов к MySQL, так и использования многофункционального редактора SQL кода для написания текста запроса вручную. Простой и удобный графический интерфейс позволяет подключаться к базам данных MySQL, выбирать таблицы и поля для запроса к серверу MySQL, устанавливать критерии отбора и многое другое. Программа позволяет работать с несколькими запросами одновременно, редактировать текст запроса во многофункциональном редакторе SQL, просматривать результаты выполнения в различных режимах, визуально создавать запросы MySQL с объединениями и подзапросами, строить основанные на запросах диаграммы, просматривать план выполнения запросов MySQL и выполнять другие операции необходимые для работы с запросами к базам данных MySQL.

Посетите наш сайт: http://www.sqlmanager.net

Key features

  • Современный графический интерфейс пользователя
  • Соединение через SSH туннель: подключение к промежуточному SSH серверу и переадресация всех команд MySQL через безопасный туннель
  • Соединение через HTTP туннель в случае доступа к Интернету только через HTTP прокси сервер, или если сервер не разрешает прямое подключение к MySQL
  • Визуальный выбор таблиц и полей для запроса путем их перетаскивания
  • Работа с несколькими запросами в отдельных окнах
  • Возможность регистрации баз данных для работы только с требуемыми базами
  • Соединение с несколькими базами данных одновременно
  • История недавно написанных запросов
  • Подсветка синтаксиса, возможность "быстрого кода" и шаблоны клавиатуры для ускоренного редактирования текста запросов
  • Инструменты для группировки и фильтрации данных
  • Возможность визуально создавать запросы с объединениями и подзапросами
  • Возможность создания диаграмм на основе запросов
  • Возможность представления планов запросов
  • Гибкая система настройки интерфейса пользователя
  • Многоязыковая поддержка пользовательского интерфейса

Информация по продукту

Домашняя страница: | http://www.sqlmanager.net/ru/products/mysql/query
Служба поддержки: | http://www.sqlmanager.net/ru/support
Регистрация: | http://www.sqlmanager.net/ru/products/mysql/query/buy


Новости

Версия | Дата выпуска
SQL Query for MySQL 3.4.1 | 27.03.2020

Что нового в SQL Query версии 3.4.1?

  • Добавлена поддержка Azure, SQL Server 2017, MySQL Server 8, PostgreSQL 12 и Firebird 3.0.
  • PostgreSQL. Добавлена поддержка материализованных представлений.
  • Oracle. Исправлено отображение результата для колонок типа NCHAR.
  • Исправлена работа туннелинга SSH с использованием секретной фразы.
  • В некоторых случаях при одновременной регистрации нескольких БД выдавалась ошибка. Исправлено.
  • Исправлено повторное отображение ошибки при переключении вкладок редактора.
  • PostgreSQL. Исправлено отображение результата для запросов WITH.
  • Oracle. Добавлена поддержка подключения с использованием переменной окружения TNS_ADMIN.
  • Другие изменения и улучшения.

Желаем приятной работы с нашими программами.

Смотрите также:

История версий


Системные требования

Системные требования для SQL Query for MySQL

  • Microsoft Windows XP, Microsoft Windows Server 2003, Microsoft Windows Server 2008, Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, Microsoft Windows Server 2016, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8/8.1, Microsoft Windows 10
  • 64 MB RAM (рекомендуется 128 MB или более)
  • 20MB свободного пространства на жестком диске для установки программы
  • Возможность соединения с локальным или удаленным сервером MySQL
  • Поддерживаемые версии сервера MySQL: с 4.1 по 8.0


Установка

Установка программы

  • загрузите установочный файл SQL Query for MySQL программы со страницы загрузки;
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped);
  • откройте файл MyQuerySetup.exe и следуйте инструкциям мастера установки;
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Обновление программы

  • загрузите установочный файл SQL Query for MySQL программы со страницы загрузки;
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped);
  • закройте программу SQL Query for MySQL, если она запущена;
  • запустите файл MyQuerySetup.exe и следуйте инструкциям мастера обновления.

Смотрите также:

Часто задаваемые вопросы


Приобретение

Чтобы упростить процесс приобретения наших продуктов, мы заключили контракт с Интернет-регистратором Digital River. Процедура совершения покупки через Digital River защищена безопасным соединением и делает процесс оплаты быстрым и безопасным.

Если Вы заказали программное обеспечение компании EMS в Интернет и хотели бы посмотреть информацию о Вашем заказе, или же если у Вас возникли вопросы, касающиеся приобретения наших продуктов, оплаты или процедуры доставки, пожалуйста, обратитесь в техническую поддержку, обслуживаемую компанией Digital River.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery). Сделав заказ, Вы сможете немедленно скачать регистрационные ключи или пароли и ссылки на архивы полных версий программ. Также Вы получите копию регистрационных ключей или паролей по электронной почте.

Если при оформлении не получили регистрационный ключ в течение двух часов, обратитесь в службу поддержки по этому адресу sales@sqlmanager.net.

Если Вы являетесь зарегистрированным пользователем, то при возникновении проблем или вопросов при использовании нашего программного обеспечения обращайтесь в службу поддержки.

Описание продукта | MyCommerce/Digital River
SQL Query for MySQL (Бизнес версия) + 1 год Сопровождения* | Купить!
SQL Query for MySQL (Бизнес версия) + 2 года Сопровождения*
SQL Query for MySQL (Бизнес версия) + 3 года Сопровождения*
SQL Query for MySQL (Некоммерческая версия) + 1 год Сопровождения*
SQL Query for MySQL (Некоммерческая версия) + 2 года Сопровождения*
SQL Query for MySQL (Некоммерческая версия) + 3 года Сопровождения*
SQL Query for MySQL (Пробная версия) | Скачать

Программа EMS по Сопровождению ПО это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО. Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Мгновенное возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО

Подробнее об услуге сопровождения читайте на странице http://sqlmanager.net/ru/support/faq/maintenance

Смотрите также:

Регистрация


Регистрация

Если Вы не зарегистрировали свою копию программы SQL Query for MySQL, то Вы можете сделать это, нажав кнопку Register Now в окне, открывающемся при выборе пункта главного меню программы Help | About.

hs1500 - Unregistered copy

В появившемся окне укажите регистрационное имя - в поле Registration name, и ключ - в поле Registration Key.

hs1500 - Register product

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией от Softkey!
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно. Для этого необходимо открыть окно About SQL Query for MySQL, выбрав пункт главного меню Help | About. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Смотрите также:

Приобретение


История версий

Версия | Дата выхода
Версия 3.4 | 26.03.2012
Версия 3.3 | 11.07.2011
Версия 3.2 | 07.10.2008
Версия 3.1 | 25.03.2008
Версия 3.0 | 23.05.2007
Версия 2.2 | 13.04.2006
Версия 2.1 | 16.11.2005
Версия 2.0 | 28.09.2005
Версия 1.8 | 26.04.2005
Версия 1.7 | 25.10.2004
Версия 1.6 | 09.06.2004
Версия 1.5 | 19.04.2004
Версия 1.4 | 02.03.2004
Версия 1.2 | 02.02.2004
Версия 1.0 | 03.04.2003

Полная история версий доступна на нашем сайте: http://www.sqlmanager.net/ru/products/mysql/query/news

Версия 3.3

  • Теперь файл Справки запускается на языке локализации программы;
  • Добавлена проверка версии библиотеки libmysql;
  • Результаты выполнения запроса BLOB - полей в кодировке UTF-8 отображались неверно. Исправлено;
  • Параметры подключения по SSH не сохранялись. Исправлено;
  • Последовательность таких действий как: выполнение корректного запроса, который не может быть разобран; переход на вкладку Builder; переход на вкладку редактора SQL - приводила к удалению текста запроса. Исправлено;
  • Прочие незначительные изменения и исправления.

Версия 3.3

  • Добавлена возможность разбора подзапросов в операторе JOIN;
  • В конструкторе запросов добавлено автоматическое отражение оператора JOIN для таблиц с внешними ключами;
  • В конструкторе запросов добавлена возможность использования агрегатных функций для оператора CASE;
  • Добавлена возможность выполнять только выделенную часть запроса в редакторе запросов;
  • При разборе запроса, в котором содержалось имя таблицы, начинающееся с символа подчеркивания, возникала ошибка AV. Исправлено;
  • В SQL Query for MySQL возникала ошибка при разборе запроса UPDATE с подзапросом в конструкции WHERE. Исправлено;
  • Параметры программы сохранялись некорректно. Исправлено;
  • Прочие незначительные изменения и исправления.

Версия 3.2

  • Добавлена вкладка Favorites для быстрого доступа к избранным запросам
  • Добавлена возможность визуального построения подзапросов, участвующих в выражении FROM
  • Другие улучшения и исправления.

Версия 3.1

  • Редактор SQL теперь поддерживает Unicode
  • Добавлена возможность сохранения настроек приложения в файл реестра
  • При удалении таблиц на закладке Builder, теперь автоматически удаляются поля таблицы, находящиеся в условии Where.
  • Другие улучшения и исправления.

Версия 3.0

  • Добавлена поддержка данных UNICODE в сетке данных
  • Асинхронное выполнение запросов
  • Улучшена поддержка SSH туннелирования: добавлена поддержка секретного ключа для SSH аутентификации
  • Добавлены HTML представления и Hexadecimal представления для BLOB – полей
  • Расширена функциональность ToolTips в Проводнике баз данных: отображаются комментарии для объектов и информация о базе данных
  • В SQL ассистенте теперь отображаются комментарии для полей
  • Добавлена функция поиска объекта в Проводнике баз данных
  • Теперь можно использовать единый репозиторий зарегистрированных баз данных для SQL Query и SQL Manager (если последний установлен на той же рабочей станции)
  • Улучшен интерфейс
  • Улучшен Проводник баз данных: значительно более удобная панель инструментов и контекстное меню
  • Другие улучшения и исправления.

Наверх

Версия 2.2

  • Улучшен интерфейс: доступны визуальные схемы Office 11 и Windows XP
  • Реализован вывод результата выполнения запроса на отдельную закладку
  • Загрузка данных в таблицу для запросов, возвращающих огромное количество записей в режиме 'Load All Rows' теперь работает гораздо быстрее
  • Улучшена обработка ошибок при соединении с базой данных
  • Построение диаграммы на базе запроса, возвращающего значительное число строк, теперь может быть отменено
  • Query Builder: Опция 'Script Format' теперь работает отлично
  • Редактор SQL: Quick Code, опция 'Code Case' работала некорректно. Исправлено
  • Ошибка, возникавшая после множественного нажатия на кнопку 'Explain Query' теперь исправлена
  • Другие улучшения и исправления.

Наверх

Версия 2.1

  • Пункт 'Column Summary' контекстного меню позволяет редактировать сводку по столбцу при просмотре данных в виде таблицы
  • Добавлена возможность быстрого поиска при просмотре данных в виде таблицы
  • Конструктор запросов: большие диаграммы теперь загружаются корректно
  • Диалоговое окно About отражает все изменения, если пройдена регистрация
  • При регистрации новой базы данных, информация о хосте по умолчанию берется из регистрационной информации текущего хоста
  • Свойства фильтра теперь можно открыть с помощью кнопки 'Filter'
  • В случае ошибки синтаксиса в SQL выражении, описание ошибки можно увидеть в окне сообщений.

Наверх

Версия 2.0

  • Новый, современный графический интерфейс
  • Возможность добавлять в запрос поля и таблицы посредством перетаскивания (drag-and-drop)
  • Реализована возможность одновременной работы с несколькими запросами в отдельных окнах
  • Для работы с базой данных в SQL Query for MySQL, необходимо ее зарегистрировать
  • Визуальное построение запросов с объединениями и подзапросами теперь доступно
  • Теперь возможны одновременные подключения к нескольким базам данных
  • Доступны расширенные возможности печати
  • Добавлена возможность построения плана запроса
  • Реализовано построение диаграмм по данным запросов
  • Доступна история недавно открытых запросов
  • Добавлен набор полезных инструментов, таких как группировка и фильтрация
  • Подсветка синтаксиса, "быстрый код" и шаблоны клавиатуры призваны ускорить работу с текстом запроса
  • Поддержка представлений в MySQL 5.x.xx
  • добавлена возможность тщательной настройка графического интерфейса (в том числе выбор языка)
  • Реализовано подключение через SSH туннель
  • Реализовано подключение через HTTP туннель
  • Другие улучшения и исправления.

Наверх

Версия 1.8

  • Обновление объектов в дереве проводника баз данных теперь происходит быстрее
  • Добавлена поддержка представлений
  • Поддержка наборов символов: стала возможной работа с базами данных с различными наборами данных, независимо от настроек сервера
  • Добавлена поддержка серверов использующих длинные имена (более 16 символов)
  • Реализована возможность печати текста запроса
  • Функция автозавершения кода теперь включается автоматически
  • Добавлено сочетание клавиш Ctrl+G для перехода на строку с указанным номером
  • Шаблон для строки символа '**' ошибочно подменялся шаблоном для символа '*'. Исправлено
  • Другие улучшения и исправления.

Наверх

Версия 1.7

  • Теперь время выполнения запроса и количество выбранных/измененных записей отображается в строке сообщений
  • Результат запроса может быть скопирован в буфер обмена
  • Добавлено выделение цветом имен процедур и параметров
  • Улучшен просмотр данных в виде таблицы: Вы можете использовать сочетание клавиш Ctrl+C, чтобы скопировать содержимое в буфер обмена
  • При открытии окна с запросом, программа выдавала ошибку Access Violation, если значение опции Query builder | Condition Button Style отлично от 3D-look. Исправлено.

Наверх

Версия 1.6

  • Реализовано взаимодействие между SQL Query и Data Export: Вы можете экспортировать результаты запросов посредством утилиты Data Export
  • Реализовано отображение результатов выражения SHOW...
  • Ширина столбцов при просмотре перед печатью совпадает с шириной столбцов при просмотре данных в виде таблицы. Также в этой версии ширина столбцов может быть изменена
  • В диалоговом окне Print View добавлена кнопка Refresh Report
  • Если утилита обнаруживает ошибки при проверке запроса, то она выводит их описание.

Наверх

Версия 1.5

  • Теперь диаграмму файл запроса или диаграммы можно загрузить в ранее открытое окно
  • Добавлена возможность открытия ранее редактируемых запросов при помощи меню проводника баз данных
  • Пути к ранее открытым/сохраненным файлам теперь сохраняются для каждой базы данных
  • Данная версия программы строит форму просмотра перед печатью заново, если результаты запроса были изменены
  • Добавлена возможность сохранять диаграмму как изображение. Доступны форматы BMP и WMF
  • Добавлена поддержка MySQL 4.1.1
  • Другие улучшения и исправления.

Наверх

Версия 1.4

  • В проводник баз данных добавлена ветка История запросов. Вы можете отключить ее отображение с помощью опции диалогового окна Environment Options
  • Теперь возможно выбрать: показывать историю всех запросов, или только для текущего. Соответствующий пункт добавлен в контекстное меню истории запросов
  • Добавлена возможность фильтрации данных, полученных в результате выполнения запроса
  • При переходе на вкладку редактора, в конструкторе запросов теперь сохраняется визуальное представление
  • В разделы проводника баз данных Favorite Queries и Query History добавлена всплывающая подсказка, позволяющая увидеть текст запроса, не открывая его
  • Размер страницы по умолчанию для просмотра перед печатью теперь можно задать в разделе Report диалогового окна Environment Options.
  • Добавлена опция 'Autofit Row Height'.
  • Исправлена ошибка, связанная с опциями 'Fetch All' и 'Load All'.

Наверх

Версия 1.2

  • Значительно улучшен просмотр данных в виде таблицы; добавлена возможность фильтрации записей
  • Теперь доступен просмотр данных типа BLOB
  • Добавлен просмотр результатов запроса в виде печатной формы
  • Реализована возможность выделять и копировать текст с вкладки History
  • Подзапросы вида "SELECT Field1 FROM Table1 WHERE Field1 IN (SELECT Field2 FROM Table2 WHERE Field2='Value')" и условия типа "Field1 = (SELECT Field2 FROM Table1 WHERE Field2='Value')" теперь обрабатываются корректно
  • Утилита некорректно разбирала логические и составные условия. Исправлено.

Наверх

Версия 1.0

Основные возможности:

  • Графический пользовательский интерфейс
  • Подключение к серверу MySQL
  • Визуальное построение запросов и редактирование текста запроса
  • Одновременная работа с несколькими запросами
  • Редактирование запросов и просмотр результатов в различными способами

и другие...

Наверх

Смотрите также:

Новости


Часто задаваемые вопросы

Если у Вас есть вопросы о программе SQL Query for MySQL, пожалуйста, прочтите внимательно эту страницу.

Содержание

Вопросы о продукте

  • Что такое EMS Query MySQL?
  • Что требуется, чтобы начать работу с SQL Query for MySQL?
  • Чем отличается модуль Query Builder в SQL Manager for MySQL от утилиты SQL Query?
  • Есть ли какие-нибудь ограничения в пробной версии?

Неполадки

  • Как можно использовать функцию Export dataset? Когда я нажимаю на кнопку Export Data на панели инструментов, ничего не происходит.
  • Я использую базу данных с набором символов UTF-8. Некоторые символы отображаются некорректно в результате запроса. Что не так?
  • Я зарегистрировал базу данных, но при попытке подключения к ней программа выдает сообщение: "dynamic library libmysql.dll not found".
  • Когда я пытаюсь соединиться с базой данных, я получаю следующее сообщение: Access denied for user:user@host.domain. Почему так происходит?
  • Я пытаюсь связаться с удаленным хостом MySQL, но получаю сообщение: "Host not allowed to connect to server". В чем причина?
  • При попытке соединения с MySQL 4.1.x. я получаю сообщение "Bad Handshake". Вообще, этот продукт поддерживает 4.1.x.?
  • При каждой попытке подключения к удаленной базе MySQL на Linux-сервере, я получаю сообщение об ошибке 'Lost connection to MySQL server during query'. В чем дело?

В: Что такое EMS Query MySQL?

О: SQL Query for MySQL - это утилита для простого и быстрого создания запросов к базам данных MySQL. SQL Query for MySQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое. Также Вы можете работать с несколькими запросами одновременно, редактировать их, просматривать полученные результаты в нескольких режимах и производить любые, необходимые для Вашей работы, операции с запросами к базам данных.

В: Что требуется, чтобы начать работу с EMS SQL Query?

О: Во-первых, Вы должны иметь возможность подключиться к локальному или удаленному серверу <%SERVER_TITLE%> (http://www.mysql.com/downloads/index.html). Загрузка бесплатна.

Во-вторых, Вам нужен компьютер, работающий под управлением ОС Microsoft Windows NT4 с SP4 или выше, Microsoft Windows 2000, Microsoft Windows 2000 Server, Microsoft Windows XP, Microsoft Windows 2003 Server, Microsoft Windows Vista и удовлетворяющий системным требованиям.

В: Чем отличается функция "Query Builder" из инструментария SQL Manager for MySQL от приложения SQL Query?

О: В первую очередь, SQL Query for MySQL работает быстрее, так как это более легкий продукт. Также SQL Query for MySQL обладает рядом дополнительных функций для построения запросов, например:

  • "избранные/favorite" запросы для поиска и быстрого запуска наиболее часто исполняемых запросов;
  • хранение истории запросов, позволяющей совершить "откат" к любому отредактированному запросу;
  • различные улучшения интерфейса программы для более продуктивной и удобной работы;
  • возможность просматривать результаты запросов в виде диаграмм

В: Есть ли какие-нибудь ограничения в пробной версии?

О: Функциональных различий между полной и пробной версиями программы фактически нет. Это значит, что Вы можете в полной мере испытать весь функционал SQL Query for MySQL за 30 дней тестового периода.

Наверх

Неполадки

В: Как можно использовать функцию Export dataset? Когда я нажимаю на кнопку Export Data на панели инструментов, ничего не происходит.

О: Убедитесь, что на Вашей рабочей станции установлена последняя версия EMS Data Export for MySQL. Она должна быть зарегистрирована, и как минимум единожды запущена, перед тем как Вы сможете использовать функцию экспорта результатов.

В: Я использую базу данных с набором символов UTF-8. Некоторые символы отображаются некорректно в результате запроса. Что не так?

О: Вам необходимо указать используемую кодировку в поле Client charset диалогового окна Database Registration Info.

В: Я зарегистрировал базу данных, но при попытке подключения к ней программа выдает сообщение: "dynamic library libmysql.dll not found".

О: Убедитесь, что файлы libmysql.dll находятся в одной директории с утилитой. Переустановка программы может решить проблему.

В: Когда я пытаюсь соединиться с базой данных, я получаю следующее сообщение: Access denied for user:user@host.domain. Почему так происходит?

О: Эта ошибка генерируется сервером MySQL из-за того, что у Вас нет полномочий для связи с сервером непосредственно с Вашего хоста. Пожалуйста, свяжитесь с Вашим администратором базы данных для разрешения этой проблемы.

В: Я пытаюсь связаться с удаленным хостом MySQL, но получаю сообщение: "Host not allowed to connect to server". В чем причина?

О: Данная ошибка вызвана отсутствием прав у вашего хоста на соединение с удаленным MySQL сервером. Пожалуйста, свяжитесь с вашим системным администратором или, если у Вас есть доступ к MySQL серверу с GRANT привилегией, Вы можете использовать оператор GRANT, чтобы добавить нового пользователя. Например, чтобы открыть полный доступ пользователю с вашего хоста, можно выполнить команду: /*!50003 CREATE USER 'user'@'user_host'*/; GRANT ALL PRIVILEGES ON *.* TO 'user'@'user_host' IDENTIFIED BY ' user_password '; (http://dev.mysql.com/doc/refman/5.1/en/privileges.html)

В: При попытке соединения с MySQL 4.1.x. я получаю сообщение "Bad Handshake". Вообще, этот продукт поддерживает 4.1.x.?

О: Скорей всего, Вы используете старую версию библиотеки libmySQL.dll. Используйте клиентскую библиотеку из нашего установочного пакета. Попробуйте переустановить утилиту.

В: При каждой попытке подключения к удаленной базе MySQL на Linux-сервере, я получаю сообщение об ошибке 'Lost connection to MySQL server during query'. В чем дело?

О: Эта ошибка появляется в том случае, если Ваш Linux glibc требует больше, чем 128Кб размер стека для разрешения имени хоста. В основном, это происходит на системах с RedHat 8.0 и версией сервера MySQL ниже 4.0.10, но иногда встречается и на других конфигурациях. Чтобы решить эту проблему, добавьте/отредактируйте следующую строку в секции [mysqld] файла конфигурации MySQL: set-variable = thread_stack=192k # (значение должно быть 192k или больше)

Наверх


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Начало работы

SQL Query for MySQL помогает быстро и просто создавать запросы SQL, что позволяет эффективнее работать с базами данных.

Дальнейшие разделы посвящены подробному описанию встроенных средств утилиты и ее возможностей. Пожалуйста, ознакомьтесь с последующими инструкциями, чтобы эффективно и быстро выполнять различные действия.

Первый запуск

Навигация по базам данных

Работа с запросами

Контекстное меню

Импорт настроек

Выбор языка программы

Желаем приятной работы с SQL Query for MySQL!

hs2000 - Getting started

Смотрите также:

Инструменты EMS SQL Query

Опции EMS SQL Query


Первый запуск

Так выглядит SQL Query for MySQL при первом запуске.

Главное меню позволяет Вам работать с базами данных (Databases), редактировать (Edit) запросы, отображать/скрывать Проводник баз данных (Database Explorer), SQL ассистент (SQL Assistant), и панели инструментов (Toolbars) для быстрого доступа к операциям с базами данных (Database operations), опциям (Options), инструментам управления запросами (Query management tools) в разделе меню View.

Для начала работы с сервером MySQL необходимо сначала зарегистрировать хост при помощи мастера регистрации хоста. После этого нужно зарегистрировать одну или несколько баз данных, используя мастер регистрации баз данных.

По умолчанию кнопки Register Host btnRegisterDB, Register Database btnRegisterDB доступны на панели инструментов и в меню Database.

hs2100 - First time started

После того как настройки подключения определены, Вы можете установить соединение с базой данных и начать работу с запросами SQL.

Смотрите также:

Контекстные меню

Выбор языка программы

Импорт настроек


Навигация по базам данных

После регистрации необходимых баз данных, в дереве Проводника баз данных появятся соответствующие ветки. Если на вкладке DB Explorer в диалоговом окне Environment Options включена опция Show Hosts, то хосты будут отображаться в дереве проводника; управлять отображением хостов Вы можете с помощью соответствующего пункта контекстного меню баз данных.

Для подключения к базе данных щелкните дважды клавишей мыши на ее псевдониме в дереве проводника баз данных, или выделите псевдоним и нажмите Enter. При успешном подключении, объекты базы данных отобразятся в виде подузлов. После подключения к базе данных Вы можете использовать Проводник баз данных для навигации по зарегистрированным объектам MySQL и SQL запросам. SQL ассистент поможет Вам получить более подробную информацию о выбранном объекте.

hs2200 - Database navigation

Смотрите также:

Работа с запросами

Контекстные меню

Выбор языка программы

Импорт настроек


Работа с запросами SQL

Элементы дерева Проводника баз данных позволяют Вам работать с объектами базы данных. Двойное нажатие на объект (или выделение объекта и нажатие клавиши Enter) создает запрос для этого объекта. Нажатие правой клавиши мыши на выделенном объекте открывает контекстное меню, позволяющее выполнять различные операции над этим объектом или базой данных в целом.

hs2000 - Getting started

Смотрите также:

Навигация по базам данных

Контекстные меню

Выбор языка программы

Импорт настроек


Контекстные меню

Контекстные меню упрощают работу с SQL Query for MySQL, позволяя выполнять множество различных операций.

Выберите объект в Проводнике баз данных и щелкните на нем правой клавишей мыши, чтобы открыть контекстное меню.

Контекстное меню хоста

Контекстное меню базы данных

Контекстное меню запросов

Смотрите также:

Навигация по базам данных

Работа с запросами

Выбор языка программы

Импорт настроек


Контекстное меню хоста

В Проводнике баз данных контекстное меню зарегистрированного хоста позволяет:

  • регистрировать базы данных с помощью мастера регистрации баз данных;
  • регистрировать хост используя мастер регистрации хоста;
  • удалить регистрацию хоста;
  • осуществлять поиск объектов в дереве проводника баз данных;
  • настраивать представление объектов в проводнике.

hs2410 - DB Explorer - Host context menu

Смотрите также:

Контекстное меню базы данных

Контекстное меню запросов


Контекстное меню базы данных

С помощью этого контекстного меню можно:

  • подключаться к выбранной базе данных (если соединение с ней не установлено);
  • отключаться от выбранной базы данных (если соединение установлено);
  • регистрировать новую базу данных при помощи мастера регистрации баз данных;
  • ударить регистрацию выбранной базы данных;
  • регистрировать новый хост используя мастер регистрации хоста;
  • просматривать и изменять информацию о регистрации базы данных;
  • осуществлять поиск объектов в дереве проводника баз данных;
  • настраивать представление объектов в проводнике;
  • повторно открывать сохраненные в файл запросы.

hs2420 - DB Explorer - Database context menu

Смотрите также:

Контекстное меню запросов

Контекстное меню хоста


Контекстное меню запроса

В Проводнике баз данных контекстное меню запроса позволяет следующее:

hs2430 - DB Explorer - Query context menu

для ветки История запросов:

  • открывать запрос в редакторе SQL;
  • просматривать текст запроса;
  • очищать историю.

для ветки Избранные запросы:

  • открывать запрос в редакторе SQL
  • просматривать текст запроса;
  • переименовать запрос;
  • удалить запрос;
  • удалить все запросы ветки.

Смотрите также:

Контекстное меню базы данных

Контекстное меню хоста


Импорт настроек

При первом запуске SQL Query, программа проверяет установлен ли SQL Manager for SQL Query на рабочей станции и предлагает импортировать его репозитарий в SQL Query.

hs2500 - Database repository

При необходимости Вы можете импортировать настройки SQL Manager в SQL Query for MySQL. Диалоговое окно импорта настроек из SQL Manager позволит определить группы настроек, которые необходимо применить для SQL Query.

hs2500 - Import settings

Открыть это диалоговое окно можно с помощью пункта главного меню Options | Import settings from SQL Manager.

Смотрите также:

Навигация по базе данных

Работа с запросами

Контекстные меню

Выбор языка программы


Выбор языка программы

В окне Select Language Вы можете выбрать любую из предложенных локализаций интерфейса.

hs2600 - Selecting program language

Чтобы открыть это окно, выберите пункт главного меню Options | Select Language.

Это окно содержит список доступных языков, найденных в директории, указанной на вкладке Localization диалогового окна Environment Options.

Смотрите также:

Навигация по базам данных

Работа с запросами

Контекстные меню

Импорт настроек


Инструменты EMS SQL Query

SQL Query for MySQL предлагает множество инструментов для эффективной работы с базами данных MySQL.

Проводник баз данных

Управление базами данных

Управление запросами

Управление данными

Смотрите также:

Начало работы

Опции EMS SQL Query


Проводник баз данных

Проводник баз данных (Database Explorer или DB Explorer) основное навигационное окно SQL Query for MySQL для работы с базами данных, их объектами и запросами. Имеет иерархическую структуру. Состоит из нескольких окон. Позволяет быстро выполнять, практически, все операции с базами данных.

Информация о регистрации базы данных

Подключение к базе данных

Краткая информация о базе данных

История запросов

SQL ассистент

hs3100 - Database Explorer

Скрыть/отобразить окно проводника баз данных можно, используя пункт главного меню View | DB Explorer или кнопку F11.

Смотрите также:

Управление базами данных

Управление запросами

Управление данными


Информация о регистрации баз данных

Зарегистрировав базу данных в SQL Query for MySQL, Вы можете использовать контекстное меню для различных операций над ней.

hs2420 - DB Explorer - Database context menu

Чтобы просмотреть или изменить информацию о регистрации базы данных, щелкните правой клавишей мыши на представлении нужной базы данных в дереве проводника и выберите пункт контекстного меню базы данных Database Registration Info..., после чего откроется диалоговое окно Database Registration Info.

Смотрите также:

Подключение к базе данных

Краткая информация о базах данных

История запросов

SQL Ассистент


Подключение к базе данных

После регистрации хоста и базы данных Вы можете установить с ней соединение.

hs3120 - Connecting to databases

Самый простой способ подключения к базе данных - дважды кликнуть на ее представлении в дереве Проводника баз данных. Также можно выбрать пункт контекстного меню Connect to Database или пункт главного меню Database | Connect to Database.

Альтернативный путь подключения к базе данных - использование сочетания клавиш Shift+Ctrl+C.

Смотрите также:

Информация о регистрации баз данных

Краткая информация о базах данных

История запросов

SQL ассистент


Краткая информация о базах данных

Проводник баз данных позволяет получить краткую информацию о базе данных, не использую контекстного меню.

hs3130 - Viewing brief DB info

Если Вы зарегистрировали несколько баз данных, то для просмотра краткой информации о базе данных можно использовать всплывающее окно, которое появится, если задержать курсор мыши над представлением базы данных в Проводнике баз данных.

Смотрите также:

Информация о регистрации баз данных

Подключение к базе данных

История запросов

SQL ассистент


История запросов

Ветка истории запросов (Query History) в Проводнике баз данных содержит список ранее выполненных запросов. История запросов у каждой базы данных своя.

hs3140 - Viewing query history

Двойной щелчок мыши по запросу откроет его в Редакторе SQL.

Чтобы упростить поиск нужного запроса, можно воспользоваться всплывающим окном, которое появится если выделить нужный запрос и задержать курсор мыши над его представлением. В этом окне отображается текст запроса, что избавляет Вас от необходимости открывать каждый запрос в поисках требуемого.

Для Вашего удобства также доступен перечень избранных запросов (Favourite Queries iconFavoriteQueries) в проводнике баз данных SQL Query for MySQL.

Добавить запрос в список избранных Вы можете используя кнопку Add Query to Favorites iconFavoriteQueries на панели инструментов Редактора SQL или Визуального конструктора запросов.

Смотрите также:

Информация о регистрации баз данных

Подключение к базе данных

Краткая информация о базах данных

SQL ассистент


SQL ассистент

SQL ассистент - окно, расположенное в нижней части Проводника баз данных, которое помогает Вам в работе с объектами базы данных. При выборе объекта в Проводнике баз данных, дополнительная информация о нем отобразится в окне SQL ассистента.

hs3150 - SQL Assistant

Если выбран(а):

Хост - SQL ассистент отобразит список зарегистрированных на нем баз данных. Имена баз данных, с которыми не установлено соединение будут серыми.

База данных - SQL ассистент отобразит список групп объектов с указанием количества объектов в них.

Группа объектов - SQL ассистент выведет список содержащихся в ней объектов.

Таблица или представление - SQL ассистент покажет список полей, их тип и комментарии к ним.

Запрос - SQL ассистент отобразит дату и время его создания.

Вы можете использовать SQL ассистент для быстрого создания запроса. Перетащите любой объект из него на рабочую область Редактора SQL или Визуального конструктора запросов для включения этого объекта в запрос.

Смотрите также:

Информация о регистрации

Подключение к базе данных

Краткая информация о БД

История запросов


Управление базами данных

SQL Query for MySQL имеет множество инструментов для управления базами данных MySQL:

Регистрация хоста

  • выберите пункт главного меню Database | Register Host... или нажмите соответствующую кнопку btnRegisterHost на панели инструментов;
  • настройте необходимые опции с помощью Мастера регистрации хоста.

Регистрация базы данных

Чтобы зарегистрировать одну базу данных в SQL Query for MySQL:

  • выберите пункт главного меню Database | Register Database... или нажмите соответствующую кнопку btnRegisterDB на панели;
  • включите опцию Register a single database и измените необходимые настройки в Мастере регистрации базы данных.

Чтобы зарегистрировать несколько баз данных:

  • выберите пункт главного меню Database | Register Database... или нажмите соответствующую кнопку btnRegisterDB на панели;
  • отключите опцию Register a single database и измените необходимые настройки в Мастере регистрации базы данных.

Удаление регистрации базы данных

Чтобы удалить регистрацию базы данных в SQL Query for MySQL:

  • выделите нужную базу данных в дереве Проводника баз данных;
  • выберите пункт главного меню Database | Unregister Database или нажмите соответствующую кнопку btnUnregisterDB на панели инструментов;
  • подтвердите удаление регистрацию базы данных в соответствующем диалоговом окне.

Чтобы удалить регистрацию хоста и всех баз данных, расположенных на нем:

  • выделите требуемый хост в дереве Проводника баз данных;
  • выберите пункт главного меню Database | Unregister Host или нажмите соответствующую btnUnregisterHost кнопку на панели инструментов;
  • подтвердите удаление регистрации в соответствующем диалоговом окне.

Подключение к базе данных

Чтобы подключиться к базе данных в SQL Query for MySQL:

  • выделите нужную базу данных в дереве Проводника баз данных;
  • дважды щелкните мышью на ее представлении

или

  • выберите пункт главного меню Database | Connect to Database или нажмите соответствующую кнопку btnConnectToDB на панели инструментов

или

  • щелкните правой клавишей мыши на представлении базы данных и выберите пункт контекстного меню Connect to Database;

Отключение от базы данных

Чтобы отключится от базы данных в SQL Query for MySQL:

  • выделите представление базы данных в дереве Проводника баз данных;
  • выберите пункт контекстного меню Database | Disconnect from Database или нажмите соответствующую кнопку btnDisconnectFromDB на панели инструментов;

или

  • щелкните правой клавишей мыши на представлении базы данных, или на любом ее объекте и выберите пункт контекстного меню Disconnect from Database.

Смотрите также:

Проводник баз данных

Управление запросами

Управление данными


Мастер регистрации хоста

Мастер регистрации хоста позволяет Вам регистрировать хост и базы данных на нем.

hs3210 - Register Host Wizard

Чтобы запустить мастер, выберите пункт главного меню Database | Register Host... или используйте соответствующую кнопку btnRegisterHost на панели инструментов. Вы также можете использовать сочетание клавиш Shift+Ctrl+R.

  • Настройки подключения
  • Параметры туннелирования
  • Параметры регистрации

Смотрите также:

Мастер регистрации базы данных

Информация о регистрации базы данных


Настройки подключения

Настройте необходимые параметры подключения к серверу MySQL.

hs3211 - Setting connection properties

В поле Host name необходимо указать имя сервера. Из раскрывающегося списка можно выбрать уже зарегистрированный сервер.

Для подключения к серверу необходимо указать порт - Port. По умолчанию используется порт '3306'.

Затем необходимо указать параметры авторизации: имя пользователя - User name и пароль - Password. Имя привилегированного пользователя по умолчанию - 'root' без пароля.

CheckBox Register a single database

Включите опцию, если хотите зарегистрировать одну базу данных на хосте.

CheckBox Use tunneling

При использовании туннелирования Вам необходимо будет настроить параметры туннелирования на соответствующем шаге мастера.

RadioButton SSH tunneling

Установите флажок, если хотите использовать промежуточный SSH сервер. Все команды сервера MySQL в этом случае будут проходить через SSH туннель. Следующий шаг позволит Вам настроить параметры SSH туннелирования.

RadioButton HTTP tunneling

Выберите опцию для подключения к MySQL через протокол HTTP, в случае если возможно подключение через Интернет только через прокси, либо если сервер запрещает прямые подключения, но разрешает подключения по HTTP протоколу. На следующем шаге Вы сможете установить соответствующие параметры HTTP туннелирования.

Если опция Register a single database отключена, то нужно будет указать базы данных, которые необходимо зарегистрировать на этом сервере.

hs3211 - Selecting databases

Для этого переместите нужные базы данных из списка доступных (Available databases) в список выбранных (Selected databases) посредством кнопок Move to Selected Move all to Selected Move to Available Move all to Available, или "перетаскиванием".

Нажмите кнопку Next для перехода на шаг задания параметров регистрации, или настройки параметров туннелирования, если было указано использовать SSH или HTTP туннелирование.


Параметры туннелирования

На этом шаге необходимо настроить параметры подключения через SSH или HTTP туннель (если на предыдущем шаге было выбрано SSH или HTTP туннелирование).

Помните, что и SSH и HTTP туннелирование может быть использовано для одного подключения, но только не одновременно.

hs3212 - Specifying SSH Tunnel parameters

Параметры SSH-туннелирования

Здесь Вам нужно указать имя хоста SSH (SSH Host name), порт (SSH port), имя пользователя (SSH user name), пароль (SSH password) и, путь к ключу (SSH key file), если установлен флажок Use Private Key for authentication.

Важно: В случае использования SSH-туннелирования имя хоста MySQL должно быть задано относительно сервера SSH.

Более подробно в разделе SSH туннелирование.

Параметры HTTP-туннелирования

Если на предыдущем шаге было указано использовать HTTP-туннелирование, то Вам необходимо будет загрузить на сервер скрипт emsproxy.php и указать в соответствующем разделе адрес URL в формате: http://webserver_address/emsproxy.php

Более подробно в разделе HTTP туннелирование.

hs3212 - Specifying HTTP Tunnel parameters

Нажмите кнопку Next для перехода на шаг настройки параметров регистрации.


Параметры регистрации

Выберите из списка Database name нужную базу данных и укажите ее псевдоним в поле Database alias. Затем установите необходимые опции. Повторите действия для каждой базы данных на выбранном хосте.

При необходимости Вы можете указать клиентскую кодировку Client charset и кодировку шрифта Font charset.

hs3213 - Setting registration options

CheckBox Login prompt before connection

Если Вы не хотите хранить пароль, то устанавливайте этот флажок и каждый раз при подключении пароль будет запрашиваться заново.

CheckBox Use compression protocol

Включите опцию для использования протокола сжатия данных при подключении к серверу базы данных.

CheckBox Autoconnect at startup

При запуске программы связь с этой базой данных будет устанавливаться автоматически.

CheckBox Keep connection alive

Опция определяет будет ли опрашиваться сервер перед каждым выполнением запроса.

CheckBox Use SSL protocol

Если опция включена, обмен данными происходит с использованием удаленного MySQL сервера с использованием шифрованного канала. Опция работает только с версией сервера, поддерживающей SSL подключения.

CheckBox Interactive mode

Установив этот флажок Вы позволяете использовать значение переменной interactive_timeout, из файла my.cnf вместо переменной wait_timeout для задания ограничения времени подключения.

CheckBox Quote identifiers

Если установлен этот флажок, то все идентификаторы будут заключены в открывающие кавычки ('`'). Примечание: эта функция применима только к тем серверам, которые используют псевдонимы в кавычках.

CheckBox Disable transactions

Установив этот флажок Вы указываете что транзакции будут выключены, а вносимые изменения автоматически будут применяться.

CheckBox Enable log of SQL Editor queries

Опция включает/выключает журналирование SQL запросов.

Log file

Это поле доступно, если включено журналирование SQL запросов. В нем необходимо указать путь к файлу, в который будут сохраняться запросы.

Если требуется изменить настройки регистрации хоста MySQL, Вы можете вернуться на предыдущий шаг, нажав на кнопку Back.

Нажмите на кнопку Finish для завершения процедуры регистрации хоста, после чего Вы сможете работать с ним в SQL Query for MySQL.


Мастер регистрации баз данных

Мастер регистрации баз данных позволяет Вам зарегистрировать одну или несколько баз данных на хосте.

hs3220 - Register Database Wizard

Чтобы запустить мастер регистрации баз данных, выберите пункт главного меню Database | Register Database... или нажмите соответствующую кнопку btnRegisterDB на панели инструментов. Вы также можете использовать сочетание клавиш Shift+Alt+R.

  • Настройки подключения
  • Параметры туннелирования
  • Параметры регистрации

Смотрите также:

Информация о регистрации баз данных

Мастер регистрации хоста


Настройки подключения

Настройте необходимые параметры подключения к серверу MySQL.

hs3221 - Specifying the host

В поле Host name необходимо указать имя сервера. Из раскрывающегося списка можно выбрать уже зарегистрированный сервер.

Для подключения к серверу необходимо указать порт - Port. По умолчанию используется порт '3306'.

Затем необходимо указать параметры авторизации: имя пользователя - User name и пароль Password.

Имя привилегированного пользователя по умолчанию - 'root' без пароля.

CheckBox Register a single database

Включите опцию, если хотите зарегистрировать одну базу данных на хосте.

CheckBox Use Tunneling

Если флажок установлен, Вам необходимо будет установить параметры туннелирования на соответствующем шаге мастера.

RadioButton SSH tunneling

Установите флажок, если хотите использовать промежуточный SSH сервер. Все команды сервера MySQL в этом случае будут проходить через SSH туннель. Следующий шаг позволит Вам настроить параметры SSH туннелирования.

RadioButton HTTP tunneling

Выберите опцию для подключения к MySQL через протокол HTTP, в случае если возможно подключение через Интернет только через прокси, либо если сервер запрещает прямые подключения, но разрешает подключения по HTTP протоколу. На следующем шаге Вы сможете установить соответствующие параметры HTTP туннелирования.

Нажмите кнопку Next для перехода на шаг настройки параметров регистрации, или параметров туннелирования, если указано использовать SSH или HTTP туннель для подключения.


Параметры туннелирования

На этом шаге необходимо настроить параметры подключения через SSH или HTTP туннель.

Помните, что и SSH, и HTTP туннелирование может быть использовано для одного подключения, но только не одновременно.

hs3222 - Specifying SSH Tunnel parameters

Параметры SSH-туннелирования

Здесь Вам нужно указать имя хоста SSH (SSH Host name), порт (SSH port), имя пользователя (SSH user name), пароль (SSH password) и, если требуется, путь к ключу (SSH key file).

Более подробно в разделе параметры SSH туннелирования.

Параметры HTTP туннелирования

Если на предыдущем шаге было указано использовать HTTP туннелирование, то Вам необходимо будет загрузить на сервер скрипт emsproxy.php и указать в соответствующем разделе адрес URL в формате: http://webserver_address/emsproxy.php

hs3222 - Specifying HTTP Tunnel parameters

Более подробно в разделе параметры HTTP туннелирования.

Нажмите кнопку Next для перехода на шаг настройки параметров регистрации.


Параметры регистрации

Выберите имя базы данных из выпадающего списка Database name и укажите ее псевдоним в поле Database alias.

При необходимости Вы можете указать клиентскую кодировку Client charset и кодировку шрифта Font charset.

hs3223 - Setting registration options

CheckBox Login prompt before connection

Если Вы не хотите хранить пароль, то устанавливайте этот флажок и каждый раз при подключении пароль будет запрашиваться заново.

CheckBox Use compression protocol

Включите опцию для использования протокола сжатия данных при подключении к серверу базы данных.

CheckBox Keep connection alive

Опция определяет будет ли опрашиваться сервер перед каждым выполнением запроса.

CheckBox Use SSL protocol

Если опция включена, обмен данными происходит с использованием удаленного MySQL сервера с использованием шифрованного канала. Опция работает только с версией сервера, поддерживающей SSL подключения.

CheckBox Interactive mode

Установив этот флажок Вы позволяете использовать значение переменной interactive_timeout, из файла my.cnf вместо переменной wait_timeout для задания ограничения времени подключения.

CheckBox Quote identifiers

Если установлен этот флажок, то все идентификаторы будут заключены в открывающие кавычки ('`'). Примечание: эта функция применима только к тем серверам, которые используют псевдонимы в кавычках.

CheckBox Disable transactions

Установив этот флажок Вы указываете что транзакции будут выключены, а вносимые изменения автоматически будут применяться.

CheckBox Autoconnect at startup

При запуске программы связь с этой базой данных будет устанавливаться автоматически.

CheckBox Enable log of SQL Editor queries

Опция включает/выключает журналирование SQL запросов.

Log file

Это поле доступно, если включено журналирование SQL запросов. В нем необходимо указать путь к файлу, в который будут сохраняться запросы.

Если требуется изменить настройки регистрации базы данных MySQL, Вы можете вернуться на предыдущий шаг, нажав на кнопку Back.

Нажмите на кнопку Finish для завершения процедуры регистрации базы данных, после чего Вы сможете работать с ней в SQL Query for MySQL.


Информация о регистрации базы данных

Диалоговое окно Database Registration Info позволяет просматривать и редактировать свойства зарегистрированной базы данных определенных при ее создании.

Чтобы открыть это окно нужно выделить требуемую базу данных в проводнике баз данных, затем щелкнуть по ней правой клавишей мыши и выбрать пункт контекстного меню Database Registration Info... или используйте пункт главного меню Database | Database Registration Info... Вы также можете открыть это окно с помощью кнопки btnDBRegInfo на панели инструментов.

hs3250 - Database Registration Info

Настройки подключения

Опции базы данных

Настройка журналирования

Настройки SSH туннелирования

Настройки HTTP туннелирования

Смотрите также:

Мастер регистрации баз данных

Мастер регистрации хоста


Настройки подключения

На вкладке Connection диалогового окна Database Registration Info Вы можете просматривать и изменять настройки подключения.

hs3251 - Editing connection properties

Host name - имя хоста.

User name - имя пользователя.

Password- пароль.

Port - порт для подключения к хосту.

Database name - имя базы данных.

Database alias - псевдоним базы данных.

При необходимости Вы можете указать клиентскую кодировку Client charset и кодировку шрифта Font charset.

Смотрите также:

Опции базы данных

Настройка журналирования

Настройка SSH туннелирования

Настройка HTTP туннелирования


Опции базы данных

На вкладке Options диалогового окна Database Registration Info доступны различные опции базы данных.

hs3252 - Setting database options

Настройте опции соответственно своим задачам. Подробное описание дано ниже.

CheckBox Login prompt before connection

Если Вы не хотите хранить пароль, то устанавливайте этот флажок и каждый раз при подключении пароль будет запрашиваться заново.

CheckBox Use compression protocol

Включите опцию для использования протокола сжатия данных при подключении к серверу базы данных.

CheckBox Keep connection alive

Опция определяет будет ли опрашиваться сервер перед каждым выполнением запроса.

CheckBox Interactive mode

Установив этот флажок Вы позволяете использовать значение переменной interactive_timeout, из файла my.cnf вместо переменной wait_timeout для задания ограничения времени подключения.

CheckBox Quote identifiers

Если установлен этот флажок, то все идентификаторы будут заключены в открывающие кавычки ('`'). Примечание: эта функция применима только к тем серверам, которые используют псевдонимы в кавычках.

CheckBox Autoconnect at startup

При запуске программы связь с этой базой данных будет устанавливаться автоматически.

CheckBox Use SSL protocol

Если опция включена, обмен данными происходит с использованием удаленного MySQL сервера с использованием шифрованного канала. Опция работает только с версией сервера, поддерживающей SSL подключения.

CheckBox Disable transactions

Если флажок установлен, то транзакции будут выключены, а вносимые изменения автоматически будут применяться.

Смотрите также:

Настройки подключения

Настройка журналирования

Настройка SSH туннелирования

Настройка HTTP туннелирования


Настройка журналирования

На вкладке Logs диалогового окна Database Registration Info можно настроить параметры журналирования SQL запросов.

hs3253 - Setting log options

CheckBox Enable log of SQL Editor queries

Эта опция указывает будет ли выполняться журналирование SQL запросов.

SQL Editor log file

Это поле доступно если включено журналирование запросов SQL. В нем Вы можете указать путь к файлу *.sql где и будут храниться предыдущие запросы.

Смотрите также:

Настройки подключения

Опции базы данных

Настройка SSH туннелирования

Настройка HTTP туннелирования


Настройка SSH туннелирования

На вкладке SSH Tunneling диалогового окна Database Registration Info Вы можете настроить необходимые параметры туннелирования.

hs3254 - Setting SSH tunnel options

CheckBox Connect through the Secure Shell (SSH) tunnel

Установите флажок, если хотите использовать промежуточный SSH сервер. Все команды сервера MySQL в этом случае будут проходить через SSH туннель.

Здесь Вам нужно указать имя хоста SSH (SSH Host name), порт (SSH port), имя пользователя (SSH user name), пароль (SSH password) и, если требуется, путь к ключу (SSH key file).

Более подробно в разделе SSH туннелирование.

Помните, что и SSH, и HTTP туннелирование может быть использовано для одного подключения, но только не одновременно.

Смотрите также:

Настройки подключения

Опции базы данных

Настройка журналирования

Настройка HTTP туннелирования


Настройка HTTP туннелирования

На вкладке HTTP Tunneling диалогового окна Database Registration Info Вы можете настроить необходимые параметры туннелирования.

hs3255 - Setting HTTP tunnel options

CheckBox Connect through the HTTP tunnel

Выберите опцию для подключения к MySQL через протокол HTTP, в случае если возможно подключение через Интернет только через прокси, либо если сервер запрещает прямые подключения, но разрешает подключения по HTTP протоколу.

Вам необходимо будет загрузить на сервер скрипт emsproxy.php и указать в соответствующем разделе адрес URL в формате: http://webserver_address/emsproxy.php

Более подробно в разделе HTTP туннелирование.

Помните, что и SSH, и HTTP туннелирование может быть использовано для одного подключения, но только не одновременно.

Смотрите также:

Настройки подключения

Опции базы данных

Настройка журналирования

Настройка SSH туннелирования


Управление запросами

SQL Query for MySQL предлагает Вам два основных инструмента для работы с запросами SQL: Редактор SQL (SQL Editor) для редактирования текста запросов и Визуальный конструктор запросов (Visual Query Builder) для визуального построения запросов.

Ниже приведен перечень стандартных операций над запросами:

Создание нового запроса

  • выберите пункт главного меню Query | New Query или нажмите соответствующую кнопку btnNewQuery на панели инструментов;
  • задайте имя нового запроса в окне New Query;
  • перейдите на вкладку Edit, для работы с запросом посредством Редактора SQL

или

  • перейдите на вкладку Builder, для работы с запросом посредством визуального конструктора.

Редактирование запроса

Чтобы открыть запрос в SQL Query for MySQL:

  • выделите запрос в проводнике баз данных;
  • вызовите контекстное меню и выберите пункт Activate Query

или

  • дважды щелкните мышью на нужном запросе в дереве проводника баз данных.

Чтобы открыть запрос из внешнего файла *.sql:

  • выберите пункт главного меню Query | Load... или нажмите на соответствующую кнопку btnLoadQuery на панели инструментов;
  • в диалоговом окне Load SQL File укажите файл, который хотели бы открыть.

Выполнение запроса

  • создайте новый запрос или откройте существующий;
  • выберите пункт главного меню Query | Execute или нажмите соответствующую кнопку iconExecuteQuery на панели инструментов

или

  • используйте клавишу F9 для выполнения запроса.

Сохранение запроса

  • создайте новый запрос или откройте существующий;
  • выберите пункт Query | Save... или Query | Save as... в главном меню

или

  • используйте сочетание клавиш Ctrl+S

или

  • используйте пункт главного меню Query | Save all queries, чтобы сохранить все запросы.

Смотрите также:

Проводник баз данных

Управление базами данных

Управление данными


Редактор SQL

Редактор запросов - основной инструмент программы SQL Query for MySQL для работы с запросами. Он позволяет создавать, редактировать и выполнять запросы, а также просматривать результаты, полученные в ходе выполнения запроса.

Открыть редактор можно, выбрав пункт главного меню Query | New Query или нажав соответствующую btnNewQuery кнопку на панели инструментов. Также можно использовать сочетание клавиш Ctrl+N.

hs3310 - SQL Editor

Смотрите также:

Визуальный конструктор запросов


Рабочая область редактора SQL

Рабочая область Редактора SQL, позволяющая работать с запросами SQL в текстовом режиме, располагается на вкладке Edit.

Автоматическая подстановка, подсветка синтаксиса и другие функциональные возможности редактора призваны сделать работу с запросами удобной. Вы можете включить/выключить большинство из них в диалоговом окне Editor Options.

Пример автоматической подстановки показан на рисунке. Для автоматического вывода списка автоматической подстановки Вы можете установить задержку по времени в разделе Quick code диалогового окна Editor Options; для вызова списка вручную используйте сочетание клавиш Ctrl+Space.

hs3311 - Working with the editor area

Если необходимо, Вы можете распечатать текст запроса. Для этого используйте пункт контекстного меню Print или соответствующую кнопку btnPrintSQL на панели инструментов. Сочетание клавиш Ctrl+P также используется для печати запроса.

Смотрите также:

Контекстное меню

Поиск текста

Замена текста

Выполнение запроса


Контекстное меню

Для Редактора SQL существует специальное контекстное меню, которое отрывается по нажатию правой клавиши мыши в любой точке рабочей области. Это меню позволяет быстро выполнять самые используемые команды.

hs3312 - Using the context menu

Стандартные команды для работы с текстом: вырезать (Cut), копировать (Copy), вставить (Paste), выделить все (Select All).

Команды для работы с запросом в целом: перейти на заданную строчку (Go To Line Number), изменить регистр выделенного текста (Change Case), просмотреть свойства запроса (Properties), напечатать запрос (Print).

Поиск и замена текста позволят эффективнее работать с текстом запроса SQL.

Смотрите также:

Рабочая область редактора SQL

Поиск текста

Замена текста

Выполнение запросов


Поиск текста

С помощью окна Find Text можно найти сочетание символов в рабочей области редактора SQL.

Options

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Искать устойчивое выражение

hs3313 - Find Text dialog

Direction

Выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

Scope

Укажите диапазон поиска.

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

Origin

Укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Нажмите кнопку Show All, чтобы выделить в тексте все результаты поиска.

Смотрите также:

Рабочая область редактора SQL

Контекстное меню

Замена текста

Выполнение запроса


Замена текста

С помощью окна Replace Text можно найти сочетание символов в рабочей области редактора SQL и заменить его на указанное.

Text to find

В это поле вводится искомое сочетание символов.

Из раскрывающегося списка Вы можете выбрать сочетание символов, которое искали до этого.

Text to replace

В этом поле укажите то сочетание символов, на которое нужно заменить искомый текст.

hs3314 - Replace Text dialog

Options

CheckBox Case sensitive

Учитывать разряд символов при поиске

CheckBox Whole words only

Искать слово целиком

CheckBox Regular expressions

Искать устойчивое выражение

CheckBox Replace with template

Для корректной работы данной опции необходимо, чтобы был установлен флажок Regular expressions. Включите опцию, если хотите, чтобы регулярные выражения распознавались в поле Text to replace. Выражение, указанное в этом поле, будет применено к каждой строке, удовлетворяющей условию в поле Text to replace.

Важно: Синтаксис регулярных выражений, доступных для использования в полях Text to find и Text to replace схож с синтаксисом регулярных выражений Perl. Исчерпывающую информацию можно найти по адресу: http://perldoc.perl.org/perlre.html#Regular-Expressions.

CheckBox Prompt on replace - включите опцию, если хотите чтобы при каждом нахождении указанной последовательности символов программа выводила запрос о замене. Если опция выключена, замена будет происходить автоматически.

Direction

Выберите направление поиска.

RadioButton Forward - вперед

RadioButton Backward - назад

Scope

Укажите диапазон поиска.

RadioButton Global

Искать внутри всей доступной рабочей области.

RadioButton Selected text

Искать только в предварительно выделенном тексте.

Origin

Укажите, с какого места следует начать поиск

RadioButton From cursor

От курсора

RadioButton Entire scope

С начала доступной области

CheckBox Mark search result with stack marker

Если флажок установлен, то результаты поиска будут выделены цветом.

Show All, чтобы выделить в тексте все результаты поиска.

Нажмите кнопку Replace All, чтобы автоматически заменить все искомые сочетания символов.

Смотрите также:

Рабочая область редактора SQL

Контекстное меню

Поиск текста

Выполнение запросов


Выполнение запроса

Созданный или отредактированный запрос можно сразу же выполнить из редактора SQL.

hs3315 - Executing queries

Для этого выберите пункт главного меню Query | Execute или нажмите соответствующую кнопку iconExecuteQuery на панели инструментов. Нажатие клавиши F9 также приведет к выполнению запроса.

Если текст запроса содержит ошибки, то программа укажет на это и результат не будет доступен до того, как все ошибки будут исправлены.

Если запрос должен возвращать данные (в тексте содержатся SELECT), то в редакторе появится новая вкладка Results, на которую и будут вынесены полученные результаты. Если Вы хотите, чтобы полученные данные выводились на вкладке редактора - выключите опцию CheckBox Query results on separate tab в разделе Environment options | Preferences.

Если при выполнении запроса возникли ошибки, то их описание будет вынесено в информационное окно, расположенное в нижней части редактора. Двойной щелчок на ошибке делает активной строку, в которой эта ошибка была найдена.

Данные, возвращаемые запросом, по умолчанию представлены в виде таблицы.

Подробнее в разделе просмотр данных.

Смотрите также:

Рабочая область редактора SQL

Контекстное меню

Поиск текста

Замена текста


Визуальный конструктор запросов

Визуальный конструктор запросов (Visual Query Builder) позволяет создавать и редактировать запросы графически без текстового их описания на языке SQL. Вы можете создавать, выполнять просматривать результаты, используя визуальные методы, предоставленные этим инструментом.

Также с помощью Визуального конструктора запросов Вы можете получать графическое представление запроса, написанного в текстовой форме.

Открыть конструктор можно с помощью пункта меню Query | New Query или соответствующей кнопки btnNewQuery на панели инструментов.

Вы также можете использовать сочетание клавиш Ctrl+N.

Смотрите также:

Редактор SQL


Рабочая область

Рабочая область - основная часть визуального конструктора запросов. Просто поместите на нее таблицы, представления, выберите нужные поля, установите связи, если это необходимо, и запрос готов.

Переместите объект из проводника баз данных на рабочую область конструктора запросов, чтобы добавить его в запрос.

Чтобы добавить поля таблицы или представления в создаваемый запрос необходимо установить флажок около поля или выделить поле двойным щелчком мыши. Все поля, у которых установлены флажки, попадают в запрос.

Чтобы добавить в запрос сразу все поля объекта необходимо установить флажок, находящийся перед названием объекта в строке заголовка.

Если не выбрано ни одно поле, формируется оператор SQL "SELECT * FROM <table/view_name>", то есть выбираются все поля таблицы/представления.

Снимите флажок с поля, чтобы исключить его из запроса.

Чтобы удалить объект из рабочей области, нажмите на кнопку "закрыть" в заголовке объекта, или выберите пункт Delete контекстного меню, открывающегося при нажатии правой кнопкой мыши на заголовок объекта. Вы также можете выбрать объект и нажать кнопку Del.

Объект удалится только из рабочей области. В базе данных он останется.

Изменить псевдоним объекта, под которым он отображается на диаграмме, можно с помощью пункта Rename контекстного меню, открывающегося при нажатии правой кнопкой мыши на заголовок объекта. Также, Вы можете это сделать, нажав два раза мышью на названии объекта.

hs3321 - Working with Query Builder area

Выберите подходящий тип запроса из выпадающего списка: Select, Insert, Update или Delete. Если в настройках окружения включена опция CheckBox Only select mode то для выбора будет доступен только тип Select.

Visual Query Builder - Selecting query type

Используйте контекстное меню конструктора для создания объединения (Union) или подзапроса (Subquery).

Visual Query Builder - union

Создание объединения запросов происходит посредством оператора UNION или UNION ALL (если опция Union all by default включена).

Подзапрос используется в качестве источника для основного запроса.

Смотрите также:

Установка связей

Задание критериев

Выводимые поля

Критерии группировки

Параметры сортировки

Работа с окном редактирования

Выполнение запроса


Установка связей

В реляционных базах данных требуется создание связей между таблицами.

Визуальный конструктор позволяет быстро устанавливать связи между объектами, помещенными в рабочую область.

Чтобы установить связь между таблицами по двум полям необходимо поле из одной таблицы перетащить в другую (поля представлены в виде списка, в котором каждая строчка - поле).

После перетаскивания связь будет отображена в виде черной линии, соединяющей желаемые поля.

Задержите курсор над линией, соединяющей таблицы, пока не появится всплывающее окно, отображающее свойства связи.

hs3322 - Joining tables

Свойства связи можно редактировать. Для этого необходимо открыть редактор связи, два раза щелкнув на ней мышкой или выбрать пункт контекстного меню связи Property.

В появившемся окне указываете желаемые свойства редактируемой связи. Условие связи выбирается из раскрывающегося списка, находящегося между именами полей. (=, >, <, >=, <=, <>).

hs3322 - Link properties

Опции CheckBox Include all определяют тип связи.

Если установлен левый флажок Include all, то в итоговый текст запроса будет добавлен оператор LEFT OUTER JOIN.

Если установлен правый флажок Include all, то в итоговый текст запроса будет добавлен оператор RIGHT OUTER JOIN.

Если не установлен ни один флажок, то в итоговый текст запроса будет добавлен оператор INNER JOIN.

Нажмите OK, чтобы применить внесенные изменения.

Удалить связь между объектами можно щелкнув правой клавишей мыши на черной линии, отражающей эту связь, и выбрав пункт контекстного меню - Delete link.

Для удобства размещения множества связанных таблиц Вы можете поставить на лини связи точку(и), с помощью которой удобно изменять расположение связи. Точка никак не влияет на свойства связи, а только позволяет сделать визуальное отображение запроса более понятным.

Смотрите также:

Рабочая область

Задание критериев

Выводимые поля

Критерии группировки

Параметры сортировки

Работа с окном редактирования

Выполнение запроса


Задание критериев

На вкладке Criteria Вы можете установить критерии отбора данных в запросе.

Чтобы добавить условие ограничения нужно нажать кнопку EllipsisButton на форме и из появившегося контекстного меню выбрать пункт Add condition. Добавится строчка, которой будет присвоен порядковый номер. В этой строчке Вам необходимо указать условие отбора.

Чтобы задать тип составного условия нажмите на надпись All, располагающуюся рядом с EllipsisButton и выберите один из предложенных типов.

По нажатию на поле Visual Query Builder - Line открываются списки, состоящие из всех полей объектов, участвующих в запросе. В этих полях Вы можете задать операторы условия. Это могут быть как имена полей, так и константы или выражения.

Нажав на символ "=", Вы получаете возможность установить отношение между операторами.

Управлять условием можно с помощью контекстного меню, которое открывается при нажатии правой кнопки мыши на порядковом номере.

hs3323 - Setting criteria

Если на номере условия нажать правой кнопкой мыши, то появится меню с одним пунктом - Insert query. Если нажмете на этот пункт, то будет создан вложенный запрос, с которым можно работать также как и с основным. Иерархия запросов отображается в дереве подзапросов, расположенном слева от рабочей области. Если создан подзапрос то условие примет вид Editor Options - Condition первый оператор условия после символа отношения задает квалификатор запроса, а во втором отображается начало вложенного запроса.

Квалификатор запроса можно выбрать из списка, открывающегося по нажатию на нем левой кнопкой мыши.

Удалить подзапрос можно с помощью пункта контекстного меню Delete query. Это контекстное меню открывается по нажатию на условии, содержащем подзапрос правой кнопкой мыши. С помощью этого меню можно:

  • удалить подзапрос - Delete query,
  • открыть подзапрос - Show query.

Смотрите также:

Рабочая область

Установка связей

Выводимые поля

Критерии группировки

Параметры сортировки

Работа с окном редактирования

Выполнение запроса


Выводимые поля

На вкладке Selection отображаются поля, которые получены в результате выполнения запроса. Эта вкладка остаётся пустой, если были выбраны все поля (SELECT *).

hs3324 - Setting output fields

CheckBox Select only unique records

Если флажок установлен, то в результате запроса отображаются только неповторяющиеся записи.

  • Source field name содержит настоящие имена столбцов, выводимых в результат запроса.
  • В столбце Name of output указан псевдоним поля, под которым оно будет выведено в результате запроса.
  • Столбец Aggregate содержит аггрегирующую функцию.
  • Grouping указывает сгруппирован столбец или нет.

В этой таблице можно редактировать заголовки полей, менять порядок их отображения, устанавливать аггрегирующие функции (SUM, MIN, MAX, AVG и COUNT) для каждого поля. Чтобы удалить поле из списка, нажмите правой клавишей мыши на нем и выберите пункт контекстного меню Delete current row. Чтобы изменить исходное поле, дважды щелкните на нем мышкой, затем напечатайте имя поля, или выберите нужное из выпадающего списка доступных полей.

Основные действия с полями выполняются при помощи контекстного меню, которое открывается по нажатию на поле правой кнопкой мыши.

Visual Query Builder - Selection field menu

С помощью этого меню выполняются следующие операции:

  • Delete current row - удаление выделенного поля.
  • Insert Query - вставка вложенного запроса.
  • Insert CASE - вставка конструкции CASE.

Чтобы изменить имя выводимого поля, установите на нем курсор и задайте желаемое имя.

Если Вы хотите задать аггрегирующую функцию, щелкните мышкой в столбце Aggregate и укажите имя функции вручную, или выберите из списка.

Также поля можно отсортировать, щелкнув левой кнопкой мышки на заголовок столбца в котором содержатся поля.

Порядок полей в результате запроса будет соответствовать их последовательности в этой таблице.

Встроенные запрос открывается на отдельной вкладке рабочей области для редактирования и отображается в дереве подзапросов в левой части Визуального конструктора.

В поле Grouping отображается, будет ли производиться группировка данных.

При вставке конструкции CASE условия задаются в появляющемся диалоговом окне.

Query Builder - Setting output fields - CASE

Поле, для которого задается условие, выберите из раскрывающегося списка Name. Псевдоним нового поля в котором будут отображаться результаты выполнения укажите в поле Alias.

Выражения WHEN и THEN задайте в соответствующих полях. Если необходимо задать выражение ELSE, то укажите его значение в поле THEN, оставив поле WHEN пустым.

Смотрите также:

Рабочая область

Установка связей

Задание критериев

Критерии группировки

Параметры сортировки

Работа с окном редактирования

Выполнение запроса


Критерии группировки

На вкладке Grouping criteria задаются критерии, по которым будут сгруппированы данные, полученные в результате выполнения запроса.

Условия группировки данных полей задаются также как и критерии отбора данных.

hs3325 - Setting grouping criteria

Условия, заданные на этой вкладке будут использованы с оператором HAVING в тексте результирующего запроса SQL.

Смотрите также:

Рабочая область

Установка связей

Задание критериев

Выводимые поля

Параметры сортировки

Работа с окном редактирования

Выполнение запроса


Параметры сортировки

Вкладка Sorting позволяет указывать параметры сортировки полей в запросе.

В списке Output fields содержатся все поля объектов, участвующих в запросе. Чтобы указать, по какому полю будет отсортирована, полученная в результате выполнения запроса, таблица, необходимо переместить поля из списка Output fields в список Sorted fields. Делается это с помощью кнопок или перетаскивания выбранного элемента.

В списке Sorted fields для выбранных полей Вы указываете параметры сортировки:

  • порядок сортировки "по возрастанию" или "по убыванию" указывается в поле Sort order с помощью кнопки A...Z,
  • очередность сортировки (по какому полю сортировать в первую очередь, а по какому во вторую) задается расположением полей в списке Sorted fields. По первому в списке полю сортировка проходит в первую очередь и.т.д. Перемещать поля в списке можно с помощью кнопок Up и Down.

hs3326 - Setting sorting parameters

Смотрите также:

Рабочая область

Установка связей

Задание критериев

Выводимые поля

Критерии группировки

Работа с окном редактирования

Выполнение запроса


Работа с окном редактирования

В окне редактирования, расположенном на вкладке Edit, автоматически генерируется текст запроса. В этом окне Вы можете просмотреть и исправить запрос. Все изменения будут отображены в окне диаграммы.

hs3327 - Working with the editor area

Все, что в тексте запроса выделено зеленым, является ссылками на объекты. Зеленым ссылки выделяются по умолчанию. Вы можете задать любой цвет в настройках редактора (Options | Editor Options | Color).

Более подробно с областью редактирования Вы можете ознакомиться в разделе Рабочая область редактора SQL.

Смотрите также:

Рабочая область

Установка связей

Задание критериев

Выводимые поля

Критерии группировки

Параметры сортировки

Выполнение запроса


Выполнение запроса

Созданный или отредактированный запрос можно сразу же выполнить из визуального конструктора запросов.

Для этого выберите пункт главного меню Query | Execute или нажмите соответствующую кнопку iconExecuteQuery на панели инструментов. Нажатие клавиши F9 также приведет к выполнению запроса.

Если текст запроса содержит ошибки, то программа укажет на это и результат не будет доступен до того, как все ошибки будут исправлены.

Если запрос должен возвращать данные (в тексте содержатся SELECT), то в редакторе появится новая вкладка Results, на которую и будут вынесены полученные результаты. Если Вы хотите, чтобы полученные данные выводились на вкладке конструктора - выключите опцию CheckBox Query results on separate tab в разделе Environment options | Preferences.

Если при выполнении запроса возникли ошибки, то их описание будет вынесено в информационное окно, расположенное в нижней части редактора. Двойной щелчок на ошибке делает активной строку, в которой эта ошибка была найдена.

Данные, возвращаемые запросом, по умолчанию представлены в виде таблицы.

hs3328 - Query execution

Подробнее в разделе просмотр данных.

Смотрите также:

Рабочая область

Установка связей

Задание критериев

Выводимые поля

Критерии группировки

Параметры сортировки

Работа с окном редактирования


История запросов

Вкладка History содержит список ранее выполненных запросов.

hs3330 - Query History

В таблице отображается имя запроса и дата его выполнения. В правой части вкладки можно увидеть текст выбранного запроса.

С помощью контекстного меню Вы можете:

  • Activate Query - сделать запрос активным;
  • Rename Query - переименовать запрос;
  • Delete Query from History - удалить запрос из истории;
  • Clear History - очистить историю выполненных запросов;
  • Show History for the Current Query Only - отобразить историю только для текущего запроса;
  • Add to Favorite Queries - добавить выбранный запрос в избранные.

Смотрите также:

Редактор SQL

Визуальный конструктор запросов

План запроса

Избранные запросы


План запроса

SQL Query for MySQL позволяет Вам увидеть план запроса. Он располагается на вкладке Plan.

Откройте запрос в редакторе SQL или визуальном конструкторе запросов, нажмите кнопку Explain Query btnExplainQuery на панели инструментов, чтобы сформировать план запроса. Просмотреть его можно на вкладке Results | Plan.

hs3340 - Query Plan

Если Вы хотите, чтобы вкладка Plan отображалась по умолчанию для каждого выполняемого запроса, включите опцию Queries with explain plan на вкладке Preferences диалогового окна Environment options.

Смотрите также:

Редактор SQL

Визуальный конструктор запросов

История запросов


Избранные запросы

На вкладке Favorite Queries отображается перечень избранных запросов.

Visual Query Builder - Favorites

Если выделить запрос, в правой части окна будет отображен его текст. С помощью контекстного меню Вы можете открыть запрос для редактирования (Activate Query), переименовать запрос (Rename Query), удалить запрос из избранных (Delete Query from Favorites) или удалить все запросы из списка избранных (Clear Favorites).

Смотрите также:

Редактор SQL

Визуальный конструктор запросов

План запроса


Управление данными

В SQL Query for MySQL данные, возвращаемые запросами, могут быть представлены в различном виде.

Ниже перечислены наиболее используемые возможности SQL Query для эффективного управления данными.

Просмотр данных

Настройка фильтров

Конструктор фильтров

Смотрите также:

Проводник баз данных

Управление базами данных

Управление запросами


Просмотр данных

В SQL Query for MySQL существует мощные инструменты для просмотра, редактирования и печати данных из таблиц и запросов.

Полученные в результате выполнения запроса данные отображаются на вкладке Data. Если Вы хотите, чтобы полученные данные выводились на вкладке редактора или конструктора - выключите опцию CheckBox Query results on separate tab в разделе Environment options | Preferences. В противном случае данные будут выводиться на отдельной вкладке Results.

Данные могут быть представлены в четырех вариантах: в виде таблицы (Grid View), в виде печатной формы (Form View), в редакторе данных типа BLOB, если получены данные этого типа (BLOB View), в виде диаграммы (Diagram View). В строке состояния показывается количество записей в текущем наборе данных, время, за которое эти записи были получены, а также возможность их редактирования.

Чтобы изучить возможности управления данными с помощью SQL Query, просмотрите следующие разделы:

Просмотр в виде таблицы

Просмотр в виде формы

Просмотр данных типа BLOB

Просмотр в виде диаграммы

Смотрите также:

Настройка фильтров

Конструктор фильтров


Просмотр в виде таблицы

По умолчанию возвращаемые запросом данные отображаются в виде таблицы. Режим просмотра выбирается на панели, расположенной в нижней части окна.

Столбцы таблицы соответствуют полям, а строки - записям. Щелкните мышкой по заголовку столбца, чтобы отсортировать данные. Навигационная панель в верхней части окна поможет Вам быстро добавить, обновить, удалить записи, установить закладки, установить фильтр при помощи конструктора фильтров. Поле Find поможет Вам быстро найти в выбранном столбце записи, содержащие указанный набор символов.

hs3420 - Grid View

При помощи контекстного меню таблицы возможно скрывать/отображать панель группировки данных, печатать данные или редактировать сводку по столбцу.

Смотрите также:

Просмотр в виде формы

Просмотр данных типа BLOB

Просмотр в виде диаграммы


Группировка данных

Вы можете группировать данные в таблице по одному или нескольким столбцам.

hs3421 - Grouping data

Для того, чтобы сгруппировать таблицу по столбцу необходимо перетащить заголовок столбца на специальную панель над таблицей, так называемую "панель группировки". Отобразить эту панель можно используя пункт контекстного меню Show Group Box.

Если применить группировку, то данные будут отображены в виде подузлов. Чтобы отменить группировку, просто перетащите заголовок столбца обратно.

Смотрите также:

Фильтрация записей

Печать данных

Экспорт результатов

Контекстное меню


Фильтрация записей

Фильтр — это быстрый способ поиска подмножества данных и работы с ними в таблице. В отфильтрованной таблице отображаются только строки, отвечающие условиям, заданным для столбца.

Фильтр не меняет порядок записей. При фильтрации временно скрываются строки, которые не отвечают заданным условиям.

Фильтровать данные в таблице можно следующими способами:

  • В заголовке каждого столбца имеется кнопка со стрелочкой. В то появится список значений, содержащихся в этом столбце. Если выбрать одно из этих значений, то это и будет условие фильтрации. В таблице останутся видимыми только те строки, которые соответствуют этому условию.
  • Если же нажать на эту стрелочку и выбрать пункт Custom, то появится диалоговое окон фильтрации, С его помощью Вы сможете задать более сложные условия фильтрации.
  • Кнопка btnSetFilter открывает конструктор фильтров, с помощью которого Вы можете создать фильтр со множеством условий для фильтрации данных.

hs3422 - Filtering records

Если для таблицы установлен фильтр, то в нижней части появляется специальная панель, на которой отображается условие фильтра. С помощью этой панели Вы можете легко отключить/включить или изменить условия. Вы также можете нажать на кнопку Customize чтобы открыть условие в конструкторе фильтров.

Смотрите также:

Группировка данных

Печать данных

Экспорт результатов

Контекстное меню


Печать данных

Выберите пункт контекстного меню Print Grid для просмотра таблицы перед печатью (Print Preview). После этого Вы можете напечатать таблицу в том виде в котором она будет отображена.

hs3423 - Printing data

В окне просмотра перед печатью имеется панель инструментов, позволяющая создавать, сохранять и загружать шаблоны печати запроса, а также тщательно настраивать параметры печати.

hs3423 - Print Preview

Смотрите также:

Группировка данных

Фильтрация записей

Экспорт результатов

Использование контекстного меню


Экспорт результатов

Экспортировать набор данных, полученный в результате запроса, можно следующими способами:

  • экспорт данных во внешний файл возможен только в том случае, если на рабочей станции установлена зарегистрированная утилита Data Export for MySQL. В этом случае Вы можете экспортировать данные в любой из поддерживаемых форматов (MS Excel, MS Access, RTF, HTML, PDF, TXT, CSV, и т.д.). Просто нажмите кнопку Export Data btnDataExport на панели инструментов, и с помощью мастера выполните процедуру экспорта;
  • если требуется обработать данные в стороннем редакторе, Вы можете скопировать данные, полученные в результате выполнения запроса, в буфер OS Windows. Для этого нажмите кнопку Export Data to Clipboard btnExportToClipboard на панели инструментов.

Важно: Чтобы экспортировать данные вв файл формата *.accdb, необходимо наличие Microsoft Access Database Engine 2010 Redistributable.

Смотрите также:

Группировка данных

Фильтрация записей

Печать данных

Контекстное меню


Контекстное меню

Контекстное меню позволяет выполнять следующие операции: присваивать нулевые значения (пункты Set To NULL, Set to Empty String), скрывать/отображать панель группировки (пункт Show Group Box), печатать таблицу данных (Print Grid), редактировать сводку по столбцу (Column Summary...).

hs3425 - Context menu

В окне Column Summary из списка Column выбираете столбец таблицы, для которого хотите отображать дополнительную информацию.

hs3425 - Column Summary

Footer summary отображает итоговую информацию в нижнем колонтитуле таблицы.

Group header - отображает информацию в заголовке сгруппированных данных.

Group footer - отображает данные в нижнем колонтитуле сгруппированных данных.

Информация, которую можно вывести для столбцов:

  • ничего - None,
  • сумму значений в столбце - Sum,
  • минимальное значение в столбце - Minimum,
  • максимальное значение в столбце - Maximum,
  • количество значений в столбце - Count,
  • среднее значение в столбце - Average.

Для всех остальных типов столбцов доступно только количество значений в столбце - Count.

В поле Number format задаете формат числа.

Смотрите также:

Группировка данных

Фильтрация записей

Печать данных

Экспорт результатов


Просмотр в виде формы

На вкладке Form View каждая запись представлена в Виде формы. Редактировать данные удобнее, когда они представлены в таком виде.

hs3430 - Form View

Если на вкладке Grid View Вы выделили строчку или ячейку, а затем перешли на вкладку Form View, то на этой вкладке отобразится выделенная запись.

Для каждой записи отображается:

  • название полей,
  • значения.

Рядом с каждым полем расположен флажок Null. С его помощью можно это поле очистить. Вернуть удаленные данные, убрав флажок, не получится. Чтобы вернуть данные необходимо нажать на кнопку

Переключаться между записями можно с помощью навигационной панели, расположенной на панели инструментов. Она позволяет Вам создавать, редактировать, удалять записи, перемещаться по таблицы, а также устанавливать фильтры. Для каждого типа данных генерируется поле ввода соответствующее типу данных. Например, для поля типа datetime появляется календарь, позволяющий избежать ошибок при вводе даты. Для типов полей большого размера создаются большие текстовые поля.

Если Вы на этой вкладке зададите условия для фильтрации записей, то отобразится первая запись таблицы, отвечающая заданным условиям.

Смотрите также:

Просмотр в виде таблицы

Просмотр данных типа BLOB

Просмотр в виде диаграммы


Просмотр данных типа BLOB

Если в таблице содержатся поля BLOB (Binary Large Object - Hexadecimal, Text, Rich Text и др.), то при просмотре данных появляется дополнительная вкладка Blob View. На этой вкладке можно редактировать любой тип данных, относящихся к BLOB. Для каждого типа создана своя вкладка:

  • Просмотр шестнадцатеричного кода (Hexadecimal)
  • Просмотр текста (Text)
  • Просмотр RTF (Rich text)
  • Просмотр изображения (Image)
  • Просмотр HTML

hs3445 - Viewing as Image

Навигация при просмотре данных осуществляется с помощью навигационной панели в верхней части окна. Она позволяет Вам создавать, редактировать, удалять записи, перемещаться по таблицы, а также устанавливать фильтры. Вы также можете загрузить новые данные, или сохранить текущие в файл.

Смотрите также:

Просмотр в виде таблицы

Просмотр в виде формы

Просмотр в виде диаграммы


Просмотр шестнадцатеричного кода

На вкладке Hexadecimal Вы можете просмотреть и отредактировать информацию, содержащуюся в одной ячейке поля типа BLOB. В левой части формы содержимое ячейки представлено в шестнадцатеричном виде (шестнадцатеричные значения байтов), а в правой - в виде обычного текста.

hs3442 - Viewing as Hexadecimal

Контекстное меню рабочей области редактора позволяет сохранять данные в файл (пункт Save to File...) и загружать данные из внешнего файла (Load from File...).

Смотрите также:

Просмотр текста

Просмотр RTF

Просмотр изображения

Просмотр HTML


Просмотр текста

На вкладке Text содержимое ячейки представлено в виде обычного текста, доступного для редактирования.

hs3443 - Viewing as Text

Контекстное меню рабочей области редактора позволяет:

  • Load... - загрузить данные из внешнего файла *.txt;
  • Save as... - сохранить данные в файл *.txt;
  • Cut - вырезать выделенный текст;
  • Copy - копировать выделенный текст;
  • Paste - вставить из буфера;
  • Select All - выделить все;
  • Find - открыть диалоговое окно поиска;
  • Search again - повторить поиск;
  • Undo - отменить последнюю операцию;
  • Word Wrap - включить/выключить перенос по словам.

Смотрите также:

Просмотр шестнадцатеричного кода

Просмотр RTF

Просмотр изображения

Просмотр HTML


Просмотр RTF

На вкладке Rich Text текст представлен в виде RTF (Rich Text Format).

hs3444 - Viewing as Rich text

Контекстное меню рабочей области

  • Load... - загрузить данные из внешнего файла *.rtf;
  • Save as... - сохранить данные в файл *.rtf;
  • Cut - вырезать выделенный текст;
  • Copy - копировать выделенный текст;
  • Paste - вставить из буфера;
  • Select All - выделить все;
  • Find - открыть диалоговое окно поиска;
  • Search again - повторить поиск;
  • Undo - отменить последнюю операцию;
  • Print - напечатать текст.

Смотрите также:

Просмотр шестнадцатеричного кода

Просмотр текста

Просмотр изображения

Просмотр HTML


Просмотр изображения

Вкладка Image позволяет просматривать записи, содержащие изображение.

hs3445 - Viewing as Image

Контекстное меню данной вкладки позволяет сохранить изображение в файл *.jpg или *.jpeg (пункт Save as...), а также загрузить изображение из внешнего файла (пункт Load...).

Перемещаться по записям можно с помощью навигационной панели.

Смотрите также:

Просмотр шестнадцатеричного кода

Просмотр текста

Просмотр RTF

Просмотр HTML


Просмотр HTML

Вкладка HTML позволяет просматривать данные формата HTML. Панель навигации обеспечивает простоту перемещения между записями.

hs3446 - Viewing as HTML

Смотрите также:

Просмотр шестнадцатеричного кода

Просмотр текста

Просмотр RTF

Просмотр изображения


Просмотр в виде диаграммы

Вкладка Diagram View позволяет представить данные в виде диаграмм различных типов. Чтобы перейти к просмотру данных в виде диаграмм, сделайте вкладку активной посредством одноименной кнопки в нижней части окна.

Вы можете построить диаграммы следующих типов: столбцы, линии, область, точечную, круговую, график. Различные опции помогут тщательно настроить отображение данных.

  • Выбор полей
  • Свойства диаграммы
  • Настройка диаграммы
  • Экспорт диаграмм

Смотрите также:

Просмотр в виде таблицы

Просмотр в виде формы

Просмотр данных типа BLOB


Выбор полей

Чтобы построить диаграмму, Вам необходимо выбрать из выпадающего списка Field Name поле, данные из которого станут исходными для диаграммы. В качестве исходных данных могут быть только численные поля.

hs3451 - Diagram View

Из раскрывающегося списка Field Name нужно выбрать поле, данные которого будут использованы в качестве подписей к диаграмме.

Смотрите также:

Свойства диаграммы

Настройка диаграммы

Экспорт диаграмм


Свойства диаграммы

При помощи панели, располагающейся в левой части вкладки Diagram View, Вы можете менять визуальные свойства диаграмм.

Diagram Title

В этом поле задается заголовок диаграммы.

Field Name

Используйте выпадающий список для выбора поля с исходными значениями.

Label Source

Выберите поле, значения из которого будут использоваться в качестве подписей к диаграмме.

Diagram Type

С помощью выпадающего списка выберите подходящий тип диаграммы: Bar - значения представлены в виде столбцов, Line - в виде отрезков непрерывного графика, Area - в виде областей, Point - в виде точек, Pie - сектора, FastLine - в виде одноцветного графика.

hs3452 - Setting diagram properties

CheckBox Color each point

Включите опцию, если хотите чтобы каждому значению соответствовал свой цвет. Если опция выключить, то все значения будут красного цвета.

CheckBox Show marks

Если флажок установлен, для сегментов диаграммы будут отображены подписи.

CheckBox Show axis

С помощью этой опции Вы можете отобразить или скрыть оси диаграммы.

CheckBox Show legend

Данное свойство определяет будет ли отображена легенда диаграммы.

CheckBox Monochrome

Включите опцию, чтобы сделать диаграмму монохромной (например для черно-белой печати).

CheckBox View 3D

При использовании этой опции диаграмма принимает трехмерный вид.

CheckBox View 3D walls

Если включить данную опцию, оси диаграмм образуют плоскости, что создаст эффект объемного изображения.

Смотрите также:

Выбор полей

Настройка диаграммы

Экспорт диаграмм


Настройка диаграммы

Если необходимо, Вы можете настроить диаграмму, используя ряд опций диалогового окна Editing Chart.

Чтобы открыть это диалоговое окон, достаточно дважды щелкнуть мышкой на диаграмме.

Для получения более подробной информации смотрите раздел Настройка диаграммы.

Смотрите также:

Выбор полей

Свойства диаграммы

Экспорт диаграмм


Экспорт диаграмм

Построенную диаграмму можно экспортировать в графическое изображение ряда форматов.

Чтобы запустить мастер экспорта диаграмм нажмите на кнопку Export Diagram, расположенной в левой части окна.

  • Выбор имени и формата файла
  • Опции экспорта диаграмм

Смотрите также:

Выбор полей

Свойства диаграммы

Настройка диаграммы


Выбор имени и формата файла

На этом шаге мастера необходимо выбрать формат файла, в который будет экспортирована диаграмма.

В секции Destination format задайте желаемый формат, а в поле Destination file name укажите имя файла и путь к нему.

hs3455 - Setting file name and format

Нажмите кнопку Next, чтобы перейти к следующему шагу мастера.


Опции экспорта диаграмм

На данном шаге необходимо задать параметры экспортируемого изображения.

hs3456 - Export Diagram options

Width - ширина изображения в пикселях;

Height - высота изображения в пикселях;

CheckBox Keep aspect ratio

Включите эту опцию, если нужно сохранить пропорции исходного изображения.

CheckBox Open exported diagram in associated program

Установите флажок, если по завершении процедуры экспорта Вы хотите открыть экспортированный файл в программе, которая ассоциируется в системе с данным типом файлов.

Если необходимо внести изменения в настройки экспорта диаграммы, Вы можете вернуться на предыдущий шаг мастера, нажав на кнопку Back.

Нажмите кнопку Finish, для завершения процедуры экспорта.


Задание настроек фильтрации

Custom Filter - одно из средств SQL Query for MySQL для фильтрации записей при просмотре данных.

Открыть Custom Filter можно, нажав на стрелочку, расположенную справа от заголовка столбца, и выбрав из выпадающего списка пункт Custom.

В выпадающем списке необходимо задать оператор условия:

Equals - равно;

Does not equal - не равно;

Is less than - меньше;

Is less than or equal to - меньше или равно;

Is greater than - больше;

Is greater than or equal to - больше или равно;

Like - равно;

Not like - не равно;

Is blank - пустое;

Is not blank - не пустое.

В следующем поле необходимо указать значение, относительно которого будет происходить сравнение.

hs3460 - Custom Filter

Если Вы задаете два условия, то между ними нужно установить отношение. Если данные должны удовлетворять и первому и второму условию, выберите вариант RadioButton AND. Если же данные должны удовлетворять любому из указанных условий, то нужно выбрать вариант RadioButton OR. Символ '_' в значении представляет любую букву или цифру. Символ '%' представляет любую последовательность букв и цифр.

Смотрите также:

Просмотр данных

Конструктор фильтров


Конструктор фильтров

В SQL Query for MySQL имеется специальный инструмент для задания условий отбора данных в таблице при просмотре данных. С помощью конструктора фильтров Вы можете не только создать условие отбора любого уровня сложности, но и сохранить его в файл и загрузить из файла, что позволяет многократно использовать один фильтр.

Запустить конструктор можно с помощью кнопки Set filter btnSetFilter, располагающейся на навигационной панели.

Запуск конструктора фильтров

Добавление условий

Выбор поля

Задание оператора условия

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации

Смотрите также:

Просмотр данных

Задание настроек фильтрации


Запуск конструктора фильтров

Конструктор фильтров может быть запущен следующими способами:

  • нажатием на кнопку Customize, которая появляется в нижней части окна, если используется фильтрация;
  • нажатием на кнопку Set filter btnSetFilter, расположенную на навигационной панели.

В последующих разделах описаны возможности конструктора фильтров.

Смотрите также:

Добавление условий

Выбор поля

Задание оператора условия

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации


Добавление условий

Допустим, нам необходимо получить список всех инженеров мужского пола из отдела Engineering и Tool Design нанятых после 01/10/2007. В этом случае нужно добавить условия с участием столбцов Gender, HireDate, Position и DepID.

Filter Builder dialog - Adding a new condition

Чтобы добавить условие, нажмите кнопку press the button to add a new condition. Вы также можете нажать на кнопку Filter и выбрать пункт Add Condition в выпадающем меню.

Смотрите также:

Запуск конструктора фильтров

Выбор критериев

Задание оператора условий

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации


Выбор поля

Поскольку нам нужно задать условие с участием поля HireDate, мы должны выбрать его в выпадающем списке всех полей таблицы, который отобразится, если щелкнуть левой клавишей мыши на имени поля, выделенном зеленым цветом.

Filter Builder dialog - Setting filter criteria

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Задание оператора условия

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации


Задание оператора условия

После того как выбрано участвующее в условии поле, необходимо задать оператор условия. Щелкните мышкой на тексте, выделенном коричневым цветом, чтобы увидеть список доступных операторов. В нашем случае требуется оператор is greater than (больше чем).

Filter Builder dialog - Setting filter operator

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Выбор поля

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации


Указание значения для условия

Выбрав оператор условия, необходимо указать значение, относительно которого будет происходить фильтрация. В нашем случае для оператора IS GREATER THAN следует указать значение '1/10/2007', так как цель - получить список инженеров нанятых позднее 01/10/2007. Для указания интервала (операторы between и not between) необходимо задать два значения, для чего отобразится второе поле ввода.

Значения для поля типа Date, возможно вводить как вручную, так и в диалоговом окне, открывающемся при нажатии на кнопку со стрелкой. Вид окна, появляющегося при нажатии на эту кнопку, зависит от типа данных выбранного поля.

Filter Builder dialog - Setting filter criteria values

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Выбор поля

Задание оператора условия

Добавление группы условий

Отношение условий внутри группы

Применение фильтрации


Добавление группы условий

Нам осталось добавить условия фильтрации по полу, профессии и подразделению. Можно создать группу, объединяющую простые условия, используя оператор AND, но в данном случае нет необходимости в объединении.

Чтобы добавить группу условий, нажмите кнопку EllipsisButton и выберите пункт меню Add Group.

Filter Builder dialog - Adding a new group

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Выбор поля

Задание оператора условия

Указание значения для условия

Отношение условий внутри группы

Применение фильтрации


Отношение условий внутри группы

Отношение условий внутри группы может быть определено посредством одного из четырех операторов:

AND - одновременно должны выполняться все условия,

OR - выполняться должно хотя бы одно условие,

NOT AND - не должно выполняться хотя бы одно из перечисленных условий,

NOT OR - не должно выполняться ни одно из перечисленных условий.

В нашем случае достаточно выбрать оператор AND.

Filter Builder dialog - Setting group operator

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Выбор поля

Задание оператора условия

Указание значения для условия

Добавление группы условий

Применение фильтрации


Применение фильтра

Предположим что мы объединили условия в группу. Если необходимо, можно добавить условия на том же уровне. После того как все настройки произведены, окно конструктора фильтра будет выглядеть как на рисунке ниже.

Нажмите кнопку Apply, чтобы применить фильтрацию к набору данных. Нажатие на кнопку Ok приведет к применению условий фильтра и закрытию окна. Используйте кнопку Cancel, если хотите отменить изменения и закрыть окно.

Filter Builder dialog - Applying filter conditions

В конструкторе фильтра у Вас есть возможность сохранять настройки фильтра во внешнем файле, а также загружать их. Нажмите кнопку Save As, чтобы открыть окно сохранения файла. Настройки сохраняются в файл с расширением *.flt. Чтобы загрузить настройки фильтра нажмите кнопку Open.

Важно: при сохранении настроек фильтра важен порядок столбцов в исходном представлении таблицы. Если при последующем использовании файла количество или порядок столбцов будет иным, чем при сохранении настроек, то в этом случае фильтрация может быть применена некорректно.

Смотрите также:

Запуск конструктора фильтров

Добавление условий

Выбор поля

Задание оператора условия

Указание значения для условия

Добавление группы условий

Отношение условий внутри группы


Опции EMS SQL Query

SQL Query for MySQL
  • В начало
  • « Назад
  • Вперед »

Опции

Ниже приведен список основных групп опций в SQL Query for MySQL.

Настройки окружения

Настройки редактора

Настройки внешнего вида

Сохранение настроек

Шаблоны клавиатуры

Локализация

Смотрите также:

Шаблоны клавиатуры

Локализация


Настройки окружения

Environment Options - основной инструмент для управления свойствами и внешним видом объектов в SQL Query.

Открыть диалоговое окно настроек окружения можно с помощью пункта главного меню Options | Environment Options или кнопки Environment Options btnEnvironmentOptions , располагающейся на панели инструментов.

Предпочтения

Вкладка по умолчанию

Подтверждения

Проводник баз данных

Конструктор запросов

Палитра цветов

Шрифты

Параметры сетки данных

Отчеты

Локализация

Смотрите также:

Настройки редактора

Настройки внешнего вида


Предпочтения

General

CheckBox Save desktop on disconnect

Cохранять состояние рабочего стола при отключении. При следующем запуске программы все редакторы, которые были открыты перед выходом из программы, будут открыты заново.

CheckBox Encrypted passwords

Хранить пароли в зашифрованном виде.

hs4111 - Environment Options - Preferences

CheckBox Use transactions

Использовать транзакции при выполнении запросов.

CheckBox Disable multiple instances

Не разрешать одновременный запуск в одной системе нескольких экземпляров SQL Query for MySQL.

CheckBox Allow query parameters

Разрешить использование параметров в тексте процедур и запросов. Используйте двоеточие (':') перед идентификатором (:P1), чтобы задать значение параметра в запросе.

CheckBox Show splash screen at startup

Показывать заставку при запуске.

CheckBox Autoconnect databases on startup

Производить подключение к базам данных автоматически при запуске программы.

CheckBox Queries with explain plan

Отображать план запроса на вкладке Results по его выполнении.

CheckBox Query results on separate tab

Отображать результаты запроса на отдельной вкладке.

History

CheckBox Use history

Сохранять историю измененных запросов. В поле History depth задается количество запросов, которое следует хранить в истории.

CheckBox Show history for current query only

Показывать историю только для текущего запроса.

Смотрите также:

Подтверждения

Проводник баз данных

Конструктор запросов

Шрифты

Параметры сетки данных

Отчеты

Локализация


Вкладка по умолчанию

Выберите вкладку конструктора запросов, которая будет открываться по умолчанию при создании/открытии запроса: Editor, Query Builder, History, Favorite Queries.

Environment Options - Preferences - Default Sheet

Смотрите также:

Предпочтения


Подтверждения

На этой вкладке можно выбрать действия, при выполнении которых будет запрашиваться подтверждение.

hs4112 - Environment Options - Confirmations

CheckBox Confirm exit from SQL Query for MySQL

Подтверждать выход из программы.

CheckBox Confirm commit transaction

Подтверждать фиксацию транзакции.

CheckBox Confirm rollback transaction

Подтверждать откат транзакции.

CheckBox Confirm delete records

Подтверждать удаление записей.

Смотрите также:

Предпочтения

Проводник баз данных

Конструктор запросов

Шрифты

Параметры сетки данных

Отчеты

Локализация


Проводник баз данных

На этой вкладке задайте настройки проводника баз данных.

hs4113 - Environment Options - DB Explorer

CheckBox Show hosts in DB Explorer

Показывать хосты в дереве объектов проводника баз данных.

CheckBox Show history in DB Explorer

Отображать историю запросов в дереве объектов.

CheckBox Show hints

Показывать текст запроса в окне всплывающей подсказки.

CheckBox Show fields comments in the SQL Assistant

Показывать комментарии к полям в окне SQL ассистента.


Конструктор запросов

На этой вкладке можно задать настройки Визуального конструктора запросов.

hs4114 - Environment Options - Query Builder

General options

CheckBox Select condition row

Отображать выбранные условия в разных строках на вкладках Criteria и Grouping Criteria Визуального конструктора запросов

CheckBox Drag field name

Отображать имя поля при перетаскивании.

CheckBox Hide selection when inactive

Скрывать выделение полей объектов, когда отсутствует фокус.

CheckBox Show field types in hints

Показывать типы полей.

CheckBox Clear condition on query type changing

Удалять заданные условия при изменении типа запроса.

Visible tabs

В этой секции Вы можете изменить набор доступных вкладок редактора запросов.

Script format

В данном разделе можно задать некоторые особенности формата скрипта:

Из раскрывающегося списка Keywords format выбрать формат ключевых слов.

Вид отображения функций выберите из раскрывающегося списка Function format.

Для ключевых слов и функций предлагается четыре типа написания:

  • As is - Как есть,
  • Uppercase - ВСЕ ПРОПИСНЫЕ,
  • Lowercase - все строчные,
  • First upper - Начинать С Прописных.

Style

Из раскрывающихся списков Condition button style и Object border kind выберите стиль отображения кнопок и вид границ объектов.

Additional

CheckBox XP tables style

Cтиль таблиц Windows XP.

CheckBox Union all by default

Cвязь "UNION ALL" (для объединения с подзапросами) или "UNION" для нескольких запросов по умолчанию.

CheckBox Only select mode

Блокирует построение запросов типа INSERT, UPDATE или DELETE в визуальном конструкторе запросов.

CheckBox Use icons

Показывать иконки для объектов баз данных.

Смотрите также:

Предпочтения

Подтверждения

Проводник баз данных

Шрифты

Параметры сетки данных

Отчеты

Локализация


Палитра цветов

В этом разделе Вы можете изменить цвета объектов и элементов управления визуального конструктора запросов. Вызвать палитру для выбора цвета можно, нажав на цветной квадрат рядом с наименованием элемента управления.

hs4115 - Environment Options - Color Palette

Элементы, для которых можно задавать цвета:

Active condition row - активная строка в окне задания условий отбора.

Environment Options - QB - Style & Color - Active condition row

Condition text - текст условий отбора.

Environment Options - QB - Style & Color - Condition text

Condition item text - текст кнопок, расположенных рядом с условиями отбора.

Environment Options - QB - Style & Color - Condition item text

Table client area - фон объектов, помещенных в окно диаграммы.

Environment Options - QB - Style & Color - Table client area

Work space - цвет рабочей области диаграммы.

Environment Options - QB - Style & Color - Work space

Operation - знак операции в окне задания условий отбора.

Environment Options - QB - Style & Color - Operation

Predicate - предикат, если создан подзапрос.

Environment Options - QB - Style & Color - Predicate

Active table caption - заголовок активной таблицы.

Environment Options - QB - Style & Color - Active table caption

Inactive table caption - заголовок неактивной таблицы.

Environment Options - QB - Style & Color - Inactive table caption

Field text - текст имен полей на диаграмме.

Environment Options - QB - Style & Color - Field text

Selected field text - текст выделенного поля.

Environment Options - QB - Style & Color - Selected Field text

Field - текст имен полей в окне задания условий отбора.

Environment Options - QB - Style & Color - Field

Group - знак группировки в окне задания условий отбора, на вкладке Grouping criteria.

Environment Options - QB - Style & Color - Group

Смотрите также:

Конструктор запросов


Шрифты

На вкладке Fonts можно задать вид и размер шрифта для всей программы SQL Query for MySQL.

hs4116 - Environment Options - Fonts

System font name

Задайте шрифт, который будет использован во всех элементах управления программы SQL Query for MySQL.

System font size

Укажите размер шрифта.

В нижнем окне отображается образец текста, показывающий внесенные изменения.

Смотрите также:

Предпочтения

Подтверждения

Проводник баз данных

Конструктор запросов

Параметры сетки данных

Отчеты

Локализация


Параметры сетки данных

Colors

Опции в этой группе позволяют задавать цвета для основных элементов сетки данных. Кнопка EllipsisButton открывает стандартную палитру, с помощью которой Вы можете подобрать желаемый цвет.

Grid

Определяет цвет фона сетки данных.

Row

Определяет цвет выбранной строки.

Stripy

Определяет цвет нечетной строки (возможно, если опция включена опция Stripy grids).

Display formats

Выберите формат отображения для следующих форматов:

Integer fields - целое число.

Float fields - число с плавающей точкой.

DateTime fields - дата и время.

Date fields - дата.

Time fields - время.

hs4117 - Environment Options - Grid

NULL values

Для пустых значений можно задать:

Text - текст;

Font color - цвет шрифта.

Options

CheckBox Stripy grids

Выделять нечетные строки цветом, указанным в поле Stripy.

CheckBox Use Ctrl+Up to increase spin values

Использовать сочетание клавиш Ctrl+Up вместо Up для увеличения числового значения в ячейке.

CheckBox Show editor immediately

Позволять редактировать данные без задержки.

CheckBox Enable auto-search in grid

Осуществлять автоматический поиск совпадений с набранным текстом.

CheckBox Row multi-selection

Разрешать выделение нескольких строк.

CheckBox Load all rows mode

Загрузить все записи в инструмент просмотра. В этом случае в таблицу загружаются все данные из возвращаемого сервером набора данных. Выключение данной опции делает невозможным фильтрацию, автоматическую сортировку и получение сводных данных.

CheckBox Query fetch all records

Делать выборку всех записей при выполнении запроса.

CheckBox Show text fields as string

Отображать данные текстовых полей как строку. Если опция выключена, то данные будут представлены как в поле типа BLOB.

Max fields width (chars)

Определяет максимальную ширину для отображения в сетке полей типа CHAR и VARCHAR.

Min fields width (chars)

Определяет минимальную ширину для отображения в сетке полей типа CHAR и VARCHAR.

Grid layout preferences

В этой секции можно задать некоторые параметры размещения сетки данных.

RadioButton Save and restore layout - сохранение расположения и ширины.

RadioButton Autofit column width - автовыбор ширины столбцов.

Смотрите также:

Предпочтения

Подтверждения

Проводник баз данных

Конструктор запросов

Шрифты

Отчеты

Локализация


Отчеты

Default paper size

Размер бумаги для печати отчета, созданного в SQL Query for MySQL.

hs4118 - Environment Options - Report

Default page orientation

Ориентация страницы:

Portrait - портретная, Landscape - альбомная.

Margins

Размер полей страницы.

Left - левого,

Right - правого,

Top - верхнего,

Bottom - нижнего.

Смотрите также:

Предпочтения

Подтверждения

Проводник баз данных

Конструктор запросов

Шрифты

Параметры сетки данных

Локализация


Локализация

С помощью инструментов, расположенных на этой вкладке, Вы можете задавать язык программы.

hs4119 - Environment Options - Localization

Вы можете добавить свой файл с расширением *.lng, в список доступных локализаций. Для этого скопируйте его в папку %program_directory%\Languages folder и добавьте его в список с помощью диалогового окна Add language, вызываемого нажатием кнопки Add.

Available Languages

В списке показан перечень доступных локализаций, которые можно установить как основной язык программы. Дважды щелкните мышкой по локализации, если Вы хотите изменить ее имя или исходный файл.

Default Directory

В поле указан путь к папке, в которой по умолчанию находятся все файлы локализации, имеющие расширение *.lng.

Add Defaults

При нажатии на кнопку проверяется наличие файлов *.lng в папке по умолчанию, которые автоматически добавляются в список доступных языков программы.

Смотрите также:

Предпочтения

Подтверждения

Проводник баз данных

Конструктор запросов

Шрифты

Параметры сетки данных

Отчеты


Настройки редактора

В данном разделе Вы можете задать настройки для Редактора SQL.

Открыть окно настройки можно, выбрав пункт Options | Editor Options в главном меню программы, или нажав на кнопку Editor Options btnEditorOptions , расположенную на панели инструментов.

  • Общие настройки
  • Отображение
  • Цвет
  • Быстрый код

Смотрите также:

Настройки окружения

Настройки внешнего вида


Общие настройки

CheckBox Auto indent

Каждый новый отступ такой же, как в предыдущей строке.

CheckBox Insert mode

Включен режим автоматической вставки символов.

CheckBox Use syntax highlight

Использовать подсветку синтаксиса.

CheckBox Find text at cursor

Слово, на котором стоит курсор, автоматически попадает в окно поиска при нажатии Ctrl+F.

CheckBox Show line numbers

Показывать нумерацию строк в рабочей области редактора SQL.

CheckBox Use smart tabs

Варьировать размер отступа в зависимости от его величины на соседних строках.

CheckBox Take from previous line only

Размер отступа изменяется по аналогии с предыдущей строкой кода.

hs4121 - Editor options - General

Tab stops

Размер отступа при табуляции.

Undo limit

Максимальное число хранимых операций для отмены действия.

Смотрите также:

Отображение

Цвет

Быстрый код


Отображение

CheckBox Visible right margin

Отображать правое поле редактора.

CheckBox Visible gutter

Отображать левое поле редактора.

Right margin

Отступ от левого края для этой границы.

Gutter width

Ширина левого поля.

hs4122 - Editor options - Display

Editor font

Использовать шрифт используемый в редакторе SQL.

Size

Размер шрифта.

CheckBox Show only fixed-width fonts - если установлен этот флажок, то в списке выбора шрифтов будут отображаться только те, которые имеют фиксированную ширину символов (моноширинные шрифты).

Все изменения отображаются на образце, расположенном в нижней части формы.

Смотрите также:

Общие настройки

Цвет

Быстрый код


Цвет

SQL Query for MySQL
  • В начало
  • « Назад
  • Вперед »

Color

На вкладке Color Вы можете задать цвет и шрифт различных элементов текста, таких как ключевые слова, знаки препинания, комментарии, ссылки и т.д.

hs4123 - Editor options - Color

В верхней части формы в списке Element представлены все элементы. В нижней части окна на образце текста отображаются все внесенные изменения.

Справа расположены элементы управления, позволяющие менять вид объекта, выбранного в списке Element.

В разделе Text attributes задайте начертание шрифта используемого в редакторе SQL:

CheckBox Bold - жирный;

CheckBox Italic - курсив;

CheckBox Underline - подчеркнутый.

Секция Use defaults for позволяет восстановить исходные настройки цвета фона (Background) и элемента (Foreground).

Щелкните мышкой на элементе Foreground color или Background color, чтобы изменить цвет текущего элемента, или его выделения соответственно.

Смотрите также:

Общие настройки

Отображение

Быстрый код


Быстрый код

CheckBox Code completion - если флажок установлен, то при вводе первых символов слова в редакторе SQL, автоматически будет предложен список из слов, начинающихся с этих символов.

hs4124 - Editor options - Quick code

Delay (sec) - задайте время ожидания появления подсказки.

Code case - выбрать регистр для автоматически предлагаемых слов: Upper - верхний регистр, Lower - нижний регистр, First upper - все буквы нижнего регистра, кроме первой.

CheckBox Auto launch keyboard templates - шаблоны клавиатуры будут применяться автоматически.

CheckBox Color scope categories - выделять различные типы объектов своим цветом.

RadioButton Sort by scope

Сортировать объекты по типам.

RadioButton Sort by name

Сортировать объекты по именам.

Смотрите также:

Общие настройки

Отображение

Цвет


Настройки внешнего вида

С помощью этого инструмента Вы можете задать стиль отображения всех элементов интерфейса программы SQL Query for MySQL. Чтобы открыть окно настроек внешнего вида выберите в главном меню программы пункт Options | Visual Options, или нажмите на кнопку Visual Options btnVisualOptions, расположенную на панели инструментов.

Внесенные изменения можно сохранять в виде схемы. Для этого на каждой вкладке в верхней части находится кнопка Save as. Нажав на неё, укажите в появившемся окне имя сохраняемой схемы. Выбрать схему можно из списка Scheme Name, в котором содержатся и схемы по умолчанию, и созданные пользователем. Удалить схему можно с помощью кнопки Delete.

Visual Options - Save Visual Scheme

Все инструмента редактора расположены на вкладках:

Панели и меню

Деревья и списки

Элементы управления редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Разделители

В нижней части каждой вкладке, на образце, отображаются все внесенные во внешний вид изменения.

Смотрите также:

Настройки окружения

Настройки редактора

Шаблоны клавиатуры

Локализация


Панели и меню

Используйте вкладку Bars and menus для настройки внешнего вида панелей инструментов и меню программы SQL Query for MySQL.

Visual Options - Bars and menus

Из раскрывающегося списка Bar style выберите один из стандартных стилей панели инструментов:

Standard - стандартный вид;

Enhanced - улучшенный вид;

Flat - двумерный;

XP native - стиль MS Windows® XP;

Office 11 - стиль MS Office 11.

Важно: Если выбран стиль XP, то к панелям инструментов будет применена схема, выбранная в операционной системе. Если же установлена иная операционная система или выбрана схема Windows Classic, то будет применен стиль Enhanced.

Из списка Menu Animation можно выбрать один из вариантов анимации при открытии меню:

None - без анимации;

Random - случайный выбор анимации;

Unfold - разворачивающееся меню;

Slide - выезжающее;

Fade - проявляющееся.

CheckBox Sunken border - утопленная рамка.

CheckBox Use F10 for menu - при нажатии клавиши F10 происходит фокусировка на главном меню SQL Query for MySQL.

CheckBox Show full menus after delay - показать всё меню после задержки. Эта опция доступна, только если установлен флажок Menus show recently used commands first в диалоговом окне Customize.

CheckBox Flat close buttons - использовать двумерные закрывающие кнопки.

CheckBox Gray-scale disabled images - иконки недоступных пунктов меню изображены с помощью оттенков серого. Если опция выключена - такие иконки будут затененными. Если выбран стиль XP native или Office 11, то опция включается автоматически, и становится недоступной для изменения.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Деревья и списки

На вкладке Trees and Lists настройте внешний вид списков.

Visual Options - Trees and lists

Из раскрывающегося списка Look & Feel выберите один из стандартных стилей оформления списков.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Hide selection - скрыть выделение.

CheckBox Hide focus rectangle - прятать прямоугольник фокуса.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Элементы редактирования

На вкладке Edit controls задайте стиль элементов управления и редактирования.

Visual Options - Edit controls

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия;

Thick - одинарная широкая линия;

Flat - плоская с тенью;

3D - трехмерная;

Ultraflat - плоская.

Из списка Button style - стиль кнопок.

3D - трехмерные;

Flat - плоские с тенью;

Simple - простые;

Hotflat - плоские в рамке;

Ultraflat - плоские.

Стиль кнопок, расположенных в пределах поля, можно задать с помощью раскрывающегося списка Button transparency.

None - непрозрачные;

Inactive - прозрачные, когда неактивные;

Always - прозрачные;

Hide inactive - показывать при редактировании;

Hide unselected - показывать при наведении курсора.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Edges - границы:

CheckBox Left - слева;

CheckBox Right - справа;

CheckBox Top - сверху;

CheckBox Bottom - снизу.

Смотрите также:

Панели и меню

Деревья и списки

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Флажки

SQL Query for MySQL
  • В начало
  • « Назад
  • Вперед »

Флаги

На вкладке Check boxes задайте вид флажков и переключателей.

Visual Options - Check boxes

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Кнопки

Элементы окна

Группы опций

Разделители


Кнопки

На этой вкладке настройте внешний вид кнопок.

Visual Options - Buttons

Из списка Button kind выберите вид кнопок.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Элементы окна

Группы опций

Разделители


Элементы окна

В этом окне задайте стиль оформления вкладок.

Visual Options - Page controls

Из списка Tab Style выберите нужный стиль вкладок.

Tabs - в виде вкладок,

Buttons - в виде кнопок

Flat - плоские.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Группы опций

Разделители


Группы опций

Задайте стиль отображения групп опций на вкладке Group boxes.

Visual Options - Group boxes

Из раскрывающегося списка Border style выберите стиль рамки.

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Разделители


Разделители

На вкладке Splitters задайте стиль разделителей (сплиттеров).

Visual Options - Splitters

Из раскрывающегося списка Hot zone style выберите стиль отображения разделителей.

Windows XP task bar - стиль Windows® XP,

Media Player 8 - стиль Media Player 8,

Media Player 9 - стиль Media Player 9,

Simple - простой,

None - нет.

CheckBox Hot zone drags a splitter

Если флажок установлен, то разделитель можно перемещать, потянув за среднюю рабочую область. Если не установлен, то по нажатию на эту область окно, ограниченное сплиттером будет сворачиваться и разворачиваться.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций


Мастер сохранения настроек

Мастер сохранения настроек позволяет экспортировать все настройки программы SQL Query for MySQL во внешний файл. Файл настроек имеет расширение *.reg (файл системного реестра Windows). Применить сохраненные настройки Вы можете как для этой программы, так и для заново установленного SQL Query for MySQL. Чтобы открыть Мастер сохранения настроек в главном меню программы выберите пункт Options | Save Settings.

Чтобы применить настройки, сохраненные в файл *.reg необходимо открыть этот файл двойным щелчком мыши. В появившемся окне нажать кнопку OK. Все настройки автоматически будут применены (добавлены в системный реестр Windows).

Мастер состоит из следующих шагов:

  • Выбор файла
  • Выбор настроек для сохранения
  • Выбор баз данных

Смотрите также:

Настройки окружения

Настройки редактора

Настройки внешнего вида


Выбор файла

На первом шаге необходимо задать имя файла, в который будут сохранены настройки и путь к нему.

Save Settings - Specifying destination file

В поле Filename с помощью кнопки btnSaveAs , в открывшемся стандартном диалоговом окне укажите имя и адрес создаваемого файла.

Следующий шаг


Выбор настроек для сохранения

Отметьте флажками те настройки, которые необходимо сохранить:

Save Settings - Selecting settings

CheckBox Database registration info - регистрационная информация баз данных;

CheckBox Favourite queries - избранные запросы;

CheckBox Query history - история запросов;

CheckBox Environment options - настройки окружения;

CheckBox Editor options - настройки редактора;

CheckBox Visual options - настройки внешнего вида;

CheckBox Keyboard templates - шаблоны клавиатуры;

CheckBox External tools list - список внешних инструментов;

CheckBox Form placements - расположение открытых окон;

CheckBox MRU lists - списки недавно использовавшихся объектов.

Следующий шаг


Выбор баз данных

На этом шаге необходимо выбрать те базы данных, для которых нужно сохранить регистрационную информацию и настройки.

Save Settings - Selecting databases

В списке Available Databases находятся доступные базы данных.

Выберите из списка те, для которых необходимо сохранить регистрационную информацию и настройки и переместите их в список Selected Databases с помощью кнопок Move all to Selected Move to Selected Move to Available Move all to Available или перетащите объект из одного списка в другой.

Нажмите кнопку Finish для начала создания файла настройки.


Шаблоны клавиатуры

С помощью инструмента Keyboard Templates задайте шаблоны для быстрого ввода текста.

Чтобы открыть редактор шаблонов клавиатуры выберите в главном меню пункт Options | Keyboard Templates или нажмите кнопку Keyboard Templates btnKeyboardTemplates на панели инструментов.

Чтобы создать шаблон нажмите на кнопку Add Template... В появившемся окне укажите последовательность символов, которая должна будет при вводе замениться определенным текстом.

Чтобы изменить уже созданный шаблон выделите его в общем списке и нажмите кнопку Edit Template. Нажав на кнопку Delete Template, Вы удалите выбранный шаблон.

В разделе Expansion укажите тот текст, которым должен быть заменен набор символов шаблона.

С помощью кнопок можно вставить автотекст:

  • Cursor - позиция курсора, при применении курсор будет переведен в указанное место,
  • Author - имя учетной записи,
  • Time - время редактирования
  • Date - дата редактирования,
  • Clipboard - содержимое буфера обмена,
  • Marker - маркер.

Также, в разделе Case of Templates, можно указать регистр, в котором должно вводиться сочетание символов, являющееся шаблоном.

RadioButton As is - оставлять как есть,

RadioButton Uppercase - ВСЕ ПРОПИСНЫЕ,

RadioButton Lowercase - все строчные,

RadioButton First upper - Начинать С Прописных.

Чтобы применить шаблон необходимо в редакторе набрать сочетание символов, указанное в шаблоне, а затем нажать сочетание клавиш Ctrl+J.

Восстановить значения шаблонов, принятые по умолчанию можно, нажав на кнопку By Default.

Смотрите также:

Опции

Локализация


Локализация

SQL Query for MySQL позволяет изменять язык интерфейса программы для удобства пользователей.

  • Выбор языка программы
  • Настройка директорий локализации

Смотрите также:

Опции

Шаблоны клавиатуры


Параметры SSH туннелирования

SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации Вы можете посетить http://openssh.org. Опция SSH туннель в SQL Manager представляет собой средство организации безопасного доступа к MySQL серверам при работе по небезопасным каналам связи. Также Вы можете использовать SSH туннель для доступа к удаленным MySQL серверам, если по каким-либо причинам порт 3306 закрыт для внешних подключений. Соединение через SSH туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в SQL Query for MySQL SSH клиентом и удаленным SSH сервером, затем вся исходящая и входящая информация между программой и MySQL сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно MySQL серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, Вы должны задать следующие параметры при регистрации базы данных в MySQL:

SSH Host - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH Port - порт SSH сервера на удаленном хосте (по умолчанию равен 22).

SSH User Name - имя пользователя на сервере (пользователь SSH сервера, а не сервера MySQL).

SSH Password - пароль пользователя SSH сервера.

Имейте в виду, что в случае использования SSH туннелирования имя хоста MySQL должно быть задано относительно сервера SSH. Например, если MySQL и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

SSH Private Key - Passphrase


Параметры HTTP туннелирования

HTTP туннелирование - это способ, при котором соединение и передача данных между программой и MySQL сервером происходит через протоколы HTTP/HTTPS, используя порт 80, через который работает обычный браузер. Этот способ подходит для соединения с MySQL, расположенным на удаленным сервере хостинг провайдера, когда прямое соединение невозможно из соображений безопасности. Соединение через HTTP туннель выглядит следующим образом: все исходящие запросы и команды с клиентских программ кодируются и передаются по протоколу HTTP/HTTPS, используя порт 80, специальному скрипту, который декодирует их и передает MySQL серверу на обработку, и возвращает обратно результат. Для использования этого способа на удаленном сервере должен быть установлен HTTP сервер (например, Apache) и PHP с подключенным расширением MySQL. Как правило, это программное обеспечение предлагают все хостинг-провайдеры, предоставляющие услуги хостинга на Linux платформах. Кроме того, Вы должны разместить наш emsproxy.php скрипт на вашем веб-сервере так, чтобы иметь к нему доступ извне (например, поместить его в каталог, где находятся ваши остальные PHP скрипты). Если ваш веб-сервер удовлетворяет данным требованиям и скрипт установлен правильно, то при открытии http://<your_webserver_name>/emsproxy.php в веб-браузере Вы увидите “EmsProxy v1.31” (версия может меняться).

URL - это адрес, где находится скрипт emsproxy.php (например, http://mywebserver /emsproxy.php).


Настройка панелей управления и меню

Любую панель инструментов можно настроить.

Её можно настраивать, используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку btnMoreButtons в правом углу панели.

В появившемся окне выбираете те кнопки, которые нужны Вам для работы.

Нажав на любую панель управления правой кнопкой мыши и выбрав пункт Customize.

Если на панели инструментов нажать правой кнопкой мыши, то тоже появится кнопка Customize.

При нажатии на эту кнопку открывается окно редактирования панели инструментов.

Toolbars

Appendix - Customize - Toolbars

На этой вкладке можно создавать, редактировать и удалять панели инструментов.

New - добавить панель инструментов,

Rename - переименовать,

Delete - удалить.

Commands

На этой вкладке выберите кнопки, которые будут отображаться на панели инструментов.

Appendix - Customize - Commands

Options

Appendix - Customize - Options

CheckBox Menus show recently used command first

Всегда показывать полные меню.

CheckBox Show full menus after a short delay

Показывать полные меню после небольшой задержки.

Reset my usage data - сбросить настройки.

Other

CheckBox Large icons

Крупные значки.

CheckBox Show ToolTips on Toolbars

Отображать подсказки для кнопок.

CheckBox Show shortcut keys in ToolTips

Включить в подсказки сочетания клавиш.

Menu animations

Анимация при выборе меню.


Задание настроек диаграммы

Если необходимо, Вы можете настроить диаграмму, используя опции, расположенные в окне Editing Chart.

Чтобы открыть это диалоговое окно, достаточно дважды щелкнуть мышкой на диаграмме.

Ниже представлен список основных вкладок:

График

Последовательности

Данные

Экспорт

Печать

Смотрите также:

Выбор полей

Свойства диаграммы

Экспорт диаграмм


График

Вкладка Chart позволяет удалять/создавать/редактировать последовательности, а также настраивать внешний вид графика.

Editing Chart - Chart

  • Последовательности
  • Общие
  • Оси
  • Заголовки
  • Легенда
  • Панель
  • Страницы
  • Грани
  • Трехмерность


Последовательности

Вкладка Series позволяет Вам добавлять последовательности на график, удалять их и редактировать.

Editing Chart - Chart - Series

Нажмите кнопку Add, чтобы открыть галерею TeeChart Gallery, где представлены все доступные виды графиков. Выберите подходящий вид и нажмите Ok. Вы также можете открыть галерею, нажав на кнопку Change. В этом случае вид графика будет задан для выбранной последовательности.

Editing Chart - Chart - Series - TeeChart Gallery

С помощью раскрывающегося списка в нижней части окна можно изменить стиль графика. Опция CheckBox 3D сделает график трехмерным, а CheckBox Smooth сглаженным.

Нажатием на кнопку Delete можно удалить выбранную последовательность.

Чтобы переименовать последовательность, выберите ее в списке и нажмите Rename. Затем укажите желаемое имя в появившемся окне.

Используйте кнопку Clone для создания копии выбранной последовательности.

Если щелкнуть дважды по последовательности, откроется вкладка Series, с помощью которой Вы сможете изменить ее параметры.


Общие

С помощью данной вкладки Вы можете изменить параметры масштабирования, прокрутки, настройки курсора и шрифтов.

Секция Zoom позволяет разрешить/запретить возможность масштабирования диаграммы, включить/выключить анимацию, задать кнопку мыши для управления функцией и т.д.

Editing Chart - Chart - General

Вы можете задать направление масштабирования с помощью выпадающего списка Direction.

Для того, чтобы увеличить изображение диаграммы необходимо удерживая нажатой выбранную клавишу мыши выделить курсором область, которую Вы хотите увеличить, и затем отпустить клавишу мыши.

Настройки, установленные по умолчанию, не позволяют точно определить область, выбранную для увеличения. Кнопка Pen... откроет окно, в котором можно настроить внешний вид границы выделенной зоны, а кнопка Pattern... позволит настроить закрашивание области выделенной зоны.

Секция Scroll позволяет управлять прокруткой диаграммы. Можно выбрать допустимость прокрутки по вертикали, горизонтали или в оба направления (по умолчанию).

В секции Cursor можно изменить тип курсора, или загрузить его из внешнего файла с расширением *.cur или *.ani.

Раздел Fonts содержит элементы настройки шрифта выбранного элемента диаграммы, его цвета, границ, теней и другие.


Оси

На этой вкладке Вы можете изменить параметры осей.

Editing Chart - Chart - Axis

В секции Scales можно задать минимум, максимум и инкремент для выбранной оси, включить/выключить ее отображение и другое.

Секция Title позволяет задать имя выбранной оси, а также изменить шрифт и цвет текста.

С помощью раздела Labels Вы можете изменить стиль (Style), формат значений (Format) и настройки текста (Text) для меток.

Секции Ticks и Grid позволяют настраивать стиль, размер и цвет делений на выбранной шкале и сетки графика соответственно.

Раздел Position служит для определения положения выбранной оси.


Заголовки

На этой вкладке Вы можете указать заголовок диаграммы и подобрать для него стиль (Style), указать положение (Position), цвет и фон (Format). Также можно определить границы (Border), градиент (Gradient), тени (Shadow) или установить рисунок из внешнего файла в качестве фона (Picture).

Editing Chart - Chart - Titles

Используйте выпадающий список в верхней части окна для выбора типа заголовка: Title, SubTitle, SubFoot, Foot.


Легенда

Вкладка Legend позволяет изменять параметры легенды диаграммы: стиль, положение, иконки, заголовок, оформление, границы, формат текста, градиент, тени и фоновый рисунок.

Editing Chart - Chart - Legend


Панель

SQL Query for MySQL
  • В начало
  • « Назад
  • Вперед »

Panel

Вкладка Panel позволяет настроить оформление окна диаграммы. Вы можете изменить цвет, параметры границ, отступы, задать градиент, тени или фоновый рисунок.

Editing Chart - Chart - Panel


Страницы

С помощью вкладки Paging Вы можете разбить график на несколько страниц и установить текущую.

Editing Chart - Chart - Paging

Установите флажок CheckBox No pages, чтобы отменить деление на страницы.

Опция CheckBox Current Page Legend определяет формат легенды графика. Отключите опцию, если необходимо отображать легенду для всех значений.

Если установлен флажок CheckBox Scale Last Page, то максимальное значение на шкале будет соответствовать максимальному значению в последовательности. В противном случае будет происходить масштабирование шкалы в соответствии с текущей страницей.


Грани

Вкладка Walls содержит элементы для настройки отображения граней диаграммы. Вы можете управлять их положением, размером (объемностью), цветом, узором окраски и прочим.

Editing Chart - Chart - Walls

Вкладка содержит секции, позволяющие настроить отображение каждой грани индивидуально.


Трехмерность

С помощью вкладки 3D Вы можете настроить трехмерность диаграммы.

Editing Chart - Chart - 3D - Views

Вы можете выбрать один из доступных шаблонов в секции Views, или настроить вид диаграммы вручную.

Editing Chart - Chart - 3D

CheckBox 3 Dimensions

Данная опция показывает будет ли диаграмма трехмерной. Ниже в поле 3D% Вы можете задать степень трехмерности в процентах.

CheckBox Orthogonal

Если флажок установлен, диаграмма будет представлена как параллелепипед. Вращение его будет возможно только с помощью поля Angle.

CheckBox Clip Points

Эта опция ограничивает отображение графика верхней и нижней гранью. Если опция выключена, то при увеличении масштаба часть графика будет отображена вне граней.

CheckBox Zoom Text

Используйте данную опцию для масштабирования текста.


Последовательности

С помощью вкладки Series Вы можете изменять различные параметры созданных последовательностей.

Editing Chart - Series

Format

Эта секция уникальна для каждого типа диаграмм и содержит различные визуальные настройки.

General

В этой секции Вы можете изменить общие опции, форматы значений и настроить оси.

Marks

Эта секция позволяет Вам настроить стиль и формат меток, размер отступов, тип границ и многое другое.

Data Source

В этой секции задайте источник значений для выбранной последовательности.

Editing Chart - Series - Data Source

В раскрывающемся списке доступны следующие значения:

  • Manual - значения должны быть заданы вручную;
  • Random - случайные значения;
  • Series - использовать значения существующей последовательности;
  • Function - использовать функцию в качестве источника значений;
  • Single record - выбрать значения из одной записи;
  • Summary - использовать сводку по столбцу в качестве источника;
  • Dataset - связать последовательность и результат запроса.


Данные

Вкладка Data просматривать и редактировать значения последовательности.

Editing Chart - Data

Дважды щелкните мышкой на поле, чтобы перейти в режим редактирования.


Экспорт

Вкладка Export позволяет экспортировать изображение диаграммы (Picture), данные (Data), а также код построения (Native).

Доступные форматы отображены в разделе Format.

Editing Chart - Export

Сначала следует выбрать тип экспорта. Затем укажите формат файла и нажмите кнопку Save, для экспорт во внешний файл; Copy для копирования в буфер обмена; Send для отправки по электронной почте.


Печать

SQL Query for MySQL
  • В начало
  • « Назад

Print

Вкладка Print позволяет задать настройки печати диаграммы.

Editing Chart - Print

Укажите требуемую ориентацию страницы (Orientation), поля (Margins), размер текста (Detail), затем выполните настройку печати (Setup) и нажмите кнопку Print.