Bienvenue dans EMS SQL Studio !

SQL Management Studio for PostgreSQL est une solution complète d'administration et de développement des bases de données. Si vous êtes un développeur de bases de données ou d'applications, un DBA ou un analyste commercial, SQL Studio vous offre tous les outils nécessaires pour rendre votre travail plus efficace que jamais. SQL Studio est un environnement de travail puissant et facile à utiliser qui propose tout un ensemble d'outils essentiels.

SQL Studio offre une multitude d'outils puissants pour l'administration de bases de données, la gestion des objets des bases de données, pour la migration, la comparaison, l'extraction des bases de données, pour l'importation, l'exportation et la comparaison des données.

Fonctionnalités :

  • Lancement facile des utilitaires et des services
  • Stockage des modèles dans un seul dépôt
  • Liste commune des sources de données pour tous les services et utilitaires
  • Création de scripts ramifiés et compliqués
  • Possibilité d'exécuter des applications externes à partir de scripts
  • Stockage des journaux d'exécution de tous les scripts dans une seule base de données
  • Exécution planifiée d'un script
  • Création des notifications personnalisées ; l'opportunité d'envoyer les notifications par différents moyens
  • Accès rapide au Service de Support Technique
  • Mode unique de personnalisation de l'apparence de toutes les applications

Avantages :

  • Le lancement rapide des tâches vous permet de vous concentrer sur le résultat
  • Le stockage des modèles dans un seul dépôt facilite le travail avec les utilitaires
  • La flexibilité des scripts permet d'économiser votre temps en vous débarrassant des tâches routinières
  • L'exécution planifiée de scripts permet d'automatiser les tâches routinières
  • Les e-mails de notification vous permettent d'être au courant des nouvelles informations
  • Le stockage des journaux d'exécution de tous les scripts vous permet de contrôler toutes les opérations
  • Le style unique de l'interface de tous les produits rend votre travail plus agréable


Quoi de neuf ?

SQL Management Studio for PostgreSQL 1.2.0.1

Décembre 4, 2008

Quoi de neuf dans SQL Management Studio 1.2 ?

  • Le planificateur des tâches peut être maintenant exécuté en tant que service système (Service Windows) ou processus à part.
  • Si une tâche personnalisée est exécutée manuellement, le processus d’exécution peut être suivi dans une fenêtre spéciale.
  • Le service de sauvegarde/restauration est maintenant disponible dans SQL Studio for PostgreSQL.
  • Le type de connexion SSH ou HTTP s’affiche maintenant dans le champ du nom de l’hôte.
  • Les paramètres de la barre d’outils se réinitialisaient après l’arrêt du programme. L’erreur est corrigée.
  • La possibilité d’ouvrir la documentation PDF via le menu principal a été ajoutée.
  • D’autres améliorations et corrections d’erreurs mineures ont été réalisées.


Exigences système

Pré-requis Windows

  • Pentium II ® 300MHz ou supérieur recommandé
  • Microsoft® Windows NT4 SP4, Microsoft® Windows 2000, Microsoft® Windows 2000 Server, Microsoft® Windows XP, Microsoft® Windows 2003 Server, Microsoft Windows Vista, Microsoft Windows 7
  • 64 Mo RAM (128 Mo ou plus recommandés)
  • 140 Mo d'espace disque minimum sont nécessaires pour une installation
  • Carte vidéo compatible avec Windows® ; Carte vidéo résolution 800x600 (1024x768 recommandé)
  • Souris compatible Windows® ou périphérique de pointage compatible
  • Possibilité de se connecter à PostgreSQL local ou distant


Installation

Si vous installez SQL Management Studio for PostgreSQL pour la première fois :

  • Veuillez télécharger le paquet d'installation SQL Management Studio for PostgreSQL depuis le site EMS ;
  • Décompressez le fichier téléchargé dans n'importe quel dossier local, par exemple c:\unzipped ;
  • Exécutez setup.exe depuis le dossier et suivez les instructions de l'assistant d'installation ;
  • Une fois l'installation terminée, vous trouverez un raccourci de SQL Management Studio for PostgreSQL dans le menu de démarrage Windows.

Si vous voulez mettre à niveau SQL Management Studio for PostgreSQL déjà installé :

  • Veuillez télécharger le fichier exécutable de SQL Management Studio for PostgreSQL depuis le site EMS ;
  • Décompressez le fichier téléchargé dans n'importe quel dossier local, par exemple c:\unzipped ;
  • Quittez SQL Management Studio for PostgreSQL s'il est lancé ;
  • Remplacez la version précédente de SQL Management Studio for PostgreSQL en copiant les fichiers décompressés depuis le dossier SQL Management Studio for PostgreSQL de EMS ;
  • Exécutez SQL Management Studio for PostgreSQL à l'aide du raccourci situé dans le menu de démarrage Windows.


Enregistrement

Nous avons passé un contrat avec le fournisseur de commerce électronique share-it! pour faciliter les processus d'achat de nos produits. L'achat en ligne via share-it ! est totalement protégé, c'est pourquoi le processus de paiement par carte de crédit est très rapide et absolument sécurisé.

Share-it ! est le fournisseur mondial de services e-Commerce dédiés à la vente de logiciels et de sharewares sur Internet. Share-it! accepte les paiements en dollars US, Euros, Livres Sterling, Yen Japonais, Dollars Australiens, Dollars canadiens ou Francs suisses par carte de crédit (Visa, MasterCard/EuroCard, American Express, Diners Club), transfert bancaire, chèque ou comptant.

Si vous avez commandé notre logiciel en ligne et voulez revoir l'information de votre commande, ou si vous avez des questions à propos de la commande, du paiement ou de la livraison, visitez notre Customer Care Center, sur le site de Share-it!

Notez s'il-vous-plaît que nous distribuons uniquement tous nos produits via le système ESD (Electronic Software Delivery).

Pour en SAVOIR PLUS sur ce produit, rendez-vous sur notre site : http://sqlmanager.net/en/products/studio/postgresql

Description du produit | Share It!
EMS SQL Management Studio for PostgreSQL (Business) + maintenance trois ans | Acheter !
EMS SQL Management Studio for PostgreSQL (Business) + maintenance deux ans
EMS SQL Management Studio for PostgreSQL (Business) + maintenance un an
EMS SQL Management Studio for PostgreSQL (Non-commercial) + maintenance trois ans
EMS SQL Management Studio for PostgreSQL (Non-commercial) + maintenance deux ans
EMS SQL Management Studio for PostgreSQL (Non-commercial) + maintenance un an

Le programme de maintenance du logiciel EMS offre les avantages suivants:

  • Les corrections d'erreurs gratuites, les améliorations, les mises à jour mineures et mises à jour majeures gratuites lors de la période de maintenance;
  • L'opportunité de contacter gratuitement notre équipe de support et nous faire part des erreurs de fonctionnement du logiciel
  • L'opportunité de nous contacter gratuitement à propos des aspects opérationnels de notre logiciel

Après l'expiration de votre maintenance, vous ne pourrez plus obtenir les mises à jour des produits et le support téchnique. Vous devez renouveler votre maintenance pour acquitter vos dépenses et utiliser des nouvelles versions du logiciel.

Vous pouvez renouveler facilement votre maintenance en utilisant le dialogue en ligne Maintenance Reinstatement Interface. Après avoir renouvelé votre maintenance vous recevrez un email de confirmation avec les informations nécessaires.


Bref historique

Version | Date de sortie
Version 1.1 | Décembre 12, 2007
Version 1.0 | Octobre 18, 2006

http://www.sqlmanager.net/products/studio/postgresql/news

Quoi de neuf dans SQL Management Studio 1.1 ?

  1. Planificateur de tâches : nous avons ajouté la possibilité d'exécuter les tâches planifiées plusieurs fois par jour.
  2. Vous pouvez maintenant lancer tous les outils SQL Studio via le menu contextuel d’Agent situé sur la barre des tâches.
  3. Le message correspondant s’affiche où se crée dans le journal lors de la tentative d’appeler l’utilitaire à l’aide du modèle impropre.
  4. SQL Query permet maintenant d’utiliser le dépôt des bases de données partagé avec SQL Studio.
  5. La mise à jour du logiciel via SQL Studio Direct a été améliorée :
  • le progrès de téléchargement s’affiche lors du téléchargement de la mise à jour;
  • le message correspondant s’affiche lors de la tentative d’installer la mise à jour qui n’est pas disponible à cause de la maintenance expirée.
  6. Nous avons éliminé l’erreur qui survenait lors de la tentative de supprimer une seule étape de la tâche.
  7. La configuration des options visuelles peut être maintenant appliquée à tous les composants de SQL Studio.
  8. L’ajout et la suppression des bases de données exécutées dans SQL Manager ne s’affichaient pas dans l’arbre de l’explorateur de SQL Studio lancé. L’erreur est corrigée.
  9. Nous avons corrigé un certain nombre d’artefacts qui survenaient lors du travail avec deux moniteurs.
  10. L’erreur de lancement d’Agent survenait si un utilisateur avec les droits restreints exécutait SQL Studio avec SQL Studio Agent pas lancé. L’erreur est corrigée.
  11. Nous avons considérablement agmenté la vitesse de l’ouverture de la section ‘Gestion de modèles’ (Template Management) avec une grande liste des modèles.
  12. La position de la fenêtre SQL Studio se sauvegarde pour la session suivante.
  13. L’erreur "Tool path is not correct" survenait lors de la tentative d’exécuter une tâche pendant le travail avec Windows 2003 Server. L’erreur est corrigée.
  14. Nous avons ajouté la requête de confirmation qui apparait lors de la suppression d’une étape à partir d’une tâche.
  15. D’autres améliorations et corrections d’erreurs mineures ont été réalisées

Lancement de EMS SQL Management Studio!

Fonctionnalités supplémentaires de SQL Studio:

  • Lancement facile des utilitaires et des services
  • Stockage de tous les modèles dans un seul dépot
  • Liste de sources de données commune pour tous les services et utilitaire
  • Création des tâches compliquées et l’exécution des tâches planifiées
  • Possibilité d’exécuter les applications externes en utilisant le planificateur de tâches
  • Stockage de tous les journaux de tâches exécutées dans une seule base de données
  • Création des notifications personnalisées avec des options différentes de livraison
  • Possibilité d’appliquer un style visuel unique pour tous les applications SQL Studio
  • Accès rapide au Service de Support Technique EMS

Avantages de SQL Studio:

  • Lancement rapide des tâches vous permet de vous concentrer sur le résultat
  • Stockage de modèles dans un seul dépôt facilite le travail avec des utilitaire
  • Flexibilité des scripts permet d'économiser votre temps en vous débarrassant des tâches routinières
  • Exécution planifiée d'un script permet d'automatiser les tâches routinières
  • E-mails de notification vous permettent d'être au courant de nouvelles informations
  • Stockage des logs d'exécution de tous les scripts vous permet de contrôler toutes les opérations
  • Style unique de l'interface de tous les produits rend votre travail plus agréable


EMS SQL Studio for PostgreSQL FAQ

Si vous avez des questions propos d' SQL Management Studio for PostgreSQL veuiller lire attentivement cette page.

À propos de STUDIO

  • EMS SQL Management STUDIO for PostgreSQL (STUDIO), qu’est-ce que c’est ?
  • STUDIO dispose d’un grand nombre de fonctionnalités. Est-ce que j’ai besoin de toutes ces fonctionnalités ? Existe-t'il un produit plus simple ?
  • Que dois-je faire pour commencer à travailler avec STUDIO ?
  • Plusieurs utilitaires inclus dans STUDIO sont vendus séparément. Quelles sont les avantages de l’achat de composants faisant partie de STUDIO ?
  • Comment puis-je mettre à niveau les composant de SQL Studio ?

Enregistrement de la base de données et connexion

  • Est-ce que je peux travailler simultanément avec plusieurs bases de données ?
  • J’utilise Windows mais mon serveur PostgreSQL fonctionne sur Linux. Est-ce que je peux utiliser STUDIO pour travailler avec ce serveur ?
  • Pourquoi STUDIO utilise-t'il un seul dépôt de bases de données enregistrées ?
  • Avec quelles bases de données STUDIO fonctionne-t-il ?
  • Le tunnel HTTP, qu’est ce que c’est ?
  • Le tunneling SSH, qu’est ce que c’est ?
  • Je travaille derrière le coupe-feu (routeur). Est-ce que je peux utiliser STUDIO pour gérer un serveur PostgreSQL distant ?
  • Pourquoi je n’arrive pas à me connecter au serveur PostgreSQL ?
  • Je n’arrive pas à paramétrer la connexion au serveur PostgreSQL via SSH. Quelles valeurs dois-je entrer dans les champs sur l’onglet SSH du dialogue d'enregistrement de la base de données ?
  • J’ai enregistré une base de données mais, quand j’essaie de l’ouvrir, j’ai un message d’erreur “dynamic library libpq.dll not found”.

Manipulation des objets

  • Quels objets de base de données seront accessibles avec STUDIO ?
  • J’ai plus d’un million d’enregistrements dans la table, pourtant seulement 1000 s’affichent dans la grille des données. Que faire ?
  • Comment puis-je augmenter la vitesse de travail avec des grandes tables ?
  • Comment puis-je travailler avec les objets d'une base de données ?
  • Quand je crée une table `TestTable`, elle est sauvegardée comme `testtable`. C’est pas correct !
  • Comment puis-je personnaliser les formats de données dans la grille ?
  • Ma base de données utilise l’encodage "Greek". Toutes les données s’affichent dans la grille comme «?????????». Que faire ?
  • Je n’arrive pas à modifier la DDL. Pourquoi ?
  • J’ai une table qui contient seulement ~ 1000 enregistrements et un grand nombre de champs. L’ouverture de cette table dans l’onglet ‘Données’ prend beaucoup de temps.

Requête

  • Je débute avec PostgreSQL. Je ne sais presque pas écrire les commandes SQL à la main. Est-ce que STUDIO dispose comme MS ACCESS d’un Constructeur visuel de requêtes ?
  • Puis-je utiliser le Constructeur visuel de requêtes de STUDIO pour construire les requêtes complexes avec des unions et des sous-requêtes ?
  • Puis-je sauvegarder une requête crée pour l’utiliser dans la suite ?
  • Puis-je exécuter une requête à partir de la ligne de commande ?
  • Puis-je sauvegarder le résultat de l’exécution de la requête dans un fichier CSV ou dans un fichier XLS ?

Constructeur de rapport

  • Comment puis-je créer un rapport ?
  • Comment puis-je créer un rapport basé sur une requête ?
  • Puis-je sauvegarder mon rapport en HTML et sous les formats d'EXCEL ou de WORD ?
  • J’essaye de créer un rapport dans le constructeur de rapport. J’ai ajouté Master Data Band mais je n’arrive pas à accéder aux données de la table : la liste 'Bande de sources de données' est vide.

Manipulation des données

  • Quelle est la différence entre les fonctions export/import de STUDIO et celles de SQL Manager for PostgreSQL ?
  • Je veux importer les données depuis un fichier CSV. Comment puis-je le faire en utilisant STUDIO ?
  • J’essaye d’exporter une table mais les champs de type LONGTEXT ne sont pas exportés.
  • Comment puis-je modifier le répertoire par défaut où les données exportées seront sauvegardées ?
  • À quoi servent les versions consoles des utilitaires de manipulation de données inclues dans STUDIO ?
  • J’ai une base de données dans MS Access. Je veux la migrer vers un serveur PostgreSQL distant. Comment puis-je le faire en utilisant STUDIO ?
  • J’ai une source de données ODBC. Puis-je migrer depuis cette source vers PostgreSQL ?
  • Depuis quelles bases de données puis-je migrer vers PostgreSQL en utilisant STUDIO ?
  • Je travaille avec une application seulement. La structure de la base de données est déjà créée. Comment puis-je remplir les bases de données par les données de test à l’aide de STUDIO ?
  • Ma base de données contient beaucoup de relations entre les tables et des contraintes. STUDIO prend-t-il cela en compte lors de la génération de données de test ?

Analyse des données

  • Je voudrais rechercher les différences entre les métadonnées des deux différentes bases de données et puis les synchroniser. Comment puis-je le faire en utilisant STUDIO ?
  • J’ai besoin de rechercher les différences en terme de données entre ma base de données existante et sa copie de sauvegarde que j’ai fait hier. Que dois-je faire ?
  • Puis-je synchroniser les métadonnées ou les données entre les différentes versions du serveur PostgreSQL ?
  • Puis-je exécuter la synchronisation des métadonnées ou des données à partir de la ligne de commande ?
  • Puis-je synchroniser une base de données PostgreSQL avec une base de données MySQL à l’aide de STUDIO ?

Sauvegarde/Restauration

  • Quelles possibilités de sauvegarde fournit STUDIO ?
  • Est-ce possible de restaurer une copie de sauvegarde sur un certain serveur même si elle a été créée sur un autre serveur ?

Gestion de modèles

  • Qu'est-ce qu'un modèle, utilisé par exemple dans les fonctions d’export/import ? À quoi servent-ils ?
  • Où sont placés les modèles de STUDIO ?
  • Un modèle sera-t-il supprimé depuis le disque si je le supprime dans la liste de STUDIO ?
  • Comment puis-je créer un nouveau modèle pour l’import ?

Planificateur

  • J’ai besoin d’exécuter certaines fonctions de gestion de base de données (export depuis une base de données, import de ces données vers une autre base de données, sauvegarde de toutes les deux bases de données) en dehors du temps de travail (pendant la nuit). Est-ce que je peux le faire à l’aide de STUDIO ?
  • Comment puis-je configurer une tâche pour que je puisse recevoir un email de notification précisant la réussite ou l'échec de l’exécution de cette tâche ?
  • Le processus d’exécution d’une tâche, peut-il être modifié suivant les résultats d’exécution de ses étapes ?
  • Comment puis-je visualiser l’information sur mes tâches exécutées ?
  • Que se passe-t'il si l’application ne peut pas être terminée (une erreur grave, la tâche ne répond pas) lors de l’exécution d’une tâche exécutée ? L’exécution de la tâche sera-t-elle arrêtée ?
  • De quoi ai-je besoin pour travailler avec le planificateur des tâches ?
  • Qu'arrivera-t-il si, après le démarrage de l’ordinateur, le planificateur des tâches recherche des tâches qui devaient être exécutées dans le passé mais qui ne l'ont pas été ?

Journaux

  • J’ai besoin d’obtenir l’information depuis les journaux des applications exécutées par le planificateur des tâches. Est-ce que STUDIO sauvegarde ces journaux ?
  • L’application externe exécutée dans une des tâches n’a pas de journal mais il y a un écran du journal. Comment puis-je sauvegarder les données affichées sur l'écran ?
  • Les journaux sont-ils stockés longtemps dans STUDIO ?

Traduction de l'interface

  • Quelles traductions de l’interface de STUDIO sont disponibles ?

À propos de STUDIO

Q:

EMS SQL Management STUDIO for PostgreSQL (STUDIO), qu’est-ce que c’est ?

R:

EMS SQL Management Studio est une solution complète d’administration et de développement de bases de données. STUDIO est une suite intégrée d’outils puissants de gestion de bases de données qui sont réunis dans un environnement de travail facile à utiliser. Les développeurs vont apprécier l’opportunité de créer/modifier/supprimer des objets d’une base de données ainsi que découvrir les outils utiles de comparaison des bases de données, d’export/ d’import de données et de génération de données de test. Si vous êtes un DBA, SQL Studio vous offre des outils de migration, de sauvegarde et de restauration de bases de données. Un planificateur de tâches permet d’automatiser une grande partie du travail du DBA.

Q:

STUDIO dispose d’un grand nombre de fonctionnalités. Est-ce que j’ai besoin de toutes ces fonctionnalités ? Existe-t'il un produit plus simple ?

R:

C’est une question que les novices dans le domaine de l’administration et du développement des base de données posent le plus souvent. On ne comprend pas pourquoi tous ces outils sont vraiment nécessaires. Votre expérience va grandir de jour en jour, vous aurez des nouvelles tâches compliquées à exécuter et vous aurez besoin de plus d’outils pour les mener à bien. STUDIO dispose de tous les outils nécessaires pour les développeurs et les DBA et vous donne des possibilités de croissance professionnelle. Après vous avoir familiarisé avec les outils de STUDIO, vous pourrez trouver des solutions simples et agréables pour mener à bien vos tâches. Nos produits sont utilisés non seulement par des développeurs professionnels, c’est pourquoi ils disposent d'assistants dont l’usage est simple même pour un utilisateur novice. L’interface de STUDIO est conçu pour ne pas entraver votre travail et pour appeler seulement les outils nécessaires quand vous en avez besoin. Notre expérience montre que la majorité des utilisateurs s’habitue très vite à utiliser nos produits. Nous n’avons jamais reçu les demandes de passer d'une version d’utilisation à une autre plus simple.

Q:

Que dois-je faire pour commencer à travailler avec STUDIO ?

R:

Pour commencer à travailler avec STUDIO, vous devez télécharger un paquet d'installation ici. Puis veuillez exécuter le fichier d’installation sur un PC avec MS Windows. Quand l'installation sera terminée, vous pourrez utiliser le programme en mode démonstration. Vous pouvez évaluer la version d’essai pendant 30 jours. Pendant ce temps, vous pouvez prendre une décision d’achat. Pour acheter STUDIO, cliquez ici. Après l'achat, vous recevrez un email avec les informations nécessaires pour vous enregistrer. Pour enregistrer votre copie, vous devez saisir cette information (Menu principal/Aide/Enregistrer).

Q:

Plusieurs utilitaires inclus dans STUDIO sont vendus séparément. Quelles sont les avantages de l’achat de composants faisant partie de STUDIO ?

R:

En effet, pour effectuer une simple tâche vous pouvez acheter un utilitaire EMS ou quelques-uns d'entre eux. Pourtant si vous achetez tous ces utilitaires avec STUDIO, vous disposez des fonctionnalités supplémentaires. Premièrement, vous pourrez lancer tous ces outils à partir d’un planificateur de tâches, c’est-à-dire que vous pourrez régler l’ordre de lancement des outils, initialiser les paramètres à utiliser, le temps et/ou la périodicité de l’exécution des tâches et puis aller jouer au bowling :) Le planificateur de tâches va exécuter toutes les tâches, sauvegarder les journaux des opérations effectuées et vous envoyer un email de notification précisant la réussite ou l'échec de l’exécution d’une tâche. Le planificateur de tâches vous permet d’automatiser la plupart des tâches de maintenance. Deuxièmement, vous pouvez stocker toutes les bases de données enregistrées dans un seul dépôt. Ainsi vous pouvez enregistrer une seule fois une source de données et l'utiliser pour tous les outils de STUDIO. Ceci économise votre temps et réduit au minimum les risques d’erreur. Le troisième avantage est le prix. L’achat de composants faisant partie de STUDIO vous permet d’économiser plus de 40 % du prix original!

Q:

Comment puis-je mettre à niveau les composant de SQL Studio ?

R:

Il y deux méthodes pour mettre à jour les composants de SQL Studio:
1) Il vous faut télécharger de nouveau le paquet d’installation de SQL Studio et l’installer sur la même station de travail où votre version de SQL Studio est installée. Celle-ci sera replacée par la nouvelle version, mais tous les paramétrages seront sauvegardés.
2) Vous pouvez mettre à niveau les composants en utilisant l’option SQL Studio Direct disponible via l’élément Navigation/SQL Studio Direct du menu principal du programme. La liste des mises à jour disponibles apparaîtra dans la fenêtre déroulante. Afin de charger ces mises à jour cliquez sur Yes/Oui ( la connexion à l’internet est nécessaire). Vous pouvez aussi utiliser l’icône Refresh/Rafraîchir qui se trouve sur la barre d’outils de SQL Studio Direct.
Vous pouvez régler l’intervalle pour le sondage automatique de réseau et le chargement des mises à jour (en utilisant l’icône correspondante). L’enregistrement supplémentaire n’est pas nécessaire si vous utilisez les méthodes énumérés de la mise à jour.
De plus il y a une possiblité d’enregistrer SQL Manager seulement. Vous pouvez télécharger la nouvelle version du programme (Studio edition) à partir de la page de téléchargement du produit. Puis il vous faut décompresser l’archive dans le sous-dossier où SQL Manager est installé (par défaut C:\Program Files\EMS\SQL Studio for PostgreSQL\SQL Manager).

Défiler en haut

Enregistrement de la base de données et connexion

Q:

Est-ce que je peux travailler simultanément avec plusieurs bases de données ?

R:

Oui, bien sûr ! STUDIO vous permet de travailler simultanément avec un nombre illimité de bases de données. Vous pouvez aussi travailler avec un nombre illimité de bases de données via les tunnels SSH et HTTP. Notez que vous pouvez utiliser une base de données si elle est enregistrée correctement dans un dépôt de bases de données.

Q:

J’utilise Windows mais mon serveur PostgreSQL fonctionne sur Linux. Est-ce que je peux utiliser STUDIO pour travailler avec ce serveur ?

R:

Oui, c’est possible ! Le système d’exploitation du serveur n’a aucune importance. STUDIO fonctionne seulement dans un environnement Windows.

Q:

Pourquoi STUDIO utilise-t'il un seul dépôt de bases de données enregistrées ?

R:

Un seul dépôt de bases de données enregistrées vous permet d’acceder à une base de données à partir des différents outils de STUDIO. Si vous avez déjà utilisé nos bundles, vous étiez obligés d’entrer l’information sur la base de données pour chacun des outils utilisés. Ceci prenait beaucoup de temps et était source d'erreurs. Maintenant, le problème est résolu parce que STUDIO dispose d’un seul dépôt pour les bases de données enregistrées.

Q:

Avec quelles bases de données STUDIO fonctionne-t-il ?

R:

En utilisant nos produits, vous pouvez travailler avec tous les serveurs PostgreSQL versions 7.1 - 8.1 locals via les pipes nommés ou distants sur n’importe quelle plateforme (Linux, Unix, Windows, etc.) en utilisant TCP/IP. Vous pouvez vous connecter aux serveurs PostgreSQL via les tunnels SSH et HTTP.

Q:

Le tunnel HTTP, qu’est ce que c’est ?

R:

Le tunneling HTTP est une méthode qui permet de se connecter et de transmettre des données entre un programme et un serveur PostgreSQL via les protocoles HTTP/HTTPS en utilisant le port 80, qui est utilisée par un navigateur Internet habituel. On utilise cette méthode pour se connecter au serveur PostgreSQL distant d’une compagnie d’hébergement quand la connexion directe est impossible pour des raisons de sécurité. Le tunnel HTTP fonctionne de la façon suivante : toutes les requêtes sortantes et les commandes envoyées du logiciel client sont cryptées et transmises via le protocole HTTP/HTTPS en utilisant le port 80, vers un script spécial. Ce script décode des données reçues et les transmet vers un serveur PostgreSQL pour le traitement, et enfin renvoie le résultat. Cette méthode exige qu’un serveur HTTP (Apache) et PHP avec PostgreSQL soient installés sur un serveur distant. En règle générale, ce logiciel est fourni par tous les services d’hébergement qui offrent les solutions d’hébergement Linux. Vous devez aussi télécharger un script spécial emsproxy.php sur votre serveur web avec l’accès à distance (vous pouvez le placer dans un dossier dans lequel se trouvent tous vos scripts PHP). Après avoir ouvert la page http:///emsproxy.php dans votre navigateur, vous verrez un message "EmsProxy v 1.31" (le numéro de version peut être différent) si votre serveur web répond à ces exigences et si le script est installé correctement. Pour enregistrer une base de données distante avec l’accès via le tunnel HTTP, vous devez saisir les paramètres suivants dans l’assistant d’enregistrement des bases de données de SQL Manager for PostgreSQL :
Lors de la première étape de l'assistant :
Hôte est un hôte sur lequel se trouve le serveur PostgreSQL du point de vue du serveur HTTP. En règle générale, le serveur HTTP et le serveur PostgreSQL se trouvent sur la même machine et représentent 'localhost'.
Port est un port du serveur PostgreSQL sur un hôte distant. PostgreSQL utilise le port 5432 par défaut.
Nom d’utilisateur est le nom de l’utilisateur du serveur PostgreSQL.
Mot de passe est le mot de passe de l'utilisateur du serveur PostgreSQL.
Sélectionnez ‘Utiliser tunneling' et 'tunneling SSH’.
Deuxième étape de l’assistant :
URL est une adresse où se trouve le script de emsproxy.php (par exemple, http://monserveurweb/emsproxy.php).

Q:

Le tunneling SSH, qu’est ce que c’est ?

R:

SSH (Secure Shell Host) est un protocole utilisé pour augmenter la sécurité de l’ordinateur lors de travaux avec des systèmes Unix sur l’Internet. SSH utilise plusieurs algorithmes de cryptage avec une fiabilité différente. SSH est très répandu parce que plusieurs systèmes d’exploitation de type Linux (par exemple FreeBSD) incluent le serveur SSH dans la distribution standard. Pour plus d’information, visitez http://openssh.org. Le tunneling SSH est une fonctionnalité de SQL Manager qui permet de sécuriser la connexion aux serveurs PostgreSQL lors du travail via les chaînes de connexion qui ne sont pas sécurisées. Vous pouvez aussi utiliser le tunnel SSH pour accéder aux serveurs PostgreSQL distants, si pour quelques raisons le port 5432 est bloqué pour des connexions externes. La connexion via le tunnel SSH fonctionne de la façon suivante. Tout d’abord, on établit la connexion et l’authentification entre un client SSH incorporé dans PostgreSQL et un serveur SSH distant. Puis toute l’information sortante et entrante entre le programme et le serveur PostgreSQL doit être transmise via le serveur SSH à l’aide du port de communication (d’habitude c’est 22). Puis le serveur SSH transfère directement cette information vers le serveur PostgreSQL. Pour enregistrer une base de données avec une connexion via le tunnel SSH, veuillez initialiser les paramètres suivants dans l'assistant d'enregistrement des base de données de SQL Manager for PostgreSQL :
Première étape de l'assistant:
Hôte est un hôte sur lequel le serveur PostgreSQL est situé du point de vue du serveur SSH. Si le serveur SSH et le serveur PostgreSQL sont installés sur une même machine, il est égal à l’hôte SSH et vaut probablement 'localhost'.
Port est un port du serveur PostgreSQL. PostgreSQL utilise le port 5432 par défaut.
Nom d’utilisateur est le nom de l’utilisateur du serveur PostgreSQL.
Mot de passe est le mot de passe de l’utilisateur du serveur PostgreSQL.
Notez que le nom de l'hôte PostgreSQL doit être configuré par rapport au serveur SSH. Par exemple, si les serveurs PostgreSQL et SSH sont installés sur le même ordinateur, vous devez spécifier localhost en tant que nom de l'hôte au lieu du nom de l'hôte externe ou de l’adresse IP.
Puis sélectionnez l’option 'Utiliser tunneling' et 'tunneling SSH'
Deuxième étape de assistant:
Nom du hôte SSH est un hôte sur lequel le serveur SSH est activé.
Port SSH est le port sur lequel le serveur SSH est activé.
Utilisateur SSH est un utilisateur de l’ordinateur Linux (c’est un utilisateur Linux, et non pas un utilisateur du serveur PostgreSQL)
Mot de passe SSH est le mot de passe de l’utilisateur Linux.

Q:

Je travaille derrière le coupe-feu (routeur). Est-ce que je peux utiliser STUDIO pour gérer un serveur PostgreSQL distant ?

R:

Si à cause de la politique de sécurité de votre réseau corporatif ou de votre fournisseur d’hébergement, vous n’avez pas la possibilité de vous connecter directement à votre serveur PostgreSQL via TCP/IP (par exemple c’est bloqué par un coupe-feu), vous pouvez utiliser les tunnels SSH ou HTTP, fonctionnalité de SQL Manager.

Q:

Pourquoi je n’arrive pas à me connecter au serveur PostgreSQL ?

R:

1. Veuillez vérifier qu’une enregistrement de votre ordinateur client est indiqué dans le fichier pg_hba.conf sur le serveur PostgreSQL (ce fichier se trouve dans un répertoire de données du cluster de la base de données.
2. Si vous essayez de vous connecter à un serveur distant, les connexions TCP/IP doivent être autorisés sur le serveur distant. Pour cela il faut modifier le fichier postgresql.conf sur le serveur : il vous faut ajouter un nom ou l’adresse TCP/IP d’un ordinateur client dans la liste listen_addresses. Pour autoriser la connexion depuis tout hôte, vous pouvez indiquez le caractère * . Vous pouvez aussi exécuter le serveur avec l’option -i, ce qui est equivalent à listen_addresses = '*'.
3. Veuillez vérifier que vous avez entré correctement le nom et le mot de passe de l’utilisateur.
4. Il est possible que vous utilisez l’authentification par le mot de passe, mais celle-là n’est pas supportée dans STUDIO.

Q:

Je n’arrive pas à paramétrer la connexion au serveur PostgreSQL via SSH. Quelles valeurs dois-je entrer dans les champs sur l’onglet SSH du dialogue d'enregistrement de la base de données ?

R:

Pour initialiser correctement la connexion SSH, entrez s’il vous plaît les valeurs suivantes dans les champs correspondants :
Sur la page/l’onglet SSH :
Nom de l'hôte SSH - est un hôte sur lequel le serveur SSH est activé.
Port SSH - est un port via lequel le serveur SSH est activé.
Nom de l’utilisateur SSH – est un utilisateur d’un ordinateur avec le système d’exploitation Linux (c’est un utilisateur Linux, et non pas un utilisateur du serveur PostgreSQL.)
Mot de passe SSH – est un mot de passe de l’utilisateur de Linux.
Sur la page/l’onglet ‘Propriétés de connexion/Général' :
Hôte est un hôte sur lequel un serveur PostgreSQL est situé du point de vue du serveur SSH. Si le serveur SSH et le serveur PostgreSQL sont installés sur une même machine, l’hôte est identique à l’hôte SSH et vaut généralement 'localhost'.
Port est le port du serveur PostgreSQL sur l'hôte distant. PostgreSQL utilise le port 5432 par défaut.
Nom d’utilisateur est un nom d’utilisateur du serveur PostgreSQL.
Mot de passe est le mot de passe de l’utilisateur du serveur PostgreSQL.
Notez que le nom de l'hôte PostgreSQL doit être configuré par rapport au serveur SSH. Par exemple, si les serveurs PostgreSQL et SSH sont installés sur le même ordinateur, vous devez spécifier localhost en tant que nom du hôte au lieu du nom externe du hôte ou de l’adresse IP.

Q:

J’ai enregistré une base de données mais, quand j’essaie de l’ouvrir, j’ai un message d’erreur “dynamic library libpq.dll not found”.

R:

Cette erreur survient parce que le programme ne peut pas trouver la bibliothèque client libPostgreSQL.dll qui est nécessaire pour travailler avec le serveur PostgreSQL. Le fichier libpq.dll est inclus dans le paquet d’installation Studio. Il est probable que vous avez supprimé par mégarde ce fichier ou peut-être avez-vous déplacé le fichier exécutable dans un autre dossier. Pour résoudre ce problème, réinstallez Studio (tous vos réglages seront sauvegardés) ou copiez le fichier libpq.dll depuis le dossier d’installation vers le dossier contenant le fichier exécutable.

Défiler en haut

Manipulation des objets

Q:

Quels objets de base de données seront accessibles avec STUDIO ?

R:

Vous pouvez travailler avec tous les objets de vos bases de données PostgreSQL : tables, champs, index, vues, procédures stockées, fonctions, triggers, UDF et événements.

Q:

J’ai plus d’un million d’enregistrements dans la table, pourtant seulement 1000 s’affichent dans la grille des données. Que faire ?

R:

Sélectionnez l’option ‘de tous les enregistrements d'une table’ sur l’onglet ‘Grille’ du dialogue Options/Options d’environnement. Notez que la sélection de tous les enregistrements de la table peut prendre beaucoup de temps.

Q:

Comment puis-je augmenter la vitesse de travail avec des grandes tables ?

R:

Pour votre commodité et pour augmenter la vitesse de votre travail, la grille de données permet d’ajuster plusieurs paramètres d’affichage des données. Accessibles via Options/Options d’environnement , voici les plus importants d’entre eux"): Sur l’onglet Grille:
- Limites dans l'éditeur de table et de vue. Avec l’option activée ‘de tous les enregistrements d'une table’, vous pouvez visualiser tous les enregistrements d’une table sans accéder au serveur. Si les tables sont très grandes ou si la vitesse de connexion est lente, la recherche de données s’effectue avec retard et le trafic entrant peut augmenter considérablement. Il est recommandé d’utiliser ce mode lors du travail avec les bases de données locales dans le réseau privé. Le mode ‘de seulement’ limite le nombre maximum d’enregistrements retournés par la requête. Nous avons mis en service ce mode parce que l’homme n’est pas capable de traiter une si grande quantité d’informations en une fois. Pour exécuter une requête et afficher la portion suivante de données, utilisez le bouton ‘Suivant’ sur la barre d’outils de la grille de données. Ce mode permet d'accélérer considérablement la visualisation des données de la table, de prévenir le blocage et le délai d’attente. Il est recommandé d’utiliser ce mode lors du travail avec de grandes tables, quand la vitesse de connexion est lente ou quand le volume du trafic a de l’importance. Ce mode est activé par défaut. Avec ce mode vous pouvez utiliser les options ‘Utiliser SQL pour trier’ et ‘Utiliser SQL pour filtrer’ qui sont très utiles. Sur l’onglet Grille-> Options des données:
- Mode grille par défaut. Cette option peut être utilisée pour définir si les lignes sélectionnées seront chargées en une fois dans la grille (Charger toutes les lignes) ou par parties (Charger les lignes visibles) quand l’utilisateur scrolle les données de table. Le premier mode augmente le temps d’ouverture de la requête mais accélere le défilement. L’ouverture de la requête est très rapide en mode ‘Charger les lignes visibles’ mais les retards ont lieu lors de la navigation sur la grille.
- Utiliser le tri SQL lors de la visualisation des données. Si cette option est activée quand l’utilisateur règle le tri des données, le résultat de la requête envoyée au serveur s’affiche de nouveau dans la grille. Cette option est très utile avec le mode ‘de seulement’ mais elle peut augmenter le trafic. Quand cette option est désactivée, le tri s’effectue sur l’ordinateur client sans connexion au serveur, mais ce sont les données chargées qui sont triées. C’est-à-dire que si vous avez sélectionné 1000 enregistrements à trier en utilisant l’option ‘de seulement’, ces enregistrements seulement seront triés.
- ‘Utiliser SQL pour filtrer’. Si cette option est activée, les données sont triées sur le serveur, le résultat de la requête envoyée au serveur s’affiche de nouveau dans la grille. Cette option est très utile avec le mode ‘de seulement’ mais elle peut augmenter le trafic. Quand cette option est désactivée, le filtrage s’effectue sur l’ordinateur client sans connexion au serveur, mais ce sont les données chargées qui sont triées. C’est-à-dire que si vous avez sélectionné 1000 enregistrements à trier en utilisant l’option ‘de seulement’, ces enregistrements seulement seront filtrés.

Il est recommandé de régler les options suivantes afin d’augmenter au maximum l’efficacité de travail avec des grandes tables:
- ‘de seulement’ - activé
- ‘Charger les lignes visibles’ – activé
- ‘Utiliser SQL pour trier’ – activé
- ‘Utiliser SQL pour filtrer’ - activé

Q:

Comment puis-je travailler avec les objets d'une base de données ?

R:

Vous pouvez créer des nouveaux objets, supprimer et modifier des objets existants. Vous pouvez aussi copier les objets depuis/vers les bases de données qui se trouvent sur le même serveur ou sur les différents serveurs.

Q:

Quand je crée une table `TestTable`, elle est sauvegardée comme `testtable`. C’est pas correct !

R:

Recherchez l’option ‘Convertir le nom des objets créés en minuscule’ dans le dialogue ‘Options/Options de l'environnement/ Éditeurs d'objet’ et désactivez-la.

Q:

Comment puis-je personnaliser les formats de données dans la grille ?

R:

Vous pouvez personnaliser tous les formats d’affichage: integer, float, date, time et date/time dans la fenêtre Options de l’environnement. Vous pouvez le faire en utilisant Menu Principal|Options| Options de l’environnement|Grille|Couleurs et Formats.

Q:

Ma base de données utilise l’encodage "Greek". Toutes les données s’affichent dans la grille comme «?????????». Que faire ?

R:

Vous devez initialiser les paramètres 'client charset' pour que le serveur retourne l’information au client (ou programme) dans l’encodage nécessaire. Veuillez ouvrir la fenêtre ‘Informations sur l'enregistrement de la base’ et spécifier l’option 'Jeu de Caractères Client' comme ‘greek (ISO 8859-7 Greek)’.

Q:

Je n’arrive pas à modifier la DDL. Pourquoi ?

R:

Les onglets ‘DDL’ dans l'éditeur de table et l'éditeur UDF sont en lecture seule. Ils affichent le texte des opérations SQL que vous effectuez sur les tables dans les onglets ‘Champs’, ‘Index’ etc. et le texte des opérations sur UDF. Pour modifier ce texte, vous pouvez le copier dans le presse-papiers et le modifier en utilisant l'éditeur de scripts SQL.

Q:

J’ai une table qui contient seulement ~ 1000 enregistrements et un grand nombre de champs. L’ouverture de cette table dans l’onglet ‘Données’ prend beaucoup de temps.

R:

Il est probable que l’option ‘Remplissage automatique des largeurs de colonnes’ est activée dans l’onglet ‘Options de l’environnement’ de dialogue Options. Essayez de la désactiver.

Défiler en haut

Requête

Q:

Je débute avec PostgreSQL. Je ne sais presque pas écrire les commandes SQL à la main. Est-ce que STUDIO dispose comme MS ACCESS d’un Constructeur visuel de requêtes ?

R:

Bien sûr ! STUDIO dispose d’un constructeur visuel de requêtes qui permet aux débutants de construire des requêtes assez complexes et permet aux utilisateurs professionnels d’économiser beaucoup de temps. Il vous faut seulement spécifier les tables à utiliser dans la requête, spécifier leurs relations et les données à obtenir. Le Constructeur visuel de requêtes va créer lui-même le texte de la requête. Il n'y a plus qu'à exécuter cette requête. Vous pouvez voir tout de suite le résultat de l’exécution de la requête et porter les corrections si nécessaire. Les changements peuvent être exécutés dans le constructeur visuel de requêtes ou dans l'éditeur de texte. Les changements exécutés dans le constructeur visuel seront aussi affichés dans l'éditeur de texte et vice versa.

Q:

Puis-je utiliser le Constructeur visuel de requêtes de STUDIO pour construire les requêtes complexes avec des unions et des sous-requêtes ?

R:

Bien sûr ! Le constructeur visuel de requêtes permet de construire les requêtes complexes, y compris l'opérateur UNION et des sous-requêtes.

Q:

Puis-je sauvegarder une requête crée pour l’utiliser dans la suite ?

R:

Oui, bien sûr. À l’aide de STUDIO, vous pouvez sauvegarder une requête des façons suivantes:
1. Toutes les requêtes exécutées sont automatiquement sauvegardées dans l’historique. Vous pouvez visualiser l’historique et exécuter ou éditer une requête.
2. Vous pouvez ajouter les requêtes fréquemment utilisées dans la liste des requêtes favorites.
3. Vous pouvez sauvegarder n’importe quelle requête en tant que script SQL dans un fichier sur le disque dur et le charger ou l’exécuter quand vous en aurez besoin en utilisant la ligne de commande de l’outil SQL Script.
4. Vous pouvez sauvegarder votre requête avec un diagramme. Dans ce cas, après le chargement de la requête dans SQL Studio, le diagramme sera affiché de la même façon que vous l’aviez créé.
5. STUDIO vous permet de sauvegarder le diagramme de la requête en tant qu’image bitmap.

Q:

Puis-je exécuter une requête à partir de la ligne de commande ?

R:

Oui, c’est pour cela que STUDIO dispose d’un outil SQL Script. Cet outil vous permet aussi d’exécuter un script à partir du fichier sauvegardé sur votre disque dur. Cette fonctionnalité vous permet de créer des requêtes et de planifier leur exécution en utilisant le planificateur des tâches. Le planificateur exécutera votre requête en précisant la réussite ou l'échec de l’exécution de la requête quand vous en aurez besoin.

Q:

Puis-je sauvegarder le résultat de l’exécution de la requête dans un fichier CSV ou dans un fichier XLS ?

R:

Oui, bien sûr ! STUDIO dispose d’un outil puissant d’exportation de données mais aussi des résultats de l’exécution de la requête. STUDIO permet d’exporter vers MS Access, MS Word, CSV, XLS, HTML, RTF, DBF, XML, etc. L’assistant d'export de données de STUDIO facilite la procédure d’export.

Défiler en haut

Constructeur de rapport

Q:

Comment puis-je créer un rapport ?

R:

Afin de créer un rapport, vous pouvez utiliser l’assistant de création de rapports ("Créer-->Rapport") ou le constructeur de rapport ("Outils/Constructeur de rapport"). Pour créer un rapport simple basé sur une requête sélectionnez Master Data band lors de la deuxième étape de l'assistant, double-cliquez sur Master Data band ou cliquez sur le bouton ‘Éditer’ et indiquez une requête pour votre rapport. Enfin, vous devez configurer des options supplémentaires lors des étapes restantes de l’assistant. Pour terminer, cliquez sur le bouton Finir.

Q:

Comment puis-je créer un rapport basé sur une requête ?

R:

Afin de créer un rapport basé sur une requête, vous pouvez utiliser l’assistant de création de rapports. Sélectionnez Créer-->Rapport, dans la barre d’outils, puis sélectionnez Master Data band lors de la deuxième étape de l'assistant, double-cliquez sur Master Data band ou cliquez sur le bouton ‘Éditer’ et indiquez une requête pour votre rapport. Enfin, vous devez configurer des options supplémentaires lors des étapes restantes de l’assistant et cliquer sur le bouton ‘Finir'.

Q:

Puis-je sauvegarder mon rapport en HTML et sous les formats d'EXCEL ou de WORD ?

R:

Oui. Pour cela, ouvrez votre rapport en double-cliquant sur lui dans la fenêtre de l’explorateur de bases et sélectionnez ‘Sauvegarder un rapport sous’ dans la barre de navigation ou dans la barre d’outils. Enfin spécifiez le format nécessaire pour ce rapport dans le champ ‘Sauvegarder sous un type’.

Q:

J’essaye de créer un rapport dans le constructeur de rapport. J’ai ajouté Master Data Band mais je n’arrive pas à accéder aux données de la table : la liste 'Bande de sources de données' est vide.

R:

Afin d’indiquer une source de données dans votre rapport, vous devez ajouter la forme du dialogue dans votre rapport (le menu "Édition/Ajouter la forme" ("Edit/Add dialog form") du constructeur de rapport), puis déplacez les composants de la base de données et de la requête depuis le panneau gauche du constructeur vers la forme et enfin configurez les propriétés de la requête et les propriétés de la connexion. La requête apparaîtra dans la liste de sources de données.

Défiler en haut

Manipulation des données

Q:

Quelle est la différence entre les fonctions export/import de STUDIO et celles de SQL Manager for PostgreSQL ?

R:

Les outils export/import inclus dans STUDIO disposent de fonctionnalités supplémentaires qui ne sont pas disponibles dans SQL Manager for PostgreSQL.
1. Export/import simultanés de données depuis/vers plusieurs tables de bases de données d’un seul hôte.
2. Export/import de données depuis/vers plusieurs tables de bases de données de différents hôtes.
3. L’utilitaire en ligne de commande qui permet d’automatiser l’export/import de données en utilisant le planificateur STUDIO.
4. Un seul dépôt des bases de données enregistrées.

Q:

Je veux importer les données depuis un fichier CSV. Comment puis-je le faire en utilisant STUDIO ?

R:

Vous pouvez utiliser pour cela l’assistant d'import de données. L’assistant vous permet d’initialiser tous les paramètres nécessaires à l'importation. De plus, vous pouvez sauvegarder ce paramétrage en tant que modèle et l’utiliser par la suite. Vous pouvez aussi importer depuis les fichiers MS Excel, MS Access, DBF, XML, TXT.

Q:

J’essaye d’exporter une table mais les champs de type TEXT ne sont pas exportés.

R:

Les champs de type TEXT ne sont pas exportés par défaut. Vous devez sélectionner manuellement ces champs sur l’onglet ‘Champs’.

Q:

Comment puis-je modifier le répertoire par défaut où les données exportées seront sauvegardées ?

R:

Afin de modifier un répertoire, suivez les étapes suivantes.
Cliquez avec le bouton droit de la souris sur une base de données dans l’arbre de l’explorateur de bases, puis cliquez sur l’élément ‘Informations sur la base de données enregistrée’ dans le menu contextuel qui apparaît (vous pouvez aussi rechercher cet élément dans le menu principal ‘Base de données’). La fenêtre des propriétés de la base de données va s’ouvrir. Cliquez sur l’onglet ‘Répertoires’.
Dans la section ‘Répertoire par défaut pour l'export de données’, vous pouvez sélectionner un répertoire par défaut pour un fichier à exporter.

Q:

À quoi servent les versions consoles des utilitaires de manipulation de données inclues dans STUDIO ?

R:

La fonction principale des versions consoles des outils de STUDIO consiste à exécuter certaines opérations de service avec une base de données sans participation de l’utilisateur. Tous les outils consoles supportent les fichiers de configuration (modèles) qui sont créés avec les versions GUI correspondantes. Le fichier modèle contient toute l’information nécessaire pour le fonctionnement de la version console d’un outil. À l’aide de la version console et d’un fichier modèle vous pouvez créer une tâche dans le planificateur des tâches et régler l’heure et/ou la période d’exécution de la tâche. Vous pouvez aussi utiliser les versions consoles des outils de STUDIO dans vos propres applications automatiques.

Q:

J’ai une base de données dans MS Access. Je veux la migrer vers un serveur PostgreSQL distant. Comment puis-je le faire en utilisant STUDIO ?

R:

Vous pouvez utiliser pour cela l’outil Data Pump for PostgreSQL. Pour exécuter Data Pump à partir de STUDIO, sélectionnez l’onglet ‘Manipulation de données’ et cliquez sur Data Pump for PostgreSQL ou choisissez Démarrer->Programmes->EMS->SQL Studio for PostgreSQL->Data Pump for PostgreSQL->Data Pump for PostgreSQL.
Nous vous recommandons d’utiliser le fournisseur Microsoft Jet 4.0 OLE DB pour vous connecter à votre base de données MS Access.

Q:

J’ai une source de données ODBC. Puis-je migrer depuis cette source vers PostgreSQL ?

R:

ODBC (Open DataBase Connectivity) est une interface standard ouverte pour accéder aux bases de données développées par Microsoft. La plupart des systèmes de gestion des bases de données disposent de leur propre pilote ODBC ou du pilote OBDC développé par les producteurs du logiciel à part.

Pour migrer depuis les source de données ODBC, il vous faut utiliser l’outil Data Pump for PostgreSQL. Pour exécuter Data Pump à partir de STUDIO, sélectionnez l’onglet Manipulation de données et cliquez sur Data Pump for PostgreSQL, ou choisissez Démarrer->Programmes->EMS->SQL Studio for PostgreSQL->Data Pump for PostgreSQL->Data Pump for PostgreSQL.
Vous devez utiliser le fournisseur OLE DB pour les pilotes ODBC pour vous connecter à votre source de données ODBC.

Q:

Depuis quelles bases de données puis-je migrer vers PostgreSQL en utilisant STUDIO ?

R:

À l’aide de Data Pump for PostgreSQL, vous pouvez migrer depuis toutes les bases de données auxquelles vous pouvez vous connecter en utilisant le fournisseur OLE DB (par exemple SQL Server, Oracle, MS Access, DB2, etc.) et le pilote ODBC (MySQL, Interbase, Firebird, dbase files, etc.)

Q:

Je travaille avec une application seulement. La structure de la base de données est déjà créée. Comment puis-je remplir les bases de données par les données de test à l’aide de STUDIO ?

R:

STUDIO comprend Data Generator qui est un puissant outil de génération de données de test. L’assistant vous aidera à initialiser les paramètres de génération tels que le nombre de lignes à générer, la gamme de valeurs pour chacun des champs, le nombre de lignes avec la valeur NULL etc. Data Generator peut utiliser plusieurs algorithmes y compris une génération de données aléatoire ou incrémentale, une génération d’après une liste des valeurs prédéfinie, etc. Il est possible de sauvegarder ces paramétrages en tant que modèle pour l’utiliser dans la suite.

Q:

Ma base de données contient beaucoup de relations entre les tables et des contraintes. STUDIO prend-t-il cela en compte lors de la génération de données de test ?

R:

Oui, bien sûr ! Lors de la génération de données de test, STUDIO prend en considération toutes les relations et les contraintes déjà existantes dans votre base de données.

Défiler en haut

Analyse des données

Q:

Je voudrais rechercher les différences entre les métadonnées des deux différentes bases de données et puis les synchroniser. Comment puis-je le faire en utilisant STUDIO ?

R:

C’est pour cela que STUDIO dispose d’un outil Database Comparer (DB Comparer). Son interface est simple et conviviale mais les résultats du travail sont tout à fait impressionnants. Vous devez seulement sélectionner les métadonnées des deux bases de données que vous voulez comparer. Puis configurez les paramètres supplémentaires tels que les objets de base de données à comparer, la direction de la synchronisation, etc. Le résultat du travail de DB Comparer est la liste de différences entre les métadonnées de ces deux bases de données et un script à l'aide duquel vous pourrez synchroniser les bases de données. Vous pouvez aussi synchroniser chaque différence séparément de toutes les autres en utilisant seulement les changements requis dans l' ordre. Rappelez-vous combien de temps prenait la recherche d’un seul champ ajouté dans la table il y a deux mois ? :)

Q:

J’ai besoin de rechercher les différences en terme de données entre ma base de données existante et sa copie de sauvegarde que j’ai fait hier. Que dois-je faire ?

R:

Pour cela, il vous faut exécuter l’assistant Data Comparer et spécifier la base de données existante (d’exécution) en tant que base de données source. Puis spécifiez la sauvegarde de la base de données d'hier en tant que base de données cible (tout d'abord il faut la restaurer sur n’importe quel serveur disponible PostgreSQL). Sélectionnez les données des tables à comparer et suivez les étapes de l’assistant. Notez que Data Comparer permet de comparer les données dans les tables avec des métadonnées différentes. Quand la comparaison sera finie, vous verrez la liste des différences entre les bases de données aussi que la proposition d’exécuter la synchronisation de données depuis la base de données source vers la base de données cible ou depuis la base de données cible vers la base de données source. Vous pouvez aussi sauvegarder un script SQL de synchronisation dans un fichier séparé et l’exécuter dans la suite en utilisant l’outil SQL Script (vous pouvez aussi utiliser le planificateur des tâches de STUDIO).

Q:

Puis-je synchroniser les métadonnées ou les données entre les différentes versions du serveur PostgreSQL ?

R:

Vous pouvez utilisez l’outil DB Comparer for PostgreSQL pour synchroniser la structure de vos bases de données.
Pour exécuter DB Comparer à partir de STUDIO, sélectionnez l’onglet ‘Analyse de données’ et cliquez sur DB Comparer for PostgreSQL, ou sélectionnez Démarrer->Programmes->EMS->SQL Studio for PostgreSQL-> DB Comparer for PostgreSQL-> DB Comparer for PostgreSQL.
Vous pouvez utilisez l’outil Data Comparer for PostgreSQL pour synchroniser les données.
Pour exécuter DB Comparer à partir de STUDIO, sélectionnez l’onglet ‘Analyse de données’ et cliquez sur Data Comparer for PostgreSQL, ou sélectionnez Démarrer->Programmes->EMS->SQL Studio for PostgreSQL-> Data Comparer for PostgreSQL-> Data Comparer for PostgreSQL.

Q:

Puis-je exécuter la synchronisation des métadonnées ou des données à partir de la ligne de commande ?

R:

Oui, c’est pour cela qu’il existent des versions consoles à nos utilitaires DB Comparer for PostgreSQL Console Application et Data Comparer for PostgreSQL Console Application. Toutes les applications consoles supportent les fichiers de configuration (fichiers modèles) qui sont créés avec les versions GUI des programmes. Le fichier modèle contient toute l’information nécessaire pour le fonctionnement de la version console d’un outil. À l’aide de la version console et d’un fichier modèle, vous pouvez exécuter facilement la synchronisation à partir de la ligne de commande sans configurer manuellement un grand nombre de paramètres.

Q:

Puis-je synchroniser une base de données PostgreSQL avec une base de données MySQL à l’aide de STUDIO ?

R:

Cette possibilité n’est pas supportée par nos utilitaires parce qu’ils permettent de synchroniser les données et les métadonnées entre les serveurs d’un même type, c’est-à-dire entre PostgreSQL et PostgreSQL.

Défiler en haut

Sauvegarde/Restauration

Q:

Quelles possibilités de sauvegarde fournit STUDIO ?

R:

STUDIO supporte plusieurs méthodes de sauvegarde des bases de données.
1) DB Extract for PostgreSQL ou l’assistant d’extraction de bases de données de SQL Manager for PostgreSQL. Ces deux outils permettent de créer des copies de sauvegarde (en tant que script SQL) des bases de données ou des objets spécifiés par l’utilisateur. Le script généré peut contenir les instructions SQL Utility, les instructions DDL et les instructions Insert Data. L’avantage principal de cette méthode réside dans la possibilité de sauvegarder partiellement ou complètement la structure d’une base de données et les données. Pour exécuter DB Extract, veuillez ouvrir l’onglet ‘Analyse de données’ de STUDIO et sélectionnez DB Extract for PostgreSQL. Pour exécuter l’assistant d'extraction de bases de données, ouvrez SQL Manager for PostgreSQL et sélectionnez ‘Outils| Extraire la base de données’ ('Tools|Extract Database'). Pour restaurer une base de données à partir d'un script créé par cette méthode, vous pouvez exécuter ce script sur le serveur PostgreSQL. Vous pouvez utiliser SQL Script for PostgreSQL ou l’outil Script SQL de SQL Manager for PostgreSQL
2) Data Export for PostgreSQL. Vous pouvez utiliser cette méthode pour sauvegarder les données de n’importe quelle table. Cette méthode permet de sauvegarder seulement les données et non pas la structure. Nous vous recommandons d’utiliser le format CSV pour sauvegarder les données. Pour exécuter Data Export, ouvrez l’onglet ‘Manipulation de données’ dans STUDIO et choisissez Data Export for PostgreSQL. Pour exécuter l’assistant d’exportation des données depuis SQL Manager for PostgreSQL, vous devez ouvrir votre table sur l’onglet ‘Données’ et sélectionner ‘Exporter les données’ (Export Data). Pour restaurer les données à partir du fichier créé par cette méthode, vous pouvez utiliser Data Import for PostgreSQL ou l’assistant d’import des données de SQL Manager for PostgreSQL. Vous pouvez prendre connaissance des différences entre Data Import for PostgreSQL et l’assistant d’import des données de SQL Manager for PostgreSQL ici
3) L’assistant de sauvegarde des données de SQL Manager for PostgreSQL. Cette méthode est identique à la méthode 2. La seule différence réside dans le fait que les données sont sauvegardées dans un répertoire sur le serveur ou dans un dossier partagé du réseau local à l’aide de l’instruction COPY SQL. Les données sont sauvegardées sous un format texte, sous un format CSV ou sous un format binaire, mais la vitesse de création des copies de sauvegarde et de leur restauration est beaucoup plus rapide qu’en cas de sauvegarde à l’aide de Data Export. Pourtant cette méthode ne permet pas de sauvegarder les fichiers dans n’importe quel répertoire client. Pour exécuter l’assistant de sauvegarde des données s à partir de SQL Manager for PostgreSQL, veuillez ouvrir votre table sur l’onglet ‘Données’ et sélectionner ‘Copier les données dans un fichier du serveur’. Vous pouvez restaurer facilement vos données en utilisant l’assistant de chargement des données.

Q:

Est-ce possible de restaurer une copie de sauvegarde sur un certain serveur même si elle a été créée sur un autre serveur ?

R:

1) Votre fichier de sauvegarde créé par DB Extract for PostgreSQL ou à l’aide de l’assistant d'extraction de bases de données de SQL Manager for PostgreSQL sur n’importe quel serveur s’il est d'une version supérieure ou égale à celle du serveur sur lequel la copie de sauvegarde a été créée.
2) Les données sauvegardées à l’aide de Data Export for PostgreSQL ou à l’aide de l’assistant d'export de données de SQL Manager for PostgreSQL peuvent être sauvegardées vers une table de n’importe quelle version du serveur PostgreSQL.
3) Les données sauvegardées à l’aide de l’assistant de copie de données de SQL Manager for PostgreSQL sous un format texte ou un format binaire peuvent être sauvegardées vers une table sur n’importe quelle version du serveur PostgreSQL. Les données sauvegardées sous un format CSV peuvent être restaurées sur un serveur en version 8.0 ou ultérieure.

Défiler en haut

Gestion de modèles

Q:

Qu'est-ce qu'un modèle, utilisé par exemple dans les fonctions d’export/import ? À quoi servent-ils ?

R:

Les modèles sont prévus dans STUDIO pour le stockage des paramètres qui sont nécessaires pour exécuter des outils de STUDIO. En utilisant STUDIO, vous pouvez exécuter une même opération plusieurs fois à l’aide des modèles sans avoir besoin de saisir à chaque fois 10-20 paramètres dans l’assistant. Les paramètres stockés dans un modèle peuvent être modifiés, vous pouvez aussi créer un nouveau modèle basé sur un modèle existant.

Q:

Où sont placés les modèles de STUDIO ?

R:

Un modèle est un fichier dans lequel les paramètres nécessaires sont stockés sous un certain format. Le fichier modèle peut être placé n’importe où dans votre ordinateur, vous devez seulement savoir le retrouver :) STUDIO comprend un gestionnaire des modèles pour simplifier les tâches de stockage et les tâches de recherche de modèles. Le gestionnaire vous permet d’enregistrer les modèles nécessaires dans STUDIO pour que vous ne vous inquiétiez plus de l’emplacement de sauvegarde d'un modèle. Quand vous créez un nouveau modèle dans STUDIO, le gestionnaire des modèles va mémoriser automatiquement son emplacement sur le disque. Tous les modèles enregistrés sont groupés selon les outils pour lesquels ils sont prévus, les modèles sont disponibles à tout moment. Pour lancer un outil avec un modèle sélectionné ,il vous faut seulement double-cliquer sur ce modèle.

Q:

Un modèle sera-t-il supprimé depuis le disque si je le supprime dans la liste de STUDIO ?

R:

Le gestionnaire des modèles vous permet d’exécuter les deux opérations : vous pouvez supprimer un modèle seulement de la liste des modèles, ou le supprimer aussi du disque de l’ordinateur.

Q:

Comment puis-je créer un nouveau modèle pour l’import ?

R:

Afin de créer un modèle pour l’outil d’import, il vous faut exécuter l’outil d’import (Menu principal/Exécuter/ DataImport). Puis remplissez tous les paramètres nécessaires d’import en utilisant le bouton ‘Suivant’. Lors de la dernière étape de l’assistant, indiquez où et sous quel nom vous souhaitez sauvegarder un modèle créé. Pour cela utilisez le bouton ‘Outils/ Sauvegarder le modèle’.

Défiler en haut

Planificateur

Q:

J’ai besoin d’exécuter certaines fonctions de gestion de base de données (export depuis une base de données, import de ces données vers une autre base de données, sauvegarde de toutes les deux bases de données) en dehors du temps de travail (pendant la nuit). Est-ce que je peux le faire à l’aide de STUDIO ?

R:

Oui, bien sûr ! C’est pour cela que STUDIO dispose d’un planificateur de tâches. Le planificateur peut exécuter les tâches que vous avez précédemment créé. Vous pouvez initialiser le temps d’exécution d’une tâche et la périodicité de son exécution. Chaque tâche peut inclure un nombre illimité d’étapes (opérations élémentaires). Une tâche doit inclure au moins une étape. Dans votre cas, il vous faut suivre les étapes suivantes: 1. Créez une nouvelle tâche 2. Créez les quatre étapes dans cette tâche (export, import, sauvegarde, sauvegarde). Lors de la création de ces étapes, vous devez indiquer les fichiers modèles dans lesquels les paramètres nécessaires pour le travail des outils sont sauvegardés. 3. En utilisant le planificateur des tâches, créez une tâche planifiée qui utilise la tâche récemment créée (1).

Q:

Comment puis-je configurer une tâche pour que je puisse recevoir un email de notification précisant la réussite ou l'échec de l’exécution de cette tâche ?

R:

Pour cela, utilisez l'onglet ‘Notifications’ de l'éditeur des tâches. Vous pouvez aller sur cet onglet et sélectionner un mode de notification nécessaire pour être informé de l'exécution réussie ou échouée d'une tâche. La version actuelle de STUDIO supporte les modes de notification suivants : la notification NetSend, le journal système des applications (WIN), la notification par e-mail.

Q:

Le processus d’exécution d’une tâche, peut-il être modifié suivant les résultats d’exécution de ses étapes ?

R:

Oui. Vous pouvez définir une étape suivante à exécuter lors de la création/modification de chaque étape. De plus, pour chacun des événements traités (l'exécution réussie ou échouée d'une étape, l'expiration du délai d'attente), vous pouvez régler les actions qui succèdent à l'exécution d’une tâche.

Q:

Comment puis-je visualiser l’information sur mes tâches exécutées ?

R:

Toute l’information sur l’exécution des tâches est enregistrée dans un journal. Vous pouvez rechercher non seulement l’information sur l’exécution d’une tâche, mais aussi l’information sur l’exécution de ses étapes. De plus, vous pouvez voir le journal de la pièce jointe exécutée lors de certaines étapes. C‘est très utile lors de l’analyse des causes de l'exécution échouée d'une étape ou d’une tâche. Les filtres puissants du journal permettent d’afficher seulement les enregistrements sélectionnés.

Q:

Que se passe-t'il si l’application ne peut pas être terminée (une erreur grave, la tâche ne répond pas) lors de l’exécution d’une tâche exécutée ? L’exécution de la tâche sera-t-elle arrêtée ?

R:

Pour résoudre cela, vous pouvez régler le délai d’attente pour chacune des étapes d’une tâche. Si le temps d’exécution de l'étape dépasse le délai d’attente, elle sera terminée à l'expiration du délai d'attente, et l’exécution de la tâche sera continuée selon l’algorithme que vous avez configuré.

Q:

De quoi ai-je besoin pour travailler avec le planificateur des tâches ?

R:

Pour cela, il vous faut exécuter STUDIO Agent (l’icône se trouve sur la barre des tâches). Bien sûr, votre ordinateur doit être démarré tout le temps pendant lequel les tâches seront exécutées.

Q:

Qu'arrivera-t-il si, après le démarrage de l’ordinateur, le planificateur des tâches recherche des tâches qui devaient être exécutées dans le passé mais qui ne l'ont pas été ?

R:

Ces tâches ne seront pas exécutées.

Défiler en haut

Journaux

Q:

J’ai besoin d’obtenir l’information depuis les journaux des applications exécutées par le planificateur des tâches. Est-ce que STUDIO sauvegarde ces journaux ?

R:

Oui. STUDIO dispose d’un outil commode pour travailler avec des journaux. Vous pouvez spécifier l’emplacement du journal de l’application exécutée lors de la création de n’importe quelle étape d’une tâche. L’emplacement du journal est indiqué automatiquement lors de la sélection des outils de STUDIO. Les journaux des étapes exécutées sont sauvegardés dans la base de données interne de STUDIO et ils sont disponibles dans le menu Navigation/Journaux.

Q:

L’application externe exécutée dans une des tâches n’a pas de journal mais il y a un écran du journal. Comment puis-je sauvegarder les données affichées sur l'écran ?

R:

Si l’utilitaire exécuté n’a pas de journal mais qu'il affiche des informations sur l’écran (en mode texte, non pas en mode GUI), STUDIO peut enregistrer les informations affichées sur l’écran en tant que journal. Pour cela, cochez ‘Enregistrer l'écran dans un journal’ lors de la création d’une tâche.

Q:

Les journaux sont-ils stockés longtemps dans STUDIO ?

R:

Les journaux peuvent être stockés dans STUDIO pendant une période illimitée. Vous pouvez supprimer manuellement les journaux inutiles à l’aide de STUDIO (onglet Journaux).

Défiler en haut

Traduction de l'interface

Q:

Quelles traductions de l’interface de STUDIO sont disponibles ?

R:

Cette version de STUDIO supporte les traductions suivantes : anglaise, allemande, française et russe.

Défiler en haut

Si vous avez des questions, veuillez contacter notre Centre de Support.


Début du travail

La capture d'écran affichée ci-dessous est l'aperçu de SQL Management Studio for PostgreSQL. Afin d'apprendre à exécuter les opérations essentielles du programme, d'obtenir l'information nécessaire sur les fonctionnalités et l'interface du programme, s'informer à propos des possibilités de personnalisation SQL Management Studio for PostgreSQL, suivez les liens ci-dessous :

Utilisation de Studio Agent

Sélection de la langue

Démarrage

Barre de navigation

Panneau de travail

Explorateur BD

Menu principal

Barre d'outils

Nous espérons que vous aurez plaisir à travailler avec SQL Management Studio for PostgreSQL !


Utilisation de Studio Agent

SQL Management Studio for PostgreSQL Agent est un programme résident qui se trouve dans la zone de notification Windows et vous aide à exécuter les opérations fondamentales de SQL Management Studio for PostgreSQL. Veuillez double-cliquer sur l'icone Agent pour exécuter SQL Management Studio for PostgreSQL.

En utilisant Agent SQL Management Studio for PostgreSQL, vous pouvez exécuter les tâches supplémentaires suivantes :

  • Exécuter une tâche personnalisée ;
  • Suspendre une tâche personnalisée.

Vous pouvez lancer toutes ces actions énumérées via Studio Agent. Ce dernier peut être appelé par un clic droit sur l'icone correspondante dans la zone de notification.

Note : pour exécuter Studio Agent lors du démarrage de Windows il suffit de sélectionner l'élément correspondant du menu.

Getting Started - Using Studio Agent


Sélection de la langue

Vous pouvez choisir la langue du programme lors du premier démarrage de SQL Management Studio for PostgreSQL. Vous pouvez aussi modifier ces réglages plus tard en sélectionnant l'élément Options | Localisation dans le menu principal.

Getting Started - Select language

Voir aussi :

Personnaliser les réglages


Démarrage

La capture d'écran affichée ci-dessous est l'aperçu de SQL Management Studio for PostgreSQL lors du premier démarrage. Le panneau de travail est l'élément principal de SQL Management Studio for PostgreSQL - il permet de lancer les programmes et les utilitaires EMS en sélectionnant l'élément nécessaire sur la barre de navigation (le lancement avec un modèle est aussi possible), de créer des tâches et de planifier leur exécution, d'obtenir le support technique, etc.

La barre de navigation se trouve par défaut dans la partie gauche de la fenêtre de SQL Management Studio for PostgreSQL. Vous pouvez basculer entre les différentes opérations avec les données et les bases de données PostgreSQL en sélectionnant la barre nécessaire.

Les barres ci-dessous représentent les activités de gestion des données et des bases de données PostgreSQL.

Voir aussi :

Barre de navigation

Panneau de travail

Explorateur BD


Menu principal

Le menu principal de SQL Management Studio for PostgreSQL vous permet d'exécuter différentes opérations concernant l'enregistrement des bases de données, permettant de basculer entre les activités de gestion des données et des services PostgreSQL, de lancer les outils de SQL Management Studio for PostgreSQL, de personnaliser SQL Management Studio for PostgreSQL, d'appeler Aide etc.

Getting Started - Main menu

Base de données

Enregistrer une base de données

Lance l'Assistant d'enregistrement des bases de données qui va vous guider pour enregistrer une base de données.

Supprimer l'enregistrement de la base de données

Supprime l'enregistrement de la base de données, la retire de l'arbre de l'explorateur de bases.

Information sur l'enregistrement de la base de données

Affiche la fenêtre Information sur la base de données enregistrée.

Enregistrer un hôte

Lance l'Assistant d'enregistrement d'un hôte qui va vous guider pour enregistrer un hôte.

Supprimer l'enregistrement d'un hôte

Supprime l'enregistrement d'un hôte (y compris toutes ses bases de données), le retire depuis l'arbre de l'explorateur de bases.

Quitter

Quitte SQL Management Studio for PostgreSQL.

Affichage

Modifie la vue de SQL Management Studio for PostgreSQL. Vous pouvez inverser les barres d'outils et les barres de navigation, afficher ou masquer les descriptions des produits etc.

Aller à

Veuillez utiliser cet élément du menu pour basculer entre les activités de gestion des données et des services PostgreSQL. Cet élément reproduit toutes les fonctions de la barre de navigation.

Start

Lance n'importe quel utilitaire de SQL Management Studio for PostgreSQL.

Options

Modifie les réglages de l'interface de SQL Management Studio for PostgreSQL et sélectionne la langue du programme.

Aide

Démarre le système d'aide de SQL Management Studio for PostgreSQL. Vous permet aussi de visiter le site de SQL Management Studio for PostgreSQL et d'enregistrer votre copie du logiciel.


Barres d'outils

La barre d'outils principale se trouve par défaut au-dessus du panneau de travail. Vous pouvez basculer entre les activités de gestion des données et des bases de données PostgreSQL en sélectionnant l'élément nécessaire de la barre.

Les boutons suivants représentent les activités de gestion des données et des bases de données PostgreSQL.

DBManagement Gestion des bases de données

DataManipulation Manipulation de données

DataAnalysis Analyse des données

TemplateManagement Gestion de modèles

CustomTasks Tâches

TaskScheduler Planificateur

Logs Logs

Ressources Internet

SQL Direct Studio

Support

Note : Vous pouvez personnaliser la barre d'outils principale à votre discrétion.

Vois aussi :

Personnaliser les barres d'outils


Panneau de travail

Panneau de travail - le panneau de travail est l'élément principal de SQL Management Studio for PostgreSQL - il permet de lancer les programmes et les utilitaires EMS en sélectionnant l'élément nécessaire dans la Barre de Navigation (le lancement avec un modèle est aussi possible), de créer des tâches et de planifier leur exécution, d'obtenir le support technique, etc.

Getting Started - Desktop Panel

En utilisant les éléments du panel du bureau vous pouvez :

DBManagement lancer le programme complet de gestion des bases de données (SQL Manager for PostgreSQL) et d’effectuer tous les services de base dePostgreSQL :

  • Analyse des tables (avec ou sans modèle);
  • Vacuum des tables (avec ou sans modèle);
  • Réindex (avec ou sans modèle);

DataManipulation lancer les outils intégrés de manipulation de données :

  • Data Export for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • Data Import for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • Data Pump for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • Data Generator for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • SQL Script for PostgreSQL (avec ou sans modèle, IUG ou version console);

DataAnalysis lancer les outils implémentés pour l’analyse de données :

  • Data Comparer for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • DB Comparer for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • DB Extract for PostgreSQL (avec ou sans modèle, IUG ou version console);
  • SQL Query for PostgreSQL;

TemplateManagement gérer les modèles pour chaque outil et service intégré;

CustomTasks gestion des tâches diverses;

TaskScheduler gestion des tâches planifiées;

Logs gestion des journaux des tâches;

InternetResources utiliser les ressources internet disponibles :

  • visiter la page d’accueil SQL Studio;
  • parcourir les pages SQL Studio dédiées aux Questions fréquemment posées;
  • parcourir la documentation en ligne concernant les composants SQL Studio;
  • visiter les ressources apparentés au PostgreSQL;

StudioDirect utiliser la fonctionnalité SQL Studio Direct;

Support bénéficier de l’assistance technique en ligne.

Conseil : Afin d’activer/désactiver les descriptions courtes affichées pour chaque outil dans le panel du bureau, vous pouvez utiliser l’élément ‘Afficher| Afficher les descriptions des outils’ (View | Show Tool Descriptions) du menu principal.


Barre de Navigation

La barre de navigation se trouve par défaut dans la partie gauche de la fenêtre de SQL Management Studio for PostgreSQL. Vous pouvez basculer entre les activités de gestion de données et de bases de données PostgreSQL en sélectionnant une barre nécessaire.

Les barres ci-dessous représentent les activités de gestion de données et de bases de données :

Barre d'outils

Gestion des bases de données

Manipulation de données

Analyse de données

Gestion de modèles

Barre des tâches

Tâches

Planificateur

Logs

Barre Internet

Ressources Internet

SQL Studio Direct

Support


Explorateur BD

L'explorateur de bases se trouve par défaut au-dessous de la barre de navigation dans la fenêtre de SQL Management Studio for PostgreSQL et affiche tous les hôtes enregistrés et les bases de données. Vous pouvez ajouter et supprimer des éléments depuis l'arbre de bases de données, visualiser des informations sur l'enregistrement des hôtes, lancer les services PostgreSQL pour les bases de données sélectionnées. L'information sur l'enregistrement des bases de données peut être aussi utilisée dans les utilitaires appartenant à SQL Management Studio for PostgreSQL.

Getting Started - DB Explorer

Pour ajouter un hôte ou une base de données dans l'explorateur de bases, utilisez les éléments correspondants du menu contextuel ou choisissez les éléments suivants de menu principal : Base de données | Enregistrer un hôte (Base de données | Enregistrer une base de données). Vous pouvez aussi utiliser les boutons de la barre d'outils de l'explorateur de bases.

Pour supprimer un hôte ou une base de données, utilisez les éléments correspondants du menu contextuel ou choisissez les éléments suivants du menu principal Base de données | Annuler l'enregistrement de l'hôte (Annuler l'enregistrement de la base de données). Vous pouvez aussi utiliser les boutons de la barre d'outils de l'explorateur de bases.

Pour visualiser les informations sur l'enregistrement de la base de données, sélectionnez l'élément correspondant du menu contextuel de l'explorateur de bases ou l'élément correspondant du menu principal de SQL Management Studio for PostgreSQL.

Afin de lancer un service de PostgreSQL pour une base de données enregistrée, vous devez :

  • sélectionner ce service dans l'arbre de l'explorateur de bases ;
  • sélectionner un service dans la section Gestion des bases de données du menu contextuel.


Gestion des données et des bases de données

Toutes les possibilités proposées par SQL Management Studio for PostgreSQL en terme de gestion de bases de données PostgreSQL sont divisées dans les groupes suivants :

Gestion des bases de données

Ce groupe vous permet d'administrer et de développer les bases de données en utilisant SQL Manager for PostgreSQL ainsi que d'activer les services PostgreSQL.

Manipulation de données

Ce groupe vous offre la possibilité d'exporter/importer les données vers les quinze formats les plus populaires. Vous pouvez transférer les données entre les différents serveurs de bases de données, générer les données de test pour les bases de données, analyser les données.

Analyse de données

Vous pouvez comparer et synchroniser le contenu et la structure des bases de données, créer les copies de sauvegarde sous forme de script SQL, analyser et récupérer les données à l'aide de la construction visuelle du script.

Gestion de modèles

Vous pouvez créer et gérer de nouveaux modèles.


Gestion des bases de données

La section Gestion des bases de données vous permet de développer et d'administrer les bases de données en utilisant SQL Manager for PostgreSQL et d'activer les services PostgreSQL.

Database Management - Desktop Panel

Démarrage de SQL Manager

Utilisation des services


Démarrage de SQL Manager

EMS SQL Manager for PostgreSQL est un outil puissant d'administration et de développement de serveurs de bases de données PostgreSQL. SQL Manager for PostgreSQL fonctionne avec toutes les versions de PostgreSQL et la 9.2, et supporte toutes les dernières fonctionnalités de MySQL, y compris les vues, les procédures et les fonctions stockées, les clés étrangères pour les tables InnoDB etc. A l'aide de l'interface conviviale, vous pouvez travailler avec les objets des bases de données, gérer les tables de données et exécuter les scripts SQL. SQL Manager for PostgreSQL vous permet de gérer les droits des utilisateurs, travailler avec les métadonnées, exporter et importer les données vers les quinze formats les plus populaires, visualiser et éditer les champs BLOB etc.

Pour activer SQL Manager for PostgreSQL, cliquez sur l'icône correspondante ou sur la légende qui se trouvent sur le panneau de travail.

Database Management - Running SQL Manager

SQL Manager documentation.

Voir aussi :

Utilisation des services


Utilisation des services

SQL Management Studio for PostgreSQL vous offre l'opportunité de lancer les services PostgreSQL nécessaires à la maintenance des tables et des bases de données. Les services suivants sont disponibles :

Database Management - Services

Analyse des tables (Analyze Tables)

Recherche des statistiques à propos du contenu des tables.

Vacuum des tables (Vacuum Tables)

Récupération de l'espace occupé par les enregistrements supprimés.

Réindex (Reindex)

le service permet de reconstituer les indexes corrompus.

Sauvegarde de la base (Backup Database)

Sauvegarde des tables à partir du hôte local vers les fichiers pour les utiliser dans la suite.

Restauration de la base (Restore Database)

Restauration des tables depuis les fichiers sur le disque vers la base de données.

Pour exécuter le service cliquez sur l'icône correspondante ou sur la légende sur le panneau de travail et suivez les étapes de l'assistant.

Voir aussi :

Gestion des bases de données


Manipulation de données

Data Manipulation vous offre la possibilité d'exporter/importer les données vers les quinze formats les plus populaires. Vous pouvez transférer les données entre différents serveurs de bases de données et générer les données de test pour les bases de données.

Getting Started - Desktop Panel

Démarrage de Data Export

Démarrage de Data Import

Démarrage de Data Pump

Démarrage de Data Generator


Démarrage de Data Export

EMS Data Export for PostgreSQL est un outil puissant d'exportation rapide de vos données depuis les bases de données de MySQL® vers les quinze formats les plus populaires tels que MS Access, MS Excel, MS Word (RTF), HTML, XML, PDF, TXT, CSV, DBF etc. Data Export for PostgreSQL comprend un assistant d'utilisation simple pour le réglage visuel des paramètres d'exportation de chacune des tables (les noms finals des fichiers, les champs exportés, les formats de données etc). Data Export for PostgreSQL comprend aussi un outil en ligne de commande pour exporter rapidement des données depuis les tables et les requêtes.

L'utilitaire Data Export peut être lancé indépendamment, l'assistant vous guidera pour l'exportation de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Export.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Manipulation - Running Data Export

Data Export documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Import

EMS Data Import for PostgreSQL est un puissant outil d'exportation rapide de vos données depuis les fichiers MS Excel, MS Access, DBF, XML, TXT et CSV vers les tablesPostgreSQL. Data Import for PostgreSQL permet d'ajuster les paramètres d'importation, y compris les formats source de données pour tous les champs, les paramètres des colonnes de destination pour les champs sélectionnés, les validations de données, le nombre de lignes à sauter etc. Data Import for PostgreSQL comprend un assistant de réglage visuel des paramètres d'importation pour les différents types de fichiers et d'un outil en ligne de commande pour une importation rapide.

L'utilitaire Data Import peut être lancé indépendamment, l'assistant vous guidera pour l'importation des données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Import.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Manipulation - Running Data Import

Data Import documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Pump

EMS Data Pump for PostgreSQL est un puissant outil qui vous facilite la conversion des bases de données et l'importation des données depuis n'importe quelle source compatible avec ADO (par exemple, MS Access, les bases de données MS SQL ou n'importe quelle base de données compatible avec ADO) vers les bases de données PostgreSQL. L'assistant simple d'emploi permet d'établir les lignes de connexion avec ADO, de sélectionner les tables, les champs et les indices à convertir, de visualiser et d'éditer le script SQL pour la création d'une base de données PostgreSQL de destination, de sélection des tables à importer. La conversion des bases de données est plus simple que jamais grâce à Data Pump for PostgreSQL !

L'utilitaire Data Pump peut être lancé indépendamment, l'assistant vous guidera pour la conversion des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Pump.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Manipulation - Running Data Pump

Data Pump documentation.

Voir aussi :

Manipulation de données


Démarrage de Data Generator

EMS Data Generator for PostgreSQL est un puissant outil qui vous permet de générer instantanément les données de test pour les différentes tables des bases de données PostgreSQL. L'assistant simple d'emploi permet de définir les tables et les champs de données à générer, de créer les champs texte en utilisant le masque, de charger les valeurs pour les champs BLOB directement depuis les fichiers, de sélectionner les listes de valeurs dans les requêtes SQL et d'exécuter d'autres opérations de génération des données de test simplement et efficacement. L'utilitaire en ligne de commande permet de générer rapidement les données à l'aide de modèles de génération.

Data Generator peut être lancé indépendamment, l'assistant vous guidera pour la génération des données de test. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Generator.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Manipulation - Running Data Generator

Data Generator documentation.

Voir aussi :

Manipulation de données


Démarrage de SQL Script

SQL Script utility is an easy-to-use tool allowing you to execute your SQL scripts fast and easy.

SQL Script peut être lancé indépendamment, l'assistant vous guidera pour la génération des données de test. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire SQL Script.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Manipulation - Running SQL Script

SQL Script documentation.

Voir aussi :

Manipulation de données


Analyse de données

La section Analyse des données vous offre la possibilité de comparer et de synchroniser le contenu et la structure des bases de données, de créer des copies de sauvegarde sous forme de script SQL, d'analyser et de récupérer des données à l'aide de la construction visuelle du script.

Data Analysis - Desktop Panel

Démarrage de Data Comparer

Démarrage de Database Comparer

Démarrage de DB Extract

Démarrage de SQL Query


Démarrage de Data Comparer

EMS Data Comparer for PostgreSQL est un utilitaire puissant et simple d'emploi qui effectue la comparaison et la synchronisation des données. En utilisant Data Comparer for PostgreSQL, vous pouvez découvrir les différences entre les tables comparées et exécuter un script généré automatiquement pour éliminer ces différences. Vous pouvez sélectionner les tables et les champs à comparer et modifier d'autres paramètres en utilisant les nombreux réglages du processus de comparaison et de synchronisation. Data Comparer for PostgreSQL comprend un assistant graphique qui va vous guider pour comparer et synchroniser les données pas à pas. L'utilitaire en ligne de commande permet d'exécuter la synchronisation des données en un instant.

Data Comparer peut être lancé indépendamment, l'assistant vous guidera pour la comparaison et la synchronisation du contenu des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Data Comparer.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Analysis - Running Data Comparer

Data Comparer documentation.

Voir aussi :

Analyse de données


Démarrage de Database Comparer

EMS DB Comparer for PostgreSQL est un puissant outil de comparaison de bases de données DB Comparer for PostgreSQL ce qui vous permet de découvrir les différences entre leurs structures. Vous pouvez visualiser les différences entre les objets comparés des bases de données et les éliminer partiellement ou totalement en utilisant le script généré automatiquement. L'interface graphique intuitive vous permet de travailler simultanément sur plusieurs projets, de définir les paramètres de comparaison et d'éditer les scripts de modification. Votre travail avec DB Comparer for MySQL sera plus simple et plus rapide grâce à la multitude de fonctionnalités utiles.

Database Comparer peut être lancé indépendamment, l'assistant vous guidera pour la comparaison et la synchronisation de la structure des bases de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire Database Comparer.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Analysis - Running DB Comparer

DB Comparer documentation.

Voir aussi :

Analyse de données


Démarrage de DB Extract

EMS DB Extract for PostgreSQL est un utilitaire simple d'emploi et puissant destiné à créer des copies de sauvegarde des bases de données sous forme de scripts SQL. DB Extract for PostgreSQL permet de sauvegarder partiellement ou complètement les métadonnées des objets des bases et les données des tables. Vous pouvez sélectionner les objets et les tables des bases nécessaires et ajuster d'autres paramètres à l'aide des réglages flexibles du processus d'extraction. DB Extract for PostgreSQL comprend un assistant graphique qui vous aide à exécuter le processus d'extraction pas à pas. L'utilitaire en ligne de commande permet de créer rapidement des copies de sauvegarde des bases.

DB Extract peut être lancé indépendamment, l'assistant vous guider pour la génération du script SQL nécessaire pour la création d'une copie de sauvegarde d'une base de données. Pour cela, cliquez sur l'icône correspondante ou sur la légende.

Si vous voulez utiliser l'utilitaire avec un modèle, cliquez sur l'étiquette correspondante au-dessous du titre de l'utilitaire DB Extract.

L'étiquette Gestion de modèles va vous rediriger vers la section correspondante de SQL Management Studio for PostgreSQL.

Data Analysis - Running DB Extract

DB Extract documentation.

Voir aussi :

Analyse de données


Démarrage de SQL Query

EMS SQL Query for PostgreSQL est un utilitaire de création simple et rapide de requêtes SQL vers les bases de données PostgreSQL. La création visuelle des requêtes et l'édition du texte de la requête sont possibles simultanément. L'interface simple d'emploi permet de se connecter aux bases de données, de choisir les tables et les champs, de déterminer les critères de sélection et de groupement, etc. Vous pouvez travailler simultanément avec plusieurs requêtes, modifier les requêtes, examiner les résultats d'exécution sous diverses formes et effectuer d'autres opérations nécessaires avec les requêtes vers les bases de données.

Pour lancer SQL Query, veuillez cliquer sur l'icône correspondante ou sur la légende correspondante qui se trouvent sur le panneau de travail.

Data Analysis - Running SQL Query

SQL Query documentation.

Voir aussi :

Analyse de données


Gestion de modèles

Pour votre commodité, SQL Management Studio for PostgreSQL vous offre la possibilité de créer des nouveaux modèles et de les gérer. Vous pouvez exécuter ces opérations en utilisant la section Gestion de modèles.

Template Management - Overview

Gérer les modèles existants

Créer un modèle


Gérer les modèles existants

La barre d'outils Modèles vous permet d'ajouter et de supprimer les modèles dans/depuis la liste, de créer de nouveaux modèles et de supprimer les modèles existants. Vous pouvez sélectionner et lancer un outil avec un modèle en un simple clic. Toutes ces opérations peuvent être effectuées par sélection des éléments correspondants à partir du menu contextuel.

La liste déroulante Outil ou service vous permet de trier les modèles par outil ou par service sélectionnés.

Template Management - Managing existing templates

Voir aussi :

Créer un modèle


Créer un modèle

Pour lancer cette opération, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton approprié de la barre d'outils Modèles. Suivant l'utilitaire ou le service pour lequel il faut créer un modèle, SQL Management Studio for PostgreSQL va lancer un outil ou un dialogue appropriés. Après avoir passé toutes les étapes de l'assistant correspondant, vous pouvez sauvegarder tous les réglages en tant que modèle.

Voir aussi :

Gérer les modèles existants


Planification et exécution des tâches

Vous trouverez ci-dessous toutes les possibilités de la section Planification & Exécution des Tâches fournies par SQL Management Studio for PostgreSQL :

Tâches utilisateur

Cette section vous fournit les possibilités de créer, d'éditer, de supprimer et d'exécuter immédiatement des tâches. Vous pouvez économiser votre temps à l'aide du groupement des tâches. Vous pouvez créer votre propre tâche en utilisant l'éditeur des tâches intégré. Puis, vous pouvez sélectionner une notification confirmant l'exécution de la tâche.

Planification des tâches

Vous avez besoin d'exécuter régulierement une tâche ou remettre l'exécution d'une tâche ? La section Planificateur de tâches vous permet de régler l'exécution des tâches adéquates.

Gestion des traces

Cette section vous permet de contrôler l'exécution des tâches et de visualiser les résultats de l'exécution. Vous pouvez utiliser l'aperçu des traces, un filtre puissant et les options de tri de la grille pour économiser du temps.

Vous pouvez appeler n'importe laquelle de ces sections en sélectionnant l'élément approprié dans la barre de navigation.


Tâches utilisateur

Cette section vous fournit la possibilité de créer, d'éditer, de supprimer et d'éxecuter immédiatement des tâches. Vous pouvez économiser votre temps à l'aide du groupement des tâches. Vous pouvez créer votre propre tâche en utilisant l'éditeur de tâches intégré. Puis, vous pouvez sélectionner une notification confirmant l'exécution de la tâche.

Pour en savoir plus, cliquez sur les liens suivants :

Gestion des tâches

Éditeur des tâches

Modifications des paramètres des notifications

Éditeur des étapes


Gestion des tâches

L'onglet Gestion des tâches vous permet de gérer vos tâches. Vous pouvez créer une nouvelle tâche ou supprimer une tâche existante à l'aide de l' élément correspondant du menu contextuel ou en cliquant sur le bouton approprié de la barre d'outils. Pour modifier une tâche existante dans l'éditeur des tâches, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton approprié de la barre d'outils.

Vous pouvez exécuter immédiatement une tâche créé ou remettre l'exécution d'une tâche à plus tard. Pour lancer immédiatement une tâche, sélectionnez-la et cliquez sur le bouton correspondant de la barre d'outils (vous pouvez aussi exécuter cette fonction en utilisant l'élément respectif du menu contextuel).

La barre d'état d'une tâche en cours se trouve au-dessous de la fenêtre Gestion des tâches. Elle affiche la liste des étapes pour une tâche actuelle, un outil nécessaire, les actions finales "Tâche réussie" ou "Erreur" et d'autres informations.

Note : vous pouvez afficher ou refermer la liste des étapes d'une tâche via le menu contextuel ou en utilisant les boutons correspondants de la barre d'outils.

Scheduling and Performing tasks - Managing task steps

Voir aussi :

Éditeur des tâches


Éditeur des tâches

La fenêtre Éditeur des tâches s'ouvre automatiquement lors de la création d'une nouvelle tâche ou lors de la modification d'une tâche existante.

Pour créer une nouvelle tâche, saisissez son nom. Puis précisez les étapes nécessaires pour votre tâche dans l'onglet Étapes (chaque tâche comprend plusieurs étapes exécutées à tour de rôle).

Pour créer une nouvelle étape ou supprimer une étape existante, utilisez les éléments correspondants du menu contextuel ou cliquez sur les boutons respectifs de la barre d'outils. Pour modifier une étape existante dans l'éditeur des étapes, choisissez l'élément correspondant du menu contextuel ou cliquez sur le bouton respectif dans la barre d'outils de l'éditeur des tâches.

En outre, vous pouvez modifier l'ordre d'exécution des étapes à l'aide des boutons "Déplacer en haut" et "Descendre" de la barre d'outils. Vous pouvez aussi exécuter cette fonction en utilisant l'élément respectif du menu contextuel de l'Éditeur des tâches.

Pour en savoir plus, cliquez sur Éditeur des étapes.

La barre d'état d'une étape en cours se trouve au-dessous de l'onglet Étapes. Elle affiche le chemin vers les fichiers exécutables, le nom du modèle utilisé, le chemin vers les traces, les actions finales "Tâche réussie" ou "Erreur" ainsi que d'autres informations.

Pour être informé des résultats de l'exécution d'une tâche, vous pouvez régler les notifications optionnelles (outre les journaux de SQL Management Studio for PostgreSQL, Visionner les journaux). Pour cela, réglez l'onglet Notifications dans l'éditeur des tâches.

En outre, vous pouvez écrire n'importe quel texte en tant que description de votre tâche. Saisissez vos commentaires dans l'onglet Description de l'Éditeur des tâches.

Scheduling and Performing tasks - Task Editor - Steps

Voir aussi :

Modification des paramètres des notifications

Éditeur des étapes


Modification des paramètres des notifications

Vous pouvez régler les notifications supplémentaires pour être informé de l'exécution réussie ou échouée d'une tâche. Pour cela, utilisez l'onglet Notifications de l'éditeur des tâches. Vous pouvez sélectionner entre les modes de notification suivants : la notification Net Send, le journal système des applications, la notification par e-mail.

Scheduling and Performing tasks - Task Editor - Notifications

La notification Net Send

La notification net send vous permet d'envoyer les messages via net send. Vous pouvez créer dans l'éditeur correspondant un message à envoyer à un ordinateur distant.

Note : afin d'utiliser ce type de notifications, vous devez lancer le service d'affichage des messages (Panneau de configuration | Outils d'administration | Services | Service d'affichage des messages).

Le journal système des applications

Il vous permet d'écrire des notifications directement dans le journal système. Créez dans l'éditeur correspondant un message à enregistrer dans le journal système.

Note : pour afficher le journal système des applications, il vous faut ouvrir Panneau de configuration | Outils d'administration | Observateur d'événements | Application.

E-mail

Cela vous permet d'obtenir des notifications par e-mail. Veuillez créer dans l'éditeur correspondant un message à envoyer par e-mail.

Vous devez aussi remplir tous les champs nécessaires : Hôte (adresse du serveur SMTP), Port (25 par défaut) et l'adresse de destination.

Note : vous pouvez aussi utiliser les noms macro (#START, #STOP, #RESULT) dans le texte des notifications. #START - heure de début d'exécution d'une tâche,#STOP - heure de fin d'exécution d'une tâche, #RESULT - rapports sur les résultats de l'exécution d'une tâche.

Deux options d'envoi de notifications sont disponibles : "En cas de succès" et "En cas d'erreur". Le bouton Test vous permet d'envoyer le message de test immédiatement.

Voir aussi :

Éditeur des tâches


Éditeur des étapes

La fenêtre de l'éditeur des tâches s'ouvre automatiquement lors de la création d'une nouvelle tâche ou lors de la modification d'une tâche existante.

Pour créer une nouvelle tâche, commencez par saisir son nom dans le champ Nom de l'étape.

Scheduling and Performing tasks - Task Editor - Step Editor

Options de l'outil

Sélectionnez l'outil, indiquez le chemin vers l'outil, réglez un modèle optionnel et sélectionnez l'emplacement du journal dans les cases correspondantes.

Options des journaux

Vous pouvez spécifier ici les moyens de formation du journal de SQL Management Studio for PostgreSQL.

L'option Enregistrer l'écran dans un journal permet d'enregistrer les données affichées sur l'écran de l'utilitaire dans le journal de SQL Management Studio for PostgreSQL.

L'option Obtenir les traces depuis un fichier permet d'enregistrer le journal de l'utilitaire dans le journal de SQL Management Studio for PostgreSQL.

Actions finales

Réglez les actions qui succèdent à l'exécution réussie ou échouée d'une tâche. Vous pouvez procéder à l'étape suivante ou à l'étape sélectionnée, terminer l'exécution d'une tâche en affichant le rapport sur le résultat de l'exécution ("Réussie" ou "Erreur").

L'éditeur des étapes vous permet de régler le délai d'attente. Vous pouvez régler le temps nécessaire pour le délai d'attente et l'action qui succède à l'expiration du délai d'attente. Vous pouvez exécuter toutes ces actions en utilisant les cases appropriées de l'éditeur des étapes.

Traitement des erreurs

L'option Échec en cas d'erreurs graves seulement permet d'afficher le message qu'une tâche a été terminée avec succès même si des erreurs sans gravité ont eu lieu lors de l'exécution (par exemple quand le script extract a été exécuté avec des erreurs).

L'option Limite de la taille du journal, Ko permet de limiter la taille du journal pour l'étape actuelle.

Voir aussi :

Éditeur des tâches


Planification des tâches

Vous avez besoin d'exécuter régulièrement une tâche planifiée ou de remettre l'exécution d'une tâche à plus tard ? La section Planification des tâches vous permet de régler le lancement des tâches conformément à vos besoins.

Scheduling and Performing tasks - Managing scheduled tasks

Voir aussi :

Planificateur de tâches

Éditeur des tâches planifiées


Planificateur de tâches

La section Planification des tâches vous permet de planifier vos tâches. Vous pouvez planifier une nouvelle tâche ou supprimer une tâche existante à l'aide des éléments correspondants du menu contextuel ou en cliquant sur le bouton approprié de la barre d'outils. Pour modifier une tâche en cours dans l'éditeur des tâches planifiées, sélectionnez l'élément correspondant du menu contextuel ou cliquez sur le bouton de la barre d'outils du planificateur de tâches.

Vous pouvez accéder à l'information générale sur la tâche sélectionnée sur le panneau spécial qui se trouve au-dessous de la section Planification des tâches.

Afin de suspendre une tâche planifiée, vous devez sélectionner cette tâche dans la liste des tâches et cliquer sur le bouton Suspendre la tâche planifiée de la barre d'outils (cette fonction est aussi disponible dans le menu contextuel). Afin de lancer de nouveau une tâche, cliquez sur le bouton approprié de la barre d'outils ou utilisez l'élément correspondant du menu contextuel.

Note : SQL Management Studio for PostgreSQL Agent permet de suspendre/lancer l'exécution des tâches. Cliquez avec le bouton droit de la souris sur l'icône Studio Agent qui se trouve sur la zone de notification Windows, sélectionnez le sous-menu Suspendre la tâche et cochez la tâche requise. Décochez les tâches pour les exécuter de nouveau.

Scheduling and Performing tasks - Task Scheduler

Voir aussi :

Éditeur des tâches planifiées


Éditeur des tâches planifiées

L'éditeur des tâches planifiées s'ouvre automatiquement quand vous ajoutez une nouvelle tâche planifiée ou modifiez une tâche existante.

Pour relancer l'exécution d'une tâche, il vous faut sélectionner une tâche à planifier (sélectionnez une tâche depuis la liste des tâches dans le champ Nom de la tâche).

Scheduling and Performing tasks - Schedule Editor - Daily

Puis définissez un modèle de récurrence. L'éditeur des tâches planifiées vous permet d'exécuter une tâche chaque jour, semaine, mois ou année.

Chaque jour

Vous pouvez programmer le lancement d'une tâche : Tous les N jours ou les Jours de semaine (tous les jours sauf weekend).

Chaque semaine

Ce modèle de récurrence vous permet de planifier une tâche pour qu'elle soit exécutée certains jours (que vous définissez) pour chaque semaine (lundi, mardi, jeudi etc. - il vous faut cocher les jours correspondants).

Scheduling and Performing tasks - Schedule Editor - Weekly

Par exemple, si vous sélectionnez "Toutes les 3 semaines le mardi", la tâche sera exécutée tous les mardi une fois toutes les trois semaines.

Chaque mois

Vous pouvez planifier une tâche pour qu'elle soit exécutée à certaines dates de chaque X mois; ou d'une autre façon - à certains jours de semaine de chaque X mois.

Scheduling and Performing tasks - Schedule Editor - Monthly

Chaque année

Vous pouvez aussi fixer une date précise de l'exécution d'une tâche (par exemple le 14 juin) ou fixer une date en utilisant le modèle Chaque premier/deuxieme/... /jour de semaine de certains mois (par exemple Chaque deuxième mardi du mois d'avril).

Scheduling and Performing tasks - Schedule Editor - Yearly

Limite de récurrence

Ce groupe de l'éditeur des tâches planifiées vous permet de spécifier la date de début et de fin de la période d'exécution d'une tâche. Pour cela, il vous faut régler la Date et l'Heure de début, puis spécifier la date limite de fin de la période de lancement.

Sans fin signifie que la tâche peut être exécutée indéfiniment.

Finir après X signifie que la période de lancement sera finie après X fois l'exécution de cette tâche.

Finir avant... spécifie la date précise de fin de la période de l'exécution.

Voir aussi :

Planificateur de tâches


Gestion des traces

La section Gestion des traces vous permet de contrôler le processus de l'exécution des tâches et de visualiser le résultat de l'exécution de telle ou telle tâche. Vous pouvez économiser votre temps en utilisant l'aperçu des traces, vous pouvez aussi appliquer un filtre puissant et utiliser les options de tri de la grille.

Scheduling and Performing tasks - Managing logs

La barre d'outils Traces vous permet d'enregistrer les traces des tâches sélectionnés dans un fichier et supprimer les traces inutiles en utilisant le bouton correspondant. Vous pouvez aussi exécuter ces opérations en utilisant les éléments respectifs du menu contextuel.

Note : vous pouvez déployer ou refermer rapidement l'arbre des traces en utilisant le menu contextuel ou les boutons correspondants de la barre d'outils Logs.

La barre d'état d'un journal de traces en cours se trouve au-dessous de l'onglet Traces. Suivant les options sélectionnées pour les traces, elle affiche les données de l'écran de travail de l'utilitaire/service, les données du journal des traces de l'utilitaire/service, ou l'un et l'autre. Vous pouvez régler les options des traces lors de la création de l'étape (voir Éditeur des étapes).

La liste déroulante Afficher les traces pour la période vous permet de trier les traces des tâches par période sélectionnée.

Voir aussi :

Planification des tâches

Tâches utilisateur


Ressources en ligne

Voici les ressources en ligne de SQL Management Studio for PostgreSQL fournies par cette section :

Ressources Internet

Vous trouvez ici les liens concernants SQL Studio et les utilitaires intégrés, les liens vers les FAQ et la documentation en ligne.

SQL Studio Direct

Cette section vous emmène directement vers la section comprenant les dernières nouvelles d'EMS. Vous y trouvez aussi les liens vers les dernières nouvelles de SQLManager.net, vers les descriptions des produits et les pages de téléchargement.

Support

Cette section vous renvoie directement vers le centre de support EMS (EMS Support Center). Veuillez vous identifier et poser toutes les questions nécessaires. Si vous êtes un utilisateur enregistré du logiciel EMS, vous recevrez une réponse garantie dans les 24 heures.

Vous pouvez naviguer entre ces sections en utilisant les éléments appropriés de la barre de navigation.


Ressources Internet

Vous trouvez ici les liens concernants SQL Studio et les utilitaires intégrés, les liens vers les FAQ et la documentation en ligne.

Cliquez sur le lien qui vous intéresse.

Online Resources - Browsing Internet Resources


SQL Studio Direct

Cette section vous emmène directement vers la section comprenant les dernières nouvelles d'EMS. Vous y trouvez aussi les liens vers les dernières nouvelles de SQLManager.net, vers les descriptions des produits et les pages de téléchargement.

Online Resources - SQL Studio Direct


Support

Cette section vous renvoie directement vers le centre de support EMS (EMS Support Center) avec le navigateur incorporé. Veuillez vous identifier et poser toutes les questions nécessaires directement dans la fenêtre de SQL Management Studio for PostgreSQL.

Note : si vous êtes un utilisateur enregistré du logiciel EMS, vous recevrez une réponse garantie dans les 24 heures.

Online Resources - Support Center


Personnaliser les réglages

Vous pouvez personnaliser SQL Management Studio for PostgreSQL en utilisant cette section. Cliquez sur les liens ci-dessous afin d'obtenir les informations nécessaires.

Sélection de la langue

Personnaliser l'interface

Personnaliser les barres d'outils

Réglages de Studio Agent


Sélection de la langue

Si vous n'avez pas sélectionné la langue du programme lors du démarrage de SQL Management Studio for PostgreSQL ou si vous avez décidé de changer la langue, utilisez l'élément Options | Localisation du menu principal. Dans la fenêtre de dialogue qui apparaît, vous accédez à la liste des traductions disponibles. Sélectionnez la langue du programme et cliquez sur le bouton OK.

Options - Localization

Voir aussi :

Personnaliser les réglages


Personnaliser l'intreface

Pour votre commodité, vous pouvez modifier l'apparence et le style de l'environnement de SQL Management Studio for PostgreSQL. Pour personnaliser l'interface du programme, sélectionnez l'élément Options | Interface du menu principal.

Note : vous pouvez appliquer l'interface de SQL Management Studio for PostgreSQL à toutes ces applications en utilisant l'option correspondante.

Options - Interface

Voir aussi :

Personnaliser les réglages


Personnaliser les barres d'outils

Afin de rendre votre travail avec SQL Management Studio for PostgreSQL le plus efficace possible, vous pouvez personnaliser les barres d'outils conformément à vos besoins. Cliquez avec le bouton droit de la souris sur la barre d'outils principale ou sur la barre d'outils de l'explorateur de bases et sélectionnez Personnaliser...

Dans la fenêtre de dialogue qui apparait vous pouvez créer et supprimer les barres d'outils (l'onglet Barres d'outils), supprimer ou ajouter les boutons (l'onglet Commands) et changer certains réglages visuels et fonctionnels de la barre d'outils (l'onglet Options).

Pour ajouter un bouton dans la barre d'outils, il vous faut ouvrir le dialogue Personnaliser les barres d'outils et sélectionnez l'onglet Commandes. Puis sélectionnez une commande dont vous avez besoin et déplacez-la sur la barre d'outils. Par exemple, sur la barre d'outils principale, la barre d'outils de l'explorateur de bases ou une barre que vous avez créé vous-même. Afin de supprimer le bouton, il vous faut le glisser depuis la barre d'outils.

Note : n'importe quelle barre d'outils peut être déplacée et fixée dans la fenêtre de travail de SQL Management Studio for PostgreSQL à votre discrétion.

Options - Customizing menus and toolbars

Voir aussi :

Personnaliser les réglages


Réglages de Studio Agent

Si vous voulez que Studio Agent soit exécuté automatiquement lors du démarrage de Windows, cliquez avec le bouton droit de la souris sur l'icône Windows dans la zone de notifications et sélectionnez l'élément correspondant du menu contextuel.

Options - Setting agent options

Voir aussi :

Personnaliser les réglages


Modèles

SQL Management Studio for PostgreSQL dispose de la possibilité de sauvegarder la suite des opérations et les paramètres dans les fichiers spéciaux qu'on appelle "modèles". Les modèles sont utilisés dans les assistants, par exemple dans l'assistant d'export de données ou dans l'assistant d'import de données.

S'il y a le bouton Template dans le coin inférieur gauche de l'assistant, tous les paramètres indiqués à l'aide de l'assistant peuvent être sauvegardés dans un fichier de format correspondant. Le format spécial du modèle est prévu pour chaque assistant. Ceci permet d'éviter des erreurs lors de l'ouverture du modèle dans un autre assistant.

Cliquez sur le bouton Template pour ouvrir la liste des opérations.

Vous pouvez exécuter les opérations suivantes en utilisant cette liste :

  • 'Charger le modèle' (Load Template),
  • 'Sauvegarder le modèle' (Save Template),
  • 'Sauvegarder le paramétrage actuel comme défaut' (Save Current Settings As Default),
  • 'Réinitialiser les paramètres sauvegardés' (Reset Saved settings).

Vous pouvez sauvegarder et charger le modèle lors de n'importe quel étape de l'assistant.


Supported file formats

MS Excel

Format le plus populaire e-table utilisé par Microsoft® Excel (*.xls). Les fichiers de résultat sont entièrement compatibles avec Microsoft® Excel versions 97-2000, 2003 et XP.

MS Access

Fichiers de format (*.mdb) Microsoft® Access avec l’utilisation de connexion ADO.

MS Word

Un des formats les plus populaires de traitement de texte utilisé par Microsoft® Word (*.doc). Les fichiers de résultat sont entièrement compatibles avec Microsoft® Word versions 97-2000, 2003 et XP.

RTF

Format Rich Text (*.rtf) compatible avec la plupart des programmes de traitement de texte (ex. WordPad).

HTML

Format de fichier Hyper Text Markup Language (*.html, *.htm), la compatibilité complète avec la spécification HTML 4.0.

PDF

Format standard des publications électroniques (*.pdf).

Text file

Format de fichier texte brut (*.txt).

CSV file

Format de fichier de valeurs séparées par une virgule (*.csv).

DIF file

Format Data Interchange File (*.dif).

SYLK

Format de fichier Symbolic Links (*.slk).

Note : tous les formats texte y compris Text file, CSV, DIF, SYLK utilisés généralement pour le travail d’échange entre les formats.

LaTeX

Format de fichier spécifique (*.tex) qui est une macroextention populaire (surtout parmi les mathématiciens et physiciens) du paquet TeX développé par D.Knut.

XML

Language Markup pour les documents contenants les informations structurées (*.xml).

DBF

Format de fichier de base de données (*.dbf) utilisé par dBASE et plusieurs applications xBASE.

MS Excel 2007

Format e-table contemporain utilisé par Microsoft® Excel 2007 (*.xlsx). Les fichiers de résultat sont entièrement compatibles avec Microsoft® Excel 2007.

MS Word 2007

Format contemporain de traitement de texte utilisé par Microsoft® Word 2007 (*.docx). Les fichiers de résultat sont entièrement compatibles avec Microsoft® Word 2007.

ODF Spreadsheets

Format OASIS Open Document pour Office Applications - format de fichier ‘open document’ pour les feuilles de calcul (*.ods) utilisé par plusieurs applications comprenant OpenOffice.org et KOffice.

ODF text

Format OASIS Open Document pour les applications Office - le format de fichier ‘open document’ pour le traitement des documents word (*.odt) utilisé par plusieurs applications comprenant OpenOffice.org et KOffice.