Добро пожаловать в EMS DB Comparer for Oracle!

DB Comparer for Oracle – это удобная программа для сравнения и синхронизации баз данных Oracle. Она позволяет просмотреть все различия в объектах сравниваемых баз данных и выполнить автоматически созданный сценарий SQL для синхронизации структуры баз данных Oracle и устранения всех или выбранных отличий. Программа предоставляет возможность автоматизировать процесс синхронизации и сравнения баз данных Oracle с помощью консольного приложения. Используя EMS DB Comparer for Oracle, можно работать с несколькими проектами одновременно, задавать параметры сравнения баз данных Oracle, печатать отчеты о сравнении и изменять сценарии модификации. Интуитивно понятный интерфейс значительно упрощает поиск и устранение различий в структуре баз данных Oracle, сохраняя ваше время, а значит, ваши деньги.

Наш сайт: https://www.sqlmanager.ru

Ключевые особенности

  • Сравнение и синхронизация баз данных или схем, расположенных на разных серверах или на одном.
  • Сравнение всех или выбранных объектов баз данных. Сравнение по всем свойствам объектов или только по выбранным.
  • Визуальное представление различий баз данных вместе со скриптами модификации для отличающихся объектов.
  • Возможность синхронизации баз данных вручную или автоматически.
  • Создание отчетов, отражающих отличия между базами данных. Возможность добавления пользовательских отчетов.
  • Возможность автоматизации процесса сравнения и синхронизации баз данных с помощью консольной утилиты.
  • Работа с несколькими проектами сравнения одновременно.
  • Сохранение и загрузка всех параметров проектов сравнения.
  • Множество параметров для настройки сравнения и синхронизации.
  • Встроенный редактор сценариев SQL с подсветкой синтаксиса.
  • Новый современный графический интерфейс пользователя с поддержкой темной схемы.
  • Поддержка новейших версий Oracle.

Информация по продукту

Домашняя страница: | https://www.sqlmanager.ru/products/oracle/dbcomparer
Служба поддержки: | https://www.sqlmanager.ru/support
Регистрация: | https://www.sqlmanager.ru/products/oracle/dbcomparer/buy


Новости

Версия | Дата выпуска
DB Comparer for Oracle 5.1 | 10.07.2024

Что нового в DB Comparer?

  • Добавлена 64-битныа версия утилиты.
  • В студийной версии утилит в некоторых случаях отображались не все зарегистрированные базы. Исправлено.
  • Улучшена работа фильтра объектов.
  • При перезаписи файла скрипта консольной версией приложения сохраняется копия предыдущего файла.
  • В последовательностях различие параметра START WITH теперь синхронизируется через пересоздание.
  • Теперь в настройках SSH по умолчанию используется порт 22.

Смотрите также:

История версий


Системные требования

  • Microsoft Windows XP, Microsoft Windows Server 2003, Microsoft Windows Server 2008, Microsoft Windows Server 2008 R2, Microsoft Windows Server 2012, Microsoft Windows Server 2012 R2, Microsoft Windows Server 2016, Microsoft Windows Server 2019, Microsoft Windows Vista, Microsoft Windows 7, Microsoft Windows 8/8.1, Microsoft Windows 10, Microsoft Windows 11, Microsoft Windows 11 ARM
  • 512 Mб RAM и более
  • 50 Мб свободного пространства на жестком диске для установки программы
  • Клиент для Oracle Database 8.1.7 или выше (его разрядность должна соответствовать разрядности программы)
  • Возможность соединения с локальным или удаленным сервером Oracle
  • Поддерживаемые версии сервера Oracle: с 8.1.7 по 21c


Установка

Установка программы DB Comparer for Oracle

  • загрузите установочный файл DB Comparer for Oracle программы со страницы загрузки;
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped);
  • откройте файл OraComparerSetup.exe и следуйте инструкциям мастера установки;
  • после завершения процесса установки найдите ярлыки программы в Пуск->Программы->EMS.

Обновление программы

  • загрузите установочный файл DB Comparer for Oracle программы со страницы загрузки;
  • разархивируйте полученный файл в нужную директорию (например, c:\unzipped);
  • закройте программу DB Comparer for Oracle, если она запущена;
  • запустите файл OraComparerSetup.exe и следуйте инструкциям мастера обновления.

Часто задаваемые вопросы по установке ПО

Смотрите также:

Системные требования


Приобретение

Для приобретения наших продуктов на территории Российской Федерации вы можете использовать форму он-лайн оплаты платежной картой либо запросить счёт для безналичной оплаты путем банковского перевода.

Выбор типа лицензии, количества лет Сопровождения и способа оплаты происходит на странице покупки продукта.

Пожалуйста, учтите, что все наши программные продукты доставляются только электронными средствами (Electronic Software Delivery).

После приобретения мы отправим вам регистрационный ключ электронной почтой. Регистрационная информация будет так же доступна зарегистрированным пользователям на нашем сайте.

Программа EMS по Сопровождению ПО - это выгодная для клиента комплексная программа, включающая в себя техническую поддержку, обновления ПО и много других преимуществ. Имея действующую подписку на Сопровождение ПО, Вы автоматически получаете последние версии программ EMS сразу после их выпуска без дополнительных затрат. Это позволит Вам и Вашей компании идти в ногу с новейшими разработками в области программного обеспечения, пользоваться улучшенными версиями программ и проще отслеживать имеющиеся у Вас лицензии на ПО.

Как участник Программы EMS по Сопровождению ПО, Вы имеете право получать:

  • Техническую поддержку опытных специалистов
  • Консультации по вопросам работы ПО
  • Бесплатные обновления и релизы с улучшениями ПО в течение подписки на Сопровождение ПО
  • Доступ к персональной учетной записи клиента EMS
  • Возобновление подписки на Сопровождение ПО в режиме онлайн
  • Эксклюзивные заблаговременные уведомления о специальных предложениях
  • Эксклюзивные предложения ТОЛЬКО для владельцев подписки на Сопровождение ПО.

Подробнее об услуге сопровождения читайте на странице https://www.sqlmanager.ru/support/faq#maintenance.

Если у вас остались вопросы - вы можете найти ответы на них в разделе FAQ или обратиться в службу поддержки по адресу sales@sqlmanager.ru.


Регистрация

Если Вы не зарегистрировали свою копию программы DB Comparer for Oracle, то можно сделать это, нажав кнопку Register Now в окне, открывающемся при выборе пункта главного меню программы Help | About, или с помощью пункта Help | Register DB Comparer.

Welcome to DB Comparer - About

Чтобы зарегистрировать только что приобретенную копию программы необходимо выполнить следующие действия:

  • получить уведомительное письмо с регистрационной информацией от Softkey!
  • ввести Registration Name и Registration Key из этого письма.
  • убедиться, что регистрация прошла успешно. Для этого необходимо открыть окно About DB Comparer for Oracle, выбрав пункт главного меню Help | About. В этом окне должны отображаться введенные вами Registration Name и Registration Key.

После введения правильного регистрационного ключа появляется информационное окно, сообщающее о том, что Вы теперь имеете право пользоваться программой.

Welcome to DB Comparer - Register

Смотрите также:

Регистрация

Лицензионное соглашение


История версий

Продукт | Версия | Дата выхода
DB Comparer for Oracle | Версия 5.0.2 | 06.09.2023
DB Comparer for Oracle | Версия 5.0.1 | 16.12.2022
DB Comparer for Oracle | Версия 5.0 | 16.02.2022
DB Comparer for Oracle | Версия 4.1.1 | 04.04.2019
DB Comparer for Oracle | Версия 4.1 | 18.02.2018
DB Comparer for Oracle | Версия 4.0 | 01.04.2016
DB Comparer for Oracle | Версия 3.3.2.2 | 07.10.2009
DB Comparer for Oracle | Версия 3.2.0.1 | 13.10.2008
DB Comparer 2007 for Oracle | Версия 3.1.0.1 | 10.04.2008
DB Comparer 2007 for Oracle | Версия 3.0.0.1 | 17.09.2007
DB Comparer 2005 for Oracle | Версия 2.2.0.1 | 28.08.2006
DB Comparer 2005 for Oracle | Версия 2.1.0.1 | 17.04.2006
DB Comparer 2005 for Oracle | Версия 2.0.0.1 | 09.03.2006
Oracle DB Comparer | Версия 1.3.0.1 | 08.03.2005
Oracle DB Comparer | Версия 1.2.0.1 | 11.02.2004
Oracle DB Comparer | Версия 1.1.0.1 | 10.11.2003
Oracle DB Comparer | Версия 1.0.0.1 | 14.05.2003

Версия 5.0.2

  • В консольном приложении добавлена возможность сравнения переименованных объектов.
  • Улучшена работа фильтра для объектов сравнения.
  • Добавлена возможность создания файла типа BAT или PS1 при сохранении шаблона.
  • Исправлены проблемы связанные с масштабированием окон приложения.
  • При переходе на шаг подключения не всегда выдавался запрос пассфразы для SSH. Исправлено.

Версия 5.0.1

  • Поддержка запуска на Windows 11 ARM.
  • Исправлена ошибка при сравнении таблиц сервера Oracle 21c.
  • Исправлено отображение значения по умолчанию для полей типа DATE, TIMESTAMP.
  • Исправлены ошибки в генерации скрипта изменений таблиц и триггеров.
  • Небольшие исправления, связанные с темной темой оформления.
  • Исправления в печатных формах отчетов.
  • В некоторых случаях сбрасывалась настройка "Load last password for new projects". Исправлено.
  • Другие небольшие исправления и улучшения.

Версия 5.0

  • Добавлена поддержка темной схемы в интерфейсе.

whats new - dark schema ORA

  • Улучшена работа фильтра объектов сравнения.
  • Добавлена поддержка Юникодных имен баз данных.
  • Теперь в шаблон корректно сохраняются объекты, выбранные для исключения из сравнения.
  • Добавлена поддержка ключей Ed25519 для подключения через SSH.
  • Множество других исправлений и улучшений.

Версия 4.1.1

  • Улучшен просмотр таблиц с большим числом строк в DDL.
  • Исправлена смена шрифта редактора после изменения настроек.
  • Добавлены пункты меню для отображения\скрытия окон DDL объекта.
  • Теперь сохраняется размер окна "Script error" в редакторе скрипта.
  • Исправлена ошибка, возникавшая при закрытии программы при открытом окне справки.
  • При сбросе настроек на значения по умолчанию теперь восстанавливается путь до каталога с файлами локализации.
  • Другие небольшие исправления.

Версия 4.1

  • Добавлены кнопки для удобного перехода между строками, содержащими различия.
  • Мелкие исправления в редакторе SQL.
  • Настройки редактора теперь применяются сразу.
  • Исправлена ошибка "List index out of bounds" при отображении дерева сравнения.
  • Другие мелкие исправления и улучшения.

Версия 4.0

  • Значительно улучшена работа с зависимостями объектов. Реализована обработка циклических зависимостей.
  • Теперь возможен поиск и анализ переименованных объектов. Приложение анализирует базы данных и выдает список объектов, которые могли быть переименованы.
  • Значительно улучшен алгоритм сравнения объектов и генерирования скриптов.
  • Добавлен мастер для работы с проектами.
  • Расширен список сравниваемых свойств объектов, что позволяет сделать анализ баз данных более полным.
  • Добавлена поддержка объектов: Sys Privilege, Role, User Tablespace Quota.
  • Добавлены сравнения привилегий пользователей и прав на объекты
  • Добавлена поддержка новых возможностей Windows: индикатор выполнения процесса в панели задач и список
  • Добавлены параметры командной строки в консольной версии.
  • Исправления и улучшения интерфейса.
  • Прочие улучшения и дополнения.

Версия 3.3.2.2

  • Теперь возможно подключаться к базам данных, отсутствующим в файле TNS.
  • Использование опции "Load last password for new projects" иногда приводило к неверной подстановке паролей. Исправлено.
  • Прочие улучшения и исправления.

Версия 3.2

  • Добавлена возможность сравнения поврежденных объектов.
  • Скорость сравнения баз данных значительно увеличена.
  • Другие улучшения и исправления.

Версия 3.1

  • Улучшен Дизайнер отчетов.
  • Доступны 3 встроенных шаблона отчетов: "Summary info", "Summary info with Chart", "Detailed info".
  • Улучшение процесса создания скриптов модификации ряда объектов (Operators, Profiles, Users ident type, Arguments в Wrapped procedures, Index types, Object type bodies, Resource plans и Object tables).
  • Добавлены новые опции сравнения для следующих объектов: Clusters, Package bodies, Procedures, Functions, Users, Views и Materialized Views.
  • В редких случаях при обновлении баз данных возникала ошибка ‘Base class of "AObject" must be…'. Исправлено.
  • Исправлены некоторые ошибки возникавшие при сравнении "schema-vs-schema".
  • Другие улучшения и исправления.

Версия 3.0

  • Возможность сравнения баз данных или схем, расположенных на различных серверах.
  • Доступно сравнение как всех баз данных, так и только выбранных. Сравнение по всем или только по выбранным свойствам объектов.
  • Подробное визуальное представление различий между базами данных и скрипты синхронизации для различных объектов.
  • Возможность синхронизации баз данных вручную или автоматически.
  • Возможность генерации отчетов об отличиях баз данных. Возможность создания собственных отчетов.
  • Доступна автоматизация сравнения и синхронизации баз данных с помощью консольного приложения.
  • Работа с несколькими проектами одновременно.
  • Сохранение и открытие проектов, включая все настройки.
  • Разнообразие настроек сравнения и синхронизации.
  • Встроенный редактор SQL Script с подсветкой синтаксиса.
  • Новый графический интерфейс.
  • Поддержка последних версий сервера.

Наверх

Смотрите также:

Новости


Сопутствующие продукты

MySQL

Microsoft SQL Server

PostgreSQL

InterBase / FireBird

Oracle

IBM DB2

Tools & components

MySQL

 | SQL Management Studio for MySQL EMS SQL Management Studio for MySQL это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for MySQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for MySQL EMS SQL Manager for MySQL – это мощный графический инструмент для разработки и администрирования серверов баз данных MySQL. Простой и удобный графический интерфейс позволяет быстро и просто создавать и редактировать объекты баз данных MySQL, визуально проектировать сами базы данных, выполнять сценарии MySQL и использовать другие службы, которые сделают Вашу работу с MySQL приятной и легкой.
dataexport | Data Export for MySQL EMS Data Export for MySQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных MySQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for MySQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for MySQL EMS Data Import for MySQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных MySQL.
datapump | Data Pump for MySQL EMS Data Pump™ for MySQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных MySQL®. Теперь перенос данных при помощи Data Pump for MySQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for MySQL EMS Data Generator for MySQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных MySQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом
dbcomparer | DB Comparer for MySQL EMS DB Comparer™ for MySQL – это мощное приложение, предназначенное для сравнения баз данных MySQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for MySQL EMS DB Extract™ for MySQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for MySQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for MySQL EMS SQL Query for MySQL - это утилита для быстрого и простого построения SQL запросов к базам данных MySQL®. Используйте визуальное построение запросов вкупе с непосредственным редактированием текста запросов. Простой и удобный графический интерфейс позволяет соединяться с базами данных, выбирать таблицы и поля запроса, устанавливать критерии отбора и группировки и многое другое.
datacomparer | Data Comparer for MySQL EMS Data Comparer™ for MySQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for MySQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Microsoft SQL Server

 | SQL Management Studio for SQL Server SQL Management Studio - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for SQL Server объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for SQL Server EMS SQL Backup for SQL Server - это простой в использовании и одновременно мощный инструмент для выполнения задач резервного копирования и восстановления на всем множестве SQL серверов Вашего предприятия. EMS SQL Backup может выполнять и другие задачи по регулярному обслуживанию SQL сервера, такие как обновление статистики, реиндексация, усечение БД, проверка целостности БД и др.
sqladmin | SQL Administrator for SQL Server EMS SQL Administrator for SQL Server - это набор инструментов для эффективного администрирования SQL Server. Продукт содержит почти полный набор средств, необходимых для администрирования SQL Server. Программа предназначена для работы администраторов баз данных и позволяет выполнять задачи по администрированию максимально просто, быстро и эффективно.
 | SQL Manager for SQL Server EMS SQL Manager for SQL Server – это мощный инструмент для разработки и администрирования Microsoft SQL Server и MSDE. При помощи EMS SQL Manager for SQL Server Вы можете быстро и очень просто создавать и редактировать объекты баз данных, запускать сценарии SQL, управлять настройками пользователей, создавать визуальные SQL-запросы, а также эффективно работать с метаданными и выполнять многое другое.
dataexport | Data Export for SQL Server EMS Data Export for SQL Server – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Microsoft SQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for SQL Server располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for SQL Server EMS Data Import for SQL Server - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных SQL Server.
datapump | Data Pump for SQL Server EMS Data Pump™ for SQL Server – это мощное приложение для переноса баз данных и импортирования таблиц из любых ADO-совместимых источников (например, MS Access или любая другая ADO-совместимая база данных) в базы данных Microsoft™ SQL. Теперь перенос данных при помощи Data Pump for SQL Server стал настолько прост, насколько это возможно!
datagenerator | Data Generator for SQL Server EMS Data Generator™ for SQL Server – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for SQL Server EMS DB Comparer™ for SQL Server – это мощное приложение, предназначенное для сравнения баз данных Microsoft® SQL, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for SQL Server EMS DB Extract™ for SQL Server – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract™ for SQL Server позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for SQL Server EMS SQL Query™ for SQL Server – это специализированная утилита для простого и быстрого создания запросов к базам данных Microsoft® SQL. SQL Query™ for SQL Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for SQL Server EMS Data Comparer™ for SQL Server – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for SQL Server Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматически сравниваемый сценарий для их устранения.
 | Наверх

PostgreSQL

 | SQL Management Studio for PostgreSQL EMS SQL Management Studio for PostgreSQL - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for PostgreSQL объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | EMS SQL Backup for PostgreSQL EMS SQL Backup for PostgreSQL — это простой в использовании визуальный инструмент для создания резервных копий для нескольких серверов PostgreSQL из единой консоли. Вы можете создавать автоматизированные задачи резервного копирования на основе расписаний и хранить их в локальных или удаленных папках или облачных хранилищах.
 | SQL Manager for PostgreSQL EMS PostgreSQL Manager™ – это мощный графический инструмент для разработки и администрирования серверов баз данных PostgreSQL. PostgreSQL Manager позволяет быстро и легко создавать и редактировать объекты баз данных PostgreSQL, выполнять сценарии SQL, визуально проектировать базы данных, создавать запросы SQL, искать, извлекать и распечатывать метаданные, а также многое другое.
dataexport | Data Export for PostgreSQL EMS Data Export for PostgreSQL – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных PostgreSQL в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for PostgreSQL располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for PostgreSQL EMS Data Import for PostgreSQL - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных PostgreSQL.
datapump | Data Pump for PostgreSQL EMS Data Pump™ for PostgreSQL – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных PostgreSQL®. Теперь перенос данных при помощи Data Pump for PostgreSQL стал настолько прост, насколько это возможно!
datagenerator | Data Generator for PostgreSQL EMS Data Generator™ for PostgreSQL – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных Microsoft® SQL. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for PostgreSQL EMS DB Comparer™ for PostgreSQL – это мощное приложение, предназначенное для сравнения баз данных PostgreSQL®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for PostgreSQL EMS DB Extract™ for PostgreSQL – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for PostgreSQL позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for PostgreSQL EMS SQL Query™ for PostgreSQL – это специализированная утилита для простого и быстрого создания запросов к базам данных PostgreSQL®. SQL Query for PostgreSQL позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for PostgreSQL EMS Data Comparer™ for PostgreSQL – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for PostgreSQL Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

InterBase / Firebird

 | SQL Management Studio for InterBase/Firebird EMS SQL Management Studio for InterBase and Firebird это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for InterBase/Firebird EMS SQL Manager™ for InterBase/Firebird – это мощный графический инструмент для разработки и администрирования серверов баз данных InterBase/Firebird®. Простой и понятный интерфейс упрощает работу с объектами базы данных, позволяет управлять данными, создавать запросы SQL. Богатый инструментарий пакета включает в себя такие приложения как Visual Database Designer, Stored Procedure Debugger, Graphical Plan Analyzer. А Export Data и Import Data позволяют быстро выполнять функции импорта/экспорта в большинство популярных офисных форматов.
dataexport | Data Export for InterBase/Firebird EMS Data Export for InterBase/Firebird – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Interbase/Firebird в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for InterBase/Firebird располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for InterBase/Firebird EMS Data Import for InterBase/Firebird - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных InterBase/Firebird.
datapump | Data Pump for InterBase/Firebird EMS Data Pump™ for InterBase/Firebird – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных InterBase/Firebird®. Теперь перенос данных при помощи Data Pump for InterBase/Firebird стал настолько прост, насколько это возможно!
datagenerator | Data Generator for InterBase/Firebird EMS Data Generator™ for InterBase/Firebird – это мощная утилита для мгновенной генерации тестовых данных для различных таблиц баз данных InterBase/Firebird ®. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for InterBase/Firebird EMS DB Comparer™ for InterBase/Firebird – это мощное приложение, предназначенное для сравнения баз данных InterBase/Firebird®, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий. Полностью настраиваемые параметры сравнения баз данных и другие полезные функции сделают Вашу работу с нашим продуктом максимально комфортной.
extract | DB Extract for InterBase/Firebird EMS DB Extract for InterBase/Firebird – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for InterBase/Firebird позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for InterBase/Firebird EMS SQL Query for InterBase/Firebird™ – это специализированная утилита для простого и быстрого создания запросов к базам данных InterBase/Firebird®. SQL Query for InterBase/Firebird позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for InterBase/Firebird EMS Data Comparer™ for InterBase/Firebird – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer™ for InterBase/Firebird Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

Oracle

 | SQL Management Studio for Oracle EMS SQL Management Studio for Oracle - это комплексное решение для администрирования и разработки баз данных. С компонентами, которые предназначены для решения важнейших задач управления базами данных, SQL Studio обеспечит вас незаменимыми инструментами для администрирования баз данных и управления их объектами, осуществления миграции, сравнения и извлечения баз, а так же импорта, экспорта и сравнения данных. SQL Studio for Oracle объединяет все эти средства в единую мощную и удобную рабочую среду, чтобы сделать Вашу работу продуктивной как никогда ранее!
 | SQL Manager for Oracle EMS SQL Manager™ for Oracle – это мощный графический инструмент для разработки и администрирования серверов баз данных Oracle. Простой и удобный графический интерфейс позволяет быстро и легко создавать и редактировать объекты баз данных Oracle, визуально проектировать сами базы данных, выполнять сценарии Oracle и использовать другие службы, которые сделают Вашу работу с Oracle приятной и легкой.
dataexport | Data Export for Oracle EMS Data Export for Oracle – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных Oracle в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for Oracle располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for Oracle EMS Data Import 2007 for Oracle - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных Oracle.
datapump | Data Pump for Oracle EMS Data Pump™ for Oracle – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных Oracle®. Теперь перенос данных при помощи Data Pump for Oracle стал настолько прост, насколько это возможно!
datagenerator | Data Generator for Oracle EMS Data Generator™ for Oracle – это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных Oracle. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
dbcomparer | DB Comparer for Oracle EMS DB Comparer for Oracle – это мощное приложение, предназначенное для сравнения баз данных Oracle, обнаружения и устранения различий в их структурах. Вы можете просматривать все обнаруженные различия сравниваемых объектов баз данных, а затем выборочно или полностью устранить их, выполнив автоматически создаваемый сценарий.
extract | DB Extract for Oracle EMS DB Extract for Oracle – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract for Oracle позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for Oracle EMS SQL Query™ for Oracle – это специализированная утилита для простого и быстрого создания запросов к базам данных Oracle. SQL Query™ for Oracle Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
datacomparer | Data Comparer for Oracle EMS Data Comparer for Oracle – мощное и удобное приложение для сравнения и синхронизации Ваших данных. С помощью Data Comparer for Oracle Вы можете отслеживать все различия в сравниваемых таблицах и выполнять автоматический сценарий для их устранения.
 | Наверх

IBM DB2

 | SQL Manager for DB2 EMS SQL Manager 2007 for DB2 – это мощнейший инструмент для разработки и администрирования серверов баз данных DB2. Простой и дружественный графический интерфейс позволяет легко создавать и редактировать объекты DB2, визуально разрабатывать базы данных, запускать скрипты SQL. Многочисленные инструменты, доступные в программе, значительно облегчат вашу работу с базами данных DB2.
dataexport | Data Export for DB2 EMS Data Export for DB2 – это мощный инструмент, предназначенный для быстрого экспорта ваших данных из баз данных DB2 в любой из 20 доступных форматов, включая MS Access, MS Excel, MS Word, HTML, TXT, ODF и другие. Data Export for DB2 располагает удобным мастером настройки для визуальной установки параметров экспорта для каждой таблицы (экспортируемые поля, форматы данных и многое другое).
dataimport | Data Import for DB2 EMS Data Import 2007 for DB2 - это мощная утилита, предназначенная для быстрого импорта данных из файлов MS Excel 97-2007, MS Access, DBF, XML, TXT, CSV, MS Word 2007, ODF и HTML в таблицы базы данных DB2.
datapump | Data Pump for DB2 EMS Data Pump™ for DB2 – это мощный инструмент для переноса баз данных и импорта данных из любых ADO-совместимых источников (например, MS Access, базы данных MS SQL или любых других баз данных с поддержкой ADO) в базы данных IBM®DB2. Теперь перенос данных при помощи Data Pump™ for DB2 стал настолько прост, насколько это возможно!
datagenerator | Data Generator for DB2 EMS Data Generator™ for DB2– это мощное приложение для мгновенной генерации тестовых данных для различных таблиц баз данных DB2. Удобный мастер настройки позволяет определять таблицы и поля для генерируемых данных, задавать диапазоны значений, создавать текстовые и BLOB-поля, а также выполнять другие операции, связанные с генерацией тестовых данных, простым и понятным способом.
extract | DB Extract for DB2 EMS DB Extract for DB2 – это простое, удобное и мощное приложение для создания резервных копий баз данных в форме сценариев SQL. DB Extract позволяет сохранять метаданные всех объектов целиком или выборочно, равно как и данные из таблиц баз данных. При помощи гибких настроек процесса извлечения Вы можете выбирать необходимые объекты и таблицы баз данных, а также легко и просто настраивать многие другие параметры.
query | SQL Query for DB2 EMS SQL Query™ for DB2 – это специализированная утилита для простого и быстрого создания запросов к базам данных IBM®DB2. SQL Query™ for DB2 Server позволяет Вам визуально создавать запросы и одновременно редактировать их текст. Используя дружественный графический интерфейс пользователя, Вы можете соединяться с базами данных, выбирать таблицы и поля для запросов, задавать критерии выделения и многое другое.
 | Наверх

Tools & components

advancedexport | Advanced Data Export Advanced Data Export VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), Open XML Format, Open Document Format (ODF), HTML, XML, PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedexport | Advanced Data Export .NET Advanced Data Export .NET - это набор компонентов для Microsoft Visual Studio .NET позволяющий сохранять Ваши данные в самых популярных форматах для дальнейшего просмотра, обработки, распечатки или публикации их в сети Интернет. Вы можете экспортировать данные в MS Access, MS Excel, MS Word (RTF), PDF, TXT, DBF, CSV и многие другие! Больше не нужно тратить свое время на утомительный процесс перевода данных - Advanced Data Export быстро справится с этой задачей и выдаст результат в желаемом формате.
advancedimport | Advanced Data Import Advanced Data Import VCL - это набор компонентов для Borland Delphi и C++ Builder, позволяющий импортировать данные из большинства популярных офисных форматов напрямую в базу данных. Теперь Вы можете импортировать данные из MS Access, MS Excel, HTML, XML, PDF, TXT, DBF, CSV и ODF. Больше не нужно тратить свое время на утомительный процесс импорта данных, Advanced Data Import быстро выполнит все задачи и предоставит результат в требуемом Вам формате.
pdfgenerator | Advanced PDF Generator Advanced PDF Generator - это набор компонентов, позволяющих предельно просто и быстро создавать PDF-документы из Ваших приложений, написанных на Delphi и C++ Builder. Теперь даже не нужно знать специфику формата PDF, Advanced PDF Generator автоматически создает требуемый документ. Причем Advanced PDF Generator разбивает таблицы на несколько частей для каждой из страниц документа, поддерживает вложенные таблицы, позволяет вставлять изображения в создаваемый PDF-документ и многое другое!
querybuilder | Advanced Query Builder Advanced Query Builder™ – это набор компонентов для Borland® Delphi® и C++ Builder®, специально предназначенный для визуального построения запросов SQL для функций SELECT, INSERT, UPDATE и DELETE. Теперь Вы можете визуально создавать новые запросы к Вашим приложениям либо графически представить уже существующие. В комплект поставки входят компоненты для работы со стандартами SQL, InterBase/Firebird, MySQL, PostgreSQL и другими. Пользователи Query Builder могут создавать объемные и сложные по своей структуре запросы для разных серверов даже без знания синтаксиса SQL.
excelreport | Advanced Excel Report Advanced Excel Report™ - это мощный генератор отчетов в формате MS Excel для Delphi®. Excel Report основан на секционном принципе создания отчетов с использованием шаблонов. Простые и удобные редакторы свойств Advanced Excel Report позволяют моментально создавать подробные отчеты в формате MS Excel. Теперь созданные отчеты могут быть отредактированы, сохранены и просмотрены практически на любом компьютере. Excel Report поддерживает Borland® Delphi® 5-7, 2005-2007 а также MS Office 97 SR-1, 2000-2007.
advancedlocalizer | Advanced Localizer Advanced Localizer™ - это незаменимый пакет компонентов для Borland® Delphi®, позволяющий добавлять языковую поддержку Вашим Delphi® приложениям. Широкие возможности пакета Advanced Localizer позволяют быстро и просто локализовать свойства компонентов каждой формы, создавать языковые файлы с текущими значениями свойств компонентов, управлять файлами локализаций, а также назначать компоненты и их свойства, подлежащие локализации. Язык приложений, использующих Advanced Localizer, может быть переключен на другой непосредственно во время работы без последующего перезапуска приложения. Advanced Localizer также предусматривает возможность написания приложений-потомков, использующих языковые файлы, заданные пользователем.
 | Наверх


Управление проектами

Проект является совокупностью настроек подключения и параметров сравнения, которые могут храниться в отдельном файле.

В DB Comparer for Oracle можно создавать, открывать, изменять и сохранять проекты, что дает возможность избежать повторения действий при каждом сравнении баз данных.

Для работы с проектом существует Мастер проектов, который открывается при создании или редактировании проекта.

Можно изменить настройки существующего проекта в любой момент работы с ним. Для этого откройте проект в DB Comparer, выбрав пункт главного меню Options | btnProjectOptions Project Options или нажав кнопку btnProjectOptions Project Options на панели инструментов. В качестве альтернативы можно использовать сочетание клавиш Ctrl+P.

Важно: Файл проекта можно выполнять в консольной версии DB Comparer. Это делает возможным сравнение и синхронизацию баз данных по расписанию, заданному с помощью стандартных средств.

Первый запуск

Редактирование/сохранение проекта

Мастер проектов

Краткий отчет

Смотрите также:

Работа с проектом

Редактор SQL Script

Управление отчетами

Настройки DB Comparer

Консольное приложение


Начало работы

Так выглядит DB Comparer for Oracle при первом запуске.

Чтобы начать работу с базами данных Oracle, Вам нужно создать новый проект (или открыть существующий) и настроить параметры подключения к базе данных:

btnNewProject(Wizard) New Project (Ctrl+N) в главном меню или на панели инструментов

btnOpenFile Open Project (Ctrl+O) в главном меню или на панели инструментов

После открытия или создания, можно перейти к работе с проектом.

Смотрите также:

Редактирование/сохранение проекта

Мастер проектов

Краткий отчет


Редактирование/сохранение проекта

Открыть существующий проект DB Comparer можно, выбрав пункт главного меню Project | Open Project или нажав кнопку btnOpenFile Open project... на панели инструментов (Ctrl+O).

Чтобы сохранить проект DB Comparer, выберите пункт главного меню Project | Save Project (Save project As...) или нажмите кнопку btnSave Save Project ( btnSaveAs Save Project As...) на панели инструментов (Ctrl+S / Ctrl+Alt+S).

При первом сохранении проекта, а также при выборе пункта Save Project As... необходимо указать пусть к файлу проекта и указать его имя в диалоговом окне Save project options.

Console options

CheckBox Synchronize databases after comparing

Установите флажок, если необходимо выполнять итоговый скрипт сразу после завершения процедуры сравнения. Это может быть полезно, если Вы работаете с консольным приложением DB Comparer.

CheckBox Abort script executing on error

Останавливает выполнение скрипта при возникновении ошибки.

Direction

Выберите направление синхронизации: от исходной БД к целевой (From Master to Target) или от целевой к исходной (From Target to Master).

CheckBox Create script file

Установите флажок, чтобы указать путь для создания командного файла для командной строки или PowerShell.

CheckBox Run in background mode

Установите флажок для добавления опции /B. Программа будет запускаться в фоновом режиме.

CheckBox Analyze renamed objects

Установите флажок для добавления опции /A. При выполнении сравнения будет выполняться Анализ переименованных объектов.

CheckBox Use localization

Включите эту опцию, чтобы добавить опцию /L и выводить текст в консольном приложении на том же языке, что и в графическом интерфейсе.

Output file

Укажите директорию для сохранения файла с SQL скриптом.

Script type

Выберите тип команды Batch или PowerShell.

Comment

Добавьте текст, чтобы описать проект. Информация будет сохранена в файле шаблона в разделе [#Comment#].

Смотрите также:

Первый запуск

Мастер проектов


Мастер проектов

Для запуска мастера выберите пункт главного меню Project | New Project или нажмите кнопку btnNewProject(Wizard) New Project (Ctrl+N).

Все свойства проекта можно изменять в этом же мастере. Для этого нужно открыть сохраненный проект.

Шаги:

Параметры подключения к БД

Настройка опций сравнения

Выбор сравниваемых объектов

Переименованные объекты

Смотрите также:

Параметры подключения к БД

Настройка опций сравнения

Открытие/сохранение проекта


Параметры подключения к БД

На этом шаге следует настроить параметры подключения к исходной базе данных.

Managing Projects - New Project Wizard - Step 1

Connect options

Database home - домашняя директория Oracle клиента.

Connect as - тип подключения Oracle (серверная роль).

Database - имя базы данных, как зарегистрировано в файле TNSNAMES.ORA. Если этот список пуст, то необходимо заполнить TNS файл вручную.

В разделе Authentication Type задается способ идентификации пользователя на сервере. Будет ли программа распознавать его по доменному имени и паролю - Windows или же по его персональным имени и паролю на сервере.

Если выбираете Windows, то имя и пароль берется автоматически в соответствии с используемой учетной записью домена Windows. Если выбираете Server, то следует указать имя и пароль. Имя указывается в поле Login, пароль - в поле Password.

Если Вы используете версию DB Comparer for Oracle для EMS SQL Management Studio for Oracle, то на первом шаге доступна кнопка Select registered database, при нажатии на которую открывается диалог выбора базы данных из зарегистрированных в EMS SQL Management Studio.

На вкладке Tunneling задайте параметры туннелирования.

Managing Projects - Setting DB options - Tunneling

Помните, что необходимо иметь права на изменение исходной и/или целевой базы данных Oracle сервера.

Tunneling

SSH туннелирование будет использовано, если установлен RadioButton Connect through the Secure Shell (SSH) tunnel,

Используйте SSH туннелирование для осуществления обмена данными с сервером по шифрованному каналу.

Если требуется установить подключение через SSH туннель, укажите следующие параметры:

SSH host name - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH port - порт SSH сервера на удаленном хосте.

SSH user name - имя пользователя на сервере (пользователь SSH сервера, а не сервера Oracle).

SSH password - пароль пользователя SSH сервера.

CheckBox Use Private Key for authentication

Если флажок установлен, то в поле SSH key file можно указать ключевой файл для аутентификации.

Более подробную информацию смотрите в разделе Настройки SSH туннелирования.

Выполнив настройку подключения, переходите на шаг Compare Options для настройки параметров сравнения.

Следующий шаг >

Смотрите также:

Настройка опций сравнения


Выбор баз данных

После того как заданы все настройки подключения, выберите базы данных, которые Вы хотите сравнить. Выбор производится в диалоге Select database.

Чтобы вызвать этот диалог, нажмите на кнопку btnEllipsis в поле Database на первом шаге.

Step 1 - Selecting database

После выбора необходимой базы данных нажмите на кнопку OK.


Выбор зарегистрированной базы данных

В этом диалоге выберите базу данных для сравнения. Этот диалог доступен только в версии DB Comparer for Oracle для EMS SQL Management Studio.

Selecting registered database

В этом списке отображаются все базы данных, зарегистрированные в EMS SQL Management Studio. Выберите нужную базу и нажмите кнопку OK.

Регистрационная информация базы данных автоматически появится в соответствующих полях на первом шаге.


Настройка опций сравнения

На этом шаге необходимо задать параметры сравнения объектов баз данных.

В дереве объектов необходимо отметить флажками типы объектов и подобъектов, которые будут сравниваться и синхронизироваться.

Свойства, по которым будет проводиться сравнение объектов, отметьте в разделе Compare options. Чтобы отметить все обхекты используйте пункт Select All контекстного меню. Чтобы снять выделение со всех объектов используйте пункт Unselect All.

CheckBox Case sensitive comparing

Установите флажок, если при сравнении следует учитывать регистр.

CheckBox Compare invalid objects

Данная опция позволяет сравнивать поврежденные объекты.

CheckBox Analyze renamed objects

Если включить эту опцию, то отдельно будут отображаться таблицы и поля, которые совпадают во всем, кроме названия.

CheckBox Add comments to generated script

Опция включает/отключает отображение и возможность добавления комментария к скрипту синхронизации.

CheckBox Show objects list

Если эта опция включена, то на следующем шаге отображается полный список найденных объектов. Если нет необходимости просматривать и корректировать список найденных объектов, то вы можете отключить опцию для ускорения процесса сравнения.

CheckBox Show storage parameters

Данная опция включает\отключает сравнение информации о хранении объекта.

Managing Projects - New Project Wizard - Step 3

Filter Options

Можно отфильтровать объекты по имени. По умолчанию используется фильтр по маске. Маска состоит состоит из букв, наборов и групповых символов. Каждая буква должна соответствовать одному символу в строке. Буквенное сравнение проводится без учета регистра. Каждый набор должен начинаться с открывающей квадратной скобки ([) и заканчиваться закрывающей квадратной скобкой (]). Могут быть использованы стандартные символы подстановки: '*', '%' - заменяет любую последовательность или строку символов, '?' - заменяет любой символ.

Managing Projects - Filter Options

Чтобы задать фильтр с помощью регулярного выражения, отметьте опцию CheckBox Regular expression.

Установите опцию CheckBox Case sensitive, если при фильтрации объектов на основе регулярных выражений следует учитывать регистр.

Always exclude the following objects

В этом разделе укажите имена объектов (в одной строке - один объект), которые следует исключить из сравнения. Также можно выполнить сравнение, затем в дереве БД снять флажки с ненужных объектов, после чего они будут автоматически добавлены в список Always exclude the following objects.

Чтобы отменить действие фильтра используйте пункт Clear Filter контекстного меню Database objects.

Опции сравнения, которые буду применены по умолчанию для всех создающихся проектов, можно указать на вкладке Настройки сравнения в диалоговом окне Настройки окружения.

< Предыдущий шаг

Смотрите также:

Параметры подключения к БД


Краткий отчет

После создания/ открытия проекта, производится поиск различий между выбранными базами данных/схемами. В окне Progress отображается ход процедуры.

Working with Project - Analyzing

Важно: Если были обнаружены переименованные объекты, то процесс сравнения не может быть прерван.

Если в разделе Confirmations диалогового окна Environment Options установлен флажок CheckBox Show summary after comparing, то после завершения процесса сравнения появится окно Summary Info, в котором будет отображена сводная информация о различиях в базах данных/схемах.

Working with Project - Summary Info

Если Вы не хотите, чтобы данный отчет отображался при дальнейшей работе с программой, включите опцию CheckBox Do not show summary option.

Смотрите также:

Дерево БД

Описание объектов

Информационное окно

Скрипты синхронизации

Навигация по окнам


Работа с проектом

После создания, или открытия проекта выполняется сравнение и осуществляется переход в рабочую область.

По умолчанию рабочая область проекта содержит дерево БД, описание исходных и целевых объектов, скрипты синхронизации и информационное окно, которые можно скрыть или отобразить с помощью раздела главного меню View.

Дерево БД

Описание объектов

Информационное окно

Скрипты синхронизации

Навигация по окнам

Working with Project

Панель инструментов располагается в верхней части рабочей области. На ней расположены наиболее часто используемые элементам управления.

btnProjectOptions Project Options - открыть проект для просмотра и изменения.

btnRefresh Full Recompare - выполнить сравнение полностью заново.

View - вид отображения объектов в дереве объектов.

Reports - создание отчета по проекту.

Open selected scripts in SQL Script Editor - открыть выбранный скрипт.

Open all scripts in SQL Script Editor - открыть выбранный скрипт.

btnExecuteScript выполнение текущего скрипта

btnShowSQLScript выполнение всех скриптов

btnMoveScriptFirst btnMoveScriptDown btnMoveScriptUp btnMoveScriptLast - корректировки порядка скриптов.

Layout - схема элементов рабочей области

Из этого раскрывающегося списка можно выбрать расположение элементов рабочей области из сохраненных ранее. Если необходимо сохранить текущее расположение, нажмите кнопку btnSave Save Layout. Если же требуется удалить текущее расположение - нажмите кнопку btnCross Remove Layout.

Смотрите также:

Начало работы

Работа с проектом

Редактор SQL Script

Управление отчетами

Настройки DB Comparer

Консольное приложение


Дерево БД

В дереве баз данных, расположенном по умолчанию в левой части рабочей области, отображены объекты исходной и целевой баз данных.

Дерево состоит из четырех основных групп:

iconDifferent Different (различные) - (объекты присутствуют и в исходной и в целевой базе данных, но они не идентичны)

iconOnlyMaster Only master (только исходная) - (объекты присутствуют в исходной базе данных, но отсутствуют в целевой)

iconOnlyTarget Only target (только целевая) - (объекты присутствуют в целевой базе данных, но отсутствуют в исходной)

iconIdentical Identical (идентичные) - (объекты присутствуют в обеих базах данных, и они идентичны)

В скобках рядом с заголовками групп указано количество объектов в группе.

Идентичные объекты обозначены черным шрифтом (по умолчанию). можно настроить цвета в разделе Colors диалогового окна Environment Options.

Если в разделе Project Options диалогового окна Environment Options включена опция Show object related scripts only, то при выборе элемента в дереве баз данных в окне Modification scripts будут отображены только скрипты, относящиеся к выбранному объекту.

Важно: Можно раскрыть или свернуть группу объектов с помощью контекстного меню. Более того, контекстное меню дерева баз данных позволяет открывать необходимые скрипты синхронизации в редакторе SQL Script.

Working with Project - DB Tree

Обновить дерево баз данных можно с помощью кнопки btnRefresh Refresh на панели инструментов (Ctrl+F5). Чтобы обновить только выбранную группу объектов, щелкните по ней правой клавишей мыши и выберите соответствующий пункт контекстного меню.

Контекстное меню дерева БД позволяет:

  • открыть все скрипты в редакторе SQL Script;
  • обновить объекты выбранного типа;
  • открыть простой печатный отчет;
  • раскрыть/свернуть выбранную ветку;
  • включить отображение всех скриптов.

Getting started - DB Tree context menu

Смотрите также:

Краткий отчет

Описание объектов

Информационное окно

Скрипты синхронизации

Навигация по окнам


Описание объектов

В окнах Master Object Definition и Target Object Definition отображается DDL структура объектов исходной и целевой баз данных. Эта информация не доступна для редактирования.

Можно синхронизировать прокрутку обоих окон с помощью пункта контекстного меню Synchronization. Контекстное меню окон описания объектов позволяет копировать DDL объектов в буфер обмена.

По умолчанию окна c описанием объектов расположены в нижней части рабочей области, под окном скриптов синхронизации.

Для удобства отличия в DDL исходного и целевого объекта выделены. Цвета можно настроить исходя из своих предпочтений в разделе Colors диалогового окна Environment Options.

Working with Project - Master and Target Object Definition

Важно: Можно отобразить/скрыть окна описания объектов с помощью пунктов главного меню View | Master Object Definition и View | Target Object Definition.

При попмощи кнопок вы можете быстро перейти к следующей, предыдущей, первой и последней строке различий.

Контекстное меню области описания объектов позволяет:

  • копировать описание объекта в буфер обмена;
  • синхронизировать прокрутку описаний исходного и целевого объектов.

Getting started - Definition area context menu

Смотрите также:

Краткий отчет

Дерево БД

Информационное окно

Скрипты синхронизации

Навигация по окнам


Информационное окно

В информационном окне отображается детальная информация по объектам сравниваемых баз данных.

Помните: В разделе Настройки сравнения можно отметить объекты, которые сравнивать не обязательно.

Working with Project - Information window - total

В зависимости от выбранного элемента дерева баз данных, в информационном окне можно увидеть либо численные результаты сравнения исходной и целевой баз данных (если в дереве выбрана группа объектов), либо полный список свойств исходного объекта в сравнении с соответствующим ему целевым (если выбран конкретный объект). В заголовке информационного окна отображается имя объекта и название группы, в которой он расположен (Different, Only Master, Only Target, Identical).

Working with Project - Information window - properties

Те свойства объекта, которые отличны в исходной и целевой базах, выделяются красным цветом.

Нажатием на кнопку iconDifferent можно скрыть свойства, которые совпадают в исходной и целевой базах данных.

Смотрите также:

Краткий отчет

Дерево БД

Описание объектов

Скрипты синхронизации

Навигация по окнам


Скрипты синхронизации

После выполнения сравнения генерируются скрипты синхронизации, которые позволяют устранить различия между базами данных.

Для этого используются следующие пункты контекстного меню:

btnShowSQLScript Execute All Scripts выполнение всех скриптов

btnExecuteScript Execute Selected Scripts выполнение выбранных.

Выполнение скриптов влечет за собой изменение только одной базы данных (по умолчанию - целевой). Для изменения направления синхронизации (от исходной к целевой или наоборот) используйте вкладки окна Modification Scripts.

Можно просматривать/изменять сгенерированные скрипты, каждый их которых отмечен иконкой, указывающей на тип скрипта (ALTER, CREATE, DROP) и тип соответствующего объекта.

Изменить направленность синхронизации (от исходной к целевой или наоборот) можно переключением между вкладками окна.

Используйте кнопки btnMoveScriptFirst btnMoveScriptDown btnMoveScriptUp btnMoveScriptLast на панели инструментов или соответствующие пункты контекстного меню, чтобы изменить порядок скриптов. С помощью контекстного меню Также можно выполнить или изменить необходимый скрипт в редакторе SQL Script. Чтобы открыть скрипт в редакторе SQL Script можно использовать двойной щелчок мыши.

Если в окне Modification Scripts выделен скрипт, с помощью пункта контекстного меню Find in DB Tree можно найти в дереве баз данных соответствующий ему объект (необходимо, чтобы ветка, в которой находится данный объект была раскрытой).

Важно: Для выделения нескольких скриптов используйте клавиши Ctrl и Shift.

Working with Project - Modification Scripts

Script type

В зависимости от характера отличий между исходной и целевой базами данных DB Comparer генерирует скрипт одного из следующих типов:

Важно: Синхронизация проходит всегда в одном направлении, в зависимости от того, какая вкладка выбрана, скрипты выполняются только на одной базе, вторая остается без изменений.

iconDifferent ALTER: если в обоих базах присутствует объекты с одинаковыми именами, но разными атрибутами, то утилита генерирует скрипт, устраняющий различия (по умолчанию изменением подвергается целевая база данных);

iconOnlyTarget CREATE/ADD: если объект присутствует только в исходной базе данных, то утилита генерирует скрипт, создающий идентичный объект в целевой базе данных;

iconOnlyMaster DROP: если объект присутствует только в целевой базе данных, то программа генерирует скрипт, удаляющий данный объект.

Важно: Изменить максимальную размер поля скрипта в окне Modification Scripts можно в разделе Preferences диалогового окна Environment Options.

Контекстное меню скриптов синхронизации позволяет:

  • находить выбранный объект в дереве БД;
  • btnExecuteScript выполнять выбранный скрипт синхронизации;
  • выполнять все скрипты синхронизации проекта;
  • открывать выбранный скрипт синхронизации в редакторе SQL Script;
  • открывать все скрипты синхронизации проекта в редакторе SQL Script;
  • btnMoveScriptFirst btnMoveScriptDown btnMoveScriptUp btnMoveScriptLast изменять порядок скриптов синхронизации;
  • btnNewProject(Wizard) копировать выбранный скрипт(ы) в буфер обмена.

Getting started - Script context menu

Смотрите также:

Краткий отчет

Дерево БД

Описание объектов

Информационное окно

Скрипты синхронизации


Навигация по окнам

Панель Windows позволяет переключаться между окнами программы так же просто, как с помощью панели задач в Windows.

Чтобы сделать окно активным, щелкните по соответствующему элементу панели.

Getting started - Switching windows

Щелчок правой клавишей мыши на элементе панели Windows откроет контекстное меню, с помощью которого можно закрыть выбранное окно.

Смотрите также:

Просмотр краткого отчета

Просмотр дерева БД

Просмотр описания объектов

Информационное окно

Работа с скриптами синхронизации


Редактор SQL Script

Редактор SQL Script позволяет редактировать и выполнять скрипты синхронизации баз данных.

Открыть редактор можно с помощью контекстного меню дерева баз данных или окна Modification Scripts. Двойной щелчок мыши по представлению скрипта в окне Modification Scripts также откроет редактор SQL Script. Открыть выбранные или все скрипты можно и с помощью соответствующих кнопок на панели инструментов: Open selected scripts in SQL Script Editor и [image] Open all scripts in SQL Script Editor.

Основные возможности редактора представлены на вкладке Script, где можно работать со скриптами в текстовом режиме. Раскрывающийся список в верхней части редактора позволяет выбрать базу данных, в отношении которой следует выполнить скрипт(ы). Ход процесса отображается в нижней части редактора: отчеты об успешном выполнении и сообщения об ошибках. Результаты выполнения скрипта доступны на вкладке редактора Results.

Автоматическая подстановка, подсветка синтаксиса и другие функциональные возможности редактора призваны сделать работу в нем удобной. Можно включить/выключить большинство из них в диалоге Editor Options.

Можно установить задержку автоматической подстановки в разделе Quick code диалогового окна Editor Options, либо вызывать список подстановки сочетанием клавиш Ctrl+Space.

Раскрывающийся список Database позволяет выбрать базу данных/схему, в которой следует выполнить скрипт.

SQL Script Editor

Контекстное меню редактора SQL Script содержит большинство стандартных функций для работы с текстом (Cut - вырезать, Copy - копировать, Paste - вставить, Select All - выделить все), а также определенные функции для работы со скриптами:

  • подменю Quick Code позволяет выбрать символ, переключать регистр выделенного текста, добавлять/удалять комментарии, управлять отступами;
  • для сохранения или загрузки скрипта используйте пункт меню btnSave Save to File и btnOpenFile Load from File или соответствующие кнопки на панели инструментов;
  • можно сделать навигацию в тексте скрипта удобнее, установив закладки с помощью пункта контекстного меню Toggle Bookmarks. Для перехода к строке с закладкой используйте пункт контекстного меню Goto Bookmarks;
  • использование маркеров позволит сделать навигацию проще. Используйте подменю Markers для добавления маркера (пункт Drop marker или клавиша F2), удаления маркера (пункт Collect marker или клавиша ESC) или для смены позиции маркера (пункт Swap marker; в этом случае последний добавленный маркер переместится на текущую позицию курсора, а курсор будет установлен на исходную позицию данного маркера);
  • использование диалоговых окон Find Text и Replace Text позволяют повысить эффективность работы с текстом.

Каждая операция может быть выполнена также с помощью горячих клавиш.

Можно выполнить скрипт в сразу после редактирования. Для этого нажмите кнопку btnExecuteScript Execute, расположенную на панели инструментов, или F9.

Смотрите также:

Управление проектами

Работа с проектом

Управление отчетами

Настройки DB Comparer

Консольное приложение


Управление отчетами

В DB Comparer for Oracle встроен Дизайнер отчетов позволяющий проектировать различные отчеты.

По умолчанию панель Reports расположена в правой части рабочей области проекта. С помощью кнопок, расположенных на ней, можно создавать, удалять, переименовывать, просматривать и редактировать отчеты.

Дизайнер отчетов

Шаблоны отчетов

Смотрите также:

Управление проектами

Работа с проектом

Редактор SQL Script

Настройки DB Comparer

Консольное приложение


Дизайнер отчетов

Дизайнер отчетов позволяет создавать и редактировать отчеты. Он запускается при создании нового отчета в окне Reports или при открытии существующего.

Для Вашего удобства на панели Reports находятся несколько макетов отчетов.

Данный инструмент, предоставленный FastReport (http://www.fast-report.com), имеет собственную справочную систему, которую можно вызвать, нажав F1 в окне дизайнера отчетов.

Как создать простой отчет с помощью дизайнера отчетов:

Добавление раздела

  • перейдите на вкладку Page 1 дизайнера отчетов;
  • выберите требуемый компонент из списка [image] Insert Band (панель инструментов в левой части окна);
  • перейдите на рабочую область дизайнера отчетов;
  • измените свойства объекта с помощью Properties Inspector, если необходимо.

Важно: Панель Properties Inspector может быть вызвана/скрыта нажатием клавиши F11.

Report Designer - Adding bands

Добавление данных

  • перейдите на вкладку Data дизайнера отчетов;
  • выберите элемент(ы) дерева [image] Data tree и переместите его (их) на рабочую область;

Report Designer - Adding report data

Просмотр отчета

Предварительный просмотр отчета можно осуществить с помощью пункта главного меню Project | Preview или кнопки btnPrintPreview Preview, расположенной на панели инструментов. Также можно воспользоваться сочетанием клавиш Ctrl+P. В этом режиме возможен просмотр отчета, редактирование и печать.

Если необходимо напечатать отчет, нажмите кнопку btnPrint Print, расположенную на панели инструментов.

Report Designer - Preview

Сохранение отчета

После того как необходимые изменения были внесены, отчет можно сохранить во внешний файл *.fr3, как на локальном компьютере, так и в сети.

Чтобы сохранить отчет, Выберите пункт главного меню Project | Save или воспользуйтесь кнопкой btnSave Save report, расположенной на панели инструментов. Также можно использовать сочетание клавиш Ctrl+S.


Шаблоны отчетов

В дизайнере отчетов доступны несколько шаблонов: Detailed Info, Summary Info with Chart и Summary Info. Выбрать один из них можно с помощью меню Reports, расположенного на панели Reports справа.

Reports toolbar menu

Местонахождение пользовательских шаблонов задается в диалоговом окне Environment options.

Detailed info

Отчет, сделанный по этому шаблону, отобразит полный перечень объектов сравниваемых баз данных, их DDL, свойства и значения.

Sample report - Detailed Info

Summary Info With Info Chart

Используйте этот шаблон, если хотите получить отчет содержащий сводную информацию о сравниваемых базах данных в виде диаграммы.

Sample report - Summary Info with Chart

Summary Info

Отчет, сделанный по данному шаблону, содержит численную информацию о результатах сравнения.

Sample report - Summary Info


Настройки DB Comparer

В DB Comparer for Oracle можно настроить интерфейс программы, поведение окон, различные параметры инструментов и другое. Просмотрите данный раздел, чтобы подробнее ознакомится с возможностями настройки программы.

Основные группы настроек DB Comparer for Oracle:

Настройки окружения

Общие настройки DB Comparer: стиль окружения, подтверждения, параметры проекта, настройки сравнения, шрифты, цвета и другое.

Настройки редактора

Настройки редактора SQL Script.

Шаблоны клавиатуры

Выбор языка программы

Смотрите также:

Управление проектами

Работа с проектом

Редактор SQL Script

Управление отчетами

Консольное приложение


Настройки окружения

В разделе Environment Options можно настроить общие параметры DB Comparer.

Чтобы открыть диалоговое окно Environment Options выберите пункт главного меню Options | Environment Options, или воспользуйтесь соответствующей кнопкой btnEnvironmentOptions Environment Options, расположенной на панели инструментов.

  • Предпочтения
  • Подтверждения
  • Настройки сравнения
  • Локализация
  • Цвет

Кнопка Default, которая позволяет легко сбросить настройки, располагается в нижней части диалогового окна Environment options.

Смотрите также:

Настройки редактора

Шаблоны клавиатуры


Предпочтения

Schema

Выберите цветовую схему программы: Light (Светлая), Blue (Голубая) или Dark (Темная).

Project options

CheckBox Show object related scripts only

Если опция включена, то при выборе элемента в дереве баз данных в окне Modification scripts будут отображены только скрипты, относящиеся к выбранному объекту.

CheckBox Hide identical objects

При включенной опции идентичные объекты не будут отображаться в дереве баз данных, что упростит и ускорит навигацию.

CheckBox Save passwords into project file

Установите флажок, если хотите, чтобы пароли, используемые для подключения к базам данных, сохранялись в файле проекта.

CheckBox Load connection info for new projects

Если флажок установлен, то при создании нового проекта будет автоматически будет загружаться последняя использованная информация о соединении.

CheckBox Load last password for new projects

Если флажок установлен, то при создании нового проекта будет автоматически подставлен последний использованный пароль.

Environment Options - Preferences

Reports directory

Нажмите кнопку btnExplorer Explorer, чтобы с помощью диалогового окна выбрать директорию, где по умолчанию будут хранится отчеты, или введите путь вручную.

List of modified scripts

CheckBox Row auto height

При включенной опции в окне Modification Scripts размер поля каждого скрипта будет автоматически изменен в соответствии с количеством строк.

Max row line count

Задайте максимальный размер поля в окне Modifications Scripts в строках.

Fonts

Application font

Задайте шрифт, который будет использован во всех элементах управления программы DB Comparer for Oracle.

Application font size

Укажите размер шрифта.

В нижнем окне отображается образец текста, показывающий внесенные изменения.

Смотрите также:

Подтверждения

Настройки сравнения

Локализация

Локализация


Подтверждения

CheckBox Confirm exit from DB Comparer for Oracle

Включите опцию, если необходимо подтверждать выход из программы.

CheckBox Recompare objects after executing the script

Сразу после выполнения скриптов синхронизации заново сравнить измененные объекты.

CheckBox Autosave project before closing

Установите флажок, если требуется автоматически сохранять проект при выходе из программы. В этом случае программа не потребует подтверждения выхода.

Environment Options - Confirmations

CheckBox Show summary after comparing

Опция включает/отключает отображение окна Summary Info по завершении процесса сравнения.

CheckBox Show message after successfully executed script

Если опция включена, то после успешного выполнения скрипта будет выведено сообщение: 'Script executed successfully'.

CheckBox Close progress dialog after successful completion

Если эта опция включена, то при успешном выполнении сравнения диалоговое окно будет закрываться автоматически.

CheckBox Confirm close project

Если этот флажок установлен, то необходимо будет подтверждать закрытие проекта.

Смотрите также:

Предпочтения

Настройки сравнения

Локализация

Цвет


Параметры сравнения

Compare options

Позволяет настроить параметры сравнения для каждого типа объектов.

Выберите тип объекта в дереве, установите соответствующий флажок, чтобы включить его в процедуру сравнения и задайте настройки на вкладке Compare Options.

Группа опций Script generation позволяет выбрать тип скриптов (CREATE, ALTER, DROP), которые следует генерировать.

Пункты контекстного меню Select All, Unselect All и Invert Selection упростят процедуру выбора опций.

Environment Options - Compare Options

CheckBox Case sensitive comparing

Установите флажок, если при сравнении следует учитывать регистр.

CheckBox Compare invalid objects

Данная опция позволяет сравнивать поврежденные объекты.

CheckBox Analyze renamed objects

Если включить эту опцию, то отдельно будут отображаться таблицы и поля, которые совпадают во всем, кроме названия.

CheckBox Add comments to generated script

Опция включает/отключает отображение и возможность добавления комментария к скрипту синхронизации.

CheckBox Show objects list

Если эта опция включена, то на следующем шаге отображается полный список найденных объектов. Если нет необходимости просматривать и корректировать список найденных объектов, то вы можете отключить опцию для ускорения процесса сравнения.

CheckBox Show storage parameters

Данная опция включает\отключает сравнение информации о хранении объекта.

Эти же параметры задаются на втором шаге мастера проектов сравнения для каждого отдельного проекта.

Смотрите также:

Предпочтения

Подтверждения

Локализация

Цвет


Локализация

С помощью инструментов, расположенных на этой вкладке можно задавать язык программы.

Environment Options - Localization

Можно добавить свой файл с расширением *.lng, в список доступных локализаций. Для этого скопируйте его в папку %program_directory%\Languages folder и добавьте его в список с помощью диалога Add language, вызываемого нажатием кнопки Add.

Default directory

В поле указан путь к папке, в которой по умолчанию находятся все файлы локализации, имеющие расширение *.lng.

Choose program language

При нажатии на кнопку проверяется наличие файлов *.lng в папке по умолчанию, которые автоматически добавляются в список доступных языков программы.

Available Languages

В списке показан перечень доступных локализаций, которые можно установить как основной язык программы. Дважды щелкните мышкой по локализации, если нужно изменить ее имя или исходный файл.

Кнопка Add defaults добавляет языки из директории, где по умолчанию располагаются стандартные локализации, в список доступных.

Кнопка Add открывает диалоговое окно Add Language, в котором можно указать путь к файлу локализации и имя языка.

Environment Options - Localization - Add language

Кнопка Edit открывает диалоговое окно Edit Language, позволяющее изменить путь к файлу локализации или имя выбранного языка.

Environment Options - Localization - Edit language

Кнопка Delete исключает выбранный язык из списка Available languages (без запроса о подтверждении операции).

Смотрите также:

Предпочтения

Подтверждения

Настройки сравнения

Цвет


Цвет

В этом разделе диалогового окна Environment Options можно настроить цвета различных элементов проекта. В секции General можно задать цвет элементов дерева баз данных (Identical objects, Non-identical objects, Unique master objects, Unique target objects, Non-identical properties). В секции Definition View можно изменить цвет элементов области описания объектов (Non-identical lines, Deleted lines, Added lines, Additional lines).

Environment Options - Colors

General

Опции данной группы позволяют задать цвет элементов дерева баз данных. Выберите системный цвет из списка, или нажмите на кнопку btnEllipsis, чтобы выбрать желаемый цвет из палитры, расположенной на появившемся диалоговом окне Color.

Definition view

Опции этой группы позволяют задать цвет элементов области описания объектов. Выберите системный цвет из списка, или нажмите на кнопку btnEllipsis, чтобы выбрать желаемый цвет из палитры, расположенной на появившемся диалоговом окне Color.

Смотрите также:

Предпочтения

Подтверждения

Настройки сравнения

Локализация


Настройки редактора

В данном разделе можно изменить настройки просмотра и редактирования в редакторе SQL Script.

Открыть окно настройки можно, выбрав пункт Options | Editor Options в главном меню программы, или нажав на кнопку btnEditorOptions Editor Options, расположенную на панели инструментов.

Общие настройки

Отображение

Цвет

Быстрый код

Смотрите также:

Настройки окружения

Шаблоны клавиатуры


Общие настройки

DB Comparer for Oracle
  • В начало
  • « Назад
  • Вперед »

Общие

В разделе General доступны общие настройки редактора SQL Script.

CheckBox Auto indent

Используйте опцию, если хотите, чтобы каждый новый отступ был таким же, как в предыдущей строке.

CheckBox Insert mode

Установите флажок для включения режима автоматической вставки символов.

CheckBox Use syntax highlight

Опция управляет подсветкой синтаксиса в редакторе.

CheckBox Find text at cursor

Если опция включена, то слово, на котором стоит курсор, автоматически попадает в окно поиска при нажатии Ctrl+F.

CheckBox Always show hyperlinks

Если опция включена, в окне редактора будут отображаться гиперссылки, открыть которые можно щелкнув мышкой, предварительно зажав клавишу Ctrl.

CheckBox Use smart tabs

Установите флажок, если размер отступа следует варьировать в зависимости от его величины на соседних строках.

Editor Options - General

Tab stops

Задайте размер отступа при табуляции.

Undo limit

Укажите максимальное число хранимых операций для отмены действия.

Смотрите также:

Отображение

Цвет

Быстрый код


Отображение

Секция Display позволяет установить параметры шрифта и отступов.

Editor Options - Display

CheckBox Show line numbers

Включите опцию для отображения нумерации строк в рабочей области редактора SQL script.

CheckBox Use code folding

Использовать блоки кода в редакторе скрипта.

Editor font, Size

Укажите системный шрифт, который будет использоваться в редакторе, и его размер.

Все изменения отображаются на образце, расположенном в нижней части формы.

Смотрите также:

Общие настройки

Цвет

Быстрый код


Цвет

Раздел Color позволяет задать цвет и шрифт различных элементов текста, таких как ключевые слова, знаки препинания, комментарии, ссылки и т.д.

Editor Options - Color

В верхней части формы в списке Element представлены все элементы. В нижней части окна на образце текста отображаются все внесенные изменения.

Справа расположены элементы управления, позволяющие менять вид объекта, выбранного в списке Element.

В разделе Text attributes задайте начертание шрифта используемого в редакторе SQL Script:

CheckBox Bold - жирный;

CheckBox Italic - курсив;

CheckBox Underline - подчеркнутый.

Секция Use defaults for позволяет восстановить исходные настройки цвета фона (Background) и элемента (Foreground).

Щелкните мышкой на элементе Foreground color или Background color, чтобы изменить цвет текущего элемента, или его выделения соответственно.

Смотрите также:

Общие настройки

Отображение

Быстрый код


Быстрый код

Секция Quick Code позволяет настроить вспомогательные функции редактирования скриптов.

Editor Options - Quick Code

CheckBox Code completion

Если флажок установлен, то при вводе первых символов слова в редакторе SQL Script, автоматически будет предложен список из слов, начинающихся с этих символов.

CheckBox Code parameters

С включенной опцией при введении ключевого слова будут отображаться подсказка. В поле Delay задайте время ожидания появления подсказки.

CheckBox Sort column names

Сортировать объекты по именам.

Keyboard templates

CheckBox Use keyboard templates

Используйте опцию, чтобы применять шаблоны клавиатуры автоматически.

Смотрите также:

Общие настройки

Отображение

Цвет


Шаблоны клавиатуры

С помощью инструмента Keyboard Templates задайте шаблоны для быстрого ввода текста.

Чтобы открыть редактор шаблонов клавиатуры выберите в главном меню пункт Options | Keyboard Templates или нажмите кнопку btnKeyboardTemplates Keyboard Templates на панели инструментов.

Чтобы создать шаблон нажмите кнопку Add Template... В появившемся окне укажите последовательность символов, которая должна будет при вводе замениться определенным текстом.

Чтобы изменить уже созданный шаблон выделите его в общем списке и нажмите кнопку Edit Template. При нажатии кнопки Delete Template выбранный шаблон удаляется.

Можно исключить шаблон из списка активных. Для этого снимите соответствующий флажок в столбце Active.

В разделе Expansion укажите тот текст, которым должен быть заменен набор символов шаблона.

С помощью кнопок можно вставить автотекст:

  • Backspace -
  • Cursor position - позиция курсора, при применении курсор будет переведен в указанное место,
  • Author - имя учетной записи,
  • Time - время редактирования
  • Date - дата редактирования,
  • Clipboard - содержимое буфера обмена,
  • Marker - маркер.

Также, в разделе Case of Templates, можно указать регистр, в котором должно вводиться сочетание символов, являющееся шаблоном.

RadioButton As is - оставлять как есть,

RadioButton Uppercase - ВСЕ ПРОПИСНЫЕ,

RadioButton Lowercase - все строчные,

RadioButton First upper - Начинать С Прописных.

Чтобы применить шаблон необходимо в редакторе набрать сочетание символов, указанное в шаблоне, а затем нажать сочетание клавиш Ctrl+J.

Восстановить значения шаблонов, принятые по умолчанию можно, нажав на кнопку By Default.

Смотрите также:

Настройки окружения

Настройки редактора


Выбор языка программы

С помощью диалогового окна Select Language можно выбрать любую из предложенных локализаций интерфейса.

Чтобы открыть данное окно, выберите пункт главного меню Options | Select Program Language.

Это окно содержит список доступных языков, найденных в директории, указанной в разделе Localization диалогового окна Environment Options.

Getting Started - Selecting program language

Выберите нужный язык и нажмите OK, чтобы изменения вступили в силу.

Смотрите также:

Первый запуск


Консольное приложение

Консольное приложение DB Comparer for Oracle предназначено для быстрого и удобного сравнения и синхронизации баз данных/схем Oracle, а также для использования в любых планировщиках задач. Использовать консольное приложение следует с помощью командной строки с указанием имени проекта в качестве параметра.

Использование консольного приложения

Как выполнять сравнение по расписанию

Смотрите также:

Начало работы

Управление проектами

Работа с проектом

Редактор SQL Script

Управление отчетами

Настройки DB Comparer


Работа с консольным приложением

Все настройки сравнения можно сохранить в файле проекта (*.ocp), который можно использовать также в консольном приложении DB Comparer for Oracle.

Консольная версия DB Comparer for Oracle, отлично подходящая для быстрого сравнения структуры и синхронизации баз данных, входит в пакет установки программы.

Использование

<путь к консольному приложению DB Comparer for Oracle>\OraComparerC.exe Имя_проекта [Файл_вывода] [Файл_лога] [/E] [/B] [/L]

Имя_проекта

Следует указать имя файла с расширением *.ocp для использования в качестве параметра при выполнении консольной версии программы. В разделе Открытие/Сохранение проекта содержится инструкция по сохранению файла проекта.

Файл_вывода

Укажите файл вывода, в который следует сохранять скрипт модификации, сгенерированный утилитой. Если файл не указан, то скрипт будет сохранен в файл Имя_проекта.sql в домашнюю директорию DB Comparer for Oracle.

Файл_лога

Укажите файл, в который следует сохранять журнал выполнения программы. Если данный параметр не задан, то журнал будет сохранен в файл Имя_проекта.log в домашнюю директорию

/E

Укажите данный параметр, если следует выполнить сгенерированный скрипт по завершении процедуры сравнения.

/L

При задании этого параметра консольная версия использует локализцию, заданную в программе.

/B

Данный параметр позволяет запускать программу в тихом режиме: окно консоли не появялется.

/A

Анализировать переименованные объекты.

Примеры

"C:\Program Files\EMS\DB Comparer for Oracle\OraComparerC.exe"

DBComparer_Project.ocp

После выполнения этой команды программа сгенерирует скрипт синхронизации в файл DBComparer_Project.sql.

"C:\Program Files\EMS\DB Comparer for Oracle\OraComparerC.exe"

DBComparer_ORA.ocp Result.sql

После выполнения этой команды программа сгенерирует скрипт в файл Result.sql.

"C:\Program Files\EMS\DB Comparer for Oracle\OraComparerC.exe"

DBComparer_ORA.ocp Result.sql /E

После выполнения этой команды программа сгенерирует скрипт в файл Result.sql и выполнит его.

Важно: Следующие значения кода завершения возвращаются программой DB Comparer for Oracle операционной системе после выполнения последней операции:

0 - удачное завершение;

1 - во время выполнения произошла ошибка (или несколько);

2 - критическая ошибка. Задача не выполнена.


Как настроить сравнение по расписанию

Как настроить программу для запуска по расписанию с помощью стандартного планировщика задач Windows:

1) Задайте настройки сравнения в проекте и сохраните проект.

2) Запустите командную строку Windows (наберите CMD в диалоге Выполнить... в Windows).

3) Для запуска консольной версии программы используйте команду:

<путь консольному приложению DB Comparer for Oracle>\OraComparerC.exe имя_проекта [файл_скрипта] [файл_журнала] [/E] [/B] [/L]

Например:

"C:\Program Files\EMS\DB Comparer for Oracle\OraComparerC.exe"

DBComparer_ORA.ocp Result.sql

4) Запустите Планировщик задач в Windows.

5) Укажите команду для выполнения проекта (см. Пункт 3).

6) Настройте расписание для запуска команды.

7) Сохраните задачу.


Поиск

С помощью окна Find Text можно найти сочетание символов в рабочей области редактора SQL Script.

В поле Text to Find укажите искомую последовательность символов или выберите одну из предыдущих.

Options

CheckBox Case Sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular Expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

SQL Script Editor - Find Text dialog

Direction

Укажите направление поиска:

RadioButton Forward - вниз,

RadioButton Backward - вверх.

Scope

RadioButton Global - искать во всем тексте.

RadioButton Selected text - искать только в выделенном тексте.

Origin

RadioButton From cursor - поиск начинается с того места где стоит курсор.

RadioButton Entire scope - поиск с начала текста.

CheckBox Mark search result with stack marker - помечать результаты поиска маркером.


Поиск и замена

С помощью окна Replace Text можно найти сочетание символов в рабочей области редактора SQL Script и заменить его на указанное.

В поле Text to find укажите искомую последовательность символов. Или выберите одну из предыдущих.

В поле Text to replace укажите последовательность символов, на которою желаете заменить найденные или выберите одну из предыдущих.

Options

CheckBox Case Sensitive

При поиске учитывать регистр.

CheckBox Whole words only

Учитывать слово целиком.

CheckBox Regular Expressions

Если отмечена эта опция, то введенный текст будет распознаваться как регулярное выражение.

Например, если Вы введете "empl*", то будет произведен поиск по метаданным всех строк, содержащих подстроку "empl". При вводе "^emp" результатом поиска будут объекты, в метаданных которых есть строки, начинающиеся на "emp", а при поиске

"^emp|emp$" - строки, содержащие "emp" в начале или конце строки.

Важно: Синтаксис регулярных выражений, которые могут быть использованы в поле Text to find, соответствует синтаксису регулярных выражений языка Perl. Более подробная информация может быть найдена по ссылке: http://perldoc.perl.org/perlre.html#Regular-Expressions.

CheckBox Prompt on replace - включите опцию, если хотите чтобы при каждом нахождении указанной последовательности символов программа выводила запрос о замене. Если опция выключена, замена будет происходить автоматически.

SQL Script Editor - Replace Text dialog

Direction

Укажите направление поиска:

RadioButton Forward - вниз,

RadioButton Backward - вверх.

Scope

RadioButton Global - искать во всем тексте.

RadioButton Selected text - искать только в выделенном тексте.

Origin

RadioButton From cursor - поиск начинается с того места где стоит курсор.

RadioButton Entire scope - поиск с начала текста.

CheckBox Mark search result with stack marker - помечать результаты поиска маркером.

Кнопка Replace All позволяет заменить все совпадения. Если опция Prompt on replace включена, будет выдаваться запрос подтверждения замены текста.


Параметры SSH туннелирования

DB Comparer for Oracle
  • В начало
  • « Назад
  • Вперед »

Параметры SSH-туннелирования

SSH (Secure Shell Host) протокол используется для повышения компьютерной безопасности при работе Unix-системами в Internet. SSH использует несколько алгоритмов шифрования разной степени надежности. Распространенность SSH связана еще и с тем, что многие Linux-подобные ОС (например, FreeBSD) включают в стандартную комплектацию SSH сервер. Для получения дополнительной информации можно посетить http://openssh.org. Опция SSH туннель в SQL Manager представляет собой средство организации безопасного доступа к Oracle серверам при работе по небезопасным каналам связи. Также можно использовать SSH-туннель для доступа к удаленным Oracle серверам, если по каким-либо причинам порт 3306 закрыт для внешних подключений. Соединение через SSH-туннель выглядит следующим образом. Сначала устанавливается соединение и производится процедура аутентификации между встроенным в DB Comparer for Oracle SSH клиентом и удаленным SSH -сервером, затем вся исходящая и входящая информация между программой и Oracle сервером передается через SSH сервер с использованием коммуникационного порта (обычно 22), а SSH сервер транслирует информацию уже непосредственно Oracle серверу. Чтобы зарегистрировать базу данных, соединение к которой должно выполняться с использованием SSH туннеля, Вы должны задать следующие параметры при регистрации базы данных в Oracle:

SSH Host - имя машины (IP-адрес), на которой установлен сервер SSH.

SSH Port - порт SSH сервера на удаленном хосте (по умолчанию равен 22).

SSH User Name - имя пользователя на сервере (пользователь SSH сервера, а не сервера Oracle).

SSH Password - пароль пользователя SSH сервера.

Имейте в виду, что в случае использования SSH туннелирования имя хоста Oracle должно быть задано относительно сервера SSH. Например, если Oracle и SSH сервер установлены на одном компьютере, следует указать 'localhost' в качестве имени хоста вместо имени внешнего хоста или IP адреса.

Если установлен флажок Use Private Key for authentication, то в поле SSH key file можно указать ключевой файл для аутентификации.

SSH Private Key - Passphrase


Настройка панелей управления и меню

Любую панель инструментов можно настроить.

Её можно настраивать, используя функцию Add or Remove Buttons, открывающуюся при нажатии на кнопку btnMoreButtons в правом углу панели.

В появившемся окне выбираете те кнопки, которые нужны Вам для работы.

Нажав на любую панель управления правой кнопкой мыши и выбрав пункт Customize.

Если на панели инструментов нажать правой кнопкой мыши, то тоже появится кнопка Customize.

При нажатии на эту кнопку открывается окно редактирования панели инструментов.

Toolbars

Appendix - Customize - Toolbars

На этой вкладке можно создавать, редактировать и удалять панели инструментов.

New - добавить панель инструментов,

Rename - переименовать,

Delete - удалить.

Вкладка Commands:

На этой вкладке выберите кнопки, которые будут отображаться на панели инструментов.

Appendix - Customize - Commands

Options

Appendix - Customize - Options

CheckBox Menus show recently used command first

Всегда показывать полные меню.

CheckBox Show full menus after a short delay

Показывать полные меню после небольшой задержки.

Reset my usage data

Сброс настроек.

CheckBox Large icons

Крупные значки.

CheckBox Show ToolTips on Toolbars

Отображать подсказки для кнопок.

CheckBox Show shortcut keys in ToolTips

Включить в подсказки сочетания клавиш.

Menu animations

Анимация при выборе меню.


Дополнительные настройки подключения

Для подключения к серверу Oracle необходимо, чтобы на компьютере, на котором будет использоваться DB Comparer for Oracle, был установлен клиент Oracle. Версия клиента Oracle должна быть совместима с версией сервера Oracle, к которому необходимо подключиться.

Необходимо добавить параметры подключения баз данных Oracle в ваш TNS names файл (tnsnames.ora файл). Это конфигурационный файл, который содержит описания баз данных.

Если Вы используете Database Client, то файл tnsnames.ora находится в директории %HOME_name\NETWORK\ADMIN.

Если Вы используете Instant Client, то файл tnsnames.ora необходимо будет создать вручную. Файл должен быть создан в той же директории, в которой установлен Oracle клиент (например, C:\OracleInstantClient\). Этот файл можно создать с помощью любого текстового редактора (создать простой текстовый файл, а затем изменить его название и расширение).

Только для Instant Client

После того как файл tnsnames.ora создан, и добавлено описание базы данных, необходимо создать переменную окружения TNS_ADMIN.

Для этого необходимо выполнить следующие действия.

  1. Щелчком правой кнопки мыши на значке My computer/Мой компьютер вызовите контекстное меню.
  2. В этом контекстном меню выберите пункт Properties/Свойства.
  3. Перейдите на вкладку Advanced/Дополнительно и нажмите кнопку Environment Variables/Переменные среды.
  4. В разделе System variables/Системные переменные нажмите кнопку New.../Создать.
  5. В поле Variable name/Имя переменной задайте TNS_ADMIN, а в поле Variable value:/Значение переменной задайте C:\OracleInstantClien\tnsnames.ora.
  6. Нажмите кнопку OK и сохраните переменную.

В этом же диалоговом окне найдите переменную PATH. Двойным щелчком откройте её для редактирования в специальном окне и добавьте путь к клиентским библиотекам клиента Oracle Instant. (Они расположены в каталоге, где установлен клиент C:\OracleInstantClient\). Помните, что записи путей должны быть разделены точкой с запятой (;).

DB Comparer for Oracle подключается к серверу (с помощью клиента) через TCP/IP протокол.

Пример настроек подключения, заданных в TNS файле.

DB_Alias =

(DESCRIPTION =

(ADDRESS_LIST =

(ADDRESS = (PROTOCOL = TCP)(HOST = Host_name)(PORT = 1521))

)

(CONNECT_DATA =

(SERVER = DEDICATED)

(SERVICE_NAME = Database_Name)

)

)

Параметры:

PROTOCOL - конкретный протокол, используемый адаптером. Для этого параметра значение протокола - TCP. Значение может быть введено в верхнем или нижнем регистре.

HOST - имя сервера или IP адрес.

PORT - номер порта TCP/IP.

SERVICE_NAME - имя службы сервера; имя экземпляра базы данных может отличаться от фактического имени базы данных.

DB_Alias - ​​любое имя подключения.

При задании параметров подключения из раскрывающегося списка Database home выберите имя клиента и из раскрывающегося списка Database можно будет выбрать одну из баз данных, указанных в файле tnsnames.ora.


Панели и меню

Используйте вкладку Bars and menus для настройки внешнего вида панелей инструментов и меню программы DB Comparer for Oracle.

Visual Options - Bars and menus

Из раскрывающегося списка Bar style выберите один из стандартных стилей панели инструментов:

Standard - стандартный вид;

Enhanced - улучшенный вид;

Flat - двумерный;

XP native - стиль MS Windows® XP;

Office 11 - стиль MS Office 11.

Помните: Если выбран стиль XP native, то к панелям инструментов будет применена схема, выбранная в операционной системе. Если же установлена иная операционная система или выбрана схема Windows Classic, то будет применен стиль Enhanced.

Из списка Menu Animation можно выбрать один из вариантов анимации при открытии меню:

None - без анимации;

Random - случайный выбор анимации;

Unfold - разворачивающееся меню;

Slide - выезжающее;

Fade - проявляющееся.

CheckBox Sunken border - утопленная рамка.

CheckBox Use F10 for menu - при нажатии клавиши F10 происходит фокусировка на главном меню DB Comparer for Oracle.

CheckBox Show full menus after delay - показать всё меню после задержки. Эта опция доступна, только если установлен флажок Menus show recently used commands first в диалоговом окне Customize.

CheckBox Flat close buttons - использовать двумерные закрывающие кнопки.

CheckBox Gray-scale disabled images - иконки недоступных пунктов меню изображены с помощью оттенков серого. Если опция выключена - такие иконки будут затенёнными. Если выбран стиль XP native или Office 11, то опция включается автоматически, и становится недоступной для изменения.

Смотрите также:

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Деревья и списки

На вкладке Trees and Lists настройте внешний вид списков.

Visual Options - Trees and Lists

Из раскрывающегося списка Look & Feel выберите один из стандартных стилей оформления списков.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Hide selection - скрыть выделение.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Элементы редактирования

На вкладке Edit controls задайте стиль элементов управления и редактирования.

Visual Options - Edit controls

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия;

Thick - одинарная широкая линия;

Flat - плоская с тенью;

3D - трехмерная;

Ultraflat - плоская.

Из списка Button style - стиль кнопок.

3D - трехмерные;

Flat - плоские с тенью;

Simple - простые;

Hotflat - плоские в рамке;

Ultraflat - плоские.

Стиль кнопок, расположенных в пределах поля, можно задать с помощью раскрывающегося списка Button transparency.

None - непрозрачные;

Inactive - прозрачные, когда неактивные;

Always - прозрачные;

Hide inactive - показывать при редактировании;

Hide unselected - показывать при наведении курсора.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Edges - границы:

CheckBox Left - слева;

CheckBox Right - справа;

CheckBox Top - сверху;

CheckBox Bottom - снизу.

Смотрите также:

Панели и меню

Деревья и списки

Флажки

Кнопки

Элементы окна

Группы опций

Разделители


Флажки

На вкладке Check boxes задайте вид флажков и переключателей.

Visual Options - Check boxes

Из раскрывающегося списка Border style выберите стиль рамки:

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Кнопки

Элементы окна

Группы опций

Разделители


Кнопки

На этой вкладке настройте внешний вид кнопок.

Visual Options - Buttons

Из списка Button kind выберите вид кнопок.

Standard - стандартные,

Flat - плоские с тенью,

Ultraflat - плоские.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Элементы окна

Группы опций

Разделители


Элементы окна

В этом окне задайте стиль оформления вкладок.

Visual Options - Page controls

Из списка Tab Style выберите нужный стиль вкладок.

Tabs - в виде вкладок,

Buttons - в виде кнопок

Flat - плоские.

CheckBox Hot track - подсветка элементов управления.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Группы опций

Разделители


Группы опций

Задайте стиль отображения групп опций на вкладке Group boxes.

Visual Options - Group boxes

Из раскрывающегося списка Border style выберите стиль рамки.

None - без рамки,

Single - одинарная тонкая линия,

Thick - одинарная широкая линия,

Flat - плоская с тенью,

3D - трехмерная,

Ultraflat - плоская.

CheckBox Shadow - тень.

CheckBox Native style - естественный стиль. Применим только в Windows® XP.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Разделители


Разделители

На вкладке Splitters задайте стиль разделителей.

Visual Options - Splitters

Из раскрывающегося списка Hot zone style выберите стиль отображения разделителей.

Windows XP task bar - стиль Windows® XP,

Media Player 8 - стиль Media Player 8,

Media Player 9 - стиль Media Player 9,

Simple - простой,

None - нет.

CheckBox Hot zone drags a splitter

Если флажок установлен, то разделитель можно перемещать, потянув за среднюю рабочую область. Если не установлен, то по нажатию на эту область окно, ограниченное сплиттером будет сворачиваться и разворачиваться.

Смотрите также:

Панели и меню

Деревья и списки

Элементы редактирования

Флажки

Кнопки

Элементы окна

Группы опций